Nautilus crashes when mounted media, trash, computer or network clicked

Bug #515336 reported by bpowell on 2010-02-01
98
This bug affects 17 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Just happened after updates today (1/31/10) although, I was probably 2 weeks behind on updates. Only other bug's I've found seem to either link to Ubuntu One, or are dated from mid last-year...this is a new problem I've just developed.

Very willing to help out with troubleshooting, just give me direction like you would a 3 year-old! :)

Thanks!

I'm currently running Jaunty (9.04) 64-bit.
When I click on Trash, Computer, or Network...Nautilus crashes, I lose my desktop icons and my Conky...I do still have upper and lower bars.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.26.2-0ubuntu2
ProcCmdline: nautilus
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 g_slice_alloc () from /lib/libglib-2.0.so.0
 pango_ot_buffer_new ()
 ?? ()
 pango_shape () from /usr/lib/libpango-1.0.so.0
 ?? () from /usr/lib/libpango-1.0.so.0
Title: nautilus crashed with SIGSEGV in g_slice_alloc()
Uname: Linux 2.6.28-17-generic x86_64
UserGroups: adm admin audio cdrom fuse lpadmin mythtv plugdev pulse pulse-access pulse-rt root sambashare vboxusers video

bpowell (bpowell2008) wrote :
bpowell (bpowell2008) on 2010-02-01
visibility: private → public
Roshan George (roshan-george) wrote :

Nautilus crashes with these errors since yesterday. I am running Ubuntu 9.04 fully patched. This problem is recent and started within the last few days. Is there a workaround?

Chuck Hawley (crh0831) wrote :

I can report that I, too, had the same problem today on my Jaunty install after updates done on 01/31/2010. I was able to successfully rollback to the previous version of libglib2.0 and was able to open a "Network" connection again.

The command that worked for me was

aptitude install libglib2.0-0=2.20.1-0ubuntu2.1

The computer warned me of three other programs that would be affected and offered to downgrade them as well. I accepted the solution and everything went through fine. No other problems have been noticed so far.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
bpowell (bpowell2008) wrote :

Added Valgrind log file...I was unable to find a Nautilus dbgsym file per the "Debugging Program Crash" information page...so I ran Valgrind without that dbgsym file installed...I hope the attached log file is helpful.

bpowell (bpowell2008) wrote :

To confirm Chuck's comments above, down-grading libglib2.0-0 to a previous version solved my problem as well..."Computer, Network, and Trash" can all safely be clicked again without fear of having Nautilus bomb-out on me.

I was highly conflicted rolling back the libglib package, as I wanted to be able to continue and assist the troubleshooting efforts...however, I simply can not have my computer dysfunctional for that long; I need it up and running 100%.

I hope this bug does not get marked as "invalid" or canceled...as there is definitely a problem with the libglib2.0-0 package that manifests itself as a Nautilus problem. This problem also appears to be limited to 64-bit users.

I've had Synaptic lock the "good" version of libglib2.0-0 and I will monitor this bug in hopes I can release that lock and upgrade to a fixed version.

Thanks all!

Chris Coulson (chrisccoulson) wrote :

There hasn't been a glib2.0 update in Jaunty for over 4 months now, so which update are you referring to? If you've had a glib2.0 update in the last few days, then it's likely you've installed some packages from a third party PPA somewhere which is triggering this crash. If that's the case, then there's not a lot we can do (and this isn't the right place to report it).

What version causes the crash?

bpowell (bpowell2008) wrote :

The crash is caused by the following: libglib2.0-0 2.22.0-0ubuntu2-ppa2~jaunty (jaunty). I'm running Jaunty 9.04 fully updated (except for libglib2.0 and its associated files.) I don't recall adding any third party PPA's to my repositories, however, that's not to say it's not the cause! I'll attach my sources.list file shortly.

bpowell (bpowell2008) wrote :

Note: The last repository (remastersys) was added after this incident occurred...I was originally updating the system to prep for a remaster before I updated to Karmic. I do not recognize a couple of the repositories, so maybe they are a clue?

Chris Coulson (chrisccoulson) wrote :

2.22.0-0ubuntu2-ppa2~jaunty isn't an official Ubuntu package, and doesn't exist in our repositories. Closing this as invalid, as there's nothing we can do about third party packages. Please report it to the vendor of that package instead.

Changed in nautilus (Ubuntu):
status: Incomplete → Invalid
volkswagner (rvwbug) wrote :

I have not applied the above work around. I have had the same issue since 2/1/2010. I found a similar thread on the forums, which is dated back in July, 2009.

http://ubuntuforums.org/showthread.php?t=1211189

Is there any more I can do to help debug this. I can work around the issue for a while. I have submitted the crash report, as I have just enabled apport.

I'll upload my sources.list if it helps.

Eric

Chris Coulson (chrisccoulson) wrote :

volkswagner - please don't mix issues. The thread linked there has nothing to do with this, as this is caused by a rogue libglib2.0-0 package which has only appeared in the last couple of days or so. Also, as pointed out in my last comment, this is not an Ubuntu bug and there's nothing we can do about it. Please report the issue to whoever supplied you with the broken glib version

Roshan George (roshan-george) wrote :

Chris, the broken glib version is from the Ubuntu One ppa for Jaunty. Is it possible to switch this bug to Ubuntu One?

Peter Jakobi (jakobi) wrote :

I second Roshan's request. Thanx.

Note that for my Jaunty it's a slightly differing version than the one mentioned above, also implicating Ubuntu One:
## pool name as per aptitude -v show ~nlibglib
#bash1 % grep -r -i pool/main/g/glib2.0/libglib2.0-0_2.22.3-0ubuntu2-ppa2~jaunty_amd64.deb * | grep -i -v depend
/var/lib/apt/lists/ppa.launchpad.net_ubuntuone_beta_ubuntu_dists_jaunty_main_binary-amd64_Packages

suniyo (suniyo) wrote :

ubuntu one?

Pardon me for adding the link. I had some pertinent info in my post
showing the segfault from /var/log/messages. I just thought is was
interesting that the symptoms were the same or similar. I am just
trying to help.

I don't fully understand your mail. Is my issue related to the original
bug report? Are you just commenting because I added a link to an old
thread?

I will be researching to determine where my glib version comes from.

I am no expert, I help when I can, and seek help when I need it.

Peace,

Eric

On Wed, 2010-02-03 at 14:40 +0000, Chris Coulson wrote:
> volkswagner - please don't mix issues. The thread linked there has
> nothing to do with this, as this is caused by a rogue libglib2.0-0
> package which has only appeared in the last couple of days or so. Also,
> as pointed out in my last comment, this is not an Ubuntu bug and there's
> nothing we can do about it. Please report the issue to whoever supplied
> you with the broken glib version
>

Reproduced with ubuntuone ppa version of glib.
Jaunty fully updated + ubuntuone ppa repository; No extra software installed. Reproducible with and without nautilus plugin installed.

Backtrace for launching with computer:/// is attached.

Rodrigo Moya (rodrigo-moya) wrote :

Sorry for the inconvenience, but we tried to backport some karmic packages and some dependencies were not met, so could you please run:

$ sudo aptitude install libglib2.0-0=2.20.1-0ubuntu2.1 libsoup2.4-1=2.26.0-0ubuntu3 libwebkit-1.0-1=1.0.1-4ubuntu0.1 libsoup-gnome2.4-1=2.26.0-0ubuntu3 libglib2.0-data=2.20.1-0ubuntu2.1

and then log out and back in to see if the problem went away?

This downgrades packages to the versions in jaunty, which should fix the problem

volkswagner (rvwbug) wrote :

Rodrigo Moya

Yes the above downgrade fixes issue.

Thanks for the quick attention.

I am not sure why comments were made that this was not an Ubuntu issue.

On 3 February 2010 23:43, volkswagner <email address hidden> wrote:

>
> I am not sure why comments were made that this was not an Ubuntu issue.
>
> -
>

Because the broken package does not come from the official Ubuntu archive.
We generally don't support third-party packages that people install from
PPA's

I had the same Nautilus crash problem when clicking on network or on computer. Applying the instructions from Rodrigo above solved the problem. No idea which package has caused the issue.

Alberto (albertop) wrote :

Is it in the end still possible to use Ubuntu One without breaking nautilus?
After restoring libglib2.0-0 & co. and removing ubuntone related packages everything works again (even if I passed 2 bad hours...).
Is there a stable repository of Ubuntu One for Jaunty which doesn't overwrite any Ubuntu package?
It would be enough for me to have just the command line tool "u1sync".
Thanks.

Sense Egbert Hofstede (sense) wrote :

I've been told by the developers that the affected package was removed from the PPA and that if you have downgraded that package according to the previously mentioned instructions it's safe to use again.

ChrisBE (cbe010) wrote :

I had the same issue Nautilus crash on opening Garbage Bin. I followed suggested instructions for backports by Rodrigo Moya. Ubuntu One seems to be working fine - it connects, but when I try to empty the Garbage Bin, or delete a file I get a dialogue box of "File Operations" with a progress bar and nothing seems to happen, ie no files deleted.

ChrisBE (cbe010) wrote :

Sorry, my problem seems to have resolved itself after a second reboot. Thanks for the help.

Willem Hobers (whobers) wrote :

Is this the place to say that both my computers are affected by this bug also, and that both are running Ubuntu 9.4 32 bits?

I did the downgrade as mentioned by Rodrigo Moya on one of these systems (Acer Aspire R3600, 32 bits).
And: thanks Moya! Problem solved. :-)

.

I have the same problems
Nautilus crash when trying to open the "Trash" folder, and it only crashes if there is items in the "Trash" folder, otherwise it opens fine.
It also crashes when trying to connect to remote server.

After a crash all the desktop icons is gone.

Attached is a valgrind.log
Hope it helps in finding the problem.
I will also apply the above remedy to fix the problem.

I applied the above remedy regarding the libglib2.0-0 and nautilis is behaving now.
Thanks

Jean-Philippe Fleury (jpfle) wrote :

I have this bug on Ubuntu 10.04 Beta 1. I can always reproduce it by clicking on a mounted media icon (hard disk, cdroms) on the desktop, and then Nautilus will crash. See the attached backtrace.

summary: - nautilus crashes when TRASH, COMPUTER, or NETWORK clicked
+ Nautilus crashes when mounted media, trash, computer or network clicked
Joan Reyes (joanlrf05) wrote :

I have the same bug in ubuntu 10.10. It happens every time I try to access the trash bin or the network. could you update the command/solution for 10.10?

Thanks

To post a comment you must log in.