nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-open-terminal and ubuntuone-client-gnome are installed

Bug #865115 reported by manatorg
This bug affects 449 people
Affects Status Importance Assigned to Milestone
nautilus-open-terminal
Unknown
Critical
ubuntuone-client-gnome
Status tracked in Trunk
Stable-2-0
Critical
Unassigned
Trunk
Critical
dobey
nautilus-open-terminal (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
ubuntuone-client-gnome (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Crashed shortly after booting while clicking through unity applets

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: nautilus-open-terminal 0.19-1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Mon Oct 3 09:41:40 2011
ExecutablePath: /usr/bin/nautilus
ProcCmdline: nautilus -n
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x5900f99 <gconf_client_get+57>: cmp %eax,(%edx)
 PC (0x05900f99) ok
 source "%eax" ok
 destination "(%edx)" (0x00000008) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: nautilus-open-terminal
StacktraceTop:
 gconf_client_get () from /usr/lib/libgconf-2.so.4
 gconf_client_get_bool () from /usr/lib/libgconf-2.so.4
 nautilus_open_terminal_get_file_items () from /usr/lib/nautilus/extensions-3.0/libnautilus-open-terminal.so
 nautilus_menu_provider_get_file_items () from /usr/lib/libnautilus-extension.so.1
 ?? ()
Title: nautilus crashed with SIGSEGV in gconf_client_get()
UpgradeStatus: Upgraded to oneiric on 2011-10-01 (1 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd lpadmin netdev nvram plugdev powerdev sambashare scanner tape video
XsessionErrors:
 (Do:2589): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
 (nautilus:2564): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:2564): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:2564): GConf-CRITICAL **: gconf_client_get: assertion `GCONF_IS_CLIENT (client)' failed

Revision history for this message
manatorg (manatorg) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus-open-terminal (Ubuntu):
status: New → Confirmed
Revision history for this message
Mattias Eriksson (snaggen) wrote :

Removed the nautilus-open-terminal package, and then I could use nautilus again

Revision history for this message
Nicolás Abel Carbone (nicocarbone) wrote :

Removing the nautilus-open-terminal helped a bit, but nautilus is still crashing way too often. I can't open the Desktop, or Ubuntu-one subscribed folders, for example.

Revision history for this message
u-foka (ufooka) wrote :

Nicolás: That is an other bug: bug #804946 that showed up in the same time

Revision history for this message
Nicolás Abel Carbone (nicocarbone) wrote :

@u-foka: I meant that nautilus crashes if I try to open the Desktop folder, how is this related to a crash in gnome-settings-daemon? Thanks you.

Revision history for this message
u-foka (ufooka) wrote :

Nicolás: Sorry, the bug I originally found (Bug #865105) was marked as a dupe...
For short, you have to remove ubuntuone client too and nautilus will be okay :)

Revision history for this message
Nicolás Abel Carbone (nicocarbone) wrote :

@u-foka: Thanks for the info. I use UbuntuOne a lot so uninstalling it is not an option, but no biggie, I always knew this things can happen in a beta. Hope this get fixed fast, though.

Revision history for this message
crtm (carlosrtm) wrote :

Crashed after booting. After last update

Revision history for this message
Jeremy Price (jtull69) wrote :

For me this happens if I use gksudo nautilus

Revision history for this message
Consumology (hans-georg-schmid) wrote :

Whenever I click on Desktop Nautilus crashes. It also crashes randomly when using it in other folders. After that it does not restart for some time. Tried deinstalling nautilus-open-terminal and Ubuntu One, no effect, also after restart. The problem occurred yesterday after updating.

Revision history for this message
Thomas Schyra (arctanh) wrote :

Nautilus always crashes while opening a folder that is synced with Ubuntu One. No Prpblem with Dropbox-integration btw.

Removed
- nautilus-open-terminal
- nautilus-script-manager
- nautilus-scripts-manager
all extension like 'set as wallpaper'

without effect, nautilus still crashes while opening my synced folders.

Daniel Hahler (blueyed)
Changed in nautilus-open-terminal (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-open-terminal - 0.19-1build1

---------------
nautilus-open-terminal (0.19-1build1) oneiric; urgency=low

  * No-source-change rebuild to fix nautilus from crashing when this plugin is
    installed.
    - LP: #865115
 -- Daniel Hahler <email address hidden> Tue, 04 Oct 2011 20:55:03 +0200

Changed in nautilus-open-terminal (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Nicolás Abel Carbone (nicocarbone) wrote :

nautilus is still crashing here, if I have nautilus-open-terminal installed

Revision history for this message
Daniel Hahler (blueyed) wrote :

Nicolás, do you have version 0.19-1build1 of the package installed?
Have you rebooted your system, or made otherwise sure that nautilus is being reloaded?
(for me, even killing nautilus has not been enough yesterday, but it works now for me).

Revision history for this message
adammw (adammw) wrote :

Just installed nautilus 0.19-1build1 on my Ubuntu 11.10 system but still crashing nautilus (1:3.2.0-0ubuntu5) and had to uninstall.

Revision history for this message
Daniel Hahler (blueyed) wrote :

You are right.
I had it crashing now, too.

However, it does not appear to be 100% reproducible - sometimes nautilus starts up OK, but when killing it and starting it again, it might segfault.

Changed in nautilus-open-terminal (Ubuntu):
status: Fix Released → Triaged
Revision history for this message
Bowmore (bowmore) wrote :

Having the same issue here on two installations.

If both nautilus-open-terminal and ubuntuone-client-gnome are installed then nautilus crashes. Removing one of them makes nautilus work again.

Revision history for this message
zzeroo (co) wrote :

Confirmed that uninstalling of ubuntuone-client-gnome solves the crash, for the moment.

Daniel Hahler (blueyed)
summary: - nautilus crashed with SIGSEGV in gconf_client_get()
+ nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-
+ open-terminal and ubuntuone-client-gnome are installed
Changed in ubuntuone-client-gnome (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-client-gnome (Ubuntu):
status: New → Confirmed
Changed in nautilus-open-terminal:
importance: Unknown → Critical
status: Unknown → Invalid
Revision history for this message
Josh Carlson (jcarlson1701) wrote :

Removed the nautilus-open-terminal package, and then I could use nautilus again

Revision history for this message
Dave Stroud (bigdavesr) wrote :

Uninstalling ubunto one gnome had no effect on my machine. . It still crashes. Its to the point that nautilus is totally unusable.

Revision history for this message
Laudeci Oliveira (laudeci) wrote : Re: [Bug 865115] Re: nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-open-terminal and ubuntuone-client-gnome are installed

Removing the nautilus-open-terminal package fixed for me.

Revision history for this message
Timo Reimerdes (timorei) wrote :

removing ubuntuone-client-gnome, killing and restarting nautilus appearantly "fixed" this for me.

Revision history for this message
Viswanath (viswanathb) wrote :

Removed the nautilus-open-terminal package, and then I could use nautilus again

Revision history for this message
Nicolas McCurdy (thenickperson) wrote :

Removed the nautilus-open-terminal package, and then I could use nautilus again as well.

Changed in nautilus-open-terminal:
status: Invalid → New
Revision history for this message
Krzysztof Janowicz (janowicz) wrote :

yes, but removing the terminal package is exactly what I do not want to do :-) anyway, it is a good fix for the moment.

Revision history for this message
Laudeci Oliveira (laudeci) wrote :

I think that the best fix would be make nautilus-open-terminal use dconf
instead of gconf, this will be a god move considering that gnome3 is using
dconf too.

 https://bugs.launchpad.net/bugs/865115
>
> Title:
> nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-
> open-terminal and ubuntuone-client-gnome are installed
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/nautilus-open-terminal/+bug/865115/+subscriptions
>

Revision history for this message
Daniel Hahler (blueyed) wrote :

You can also remove ubuntuone-client-gnome and keep nautilus-open-terminal (that's what I did to work around this).

dobey (dobey)
Changed in nautilus-open-terminal (Ubuntu Oneiric):
status: Triaged → Invalid
Changed in ubuntuone-client-gnome:
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Critical
status: New → In Progress
Revision history for this message
Murat Uenalan (muenalan) wrote :

Can confirm, removing nautilus-open-terminal resolved the crashes.

Revision history for this message
Marco (u-admin-waldhufe-eu) wrote :

Problem ist gelöst Danke für die Antworten.

Revision history for this message
Claudiu Vlad (claudiu-vlad) wrote :

nautilus is unusable for me at the moment

this bug looks similar to https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/867481

Revision history for this message
Claudiu Vlad (claudiu-vlad) wrote :

purged nautilus-open-terminal
tried a few clicks, nautilus seems stable

installed nautilus-open-terminal again,
nautilus cant start and dies with:

$ nautilus
** (nautilus:19576): DEBUG: SyncDaemon already running, initializing SyncdaemonDaemon object
Initializing nautilus-gdu extension
Initializing nautilus-open-terminal extension

(nautilus:19576): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed

(nautilus:19576): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
Segmentation fault

Changed in nautilus-open-terminal (Ubuntu Oneiric):
status: Invalid → Opinion
status: Opinion → Confirmed
Changed in nautilus-open-terminal:
status: New → Unknown
Revision history for this message
Clint Byrum (clint-fewbar) wrote : Please test proposed package

Hello manatorg, or anyone else affected,

Accepted ubuntuone-client-gnome into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client-gnome (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in ubuntuone-client-gnome (Ubuntu Oneiric):
status: Fix Committed → Confirmed
Revision history for this message
Colan Schwartz (colan) wrote :

I don't see why this should be set back to Confirmed. Fixing.

Changed in ubuntuone-client-gnome (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Revision history for this message
Bowmore (bowmore) wrote :

Tested and seems to work now with both nautilus-open-terminal and ubuntuone-client-gnome (new version) installed, i.e no more crashes.

Revision history for this message
Nicolas McCurdy (thenickperson) wrote :

It works perfectly for me with Nautilus open terminal and Ubuntu One as well.

Revision history for this message
Alan (alancarvalho) wrote :

It works perfectly for me with nautilus open terminal and Ubuntu one. Congratulation for the excelente job.

Revision history for this message
orlapa (orlapa) wrote : Re: [Bug 865115] nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-open-terminal and ubuntuone-client-gnome are installed

Hi,
I have ubuntu installed on a virtual machine, and after update nautilus started again, A restart was necessary, but works!

Thnks
Bye
El 11/10/2011, a las 17:33, Alan escribió:

> It works perfectly for me with nautilus open terminal and Ubuntu one.
> Congratulation for the excelente job.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (868719).
> https://bugs.launchpad.net/bugs/865115
>
> Title:
> nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-
> open-terminal and ubuntuone-client-gnome are installed
>
> Status in nautilus-open-terminal:
> Unknown
> Status in Ubuntu One Client GNOME Integration:
> Fix Committed
> Status in ubuntuone-client-gnome stable-2-0 series:
> Fix Committed
> Status in ubuntuone-client-gnome trunk series:
> Fix Committed
> Status in “nautilus-open-terminal” package in Ubuntu:
> Confirmed
> Status in “ubuntuone-client-gnome” package in Ubuntu:
> Fix Committed
> Status in “nautilus-open-terminal” source package in Oneiric:
> Confirmed
> Status in “ubuntuone-client-gnome” source package in Oneiric:
> Fix Committed
>
> Bug description:
> Crashed shortly after booting while clicking through unity applets
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: nautilus-open-terminal 0.19-1
> ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
> Uname: Linux 3.0.0-12-generic i686
> ApportVersion: 1.23-0ubuntu2
> Architecture: i386
> Date: Mon Oct 3 09:41:40 2011
> ExecutablePath: /usr/bin/nautilus
> ProcCmdline: nautilus -n
> ProcEnviron:
> LANGUAGE=de_DE:en
> PATH=(custom, no user)
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x5900f99 <gconf_client_get+57>: cmp %eax,(%edx)
> PC (0x05900f99) ok
> source "%eax" ok
> destination "(%edx)" (0x00000008) not located in a known VMA region (needed writable region)!
> SegvReason: writing NULL VMA
> Signal: 11
> SourcePackage: nautilus-open-terminal
> StacktraceTop:
> gconf_client_get () from /usr/lib/libgconf-2.so.4
> gconf_client_get_bool () from /usr/lib/libgconf-2.so.4
> nautilus_open_terminal_get_file_items () from /usr/lib/nautilus/extensions-3.0/libnautilus-open-terminal.so
> nautilus_menu_provider_get_file_items () from /usr/lib/libnautilus-extension.so.1
> ?? ()
> Title: nautilus crashed with SIGSEGV in gconf_client_get()
> UpgradeStatus: Upgraded to oneiric on 2011-10-01 (1 days ago)
> UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd lpadmin netdev nvram plugdev powerdev sambashare scanner tape video
> XsessionErrors:
> (Do:2589): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
> (nautilus:2564): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
> (nautilus:2564): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
> (nautilus:2564): GConf-CRITICAL **: gconf_client_get: assertion `GCONF_IS_CLIENT (client)' failed
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nautilus-open-terminal/+bug/865115/+subscriptions

Revision history for this message
Ivan Lin (ivanusto) wrote :
Download full text (3.8 KiB)

Dear All,

Thanks, it works on my machine.

On Wed, Oct 12, 2011 at 8:29 AM, orlapa <email address hidden> wrote:

> Hi,
> I have ubuntu installed on a virtual machine, and after update nautilus
> started again, A restart was necessary, but works!
>
> Thnks
> Bye
> El 11/10/2011, a las 17:33, Alan escribió:
>
> > It works perfectly for me with nautilus open terminal and Ubuntu one.
> > Congratulation for the excelente job.
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (868719).
> > https://bugs.launchpad.net/bugs/865115
> >
> > Title:
> > nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-
> > open-terminal and ubuntuone-client-gnome are installed
> >
> > Status in nautilus-open-terminal:
> > Unknown
> > Status in Ubuntu One Client GNOME Integration:
> > Fix Committed
> > Status in ubuntuone-client-gnome stable-2-0 series:
> > Fix Committed
> > Status in ubuntuone-client-gnome trunk series:
> > Fix Committed
> > Status in “nautilus-open-terminal” package in Ubuntu:
> > Confirmed
> > Status in “ubuntuone-client-gnome” package in Ubuntu:
> > Fix Committed
> > Status in “nautilus-open-terminal” source package in Oneiric:
> > Confirmed
> > Status in “ubuntuone-client-gnome” source package in Oneiric:
> > Fix Committed
> >
> > Bug description:
> > Crashed shortly after booting while clicking through unity applets
> >
> > ProblemType: Crash
> > DistroRelease: Ubuntu 11.10
> > Package: nautilus-open-terminal 0.19-1
> > ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
> > Uname: Linux 3.0.0-12-generic i686
> > ApportVersion: 1.23-0ubuntu2
> > Architecture: i386
> > Date: Mon Oct 3 09:41:40 2011
> > ExecutablePath: /usr/bin/nautilus
> > ProcCmdline: nautilus -n
> > ProcEnviron:
> > LANGUAGE=de_DE:en
> > PATH=(custom, no user)
> > LANG=de_DE.UTF-8
> > SHELL=/bin/bash
> > SegvAnalysis:
> > Segfault happened at: 0x5900f99 <gconf_client_get+57>: cmp
> %eax,(%edx)
> > PC (0x05900f99) ok
> > source "%eax" ok
> > destination "(%edx)" (0x00000008) not located in a known VMA region
> (needed writable region)!
> > SegvReason: writing NULL VMA
> > Signal: 11
> > SourcePackage: nautilus-open-terminal
> > StacktraceTop:
> > gconf_client_get () from /usr/lib/libgconf-2.so.4
> > gconf_client_get_bool () from /usr/lib/libgconf-2.so.4
> > nautilus_open_terminal_get_file_items () from
> /usr/lib/nautilus/extensions-3.0/libnautilus-open-terminal.so
> > nautilus_menu_provider_get_file_items () from
> /usr/lib/libnautilus-extension.so.1
> > ?? ()
> > Title: nautilus crashed with SIGSEGV in gconf_client_get()
> > UpgradeStatus: Upgraded to oneiric on 2011-10-01 (1 days ago)
> > UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd
> lpadmin netdev nvram plugdev powerdev sambashare scanner tape video
> > XsessionErrors:
> > (Do:2589): Wnck-CRITICAL **: wnck_set_client_type got called multiple
> times.
> > (nautilus:2564): Gtk-CRITICAL **: gtk_action_set_visible: assertion
> `GTK_IS_ACTION (action)' failed
> > (nautilus:2564): Gtk-CRITICAL **: gtk_action_set_visible: assertion
> `GTK_IS_ACTION (action)' faile...

Read more...

Martin Pitt (pitti)
Changed in nautilus-open-terminal (Ubuntu Oneiric):
status: Confirmed → Invalid
tags: added: verification-done
removed: verification-needed
Revision history for this message
Diska (discardi-nicola) wrote :

it work for we too

Revision history for this message
Santhilal Subhash (santhilalsubhash) wrote : Re: [Bug 865115] Re: nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-open-terminal and ubuntuone-client-gnome are installed

Dear ubuntu's,

It worked for me too.

Thanks,
/LAL

Sent from my iPhone

On Oct 12, 2011, at 7:01 AM, Diska <email address hidden> wrote:

> it work for we too
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/865115
>
> Title:
> nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-
> open-terminal and ubuntuone-client-gnome are installed
>
> Status in nautilus-open-terminal:
> Unknown
> Status in Ubuntu One Client GNOME Integration:
> Fix Committed
> Status in ubuntuone-client-gnome stable-2-0 series:
> Fix Committed
> Status in ubuntuone-client-gnome trunk series:
> Fix Committed
> Status in “nautilus-open-terminal” package in Ubuntu:
> Invalid
> Status in “ubuntuone-client-gnome” package in Ubuntu:
> Fix Committed
> Status in “nautilus-open-terminal” source package in Oneiric:
> Invalid
> Status in “ubuntuone-client-gnome” source package in Oneiric:
> Fix Committed
>
> Bug description:
> Crashed shortly after booting while clicking through unity applets
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: nautilus-open-terminal 0.19-1
> ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
> Uname: Linux 3.0.0-12-generic i686
> ApportVersion: 1.23-0ubuntu2
> Architecture: i386
> Date: Mon Oct 3 09:41:40 2011
> ExecutablePath: /usr/bin/nautilus
> ProcCmdline: nautilus -n
> ProcEnviron:
> LANGUAGE=de_DE:en
> PATH=(custom, no user)
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x5900f99 <gconf_client_get+57>: cmp %eax,(%edx)
> PC (0x05900f99) ok
> source "%eax" ok
> destination "(%edx)" (0x00000008) not located in a known VMA region (needed writable region)!
> SegvReason: writing NULL VMA
> Signal: 11
> SourcePackage: nautilus-open-terminal
> StacktraceTop:
> gconf_client_get () from /usr/lib/libgconf-2.so.4
> gconf_client_get_bool () from /usr/lib/libgconf-2.so.4
> nautilus_open_terminal_get_file_items () from /usr/lib/nautilus/extensions-3.0/libnautilus-open-terminal.so
> nautilus_menu_provider_get_file_items () from /usr/lib/libnautilus-extension.so.1
> ?? ()
> Title: nautilus crashed with SIGSEGV in gconf_client_get()
> UpgradeStatus: Upgraded to oneiric on 2011-10-01 (1 days ago)
> UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd lpadmin netdev nvram plugdev powerdev sambashare scanner tape video
> XsessionErrors:
> (Do:2589): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
> (nautilus:2564): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
> (nautilus:2564): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
> (nautilus:2564): GConf-CRITICAL **: gconf_client_get: assertion `GCONF_IS_CLIENT (client)' failed
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nautilus-open-terminal/+bug/865115/+subscriptions

Revision history for this message
cicoandcico (cicoandcico) wrote :

fixed for me, too

Revision history for this message
thgreasi (thgreasi) wrote :

When this patch will be pushed to -recommended ???

Revision history for this message
Federico (fkremer-terra) wrote :

Al hacer click sobre carpeta personal en Unity

Revision history for this message
Almufadado (almufadado) wrote :

Nautilus are crashing way to often from the unity menu (argh!!):

->when I open a mounted ntfs disk it crashes when there are multimedia files (all multimedia files play in other apps !!!)

-> when I open a ext4 (with journal) and then navigate to PLACES where there is multimedia files

-> when navigating in dirs and trying to open files (any kind !!!)

By multimedia files i mean either images. videos and some mp3

dmsg reports this :

Oct 16 05:38:51 microwave kernel: [ 7812.624157] nautilus[4541]: segfault at 8 ip b3b24f99 sp bfae1c60 error 4 in libgconf-2.so.4.1.5[b3b0c000+2c000]
Oct 16 05:39:03 microwave kernel: [ 7824.997803] nautilus[5161]: segfault at 8 ip b3cbff99 sp bfc133b0 error 4 in libgconf-2.so.4.1.5[b3ca7000+2c000]
Oct 16 05:39:15 microwave kernel: [ 7837.047447] nautilus[5182]: segfault at 20 ip b3c62f99 sp bfbe44d0 error 4 in libgconf-2.so.4.1.5[b3c4a000+2c000]
Oct 16 05:39:25 microwave kernel: [ 7847.119495] nautilus[5212]: segfault at 20 ip b3b4ef99 sp bfb1c830 error 4 in libgconf-2.so.4.1.5[b3b36000+2c000]
Oct 16 05:39:43 microwave kernel: [ 7864.808762] nautilus[5230]: segfault at 8 ip b3c2af99 sp bf91fdb0 error 4 in libgconf-2.so.4.1.5[b3c12000+2c000]
Oct 16 22:54:50 microwave kernel: [69971.812114] nautilus[10428]: segfault at 8 ip b3ca9f99 sp bfb23c20 error 4 in libgconf-2.so.4.1.5[b3c91000+2c000]
Oct 16 23:00:06 microwave kernel: [70288.098498] nautilus[10757]: segfault at 20 ip b3cf6f99 sp bf8c8f60 error 4 in libgconf-2.so.4.1.5[b3cde000+2c000]
Oct 16 23:00:34 microwave kernel: [70316.444738] nautilus[10828]: segfault at 8 ip b3ce5f99 sp bfcc4650 error 4 in libgconf-2.so.4.1.5[b3ccd000+2c000]
Oct 16 23:07:54 microwave kernel: [70755.991366] nautilus[11117]: segfault at 8 ip b3bbef99 sp bf9bff00 error 4 in libgconf-2.so.4.1.5[b3ba6000+2c000]
Oct 16 23:08:04 microwave kernel: [70766.135280] nautilus[11138]: segfault at 8 ip b3ca6f99 sp bfd61680 error 4 in libgconf-2.so.4.1.5[b3c8e000+2c000]
Oct 16 23:17:42 microwave kernel: [71343.866315] nautilus[11263]: segfault at 8 ip b3b55f99 sp bf9ebf30 error 4 in libgconf-2.so.4.1.5[b3b3d000+2c000]

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client-gnome - 2.0.1-0ubuntu2

---------------
ubuntuone-client-gnome (2.0.1-0ubuntu2) oneiric-proposed; urgency=low

  * debian/patches/01_double_unref.patch:
    - Include config.h properly (LP: #868457)
    - Avoid a double unref (LP: #865115)
 -- Rodney Dawes <email address hidden> Tue, 11 Oct 2011 11:20:32 -0400

Changed in ubuntuone-client-gnome (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntuone-client-gnome (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Revision history for this message
Claudiu Vlad (claudiu-vlad) wrote :

No crash for me since the last update.

Congratulations for the developers!

Revision history for this message
Sasa Stamenkovic (umpirsky) wrote :

I think there Nautilus plugin system fails as well. Failure in nautilus-open-terminal or any other plugin should not cause Nautilus to crash, it can crash the plugin, but not entire app.

Revision history for this message
RobinJ (robinj) wrote :

Er... I've just installed updates and it still crashed for me.

Revision history for this message
Claudiu Vlad (claudiu-vlad) wrote :

Why don't you try

#aptitude purge nautilus-open-terminal

#aptitude install nautilus-open-terminal

(remember Windows :P )

On Tue, Oct 18, 2011 at 5:29 PM, RobinJ <email address hidden> wrote:

> Er... I've just installed updates and it still crashed for me.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/865115
>
> Title:
> nautilus crashed with SIGSEGV in gconf_client_get(), if both nautilus-
> open-terminal and ubuntuone-client-gnome are installed
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/nautilus-open-terminal/+bug/865115/+subscriptions
>

Revision history for this message
Tareq Hasan (tareq) wrote :

Damn, same problem in Oneiric. Removing nautilus-open-terminal worked :(

Oct 22 09:14:05 tareq-laptop kernel: [46230.651668] nautilus[19152]: segfault at 1f00000020 ip 00007f85770e38be sp 00007fff9085a4a0 error 4 in libgconf-2.so.4.1.5[7f85770c9000+2d000]

Revision history for this message
Guillaume Moulin (gmoulin-dev) wrote :

For information i did a fresh install last thursday and no nautilus crash.

Revision history for this message
teimcrr (marco-carrarini) wrote :

Problem solved for me with the new version of nautilis-open-terminal in Oneiric.

Thanks !

Revision history for this message
Aditya (meta1729) wrote :

Uninstalling nautilis-open-terminal solved the problem here.

Revision history for this message
Damien Carcel (damien-carcel) wrote :

After a fresh install of Oneiric and removing all my previous preferences, nautilus-open-terminal worked again for me too.

Revision history for this message
Dave Stroud (bigdavesr) wrote :

This is not fixed on my machine. Nautilus crashes every time I open a folder placed on my desktop nautilus crashes. Also is crashing desktop.

Revision history for this message
Daniel Hahler (blueyed) wrote :

@Dave and others being still affected by this in Oneiric (with updates installed): you are likely experiencing a different crash, so please report it as a new bug.
The best way would be to enable apport (via editing /etc/default/apport, then "sudo restart apport") and reproduce the crash. It should ask you to report it on Launchpad.

Revision history for this message
Marcin Plocienniczak (k1kuj1ro) wrote :

Something new. Nautilus is permanently crashed. When i try to run it print a lot of
"(nautilus:2910): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed"
 messages and ends with memory violation.

Revision history for this message
dobey (dobey) wrote :

Marcin, please file a new bug using "ubuntu-bug nautilus" to collect debug information. It is not this bug. See comment #59

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.