Can't set the time as "Automatically from the Internet"

Bug #1403828 reported by Eason on 2014-12-18
28
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu Kylin
High
Aron Xu
unity-control-center (Ubuntu)
High
Unassigned

Bug Description

Can't set the time as "Automatically from the Internet"。

时间不能设置为自动从互联网获取

Steps:
1. Login system
2. Enter into system settings-->Time&Date
3. Check the item "Automatically from the Internet"
-->Failed. Can't set the time as "Automatically from the Internet"

Configuration:
OS: Ubuntu Kylin Vivid x32 Daily Build 20141217

Huan Peng (penghuanmail) on 2014-12-18
Changed in ubuntukylin:
assignee: Huan Peng (penghuanmail) → Ubuntu Kylin Members (ubuntukylin-members)
Eason (qulei) on 2014-12-18
Changed in ubuntukylin:
assignee: Ubuntu Kylin Members (ubuntukylin-members) → nobody
assignee: nobody → Ubuntu Kylin Members (ubuntukylin-members)
Anthony Wong (anthonywong) wrote :

Eason, please confirm if Ubuntu image has this problem or not, thanks.

Eason (qulei) wrote :

This bug also exists in Ubuntu 15.04

Anthony Wong (anthonywong) wrote :

Do other functions in "Time & Date" work?

shijing (shijing) wrote :

yes, other functions normal work

Changed in ubuntukylin:
milestone: none → vivid-beta2
importance: Undecided → High
David Natkins (dnatkins) wrote :

This also affects Ubuntu Vivid-vervet amd64 as well. Same symptoms. To set time to internet automatically is shaded.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Changed in unity-control-center (Ubuntu):
importance: Undecided → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1403828

tags: added: iso-testing
Aron Xu (happyaron) on 2015-01-29
affects: unity-control-center (Ubuntu) → indicator-datetime (Ubuntu)
Logan Rosen (logan) wrote :

The bug is in unity-control-center, not indicator-datetime.

Switching to systemd from upstart fixed it for me.

affects: indicator-datetime (Ubuntu) → unity-control-center (Ubuntu)
Aron Xu (happyaron) wrote :

unity-control-center gets a boolean value about whether system supports NTP from indicator-datetime, for Ubuntu installations with upstart, ntpd isn't installed (though there is ntpdate, default configuration doesn't make it work out-of-box) , switching to systemd makes me think of systemd-timesyncd.

Barry Warsaw (barry) wrote :

Even installing ntpd manually does not allow you to select this option in the system setting panel. The item is still grayed out.

Jack Yu (jackyu) on 2015-03-11
Changed in ubuntukylin:
assignee: Ubuntu Kylin Members (ubuntukylin-members) → Aron Xu (happyaron)
Aron Xu (happyaron) wrote :

Problem vanished after switching to systemd, so that close the task for development release.

Changed in unity-control-center (Ubuntu):
status: Confirmed → Won't Fix
Changed in ubuntukylin:
status: New → Fix Released
jiaowen520li (jiaowen520li) wrote :

This bug has been fixed in UK15.04-0311-Daily-amd64.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers