fanatic disable-fan fails without docker installed

Bug #1691485 reported by Stefan Bader on 2017-05-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-fan (Ubuntu)
Medium
Stefan Bader
Xenial
Medium
Stefan Bader
Yakkety
Medium
Stefan Bader
Zesty
Medium
Stefan Bader

Bug Description

Release: 17.04/Zesty
Version: 0.12.2

When disabling fan, the code tries to check whether docker is configured. However that test is attempting to decide which docker version is installed (in order to handle the new network options). This fails but is incorrectly evaluated as docker being configured. And that prevents fan from being de-configured.

Fix: Test for docker being installed and if not return false to the configured check.

SRU Justification:

Impact: The function which does docker config updates/tests currently does not check for the presence of the docker command itself. And while there are error messages to stderr a call to check for fan being configured for docker accidentally results in returning true.

Fix: Adding a check for the docker command being present early in the function and return an error in that case (which is a false in the is-docker-configured case). Since the function should really always fail if there is no docker present the risk of regressions should be low.

Testcase:
 - [docker is not installed]
 - fanatic enable-fan ...
 - fanatic disable-fan ...

tags: added: patch
Stefan Bader (smb) wrote :

SRU Justification:

Impact: The function which does docker config updates/tests currently does not check for the presence of the docker command itself. And while there are error messages to stderr a call to check for fan being configured for docker accidentally results in returning true.

Fix: Adding a check for the docker command being present early in the function and return an error in that case (which is a false in the is-docker-configured case). Since the function should really always fail if there is no docker present the risk of regressions should be low.

Testcase:
 - [docker is not installed]
 - fanatic enable-fan ...
 - fanatic disable-fan ...

Stefan Bader (smb) on 2017-05-23
Changed in ubuntu-fan (Ubuntu Zesty):
importance: Undecided → Medium
status: New → Fix Committed
description: updated

Hello Stefan, or anyone else affected,

Accepted ubuntu-fan into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-fan/0.12.2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-fan - 0.12.3

---------------
ubuntu-fan (0.12.3) artful; urgency=medium

  * fanatic: Prevent error message without docker installed (LP: #1691485)
  * fanatic: Supply LXD storage if needed (LP: #1691490)
  * dep8: Add LXD auto-test

 -- Stefan Bader <email address hidden> Mon, 22 May 2017 14:02:34 +0200

Changed in ubuntu-fan (Ubuntu):
status: Fix Committed → Fix Released
Stefan Bader (smb) wrote :

Verification on Zesty/17.04:
- with ubuntu-fan=0.12.2 and no docker installed: error message on disable-fan
- after updating to ubuntu-fan=0.12.2.1, disable-fan runs without errors.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-fan - 0.12.2.1

---------------
ubuntu-fan (0.12.2.1) zesty; urgency=medium

  * fanatic: Prevent error message without docker installed (LP: #1691485)
  * fanatic: Supply LXD storage if needed (LP: #1691490)
  * dep8: Add LXD auto-test

 -- Stefan Bader <email address hidden> Mon, 22 May 2017 14:01:01 +0200

Changed in ubuntu-fan (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-fan has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Andy Whitcroft (apw) on 2017-06-09
Changed in ubuntu-fan (Ubuntu Xenial):
status: New → In Progress
Changed in ubuntu-fan (Ubuntu Yakkety):
status: New → In Progress
Changed in ubuntu-fan (Ubuntu Xenial):
importance: Undecided → Medium
Changed in ubuntu-fan (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in ubuntu-fan (Ubuntu Xenial):
assignee: nobody → Stefan Bader (smb)
Changed in ubuntu-fan (Ubuntu Yakkety):
assignee: nobody → Stefan Bader (smb)
Changed in ubuntu-fan (Ubuntu Zesty):
assignee: nobody → Stefan Bader (smb)
Stefan Bader (smb) on 2017-06-09
Changed in ubuntu-fan (Ubuntu Yakkety):
status: In Progress → Fix Committed

Hello Stefan, or anyone else affected,

Accepted ubuntu-fan into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-fan/0.12.0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Stefan Bader (smb) wrote :

Ran the dep8 tests which would fail for the LXD test if disable-fan without docker installed would produce an error message. Both tests passed.

tags: added: verification-done
removed: verification-needed
tags: added: verification-done-yakkety
removed: verification-done
Brian Murray (brian-murray) wrote :

There seems to be an autopkgtest regression: http://autopkgtest.ubuntu.com/packages/u/ubuntu-fan/yakkety/amd64

Could someone have a look at that?

Changed in ubuntu-fan (Ubuntu Yakkety):
status: Fix Committed → Incomplete
Stefan Bader (smb) wrote :

Not sure what that was. I just hit re-try this morning and it passed now.

Changed in ubuntu-fan (Ubuntu Yakkety):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-fan - 0.12.0.2

---------------
ubuntu-fan (0.12.0.2) yakkety; urgency=medium

  * fanatic: Prevent error message without docker installed (LP: #1691485)
  * dep8: Add LXD auto-test

 -- Stefan Bader <email address hidden> Wed, 07 Jun 2017 17:48:26 +0200

Changed in ubuntu-fan (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments