useless diagnostics in dpkg.log from journalctl due to ellipses

Bug #1693948 reported by Seth Arnold
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
init-system-helpers (Ubuntu)
Fix Released
Undecided
Unassigned
Xenial
Confirmed
Medium
Unassigned
Bionic
Fix Released
Undecided
Unassigned

Bug Description

Many of the apport hooks try to include some information about why a service didn't start correctly. One recent report included the following:

May 26 18:39:19 ux305ua-linux systemd[1]: Starting OpenBSD Secure Shell serv....
May 26 18:39:19 ux305ua-linux sshd[2500]: /etc/ssh/sshd_config line 64: miss....
May 26 18:39:19 ux305ua-linux systemd[1]: ssh.service: Main process exited, ...a
May 26 18:39:19 ux305ua-linux systemd[1]: Failed to start OpenBSD Secure She....
May 26 18:39:19 ux305ua-linux systemd[1]: ssh.service: Unit entered failed s....
May 26 18:39:19 ux305ua-linux systemd[1]: ssh.service: Failed with result 'e....
Hint: Some lines were ellipsized, use -l to show in full.

The actual error information is this:

/etc/ssh/sshd_config line 64: miss....
and
Failed with result 'e....

This is very nearly useless.

We should include the -l parameter as suggested so that we stand a chance of seeing an error that doesn't occur in the first twenty characters of program output.

Thanks

tags: added: rls-bb-incoming
Revision history for this message
Brian Murray (brian-murray) wrote :

The manual for journalctl for artful indicates that the default should be the full line.

       --no-full, --full, -l
           Ellipsize fields when they do not fit in available columns. The default is to show full fields, allowing them to wrap or be truncated by the pager, if one is used.

           The old options -l/--full are not useful anymore, except to undo --no-full.

Do you happen to know from which release the crash report you saw had ellipsized lines?

Revision history for this message
Brian Murray (brian-murray) wrote :

Looking at manpages for previous releases of Ubuntu they all contain the same information about --full for journalctl. I did find lines being ellipsized in a DpkgTerminalLog.txt file. Is that what you were looking at? An example:

Instalowanie nowej wersji pliku konfiguracyjnego /etc/apparmor.d/abstractions/libvirt-qemu ...
Setting up libvirt-daemon dnsmasq configuration.
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
   Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2017-03-07 13:07:21 CET; 44ms ago
  Process: 1289 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=2)
  Process: 1272 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)
      CPU: 25ms

mar 07 13:07:21 Leoo-G5 systemd[1]: Starting dnsmasq - A lightweight DHCP and caching DNS server...
mar 07 13:07:21 Leoo-G5 dnsmasq[1272]: dnsmasq: syntax check OK.
mar 07 13:07:21 Leoo-G5 dnsmasq[1289]: dnsmasq: failed to create listening socket for 127.0.0.1: Address al… in use
mar 07 13:07:21 Leoo-G5 systemd[1]: dnsmasq.service: Control process exited, code=exited status=2
mar 07 13:07:21 Leoo-G5 systemd[1]: Failed to start dnsmasq - A lightweight DHCP and caching DNS server.
mar 07 13:07:21 Leoo-G5 systemd[1]: dnsmasq.service: Unit entered failed state.
mar 07 13:07:21 Leoo-G5 systemd[1]: dnsmasq.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.

Changed in apport (Ubuntu):
status: New → Incomplete
Revision history for this message
Brian Murray (brian-murray) wrote :

Ah bug 1713435 looks like the situation you've reported. DpkgTerminalLog.txt contains the ellipsized lines but JournalErrors.txt does not.

summary: - useless diagnostics from journalctl due to ellipses
+ useless diagnostics in DpkgTerminalLog from journalctl due to ellipses
Revision history for this message
Seth Arnold (seth-arnold) wrote : Re: useless diagnostics in DpkgTerminalLog from journalctl due to ellipses

Thanks Brian; should we retarget this bug to dpkg to get it to show different output? or is it still apport that is collecting ellipsized logs?

Revision history for this message
Brian Murray (brian-murray) wrote :

The file /var/log/dpkg.log contains the ellipsized lines so yeah I think dpkg is better place for this.

summary: - useless diagnostics in DpkgTerminalLog from journalctl due to ellipses
+ useless diagnostics in dpkg.log from journalctl due to ellipses
Changed in apport (Ubuntu):
status: Incomplete → Confirmed
affects: apport (Ubuntu) → dpkg (Ubuntu)
tags: added: id-59ea53165a72f7114d0742ef
Balint Reczey (rbalint)
affects: dpkg (Ubuntu) → init-system-helpers (Ubuntu)
Revision history for this message
Balint Reczey (rbalint) wrote :

Fixed in https://salsa.debian.org/debian/init-system-helpers/commit/5836b307724f8731b47d3d4d064ada1833182705 thus the package is fixed in version debian/1.49 and later.

Changed in init-system-helpers (Ubuntu Xenial):
status: New → Confirmed
Changed in init-system-helpers (Ubuntu):
status: Confirmed → Fix Released
Changed in init-system-helpers (Ubuntu Bionic):
status: New → Fix Committed
status: Fix Committed → Fix Released
Changed in init-system-helpers (Ubuntu Xenial):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers