Comment 13 for bug 1281250

Upstream comment:

"I think that the TLS security type (18) is rather uncommon, but gtk-vnc
supports it. I think that virt-viewer uses gtk-vnc and should work:

http://virt-manager.org/download/
"

so basically the problem is that vino is using an encryption type which is supported only by few clients. The optimal solution would be to help vino developers to add a more common encryption type; for the time being, I will test the suggested viewer and comment.