[SRU] Please backport light-locker-settings 1.2.1-0ubuntu2 to trusty

Bug #1326741 reported by Sean Davis
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
light-locker-settings (Ubuntu)
Fix Released
Critical
Unassigned
Trusty
Fix Released
Critical
Unassigned
Utopic
Fix Released
Critical
Unassigned

Bug Description

Please note that this is a two-part fix, please see the second SRU here:
https://bugs.launchpad.net/ubuntu/+source/xfce4-power-manager/+bug/1326740

[Impact]
The updated "xfce4-power-manager" and "light-locker-settings" packages resolve a high-importance issue.
LP: #1303736 "Black screen after wakeup from suspending by closing the laptop lid"

 * Users who experience this bug find that their computer is unusable when resuming from suspend. The screen is black and there is no indication of how to restore their session. As a result, the user can only power off the computer, losing their unsaved work.

 * Since this bug causes a loss of work and usability, it is very important that the packages be uploaded quickly.

[Test Case]
This bug affects a large number of laptop users. To reproduce:

 1) Make sure light-locker is running and set to lock on suspend.
 2) Suspend the computer (lid close or the menu)
 3) Resume the computer.
 4) Unlock the user session.

[Regression Potential]
 * There is very low risk of regression. The changes to both applications are only applied when the user changes settings using light-locker-settings. The logind inhibition in xfce4-power-manager only inhibits the lid-close event, and all other events are controlled as they are now.

[Other Info]

 * Affected users will have to restart xfce4-power-manager and light-locker-settings to apply the updated settings. In order to fix the issue...
   1) sudo apt-get install xfce4-power-manager light-locker-settings
   2) Restart session or "killall xfce4-power-manager; xfce4-power-manager"
   3) Use light-locker-settings to toggle the setting.
      a) Disable "Lock on Suspend"
      b) Click "Apply"
      c) Enable "Lock on Suspend"
      d) Click "Apply"

Sean Davis (bluesabre)
description: updated
Revision history for this message
Sean Davis (bluesabre) wrote :

Attaching debdiff for no-change backport from utopic.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "debdiff backport from utopic to trusty" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

Thanks for the debdiff! I've uploaded it to be processed by the SRU team.

I made a few minor changes to the changelog:
1- used "trusty" instead of "trusty-backports"
2- removed utopic changelog entries, and merged into a single one
3- changed version number

Changed in light-locker-settings (Ubuntu Utopic):
status: New → Fix Released
Changed in light-locker-settings (Ubuntu Trusty):
status: New → In Progress
Sean Davis (bluesabre)
tags: added: verification-needed
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Sean, or anyone else affected,

Accepted light-locker-settings into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/light-locker-settings/1.2.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in light-locker-settings (Ubuntu Trusty):
status: In Progress → Fix Committed
Pasi Lallinaho (knome)
Changed in light-locker-settings (Ubuntu Utopic):
importance: Undecided → Critical
Changed in light-locker-settings (Ubuntu Trusty):
importance: Undecided → Critical
Revision history for this message
Sean Davis (bluesabre) wrote :

Marking as verification-done as verification has been performed with https://bugs.launchpad.net/ubuntu/trusty/+source/xfce4-power-manager/+bug/1326740

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-locker-settings - 1.2.1-0ubuntu1.1

---------------
light-locker-settings (1.2.1-0ubuntu1.1) trusty; urgency=medium

  * Add 01_xfpm_to_not_control_lock_on_suspend (LP: #1326741)
 -- Sean Davis <email address hidden> Thu, 05 Jun 2014 23:26:41 -0400

Changed in light-locker-settings (Ubuntu Trusty):
status: Fix Committed → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote : Update Released

The verification of the Stable Release Update for light-locker-settings has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers