[SRU] Please backport xfce4-power-manager 1.2.0-3ubuntu6 to trusty

Bug #1326740 reported by Sean Davis on 2014-06-05
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xfce4-power-manager (Ubuntu)
Critical
Unassigned
Trusty
Critical
Unassigned
Utopic
Critical
Unassigned

Bug Description

Please note that this is a two-part fix, please see the second SRU here:
https://bugs.launchpad.net/ubuntu/+source/light-locker-settings/+bug/1326741

[Impact]
The updated "xfce4-power-manager" and "light-locker-settings" packages resolve a high-importance issue.
LP: #1303736 "Black screen after wakeup from suspending by closing the laptop lid"

 * Users who experience this bug find that their computer is unusable when resuming from suspend. The screen is black and there is no indication of how to restore their session. As a result, the user can only power off the computer, losing their unsaved work.

 * Since this bug causes a loss of work and usability, it is very important that the packages be uploaded quickly.

[Test Case]
This bug affects a large number of laptop users. To reproduce:

 1) Make sure light-locker is running and set to lock on suspend.
 2) Suspend the computer by closing the laptop lid.
 3) Resume the computer.
 4) Unlock the user session.

[Regression Potential]
 * There is very low risk of regression. The changes to both applications are only applied when the user changes settings using light-locker-settings. The logind inhibition in xfce4-power-manager only inhibits the lid-close event, and all other events are controlled as they are now.

[Other Info]
 * Affected users will have to restart xfce4-power-manager and light-locker-settings to apply the updated settings. In order to fix the issue...
   1) sudo apt-get install xfce4-power-manager light-locker-settings
   2) Restart session or "killall xfce4-power-manager; xfce4-power-manager"
   3) Use light-locker-settings to toggle the setting.
      a) Disable "Lock on Suspend"
      b) Click "Apply"
      c) Enable "Lock on Suspend"
      d) Click "Apply"

Sean Davis (bluesabre) on 2014-06-05
description: updated
Sean Davis (bluesabre) wrote :

Attaching debdiff for no-change backport from utopic to trusty

The attachment "debdiff backport from utopic to trusty" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Marc Deslauriers (mdeslaur) wrote :

Thanks for the debdiff! I've uploaded it to be processed by the SRU team.

I made a few minor changes to the changelog:
1- used "trusty" instead of "trusty-backports"
2- removed utopic changelog entries, and merged into a single one
3- changed version number

Changed in xfce4-power-manager (Ubuntu Utopic):
status: New → Fix Released
Changed in xfce4-power-manager (Ubuntu Trusty):
status: New → In Progress

As for the test case, step 2 requires lid close it not reproducible using the menu

Confirming that the utopic deb files fix the issue in trusty
light-locker-settings_1.2.1-0ubuntu2_all.deb
xfce4-power-manager_1.2.0-4ubuntu1_amd64.deb
xfce4-power-manager-data_1.2.0-4ubuntu1_all.deb
xfce4-power-manager-plugins_1.2.0-4ubuntu1_amd64.deb

i seem to have a regression with sound though after suspend, maybe it is a linux 3.15 kernel bug but i doubt it
Mmy sound output device is switched to a dummy output, using analog duplex output

update: regression seems to be a kernel bug, not reproducible using linux 3.13.4

Sean Davis (bluesabre) on 2014-06-16
tags: added: verification-needed

Hello Sean, or anyone else affected,

Accepted xfce4-power-manager into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xfce4-power-manager/1.2.0-3ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xfce4-power-manager (Ubuntu Trusty):
status: In Progress → Fix Committed
Pasi Lallinaho (knome) on 2014-06-18
Changed in xfce4-power-manager (Ubuntu Trusty):
importance: Undecided → Critical
Changed in xfce4-power-manager (Ubuntu Utopic):
importance: Undecided → Critical
Sean Davis (bluesabre) on 2014-06-19
description: updated
bbop (brentastic) wrote :

Hi all, I posted a comment on this issue in the thread : [http://ubuntuforums.org/showthread.php?t=2220085], and was asked to post a comment on the results of a suggestion I received:

The suggestion was :
* enable trusty-proposed repository.
* install the updated "light-locker-settings" and "xfce4-power-manager" packages:
* restart
* Using light-locker-settings, toggle "Lock on Suspend" --> disable -->Enable

I then restarted. From there, when I suspend, and then "wake up", screen is active only for long enough to see the password prompt (which I could not see before doing this). After entering the password, however, the screen once again goes blank.

Thanks for your help, and if you have any other suggestions, I'll give them a try and report back.

Sean Davis (bluesabre) wrote :

@bbop

To be precise, be sure to:

1) Enable lock on suspend.
2) Click apply.
3) Disable lock on suspend.
4) Click apply.

Let me know if that works for you. If not, we can debug further.

Sean Davis (bluesabre) wrote :

Edit: Disable, apply, Enable, apply.

bbop (brentastic) wrote :

Hi Sean, thanks for the note, I tried both final conditions of "Enabled" and "disabled"

Enabled and clicked "Apply", then disabled and clicked "Apply", tried suspending.
Enabled and clicked "Apply", Disabled and clicked "Apply", then enabled _again_ and clicked "Apply", tried suspending.

Neither worked, (though in the first case, I was able to see only a faded version of the "drop-down" menu that comes down when you click the on/off/settings buttom at the top right hand corner. It wasn't active and I couldn't click anything, it was just a faded image on an otherwise black screen.) Couldn't do anything.

bbop (brentastic) wrote :

Just to add: I don't have the level of expertise of a developper; I'm just a marginally-competent user, but I'd like to help out in whatever way I can, and as the note above mentions, since this problem can result in lost unsaved data for others, it would be important to fix it before too many people encounter it and get turned off of Linux.

I'm also aware that sometimes these types of bugs are hard to reproduce on other machines that are working properly, so if it would help, I'd be willing to arrange a meeting over skype on my laptop so that I can show you what's happening and perhaps provide more information as to how things are going wrong on my particular system (I'll send my contact via PM). Of course, I also don't want to get in the way of things either; just let me know if there's anything else I can do.

Sean Davis (bluesabre) wrote :

Thanks for the feedback bbop. If possible, please provide the output to the following commands:

grep Exec ~/.config/autostart/light-locker.desktop

grep Exec ~/.config/autostart/screensaver-settings.desktop

ps ux | grep light-locker

xfconf-query -c xfce4-session -l -v | grep Lock

xfconf-query -c xfce4-power-manager -l -v | grep "dpms\|lock\|logind"

For this command, we're only interested in the "Screen Saver" and "DPMS" sections:
xset q

Will Law (williumbillium) wrote :

After enabling proposed, restarting, toggling "Enable lock on suspend" so it is enabled the bug is now fixed for me and the lock screen stays visible as expected.

bbop (brentastic) wrote :

ok, here's the output you requested: Keep in mind that I'm actually using a _Desktop_ PC, but it seems to be the same problem.

$ grep Exec ~/.config/autostart/light-locker.desktop
Exec=light-locker --lock-after-screensaver=0 --lock-on-suspend --no-late-locking

------------------------------------------------------
[ Note that this is when the "Log on suspend" switch is set to "on" (I'm assuming that this "enabled" state is the desired ultimate setting before trying to suspend.)

When "Log on suspend" switch is set to "off", however, then the output looks like this:
$ grep Exec ~/.config/autostart/light-locker.desktop
Exec=light-locker --lock-after-screensaver=0 --no-lock-on-suspend --no-late-locking

[For all subsequent output listed in this comment, "Lock on suspend" is set to "on", and left that way ]
------------------------------------------------------

$ grep Exec ~/.config/autostart/screensaver-settings.desktop
Exec=xset s 0 dpms 0 0 0

$ ps ux | grep light-locker
b*** 21994 0.0 0.0 18100 1440 pts/1 S+ 02:56 0:00 bash /usr/bin/light-locker-settings
b*** 22005 0.3 0.7 525168 30504 pts/1 Sl+ 02:56 0:01 python /usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py
b*** 22058 0.0 0.2 345596 10640 pts/1 Sl+ 03:01 0:00 light-locker --lock-after-screensaver=0 --lock-on-suspend --no-late-locking
b*** 22078 0.0 0.0 17412 944 pts/0 S+ 03:03 0:00 grep --color=auto light-locker

[I've editted this only to change my user account name to b***)

$xfconf-query -c xfce4-session -l -v | grep Lock
$

$ xfconf-query -c xfce4-power-manager -l -v | grep "dpms\|lock\|logind"
$
[no output from either of these last two.]

$ xset q
[*bunch of other stuff*]
Screen Saver:
  prefer blanking: yes allow exposures: yes
  timeout: 0 cycle: 0
[*bunch of other stuff*]
DPMS (Energy Star):
  Standby: 0 Suspend: 0 Off: 0
  DPMS is Enabled
  Monitor is On

If you need anything else, let me know.

Simon Steinbeiß (ochosi) wrote :

@bbop: If it's not a laptop or it has no lid to be closed, then it's *not* the same issue.

bbop (brentastic) wrote :

@Simon: It's suspending and not waking up. The comments in this forum [http://ubuntuforums.org/showthread.php?t=2220085] describe exactly the same behaviour on their laptops screens ("Black screen, hardware on and no responses from keyboard" ) as on my desktop screen. Whether the wake-up trigger is opening the lid or pressing a key shouldn't matter (ok, *shouldn't*, whether it _does_ or not is another question).

At any rate, this is also a problem for desktop users, and the issue is closely enough related (I would say it's really the same thing) that I didn't want to start a separate bug report. I said in the forum that I was using a Desktop and I was asked to report back the results here, so I did.

Sean Davis (bluesabre) wrote :

I'd investigate if the same issue occurs with just locking and unlocking. Lock your screen from the "Lock Screen" button in the menu, and then log back in. Let's try without suspending and see if the same problem occurs.

bbop (brentastic) wrote :

> I'd investigate if the same issue occurs with just locking and unlocking.

ok... Did that and it worked fine. After clicking "Lock" at the top screen, the screen switches to a password prompt with my desktop background behind it (it never actually goes blank here). Keyboard and mouse were still active, and upon entering my password, I was able to continue typing this comment.

Sean Davis (bluesabre) wrote :

OK, I think we should start debugging this in realtime. Can you head over to http://xubuntu.org/irc/ and join the webchat? I'm bluesabre on #xubuntu

bbop (brentastic) wrote :

ok, so just to follow up, I went to software & updates and switched the selection from

Using X.org Xserver -Nouveau display driver ...
 to
Using NVIDIA binary driver -version 331.38 from nvidia-331(proprietary tested)

and restarted. The load-up screen is a little different (not quite as 'sexy' :), but I'm ok with that) and now I'm able to suspend and wake-up without a problem.

The lock ->unlock functionality was fine for either driver.
So, anyway, my problem is fixed, but if you want me to do any further testing with the original open-source driver, let me know.

and THANKS FOR THE HELP!

Sean Davis (bluesabre) wrote :

^ In addition to the above, we determined that this issue applies to unity and not light-locker. The user is currently using Ubuntu and not Lubuntu/Xubuntu where light-locker may be currently used.

Shuhao (shuhao) wrote :

Works for me for 14.04 with the Thinkpad W530!

Sean Davis (bluesabre) wrote :

Marking as verification done as multiple users have now verified. Also marking light-locker-settings as verification done since it is part of the fix.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-power-manager - 1.2.0-3ubuntu4.1

---------------
xfce4-power-manager (1.2.0-3ubuntu4.1) trusty; urgency=medium

  * Add 10_inhibit_logind.patch (LP: #1326740)
 -- Sean Davis <email address hidden> Thu, 05 Jun 2014 23:30:27 -0400

Changed in xfce4-power-manager (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xfce4-power-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers