AMDRadeon HD 8670A/8670M/8690M [1002:6660] System freezes after resume from suspend with fglrx-updates

Bug #1308954 reported by Po-Hsu Lin on 2014-04-17
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
HWE Next
Critical
Alberto Milone
Trusty
Critical
Alberto Milone
fglrx-installer-updates (Ubuntu)
Critical
Alberto Milone
Trusty
Critical
Alberto Milone

Bug Description

SRU Justification

[impact]
this bug is blocking us to pass certification on OEM hardware.

[test case]
1. Install 14.04 and fglrx-updates driver
2. Suspend the machine
3. Wake it up

Expected result:
* Everything should work fine before and after S3

[regression potential]

---------------------

CID: 201305-13624

This system would freeze after resume from suspend with fglrx-updates on Trusty.

Steps:
1. Install 14.04, and fglrx-updates driver
2. Suspend
3. Wake it up

Expected results:
* Everything works fine before / after S3

Actual results:
* After S3, I can see the login screen, caps lock LED and touchpad still responsive, but I can't login. Few seconds later, system froze, error message could be found in syslog
kernel: [ 599.576267] <3>[fglrx:firegl_pplib_notify_event] *ERROR* PPLIB: PPLib Notify Event failed!
kernel: [ 599.576268] <3>[fglrx:firegl_pplib_notify_event] *ERROR* ulEventType = 00000002, ulEventData = 00000000

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: fglrx-updates 2:13.350.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Apr 17 16:42:48 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 fglrx-updates, 13.350.1, 3.13.0-23-generic, x86_64: installed
 fglrx-updates, 13.350.1, 3.13.0-24-generic, x86_64: installed
 fwts-efi-runtime-dkms, 14.03.01, 3.13.0-24-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:2162]
   Subsystem: Hewlett-Packard Company Device [103c:2162]
InstallationDate: Installed on 2014-04-10 (7 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140406)
MachineType: Hewlett-Packard HP Pavilion TS 14 Notebook PC
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic.efi.signed root=UUID=ef6ba3b5-e12b-4029-9d6b-cb1753a88ce5 ro quiet splash vt.handoff=7
SourcePackage: fglrx-installer-updates
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/27/2013
dmi.bios.vendor: Insyde
dmi.bios.version: B.09
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 2162
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 29.0A
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrB.09:bd05/27/2013:svnHewlett-Packard:pnHPPavilionTS14NotebookPC:pvr089C100000000010000630100:rvnHewlett-Packard:rn2162:rvr29.0A:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion TS 14 Notebook PC
dmi.product.version: 089C100000000010000630100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.11+14.04.20140409-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-4ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-4ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Apr 17 16:31:44 2014
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:
 Screen 1 deleted because of no matching config section.
 AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
 AIGLX error: failed to open /usr/lib64/dri/fglrx_dri.so, error[/usr/lib64/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
 AIGLX error: failed to open /usr/X11R6/lib/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.1-0ubuntu2
xserver.video_driver: fglrx

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
Gilles Gigan (gillesg) wrote :

Same problem here with HP laptop with AMD graphics. This workaround solves the problem for me: change to terminal 1 before suspend, and back to terminal 7 after resume.
Place attached script in /etc/pm/sleep.d/ and sudo chmod +x /etc/pm/sleep.d/20_fix_fglrx_freeze_on_resume

Chih-Hsyuan Ho (chih) wrote :

Please give the AMD Catalyst 14.9 driver a try which was just released recently has seemingly incorporated many bug fixes:

http://www2.ati.com/drivers/linux/amd-catalyst-14-9-linux-x86-x86-64.zip

Po-Hsu Lin (cypressyew) wrote :

Verified again on 201305-13624 with 14.04.1 + fglrx-update (2:13.350.1-0ubuntu2)
This issue still exist.

tags: removed: blocks-hwcert-enablement
Changed in fglrx-installer-updates (Ubuntu):
importance: Undecided → Medium
Po-Hsu Lin (cypressyew) on 2014-10-09
description: updated
Po-Hsu Lin (cypressyew) wrote :

Verified with the latest 14.9 Catalyst driver (release date 9/29/2014), this suspend issue could be solved by it.

Po-Hsu Lin (cypressyew) wrote :

Also affect 201305-13670 Dell Inspiron 2350, with the same GPU

tags: added: 201305-13670
Ara Pulido (ara) on 2014-10-27
Changed in fglrx-installer-updates (Ubuntu):
importance: Medium → High
importance: High → Critical
Changed in hwe-next:
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Critical
status: New → Triaged
description: updated
Alberto Milone (albertomilone) wrote :

fglrx 2:14.501-0ubuntu1 is in Ubuntu 15.04 now. I'll proceed with a backport for 14.04

Changed in fglrx-installer-updates (Ubuntu):
status: Confirmed → In Progress
Changed in fglrx-installer-updates (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer-updates (Ubuntu):
status: In Progress → Fix Released
job (jeppekdahl) on 2015-02-22
Changed in fglrx-installer-updates (Ubuntu):
assignee: Alberto Milone (albertomilone) → job (jeppekdahl)
job (jeppekdahl) on 2015-02-22
Changed in fglrx-installer-updates (Ubuntu Trusty):
status: In Progress → Fix Released

I am still having problems with this. Running a freshly installed 14.04. Any more information on how to get around this?

Po-Hsu Lin (cypressyew) wrote :

@Jason,
for the moment, you can download driver from AMD directly.
http://support.amd.com/en-us/download

Po-Hsu Lin (cypressyew) wrote :

@job (jeppekdahl)

Hi, from the launchpad page for fglrx-installer-updates [1] the version number is still 2:13.350.1
Could you explain why you mark it as "Fix-Released" in Trusty?

I will revert it to the status in comment #9

[1] https://launchpad.net/ubuntu/+source/fglrx-installer-updates

Changed in fglrx-installer-updates (Ubuntu):
assignee: job (jeppekdahl) → Alberto Milone (albertomilone)
Changed in fglrx-installer-updates (Ubuntu Trusty):
status: Fix Released → In Progress
Changed in hwe-next:
status: Triaged → Fix Released
To post a comment you must log in.