Comment 3 for bug 1311866

Steve Langasek (vorlon) wrote :

> firefox: https://launchpad.net/bugs/1451453
> arm64 only, not a regression

firefox failed to build on both arm64 and ppc64el in the toolchain test rebuild, but only failed on arm64 in a no-change rebuild.

/usr/bin/ld.bfd.real: ../libjs_static.a(linux64.o): ABI version 1 is not compatible with ABI version 2 output
/usr/bin/ld.bfd.real: failed to merge target specific data of file ../libjs_static.a(linux64.o)
/usr/bin/ld.bfd.real: ../libjs_static.a(linux64_closure.o): ABI version 1 is not compatible with ABI version 2 output
/usr/bin/ld.bfd.real: failed to merge target specific data of file ../libjs_static.a(linux64_closure.o)

https://launchpad.net/ubuntu/+archive/test-rebuild-20150317/+build/7074123

This looks to me like a toolchain-related regression.

> flite: https://launchpad.net/bugs/1451462
> fails to unpack (fuzz in diff)

Do we know why this problem affected the toolchain test rebuild, but not the no-change test rebuild? The behavior of dpkg-source in the trusty build environment should not have changed since March.

(In any case this is not an SRU blocker, because the problem is clearly not toolchain-triggered.)

> gcc-4.8:
> part of the proposed updates

There is also a build failure of gcc-4.7 on ppc64el, is that part of the update?

> pygresql: https://launchpad.net/bugs/1451530
> fails to build, needs fix from utopic

Reproducible here; but why did this build failure not show up in http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20150317-updates-trusty.html ?

> thunderbird:
> fails to build on arm64 and ppc64el, no regression.

And fixed in -updates.

> afaics, there is only one toolchain related build failure, u-boot.
> Both upstream and debian already stopped building that one,
> and this ZUMA platform was never supported in Ubuntu 14.04 LTS.

Indeed, u-boot is in main only because it's pulled in by jasper on armhf; we don't appear to use u-boot at all on powerpc. So this behavior change (which may be a deliberate change rather than a bug), if it only affects a single u-boot target on powerpc, doesn't seem to me like a blocker for the toolchain update.

Please address the firefox/ppc64el and gcc-4.7 questions.