hwe-support-status --show-replacements shows replacements that are installed

Bug #1607983 reported by Brian Murray on 2016-07-29
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Brian Murray

Bug Description

On a precise system I ran update-manager and choose to install the new HWE stack and then rebooted. After which I ran 'hwe-support-status --show-replacements' and saw the following:

bdmurray@clean-precise-amd64:~$ hwe-support-status
Your Hardware Enablement Stack (HWE) is supported until April 2017.
bdmurray@clean-precise-amd64:~$ hwe-support-status --show-replacements
linux-generic-lts-trusty linux-image-generic-lts-trusty

This seems odd to me given that the replacement packages are already installed.

bdmurray@clean-precise-amd64:~$ apt-cache policy linux-generic-lts-trusty
  Version table:
 *** 0
        500 http://mirrors.cat.pdx.edu/ubuntu/ precise-updates/main amd64 Packages
        500 http://mirrors.cat.pdx.edu/ubuntu/ precise-security/main amd64 Packages
        100 /var/lib/dpkg/status

On the plus side update-manager itself doesn't mention anything about the packages being out of date, likely because hwe-support-status does not exit 10.

Related branches

Brian Murray (brian-murray) wrote :

--show-replacements indicates that it "show what packages need installing to be supported", so this (print installed packages) doesn't seem like desired behavior.

tags: added: precise trusty
Changed in update-manager (Ubuntu):
importance: Undecided → Low
summary: - hwe-support-status --show-replacements show replacements that are
+ hwe-support-status --show-replacements shows replacements that are
Changed in update-manager (Ubuntu):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Changed in update-manager (Ubuntu Trusty):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)
no longer affects: update-manager (Ubuntu Trusty)
Changed in update-manager (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Low
Brian Murray (brian-murray) wrote :

I removed the Trusty task since the HWE support hasn't landed there anyway, so testing that the bug exists would be impossible e.g. the version of hwe-support-status uploaded to Trusty will only have the fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:16.10.5

update-manager (1:16.10.5) yakkety; urgency=medium

  [ Brian Murray ]
  * UpdateManager/UpdateManager.py: when marking HWE packages for install pass
    on a SystemError and let the problem resolver sort it out.
  * HweSupportStatus/consts.py: Improve wording of the messages.
  * hwe-support-status:
    - decode output when checking for foreign architectures so that the result
      is unicode not bytes.
    - add libwayland-egl1-mesa to the list of metapackages.
    - utilize a virtualbox metapackage set.
    - Do not show replacements that are already installed on
      the system. (LP: #1607983)
  * source_update-manager.py: collect information about the state of HWE
    support on the system. (LP: #1617080)
  * source_update-manager.py: only collect HWE information if it exists.

  [ Jeremy Bicha ]
  * Add gi.require_version in a few more places to reduce the annoying
    warnings. (LP: #1573177)

 -- Brian Murray <email address hidden> Thu, 08 Sep 2016 16:01:13 -0700

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers