gnome-settings-daemon segfaults in send_selection_notify() (incorrect clipboard handling)

Bug #873545 reported by Zordid on 2011-10-13
242
This bug affects 68 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Expired
Medium
gnome-settings-daemon (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

As described in [1] the crashes are caused by gnome-settings-daemons integrated clipboard manager trying to get clipboard content of applications being closed.

Stacktrace:
https://launchpadlibrarian.net/86505734/g-s-d_gdb_bt.log

Workaround:
gsettings set org.gnome.settings-daemon.plugins.clipboard active false

[1] http://my.opera.com/ruario/blog/2011/12/02/styling-lost-opera-shutdown

--
I just updated to Ubuntu 11.10 - and everything looked perfectly okay - except Nautilus!
All icons are the same, they are black/white and really "boring". The breadcrumb view looks like back in Windows 3.1 times...
:-(

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.2.0-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Thu Oct 13 19:58:36 2011
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (0 days ago)

Zordid (zordid-gmx) wrote :
Zordid (zordid-gmx) wrote :

Sorry. After second boot of the system everything went back to normal.
But still this is bad for everybody who updates!

Zordid (zordid-gmx) wrote :

New problem: the described behavior comes back every other boot.

Now I got the strange look again!!!

Please fix this - Ubuntu used to be so good - but now??

Zordid (zordid-gmx) wrote :

Even after a completely new install of Ubuntu 11.10 and a handfull of restarts of the system this bug comes again!

All my icons in Nautilus are gone - no nice UI anymore.

What is going on here?

summary: - After update Nautilus icons are black/white and not "normal"
+ After update Nautilus icons are black/white, no decorations of
+ breadcrumb etc.

Thank you for your bug report, could you add your ~/.xsession-errors to the bug when getting the issue?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Zordid (zordid-gmx) on 2011-10-17
Changed in nautilus (Ubuntu):
assignee: nobody → Zordid (zordid-gmx)
status: Incomplete → Invalid
status: Invalid → Incomplete
assignee: Zordid (zordid-gmx) → nobody

I can confirm, I am suffering the same issue. Opening Nautilus all ways possible results in an undecorated windows, without appropriate icons to denote file/folder type. Icons are actually just blank, white squares, with text underneath. Please let me know if I can attach anything which may be of use to help resolve this.

Ben Arnold (benedict-arnold) wrote :
Download full text (9.4 KiB)

Running X session wrapper
Loading profile from /etc/profile
Loading profile from /home/ben/.profile
Loading resource: /etc/X11/Xresources/x11-common
Loading X session script /etc/X11/Xsession.d/00_handle_guest_session
Loading X session script /etc/X11/Xsession.d/20x11-common_process-args
Loading X session script /etc/X11/Xsession.d/30x11-common_xresources
Loading X session script /etc/X11/Xsession.d/40x11-common_xsessionrc
Loading X session script /etc/X11/Xsession.d/50_check_unity_support
Loading X session script /etc/X11/Xsession.d/50x11-common_determine-startup
Loading X session script /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modules
Loading X session script /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
Loading X session script /etc/X11/Xsession.d/55gnome-session_gnomerc
Loading X session script /etc/X11/Xsession.d/60x11-common_localhost
Loading X session script /etc/X11/Xsession.d/60x11-common_xdg_path
Loading X session script /etc/X11/Xsession.d/60xdg-user-dirs-update
Loading X session script /etc/X11/Xsession.d/65compiz_profile-on-session
Loading X session script /etc/X11/Xsession.d/70gconfd_path-on-session
Loading X session script /etc/X11/Xsession.d/75dbus_dbus-launch
Loading X session script /etc/X11/Xsession.d/80appmenu
Loading X session script /etc/X11/Xsession.d/80appmenu-gtk3
Loading X session script /etc/X11/Xsession.d/80im-switch
Setting IM through im-switch for locale=en_NZ.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
Loading X session script /etc/X11/Xsession.d/90consolekit
Loading X session script /etc/X11/Xsession.d/90qt-a11y
Loading X session script /etc/X11/Xsession.d/90x11-common_ssh-agent
Loading X session script /etc/X11/Xsession.d/99x11-common_start
GNOME_KEYRING_CONTROL=/tmp/keyring-u9JdYL
GNOME_KEYRING_CONTROL=/tmp/keyring-u9JdYL
SSH_AUTH_SOCK=/tmp/keyring-u9JdYL/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-u9JdYL
GNOME_KEYRING_CONTROL=/tmp/keyring-u9JdYL
SSH_AUTH_SOCK=/tmp/keyring-u9JdYL/ssh
GPG_AGENT_INFO=/tmp/keyring-u9JdYL/gpg:0:1

(gnome-settings-daemon:1660): color-plugin-WARNING **: failed to get edid: unable to get EDID for output
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...yes
[LOG]: Moving Internal Files
[LOG]: Copying subdirectory from /home/ben/.compiz/session to /home/ben/.compiz-1/session
[LOG]: Copied file /home/ben/.compiz/session/10c077a98d8fd2fa0b131906346348993300000015730040 to /home/ben/.compiz-1/session/10c077a98d8fd2fa0b131906346348993300000015730040
[LOG]: Successfully moved internal files
Backend : gconf
Integration : true
Profile : unity
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
** (gnome-fallback-mount-helper:1691):Failed to play sound: File or data not found
Initializing nautilus-gdu extension
** (nautilus:1689): DEBUG: Syncdaemon not running, waiting for it to start in NameOwnerChanged
** Message: applet now removed from the notification area
Initializing opengl options...

Read more...

Ben Arnold (benedict-arnold) wrote :

This seemed to be a downstream effect of a display error I was having at start-up.

At start-up I was getting:

none of the selected modes were compatible with the possible modes:
Trying modes for CRTC 351
CRTC 351: trying mode 3360x1050@50Hz with output at 1680x1050@50Hz (pass 0)
CRTC 351: trying mode 3360x1050@50Hz with output at 1680x1050@50Hz (pass 1)

I fixed this by doing the following:
1. Cog Icon, System Settings, Additional Drivers.
2. Click "NVIDIA accelerated graphics griver (post-release updates) (version current-updates)".
3. Click Acitivate and wait for the install process to finish.
4. Restart Ubuntu.

I guess that if my solution works for everyone else then there are two bugs here. One is that the update of the NVIDIA drivers to the latest version should be part of the Ubuntu upgrade, the other is that the pos-release updates should be the recommend version. This might amount to the same thing.

Not sure how fixing the display error on start-up fixed the problems with Nautilus.

Diego (dmollaaliod) wrote :

I have the same problem but I'm using the NVIDIA accelerated graphics driver - post-release notes... has anybody else had the same problem and fixed it?

Even with the right graphics driver, I still have the same error about the display at startup.

Filip Vařecha (xaralis) wrote :

I can confirm something similar happening to me. Sometimes, after startup icons are fine for something like 20 seconds and after that they turn into non-decorated ones using some horrible theme. Nautilus is the only application suffering from this as you can see from screenshot attached - unity panel is not affected.

Strange is that this does not happen everytime but simply randomly. I have similar log records as listed in #7 and using post-release Nvidia driver.

Will try downgrading to nvidia non-post-release version.

Zordid (zordid-gmx) wrote :

Happens again and again and again.
Bad show!

Please fix it!

RonsonK (ronsonk) wrote :

This randomly happens to me. One indicator is that the Unity bar at the top will flash. If I then go to Nautilus, the app and icons have changed to a different theme. Screenshot attached.

ross (ross-rossmoore) wrote :

Screenshot from ronsonk exactly describes the problem for me too. Reboots don't fix it. I'm using Nvidia proprietary drivers. I noticed the problem for the first time today, the install (since fresh a week ago) has been fine until now.
Possibly related - sound sometimes doesn't start properly either (starting cheese sometimes fixes it - go figure!), and the shutdown button top right just seems to log me out when I choose restart while the "shut down" application does work.

Something's screwy...

Per Vikman (pelleve) wrote :

White icons and no logout button was my problem too after upgrading from 10.04 to 11.10 through the releases 11.10 and 11.04.

Found a solution by coincidence: had also a mismatch in wallpaper resolution and opened the select wallpaper (background) menu by right clicking on the desktop.

When clicking on the different themes I discovered that "Ambiance" and "Radiance" triggered the correct appearence to the white icons. And also showed the log out button at the clock.
Selecting the 'contrast' themes regenerated the white icons.

Per Vikman (pelleve) wrote :

edit: upgrade through 10.10 and 11.04

Dmitry Shachnev (mitya57) wrote :

@Everyone affected: Can you please paste output of these commands (to ensure that you have needed packages installed and properly configured):

1. apt-cache policy humanity-icon-theme ubuntu-mono
2. gsettings get org.gnome.desktop.interface icon-theme

Filip Vařecha (xaralis) wrote :

[~] $ apt-cache policy humanity-icon-theme ubuntu-mono
humanity-icon-theme:
  Instalovaná verze: 0.5.3.11
  Kandidát: 0.5.3.11
  Tabulka verzí:
 *** 0.5.3.11 0
        500 http://cz.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status
ubuntu-mono:
  Instalovaná verze: 0.0.37
  Kandidát: 0.0.37
  Tabulka verzí:
 *** 0.0.37 0
        500 http://cz.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

[~] $ gsettings get org.gnome.desktop.interface icon-theme
'Faenza-Cupertino'

ross (ross-rossmoore) wrote :

apt-cache policy humanity-icon-theme ubuntu-mono
ubuntu-mono
humanity-icon-theme:
  Installed: 0.5.3.11
  Candidate: 0.5.3.11
  Version table:
 *** 0.5.3.11 0
        500 http://hk.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
ubuntu-mono:
  Installed: 0.0.37
  Candidate: 0.0.37
  Version table:
 *** 0.0.37 0
        500 http://hk.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

gsettings get org.gnome.desktop.interface icon-theme
'ubuntu-mono-dark'

RonsonK (ronsonk) wrote :

apt-cache policy humanity-icon-theme ubuntu-mono
humanity-icon-theme:
  Installed: 0.5.3.11
  Candidate: 0.5.3.11
  Version table:
 *** 0.5.3.11 0
        500 http://ubuntu.mirror.rafal.ca/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
ubuntu-mono:
  Installed: 0.0.37
  Candidate: 0.0.37
  Version table:
 *** 0.0.37 0
        500 http://ubuntu.mirror.rafal.ca/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

gsettings get org.gnome.desktop.interface icon-theme
'ubuntu-mono-dark'

Dmitry Shachnev (mitya57) wrote :

Thanks, now I see that it's not a icon theme isuue.

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
Balogh Zsolt (bzzhu) wrote :

This seems to be an issue with the gnome-settings-daemon. When I run this line I will have my icons back:
gnome-settings-daemon &
killall nautilus

Several users had this problem also with the previous versions. It seemed to be a timing issue as if I started my X session with this it worked.

idovecer (igor-dovecer) wrote :

Yes,
this bug is in Ubuntu from version 10.04. Then I have added to Startup App gnome-settings-daemon and it seems that was better, because my problem was in 10.04-11.04 that every boot was started already started with this gray-ed icons.

Didn't try this in new 11.10 instllation becauise this gray icons show unexpectedly.

Anyway in 11.10 I have the same problem.
What is more strange that this bug is set as IMPORTANCE LOW.

So, Ubuntu have this bug for almost 2 years and no one did resolve it.

Arun (arunmarjun) wrote :

starting gnome-settings-daemon resolved it. As dove_g did, I added it to my startup. This is still a bug though.

Dan Lea (danlea) wrote :

Bug #881263 has been marked a duplicate of this one, although the circumstances of its appearance are different. Those experiencing that bug see the change in theme upon exiting an application, specifically Opera. It's possible that gnome-settings-daemon is crashing when Opera is closed (after moderate use) - I'll check this out if I have time. When this happens I get a lot of disk activity before the Opera window disappears.

RonsonK (ronsonk) wrote :

I can confirm that the bug rears it's head after closing Opera.

Dan Lea describes what happens perfectly. After I close Opera, the Opera window sticks around for 1-2 seconds while the disk thrashes. It then closes, the Unity bar across the top of the screen flickers (I'm assuming as gnome-settings-daemon crashes), and Nautilus resets its icons/theme.

If needed, is there anything I can do to capture the error messages that gnome-settings-daemon would produce as it crashes? Someone would have to tell me what to do / where to look for that.

Dan Lea (danlea) wrote :

Having just closed Opera and have this happen, gnome-settings-daemon is still running. Issuing a 'nautilus -q' and opening a nautilus window again brings everything back to normal.

Dan Lea (danlea) wrote :

...*but*, it appears that gnome-settings-daemon had only just started/restarted after closing Opera (based on the start time of the process).

Dmitry Shachnev (mitya57) wrote :

You can debug gnome-settings-daemon crashes/exits using Apport (read here how to enable it: https://wiki.ubuntu.com/Apport#How_to_enable_apport).

This service will generate crash reports and promt you to file a bug in Launchpad. Once you did it, please add its number in a comment.

idovecer (igor-dovecer) wrote :

Yes,
after closing Opera (Ubuntu freezes for 2-3 seconds) then Nautilus get gray icons.

Command nautilus -q and start again nautilus seems to solving this problem.

Dan Lea (danlea) wrote :

Opera terminal output on close:
I get this five times output five times:

** (opera:2185): CRITICAL **: os_pager_hide: assertion `OS_IS_PAGER (pager)' failed

(opera:2185): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

** (opera:2185): CRITICAL **: os_pager_set_parent: assertion `OS_IS_PAGER (pager)' failed

Whether or not this constitutes a crash, or is useful to anyone debugging Ubuntu, I don't know. I tried temporarily running Apport (sudo service apport start force_start=1), but the event did not trigger a bug report.

Dan Lea (danlea) wrote :

Something that may be noteworthy: a separate instance of Nautilus run after the problem occurs (say as root) appears with the correct theme.

Dan Lea (danlea) wrote :

And it seems that an already open root instance of nautilus is either entirely unaffected, or only transiently affected (a couple of seconds), by the problem, though a root instance of Opera still affects the user instance of Nautilus.

Zordid (zordid-gmx) wrote :

The problem with the undecorated elements happened again - in my case when I start Ubuntu.

nautilius -q
and restarting it with
nautilus

seems to "fix" it. At least that's quicker than a new restart... :-(
Any chance this bug is fixed soon??

Dan Lea (danlea) wrote :

Perhaps it's helpful to note that when the problem occurs the unity panel also briefly drops it's theme (most obvious with the panel icons for Empathy for example, if you've re-enabled them), but quickly restores it, whereas Nautilus is not restored.

Sebastien Bacher (seb128) wrote :

Seems like gnome-settings-daemon is having issue, nautilus doesn't pick up the theme again when that happens

affects: nautilus (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Incomplete
Giorgio (gioloi72) wrote :

The same thing happens to me after printing. Every time I send something to the printer Nautilus switches to the ugly icons. I need to kill the nautilus process and restart it to solve the problem

Sebastien Bacher (seb128) wrote :

Thank Giorgio, could you open a new bug using ubuntu-bug gnome-settings-daemon and add your .xsession-errors after getting the issue to it?

Hi, I opened a new bug:
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/894341

Giorgio

2011/11/24 Sebastien Bacher <email address hidden>

> Thank Giorgio, could you open a new bug using ubuntu-bug gnome-settings-
> daemon and add your .xsession-errors after getting the issue to it?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/873545
>
> Title:
> After update Nautilus icons are black/white, no decorations of
> breadcrumb etc.
>
> Status in “gnome-settings-daemon” package in Ubuntu:
> Incomplete
>
> Bug description:
> I just updated to Ubuntu 11.10 - and everything looked perfectly okay -
> except Nautilus!
> All icons are the same, they are black/white and really "boring". The
> breadcrumb view looks like back in Windows 3.1 times...
> :-(
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: nautilus 1:3.2.0-0ubuntu5
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 1.23-0ubuntu3
> Architecture: amd64
> Date: Thu Oct 13 19:58:36 2011
> ExecutablePath: /usr/bin/nautilus
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
> ProcEnviron:
> PATH=(custom, user)
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> SourcePackage: nautilus
> UpgradeStatus: Upgraded to oneiric on 2011-10-13 (0 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/873545/+subscriptions
>

Daniel van Vugt (vanvugt) wrote :

Confirmed. Multiple xsession-errors log files showing the crash of gnome-settings-daemon can be found in dupe bug 879793.

The common factor when the theme is lost seems to be this error:

(gnome-settings-daemon:2108): Gdk-WARNING **: The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1265 error_code 8 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Confirmed
summary: - After update Nautilus icons are black/white, no decorations of
- breadcrumb etc.
+ No GTK theme applied on login

@vanvugt: So maybe this is the same issue that causes LightDM shutdown & a11y dialogs to not use Ambiance theme?

Daniel van Vugt (vanvugt) wrote :

I'm not sure what LightDM issue you're referring to, but I do believe similar issues with gnome-settings-daemon dying at any time will cause a loss of the theme.

However I have tried to be careful to distinguish between different error codes because there could be multiple bugs. In my case, if the theme is missing when I log in then .xsession-errors always shows that gnome-settings-daemon had the codes:
"error_code 8 request_code 3 minor_code 0"

Hernando Torque (htorque) wrote :

In my case (see bug 859723) this happens with Opera and KeepassX whenever I close the application with some of its content in the clipboard. Eg. I copy a password in KeepassX or something on a web page in Opera, then close the application.

I'm attaching the backtrace from bug 859723 for what it's worth.

Col Hathi (colhathi) wrote :

I don't think the buttons for the theme appeared for my install until i changed the following default setting in dconf-editor:

/org/gnome/desktop/applications/interface/buttons_have_icons true (default is false)
                                                                screensaver/idle-activation-enabled true
Also i had to make sure the xsettings in gconf-editor were set to true and

I had to change the key so that nautilus didn't control the desktop (so no drag and drop icons on the desktop from nautilus)
Other wise my cpus were cooking and install was freezing all the time. Oh and i had to create a couple of symlinks for the unity icons - seems there was a change of name from "groups" to "categories" preventing .desktop items to be found for non-standard applications i used in 11.04.

 I realise these are all just work arounds but at least unity is usable now.

Col Hathi (colhathi) wrote :

Even though this is not relevant, i'll continue with my rant:

I also had to ensure that the compiz plugin gtk had been checked in ccsm at least once.
The compiz plugin wallpaper had to be checked and set to be identical to the wallpaper set in system settings otherwise the dash was always on the bottom of the windows stack with the super button was pressed.
I still can't get the rotating cube viewport switcher to work without flashing but the default wall works so there's no need to have an epileptic fit.
But i'm still getting the dbus warnings (don't know the cause yet) and glib-gobject errors and indexing errors when nautilus is opened but not to the same extent as immediately after the upgrade. This has prevented me from opening very large documents to work on.

Another victory for those who advise against upgrades in favour of new installs.

Col Hathi (colhathi) wrote :

In post #45 i should have mentioned that the following should be set:
/org/gnome/desktop/applications/interface/menus-must-have-icons true (default is false)
gtk-theme set to Adwaita or whatever you want
icon-theme set to Faenza-Ambiance or what ever you want
toolbar-icon-size large/small whatever you want

I also had to make sure that my legacy gnome panel icons were whitelisted in the key /desktop/unity/panel

Also to further reduce errors/warnings from filling .xsession-errors file, i had to disable "Tear-Free-Desktop" setting in amdcccle for my ATI graphics using fglrx.

Daniel van Vugt (vanvugt) wrote :

Hey all. If this bug affects you then please:

1. Wait for the bug to happen again.
2. As soon as it happens run: cp ~/.xsession-errors /tmp/xsession-errors.txt
3. Attach the file /tmp/xsession-errors.txt to this bug.

Dan Lea (danlea) wrote :

I've attached my xsession-errors.txt from after the following scenario:
1. Close Opera and get the crash, Nautilus loses theme.
2. Open Opera, copy something, close again, get the crash.

summary: - No GTK theme applied on login
+ No GTK theme applied on login / theme lost after gnome-settings-daemon
+ error.

Comment #40 explains and fixes the problem. The clipboard manager integrated in gnome-settings-daemon doesn't work correctly. When an application (like Opera or Skype) closes, it tries to get the clipboard content of those applications and crashes. Knowing this I could reproduce the crash any time.

Open Skype, copy something, close Skype, crash.

Disabling g-s-d's integrated clipboard-manager stops the crashes. If you need a clipboard manager you can try popular options like Parcellite or Diodon.

I'll update title and description with this information.

Matthias Niess (mniess) on 2011-12-04
description: updated
summary: - No GTK theme applied on login / theme lost after gnome-settings-daemon
- error.
+ gnome-settings-daemon crashes on clipboard manager failure

OK, it is now evident that my problem (bug 879793) is not a duplicate of this one. The error codes are different and the cause is different. Though both are due to gnome-settings-daemon dying.

Sebastien Bacher (seb128) wrote :

Thank you for your work there, the issue seems a bit similar to bug #626379 which was fixed in the past, the bug should be sent to GNOME as well

Changed in gnome-settings-daemon (Ubuntu):
importance: Low → High
summary: - gnome-settings-daemon crashes on clipboard manager failure
+ gnome-settings-daemon segaulfts in send_selection_notify() on clipboard
+ manager failure
summary: - gnome-settings-daemon segaulfts in send_selection_notify() on clipboard
- manager failure
+ gnome-settings-daemon segaulfts in send_selection_notify() (incorrect
+ clipboard handling)
summary: - gnome-settings-daemon segaulfts in send_selection_notify() (incorrect
+ gnome-settings-daemon segfaults in send_selection_notify() (incorrect
clipboard handling)
description: updated
Changed in gnome-settings-daemon (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

Sent upstream.

Changed in gnome-settings-daemon:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → New
Sebastien Bacher (seb128) wrote :

Thanks Dimitry!

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Confirmed → Triaged

I also have this ,when on firefox after several minutes the theme changes unexpectedly to grey.not everyday but somedays very often

Changed in gnome-settings-daemon:
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

upstream asks how to reproduce the issue, could somebody give details on the bugzilla ticket: https://bugzilla.gnome.org/show_bug.cgi?id=665602

Changed in gnome-settings-daemon:
status: Incomplete → Expired
tags: added: rls-mgr-p-tracking
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.