Comment 8 for bug 998156

Can you add my PPA to your system's software sources, following the instructions under "Adding this PPA to your system" on

https://launchpad.net/~till-kamppeter/+archive/ppa

and then update your system. You should get the CUPS packages of version 1.5.3-0ubuntu2~ppa1 then.

Now test again and tell us whether this solves your problem (so that you can use your printer with "socket://...").