Ubuntu

keyboard layout indicator reacts incorrectly

Reported by Jakub Dubovsky on 2011-11-03
804
This bug affects 187 people
Affects Status Importance Assigned to Milestone
Ubuntu network, Bluetooth, keyboard menus
High
Charles Kerr
gnome-settings-daemon
Invalid
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Hi there,

  there are few bug reports similar to this one but from their description I feel like this is a little different.

  I use three different keyboard layouts, switching between them with shortcut and having "Allow different layouts for individual windows" option enabled. In this configuration layout switch should be processed when shortcut is triggered or when I switch to another window. Moreover "to switch layout" means two things. Firstly it means to switch keyboard mappings themself and secondly to change what layout indicator shows.

  The problem itself: mappings which is used is often not the same as indicator shows. I experimented a little to find out what is wrong and now I see that the mistake is in processing switch-window event which always changes mappings used but doesn't refresh what indicator is showing...

  Sometimes it's quite annoying as nearly all bugs reported here :) This is my first bug report ever so correct me or reguest mroe info if I have fogotten something.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-settings-daemon 3.2.0-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Thu Nov 3 16:11:18 2011
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to oneiric on 2011-10-20 (14 days ago)

Jakub Dubovsky (james64) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

See also bug 891521.

Dmitry Shachnev (mitya57) wrote :

Test case (from bug 891521):
1. Configure two keyboard layouts (us and other);
2. Open a gedit window, set the layout to other;
3. Open a terminal window, ensure that the layout is us;
4. Switch to gedit window.

What should happen:
Layout indicator should display other layout's name.

What happens instead:
Layout indicator displays "us", but typing text results in text in other layout.

Changed in ubuntu-indicator-mods:
status: New → Confirmed
Doctor Rover (doctor-rover) wrote :

This bug still exists in 12.04 beta1.
I have strong hopes that it will be fixed in the release. I consider this bug as the most critical for me at the moment. I can stand all other things... But this bug just turns the work into complete mess!

Sasa Stamenkovic (umpirsky) wrote :

I can't beleive this bug exists for so long. I also consider this bug as the most critical for me at the moment.

Anton Belyaev (anton-belyaev) wrote :

This might sound stupid and out of topic, but this bug was the last straw for me to migrate from Ubuntu to MacOSX.
I survived Unity migration, but not this "tiny" bug.

subscribing rly annoying bug

sansey (ramon86) wrote :

I have also this problem! Want to fix it!

Pavlo Bohmat (bohm) wrote :
Pavlo Bohmat (bohm) wrote :

sorry this number Bug #796155

Dmitry Shachnev (mitya57) wrote :

It doesn't affect upstream g-s-d because the keyboard indicator is provided by Ubuntu patch.

Changed in gnome-settings-daemon:
status: New → Invalid
Sasa Stamenkovic (umpirsky) wrote :

@Dmitry Shachnev What does this mean for human beings? I am still affected with this bug. Should I install something?

E.Sh. (bizard-h) wrote :

And I have this problem too! Please want to fix it!

Dmitry Shachnev (mitya57) wrote :

This doesn't mean anything, I just closed the task which shouldn't be here.
I've asked the desktop team to look at it, so I hope this will be fixed for precise.

Changed in ubuntu-indicator-mods:
importance: Undecided → High
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → High
dezayan (s-zayetz) wrote :

The same at login/password page afyer auto-blocking. I would like it to be fixed.

Roman (q-goman-m) wrote :

Same problem

svedbox (svedbox) wrote :

Please fix it!

Changed in ubuntu-indicator-mods:
assignee: nobody → svedos (svedos)
Adolfo Jayme (fitoschido) wrote :

People, stop the "me too! fix it" comments, you're spamming bug subscribers :)

Changed in ubuntu-indicator-mods:
assignee: svedbox (svedos) → nobody
svedbox (svedbox) wrote :

Please fix it!

Changed in ubuntu-indicator-mods:
assignee: nobody → svedbox (svedbox)
Changed in ubuntu-indicator-mods:
assignee: svedbox (svedbox) → nobody
Sasa Stamenkovic (umpirsky) wrote :

@Fitoschido But we really need this bug fixed :)

Станислав (jools333) wrote :

Same problem

NickNeo (nickneo.one) wrote :

I have also this problem! Want to fix it!!!

I have also this problem! Want to fix it!!!

r1s (roman87-r1s) wrote :

I have also this problem! Want to fix it!

zhmurikov (mizdk) wrote :

Please fix it! Please!

ALTe0 (ctpagateji) wrote :

+ fix

Sebastien Bacher (seb128) wrote :

Could you stop those noise comments, what you will just is to get people who are likely to work on that to unsuscribe to stop getting spammed this way

z-l (guhcc) wrote :

I have also this problem! Want to fix it!!!

Dmitriy Lyalyuev (dmi5riy) wrote :

Please, fix it.

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Won't Fix
Sergej (nextdrift-gmail) on 2012-03-10
description: updated
Sebastien Bacher (seb128) wrote :

you won, closing that bug, spamming people is not how you get your issue solved

Sasa Stamenkovic (umpirsky) wrote :

Time to look for another linux distribution folks.

helboof (helboof) wrote :

I have also this problem! Want to fix it!!!

Alex Korobkin (korobkin) wrote :

Very annoying, please do something about it.

Eugene Crosser (crosser) wrote :

Dear Sebastian,

a dozen idiots spamming the ticket is a problem.
Marking the ticket "won't fix" in response is _not_ a solution.

Thanks for listening.

I have also this problem! Want to fix it!!!

FeNUMe (fenumed) wrote :

I have this problem too! fix it pls.

Giotto (cryptosonbian) wrote :

I have also this problem! fix it please!!!

I have also this problem! Want to fix it!!!

Tolstov Igor (attid) wrote :

I have also this problem! Want to fix it!!

Rem (gr-mail) wrote :

I have also this problem! Want to fix it!!!

Mikhail Kuligin (mkuligin) wrote :

I have also this problem! Want to fix it!!!

Nizzzia (nizzzia) wrote :

Same irritating bug here. Need a fix.

Charles Kerr (charlesk) on 2012-03-11
Changed in ubuntu-indicator-mods:
assignee: nobody → charles (charlesk)
status: Confirmed → Triaged
Charles Kerr (charlesk) wrote :

So, seb128 asked me a week ago to take a look at this and I've now reached it on my TODO list.

I'm new to this issue and, since so many people seem interested in this ticket, it made me wonder if someone could help walk me through this issue: The steps in comment #4 look like a good starting point, but step three says "ensure that the layout is us" -- how is that done, exactly? And how would I manually set an arbitrary window's (not just a terminal's) keyboard layout?

In Gnome Control Center > > Keyboard Layout, it appears whatever language I move to the top of the list becomes the active layout. This appears to be applied on a global basis, rather than a per-window one. (It's also not reflected in Ubuntu's keyboard indicator ;) Is this accurate?

Jakub Dubovsky (james64) wrote :

Hi Charles,

  I have already tried to make a list of steps needed to reproduce the error. But I have failed. Now I tried to reproduce it by steps in post number #4 with no success. I tried som other ways with the same result. But it still happens. Last time it was five minutes ago when switching to chat window...

  It looks like it depends not just on switching windows or workspaces but something else...

  I started to encounter this bug in unity but now I am on xfce and bug is still there if that helps. But I just installed package xfce4 on top of gnome so everything is still handled by gnome .... if that helps

  I am not sure what is meant by phrase "ensure that the layout is us" but I understood is as simply switching layout by shortcut as usual...

  I will provide you with as much information as you will need, just ask..

Jakub Dubovsky (james64) wrote :

Hi Charles,

  right now I have noticed this situation

window with "other" layout set and in effect
switch to another window
switch back
there is us layout on the indicator and in effect which does not agree with bug description. Maybe it is because I made the decsribtion under unity and now I am running xfce. MAYBE that is why I couldn't reproduce the bug by steps in message #4. IF that would be the case then there is another scenario possible:

be in window1 with other layout
switch to window2 with us layout
switch back to window1 and there is us layout set (which is a bug) and indicator shows other layout (which sort of correct)

  There are plenty of other subscribers to bug and lots of them look eager to write something so I hope they will provide some help to you as well...

Hi Charles,

"ensure that the layout is us" means that you must select the US layout either by shortcut or by using indicator menu.
So basically, open gedit and set layout #1 there. Then open terminal and set layout #2 there. Then switch to gedit window. Language indicator will still indicate layout #2 (which is incorrect), although layout #1 is selected (which is correct).

Hope this helps.

Doctor Rover (doctor-rover) wrote :

Dear Charles,

First of all, thank you very much for your intention to take care of this bug! I was afraid (and not only me) that it will be closed without fixing...
And I am sorry for the people who posted all these meaningless spamming "fix-it" comments here.

I can offer you another robust way to reproduce this bug. For me it work fine. If you can say "fine" for a bug :)
I do not know whether you have several layouts... I can guess, you don't. Otherwise, you would be aware of this bug from your own experience... In this case, you can do it in a live-session. The latest daily-live which I have tried to reproduce the bug was dated 08-Mar-2012. So do the following steps:
1) Before loading Ubuntu, choose language "Русский" (Russian). Then choose "Запустить Ubuntu без установки" (Try Ubuntu without installing).
2) After start of the system, you will have two layouts: English and Russian. Right after start, "en" layout will be active by default.
3) Run Gedit.
4) Type several letters. You will see the English letters. This corresponds to the layout -- "en".
5) Press Alt+Shift. The layout indicator will not be changed, it will stay in "en" state.
6) Type several letters. You will see the Russian letters. That's it! Typing in Russian while the indicator shows "en".

In addition, I can say several things:
1) This is not only right-after-start problem. This happens regularly during the work, after switching windows or starting new applications.
2) You can see this bug not only for Russian language, of course. For instance, I have tried the Greek live-session and the bug was perfectly the same.
3) I can reproduce absolutely the same behaviour by repeating the same steps on my 11.10 which is my basic home OS at the moment. I mean, it is not only live-session problem.
4) And one more thing, if it helps... I do not encounter this bug in Gnome Shell run in 11.10.

Once again, thank you for your efforts!

Dmitry Shachnev (mitya57) wrote :

@charles: I can only add that you need to enable per-window layouts in g-c-c to better reproduce it. In such cases, the indicator doesn't correctly update its state on windows switching.

Speaking about technical details, our patched g-s-d watches for "X-state-changed" signal (there are 2 callbacks for it — gkbd_configuration_state_callback() and state_callback() — both result in correctly updating the menu), but it seems that this signal isn't emited on window changes, so we should probably fix it or handle window switches separately.

Doctor Rover (doctor-rover) wrote :

The situation at the video of Sasa Stamenkovic is absolutely the same as described by Roman Vorobets in comment #47. And I confirm that I also can see the same behaviour. And it's repeatable. So it seems to be a good and simple way to reproduce the bug.

burchun (bur80) wrote :

I have also this problem! Want to fix it!!!

Falcon (nw-link) wrote :

I have also this problem! Want to fix it!!!

Artemhp (artemhp) wrote :

Hello, I have this problem too, have 3 languages in panel russian, ukrainian and english

Olexa (oleksa-sky) wrote :

I have also this problem! Want to fix it.

Charles Kerr (charlesk) on 2012-03-15
Changed in ubuntu-indicator-mods:
status: Triaged → In Progress
Changed in gnome-settings-daemon (Ubuntu):
status: Won't Fix → In Progress
Sebastien Bacher (seb128) wrote :

Ok, candidate fix uploaded to precise, we will backport it to older series when it's confirmed to be working, if you have the issue please try to update and comment back here

Changed in gnome-settings-daemon (Ubuntu Oneiric):
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.3.91-0ubuntu6

---------------
gnome-settings-daemon (3.3.91-0ubuntu6) precise; urgency=low

  * debian/patches/61_unity_use_application_indicator.patch:
    - update to fix issues where the keyboard indicator would not update
      or reflect the correct layout when changing layout with the keyboard,
      thanks Charles Kerr (lp: #885730)
 -- Sebastien Bacher <email address hidden> Fri, 16 Mar 2012 11:10:43 +0100

Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Released
Charles Kerr (charlesk) on 2012-03-16
Changed in ubuntu-indicator-mods:
status: In Progress → Fix Released
Doctor Rover (doctor-rover) wrote :

> if you have the issue please try to update and comment back here
The situation is as follows. At the moment, I can check the issue only within the live-session. So, I have updated the system from the live session and indeed got gnome-settings-daemon updated to 3.3.91-0ubuntu6.
So I can see that the problem described in comment #47 and shown at the video from comment #50 has vanished. Thus, during switching between different windows, the layout indicator now seems to work quite correctly. Great!
But the way of the bug reproduction which I have described in comment #48 still seems to lead to the same incorrect behavior.
So once again, the problem is in the first layout switching right after start of an application. The first switching leads to actual change of the layout but it is not followed by the indicator change. To reproduce:
1) Start any application (say, gedit). The layout is "en" and the indicator shows also "en".
2) Switch the layout to the other. The layout will be actually changed but the indicator will still show "en" which is incorrect.

And one more observation. If you do something (press Alt to reveal HUD, switch to another window and then return back) before the first layout change, the indicator will react correctly.
Also, I can reproduce this within both settings "Use the same layout for all windows" and "Allow different layouts for individual windows".
Thank you!

Hi Rover,
It seems that you have different issue from what is described here.

Doctor Rover (doctor-rover) wrote :

Hi, Roman,
I am sorry, but what does it mean in this case? Totally different bug? Not a bug at all?

Dmitry Shachnev (mitya57) wrote :

For me, this bug is totally fixed now.

@Rover: please report your issue ("Alt-Shift changes the layout but doesn't update the indicator" as I can understand) as a new bug, this one is already too much spammed :)

ironwit (ironwit) wrote :

its working for me
thanks

Jakub Dubovsky (james64) wrote :

During fixing process I have realised that what I was (am) experiencing were (are) two different bugs. Thanks for fixing this one. There is a link to another bug report if someone here has the same problem...

https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/955623

Doctor Rover (doctor-rover) wrote :

Thank you very much for fixing this bug!

@ Dmitry Shachnev: Upon your advice, I have just reported this issue as a new bug: https://bugs.launchpad.net/ubuntu-indicator-mods/+bug/958007

Mikhail V. Golubev (mvgolubev) wrote :

I think this bug occurs only when using Compiz window manager (e.g. Ubuntu Unity desktop based on Compiz).
And I think this bug is related to another bug:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/622965

The GMOME developers have closed this bug without fixing, as it only occurs with compiz:
https://bugzilla.gnome.org/show_bug.cgi?id=628529

Ravil (i-rav) wrote :

I am use ubuntu studio 12.04 beta2 and I found same bug. Or may be similar. I am not so expiriensed, the core is XFCE4. I could not find the method of configure keyboard layout switch at all. So, Alt+Shift is default and temporary. And randomly the sequence of layout changed also. And I have not yet and do not use compiz.

Dmitri (ryba4) wrote :

I used Xubuntu 11.10 + Unity. Had separate layout for each window. I had English, Russian and Spanish layouts, and every time I changed windows, the layout indicator would get incorrect. Everyone who used more than 2 layouts knows how annoying it is to cycle through them.

I stoppd using Unity recently, as it got more and more bugs in recent updates.

hdpq (defectoscopny) wrote :

Also having this issue in 12.04. I'm using English, Lithuanian and Russian layouts and whenever I switch to Lithuanian, 'en' is displayed.

Sasa Stamenkovic (umpirsky) wrote :

This bug still exists in 12.04. Since I see some fixes are released, is there any way to install them?

Sasa Stamenkovic (umpirsky) wrote :

Any update on this?

Sebastien Bacher (seb128) wrote :

> This bug still exists in 12.04.

that bug has been closed, if you still have the issue please open a new bug with a complete description if your config and what happens when doing what

Mindaugas Jakutis (4mr-minj) wrote :

Why hasn't this reached the oneiric-backports yet? It's been 4 months

Sebastien Bacher (seb128) wrote :

likely because a new version of Ubuntu is out and it's an LTS and the number of users and fixes for minor issues on old non LTS series is low, the priority is on the versions most users are running

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Triaged → Won't Fix
Vourhey (vadim-razorq) on 2012-10-03
Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: nobody → Vourhey (vadim-razorq)
Dmitry Shachnev (mitya57) wrote :

@Vourhey: please don't assign yourself to wont-fix tasks :)

Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: Vourhey (vadim-razorq) → nobody
Vadim (rezend) wrote :

I have also this problem! Want to fix it!!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.