bad default setting: suspend after 30min when plugged in

Bug #860485 reported by Jean-Baptiste Lallement on 2011-09-27
270
This bug affects 52 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
gnome-settings-daemon (Ubuntu)
Critical
Rodrigo Moya
Oneiric
Critical
Rodrigo Moya

Bug Description

By default power setting is set to 'suspend after 30 min when plugged in' it should be 'Don't suspend'

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-settings-daemon 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Tue Sep 27 13:36:56 2011
EcryptfsInUse: Yes
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to oneiric on 2011-07-12 (77 days ago)

Jean-Baptiste Lallement (jibel) wrote :
Changed in gnome-settings-daemon (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

Confirm the same issue on Oneiric i386 b2: this setting dont deal with other system but laptop. My system is a desktop and these settings are not the best for such case. (should propose to activate screensaver for example)

Martin Pitt (pitti) on 2011-09-27
Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Rodrigo Moya (rodrigo-moya)
Rodrigo Moya (rodrigo-moya) wrote :

The system won't suspend, since the daemon uses the sleep-inactive-ac (and -battery) GSettings keys, but it's a bug in the UI, which is now fixed in GIT (both master and 3-2 branch) and is coming in the next g-c-c upload

dino99 (9d9) wrote :

hm, i was surprised to ear my system to shut down after 30 mn of inactivity

Hernando Torque (htorque) wrote :

I don't even like that to happen by default when on battery. :-/

Let's say I'm a new user that just installed Oneiric. I have a notebook that has five hours of battery time. I start a download and go grab some lunch. Scenario 1: When I return I find my system sleeping rather than the download finished. Scenario 2: My notebook fails to wake up from standby and I've now successfully lost two hours of work.

This should at least be mentioned in the release notes.

Sebastien Bacher (seb128) wrote :

right, we should probably default to not suspend on idle, is that still an issue with today's version?

Changed in gnome-settings-daemon (Ubuntu Oneiric):
importance: Undecided → High
Zetoke (zetoke) wrote :

Affects me too. I was very surprised by this after update.

Rodrigo Moya (rodrigo-moya) wrote :

In Natty we had the same behavior of suspending when idle on battery by default, right Seb?

I'm not arguing what's best though, so I'm happy to use whatever default makes more sense.

Tim Cuthbertson (ratcheer) wrote :

I am confused, because in the Power applet, my settings show as:

Suspend when inactive for: Don't suspend
When power is critically low: (null)

But my system is being suspended, anyway. Is there something I can change it to to make it stop suspending?

Ian Colquhoun (icolquhoun) wrote :

I just upgraded to 11.10 Beta2 this morning on my desktop. I came back from lunch to find my machine suspended. I checked the Power setting and "Suspend when inactive for:" is indeed set to "Don't suspend".

This is a particular problem for me because I use this desktop as a VPN gateway from home for responding to pages when I'm on-call at work.

Pedro Villavicencio (pedro) wrote :
Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Confirmed → Triaged
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → New
komuta (komuta) wrote :

Still not fixed, and no workaround ?
This is really critical ! Computer is almost unusable.

komuta (komuta) wrote :

I tried to correct this from gconf-editor, but don't even know from where to begin.
The configuration in /apps/gnome-power-manager/buttons/ seems to be missing : "This key has no schema".

tags: added: rls-mgr-o-tracking
komuta (komuta) wrote :

Ok, found a workaround (not clean at all, but that's the only thing I have now) :
- edit /usr/share/polkit-1/actions/org.freedesktop.upower.policy
- replace <allow_active>yes</allow_active> by <allow_active>no</allow_active> for both actions (suspend, hibernate)

I think you don't even have to reboot, the followindg test seems to indicate the modification is immediatly taken into account :
$ pkaction --action-id org.freedesktop.upower.suspend -v
org.freedesktop.upower.suspend:
  description: Suspend the system
  message: Authentication is required to suspend the system
  vendor: The UPower Project
  vendor_url: http://upower.freedesktop.org/
  icon: system-suspend
  implicit any: no
  implicit inactive: no
  implicit active: no

Changed in gnome-settings-daemon:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

Rodrigo commited a fix in the packaging vcs

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Triaged → Fix Committed
Dustin Kirkland  (kirkland) wrote :

Wow, this bug is absolutely killing me :-( I'm leaving my laptop for a bit while it does some work (uploads a bunch of data, builds something really big, does some transcoding), and I'm very surprised to come back an hour later and find it suspended!

Dustin Kirkland  (kirkland) wrote :

Seb, eta for uploading the fix? This is release-critical, IMO.

Changed in gnome-settings-daemon (Ubuntu Oneiric):
importance: High → Critical
Nishant (nishant-singh28) wrote :

komuta, can you please tell me how to suspend my system when I want to, after applying your workaround? It seems to leave the system completely unable to suspend(hibernation is not an option here, no swap) and I do need that sometimes.

Hernando Torque (htorque) wrote :

Nishant, try this from a terminal (or alternatively via dconf-editor):

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery false
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 0
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac false
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0

Nishant (nishant-singh28) wrote :

Thanks for that...looks like the System Settings window does not change the dconf key values. Those need to be edited manually. I had tried to use that window, but even telling it not to suspend made no difference.

Jason Gerard DeRose (jderose) wrote :

So if I'm understanding the thread here, this bug will fix both the bad the "30 minutes" default and the fact that desktop systems (or laptops on AC I assume) are still being suspended even when set to "Don't suspend".

It would be nice if the bug description included mention of the latter... at first I thought this wasn't the big that was affecting me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.2.0-0ubuntu4

---------------
gnome-settings-daemon (3.2.0-0ubuntu4) oneiric; urgency=low

  * debian/patches/00git_dont_sleep_on_idle_by_default.patch:
    - Don't sleep on idle by default (LP: #860485)
  * debian/patches/00git_dont_revert_pre_idle_brigthness.patch:
    - Do not revert to the pre-idle brightness if idle dimming is disabled
  * debian/patches/50_add_dell_backlight.patch:
    - Add 'dell_backlight' module to gsd-backlight-helper (LP: #862474)
 -- Rodrigo Moya <email address hidden> Thu, 29 Sep 2011 16:47:57 +0200

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

Rodrigo, it's likely that there is still a bug even when the key value is set to 0 some people seem to have their box suspending, see bug #864479

eric (obrowny06) wrote :

I don't know if it is related to this bug but if you set lock screen to never, it locks after one or two seconds.
Tell me if you want me to subscribe it on another bug report.

Philipp Wendler (philw85) wrote :

My desktop machine just went into standby after exactly 30 minutes of inactivity although standby is disabled in the control center. After finding this bug I looked at the values of the dconf settings above. sleep-inactive-ac was set to false (with a timeout of 0). However, sleep-inactive-battery was set to true with a timeout of 1800.

For me, this looks like the actual setting used is always the -battery setting, not the -ac setting (even on a desktop machine). Can anyone verify this?

Philipp Wendler (philw85) wrote :

I filed bug #865720 about the issue with sleep-inactive-battery being used instead of sleep-inactive-ac.

I'm getting the suspend issue as well, in spite of setting things to "don't suspend" - surprisingly, it suspended even while playing music - I'd set a playlist to listen to while doing some work away from the computer, and had things come to a halt after 30 minutes. Everything is up to date on my machine.
What's worst is that this is on my desktop, which was never really meant to suspend - the hardware's a bit older and the motherboard was fairly basic even at the time of purchase. Once it suspends, I've got about a 50% chance of a successful resume that doesn't require hitting the reset button.

On Oct 04, 2011, at 02:44 AM, Sean Fitzpatrick wrote:

>I'm getting the suspend issue as well, in spite of setting things to "don't
>suspend" - surprisingly, it suspended even while playing music - I'd set a
>playlist to listen to while doing some work away from the computer, and had
>things come to a halt after 30 minutes. Everything is up to date on my
>machine.

With yesterday's updates the unexpected suspends have stopped for me.

hazylazysusan (hazylazysusan) wrote :

 I have no idea why, but my computer continues to suspend randomly...

see attached dconf-editor pictures. Maybe someone someone can tell me why in that?

hazylazysusan (hazylazysusan) wrote :

Picture 2

Rodrigo Moya (rodrigo-moya) wrote :

hazylazysusan: what gnome-settings-daemon version are you using?

hazylazysusan (hazylazysusan) wrote :

Hi, It's 3.2.0-0ubuntu5

hazylazysusan (hazylazysusan) wrote :

Hi, this still occurs with current updates.

hazylazysusan (hazylazysusan) wrote :

I have opened Bug #901898 for my issue for anyone who has the same problem.

Larry Tate (cathect) wrote :

I have version 3.2.2-0ubuntu2.1 of gnome-settings-daemon. I'm still having this issue. My computer suspends and I am unable to revive it. I have to do a hard reboot.

I have power and monitor settings such that the computer should never standby.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.