Ubuntu

The HP 1018 printer not work out of the box if used non-US locale

Reported by Wawrzyniec Niewodniczański on 2009-02-16
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
Release Notes for Ubuntu
Undecided
Unassigned
hplip (Ubuntu)
Low
Unassigned
Lucid
High
Unassigned
Maverick
Low
Unassigned
ibus (Ubuntu)
Low
Unassigned
Lucid
High
Unassigned
Maverick
Low
Unassigned

Bug Description

This bug is continuation of the bug 217215. To avoid any problems related to attempts describe I decided to start with 'clean account'. (and created the new bug entry)

Clean account means:
1) Remove hplip*, foo2zjs, footomatic package.
2) Remove any further files related to hp1018
find /usr/share -name "*1018*"
./foo2zjs/firmware/sihp1018.img
./ppd/hpijs/HP/hp_laserjet_1018-hpijs.ppd
3) Remove orphaned /usr/share/hplip directory

After restarting the printer a system message appear pointing that new hardware had been installed and suggesting that hpijs package support the HP 1018 printer.
I:
- installed hpijs with depends
- Ran Printer configure tool: a driver for HP 1018 hadn't been found
- so I chose suggested HP 1015 driver
- printer didn't react for send packages.

So I decided to use /usr/bin/hp-setup.

It ran clear but printer still wasn't working.
Error from /var/log/syslog:

Feb 16 00:02:11 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Feb 16 00:02:11 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 603: invalid product id string ret=-1
Feb 16 00:02:11 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1018?serial=KP28TX4
Feb 16 00:02:11 madryt HP_LaserJet_1018?serial=KP28TX4: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Feb 16 00:02:41 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Feb 16 00:02:41 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 603: invalid product id string ret=-1
Feb 16 00:02:41 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1018?serial=KP28TX4
Feb 16 00:02:41 madryt HP_LaserJet_1018?serial=KP28TX4: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Feb 16 00:03:11 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Feb 16 00:03:11 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 603: invalid product id string ret=-1
Feb 16 00:03:11 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1018?serial=KP28TX4
Feb 16 00:03:11 madryt HP_LaserJet_1018?serial=KP28TX4: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Feb 16 00:03:41 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Feb 16 00:03:41 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 603: invalid product id string ret=-1
Feb 16 00:03:41 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1018?serial=KP28TX4
Feb 16 00:03:41 madryt HP_LaserJet_1018?serial=KP28TX4: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Feb 16 00:04:12 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Feb 16 00:04:12 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 603: invalid product id string ret=-1
Feb 16 00:04:12 madryt HP_LaserJet_1018?serial=KP28TX4: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1018?serial=KP28TX4
Feb 16 00:04:12 madryt HP_LaserJet_1018?serial=KP28TX4: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...

Among different operation hplid did:

Copying file hp_laserjet_1018.fw.gz to /usr/share/hplip/data/firmware/hp_laserjet_1018.fw.gz...

Next step was to install foomatic-db-hpijs

After that the proper set printer appeared "automagiclly" in System->Administration->Printer Settings

The problem is that it's not working if you restart system with started printer.

I.e. error message from hp-firmaware

HP Linux Imaging and Printing System (ver. 2.8.7)
Firmware Download Utility ver. 1.1

Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Using device: hp:/usb/HP_LaserJet_1018?serial=KP28TX4
error: Unable to communicate with device (code=12): hp:/usb/HP_LaserJet_1018?serial=KP28TX4
error: Error opening device (Device not found). Exiting.

and dmesg:

[ 618.508495] type=1503 audit(1234744567.807:5): operation="inode_permission" requested_mask="::rw" denied_mask="::rw" fsuid=7 name="/dev/tty" pid=5826 profile="/usr/sbin/cupsd"
[ 623.992230] usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd hpijs rqt 128 rq 6 len 255 ret -110
[ 653.774576] type=1503 audit(1234744603.071:6): operation="inode_permission" requested_mask="::rw" denied_mask="::rw" fsuid=7 name="/dev/tty" pid=5891 profile="/usr/sbin/cupsd"
[ 657.588130] usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd hp rqt 128 rq 6 len 255 ret -110
[ 658.888164] usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd hpijs rqt 128 rq 6 len 255 ret -110
[ 681.984069] usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd python rqt 128 rq 6 len 255 ret -110
[ 686.984112] usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd python rqt 128 rq 6 len 255 ret -110
[ 692.284107] usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd python rqt 128 rq 6 len 255 ret -110
[ 692.592054] usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd hp rqt 128 rq 6 len 255 ret -110
[ 727.760205] usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd hp rqt 128 rq 6 len 255 ret -110

Some kind of workaround is to turn off and turn on printer (the lights has to go out) and manually starting queue in cups.

How you can see it's not acceptable in longer terms.

I installed foo2zjs, ran getweb1018 and set up the new 'printer' HP 1018 but with foo2zjs drivers, but now only one of queue is running.

I need to remove hplip and see what happened.

Ivan Panchenko (wao-mail) wrote :

I had similar non-printing or sometimes unstable printing with my HP 1018.

Nothing helped until reading http://gluek.info/wiki/hardware/hp-laserjet-1018
inspired me to try another (white and cool) USB cable.

It started printing ( I have foo2zjs installed ).

Mindaugas B. (embar-super) wrote :

Now works HP LaserJet 1018 for me: I have downloaded firmware from http://embar.wen.ru/html/bylos/linux/hp/sihp1018-dl.zip and extracted this archive. I put the file sihp1018.dl in /usr/share/foo2zjs/firmware directory. I have installed hplip, hp-ppd, hplip-data, hpijs, foo2zjs, libcupsimage2-dev packages (I don't know what of thees are necesary). I also run "make install-hotplug" in directory where I extracted http://foo2zjs.rkkda.com/foo2zjs.tar.gz archive. I add a firmware file

Till Kamppeter (till-kamppeter) wrote :

On Jaunty (with all updates) the firmware files for the HP printers which need a firmware file get automatically loaded when one sets up these printers with system-config-printer which makes the printer immediately working. The firmware gets download as part of the HPLIP plugin, so you need HPLIP to be able to use the files out of the box (by uncompressing, moving/linking, and renaming you could use them also with foo2zjs). Please try it out.

9.04 still broken :-(

This time problem with communication:
Downloading firmware to device hp:/usb/HP_LaserJet_1018?serial=KP1A4KL...
hp-plugin[25507]: debug: Device URI: hp:/usb/HP_LaserJet_1018?serial=KP1A4KL
hp-plugin[25507]: debug: Printer: None
hp-plugin[25507]: debug: Not starting dbus: running as root.
hp-plugin[25507]: debug: URI: backend=hp, is_hp=True, bus=usb, model=HP_LaserJet_1018, serial=KP1A4KL, dev=, host=, port=1
hp-plugin[25507]: debug: Model/UI model: HP_LaserJet_1018/HP LaserJet 1018
hp-plugin[25507]: debug: /usr/share/hplip/data/firmware/hp_laserjet_1018.fw.gz
hp-plugin[25507]: debug: Downloading firmware file '/usr/share/hplip/data/firmware/hp_laserjet_1018.fw.gz'...
hp-plugin[25507]: debug: Opening device: hp:/usb/HP_LaserJet_1018?serial=KP1A4KL (for printing)
hp-plugin[25507]: debug: I/O mode=1
error: Unable to communicate with device (code=12): hp:/usb/HP_LaserJet_1018?serial=KP1A4KL
hp-plugin[25507]: debug: Exception: 2 (Device not found)
error: unable to open channel
hp-plugin[25507]: debug: Opening device: hp:/usb/HP_LaserJet_1018?serial=KP1A4KL (for printing)
hp-plugin[25507]: debug: I/O mode=1
error: Unable to communicate with device (code=12): hp:/usb/HP_LaserJet_1018?serial=KP1A4KL
hp-plugin[25507]: debug: Exception: 2 (Device not found)
error: unable to open channel
hp-plugin[25507]: debug: Writing 129287 bytes to channel -1...
error: Channel write error
hp-plugin[25507]: debug: Exception: 12 (Device I/O error)
error: An error occured: Device I/O error

There is similar question:
https://answers.launchpad.net/ubuntu/+source/cups/+question/70481/+login

Looks like a problem of HPLIP's CUPS backend. Added upstream task.

Can someone at HP look into this? Seems to be only the 1018. My 1020 always worked correctly.

BTW.
I (or rather my father) have following errors:

 usb 1-4: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 6 len 4 ret -110

I had another round of fight we the issue. My father said that he would switch back to Win if the printer would not start to work soon.

I made some changes to the system:

1) install foo2zjs from sources
2) install foomatic-db-hpijs
3) install foo2zjs from packages

and currently I have following error messages:

Jul 13 00:06:55 pn HP_LaserJet_1018?serial=KP1A4KL: io/hpmud/musb.c 1381: unable to write data hp:/usb/HP_LaserJet_1018?serial=KP1A4KL: 45 second io timeout
Jul 13 00:07:12 pn HP_LaserJet_1018?serial=KP1A4KL: prnt/backend/hp.c 676: INFO: open device failed stat=21; will retry in 30 seconds...
Jul 13 00:07:40 pn HP_LaserJet_1018?serial=KP1A4KL: io/hpmud/musb.c 1381: unable to write data hp:/usb/HP_LaserJet_1018?serial=KP1A4KL: 45 second io timeout
Jul 13 00:07:42 pn HP_LaserJet_1018?serial=KP1A4KL: prnt/backend/hp.c 676: INFO: open device failed stat=21; will retry in 30 seconds...
Jul 13 00:08:12 pn HP_LaserJet_1018?serial=KP1A4KL: prnt/backend/hp.c 676: INFO: open device failed stat=21; will retry in 30 seconds...
Jul 13 00:08:25 pn HP_LaserJet_1018?serial=KP1A4KL: io/hpmud/musb.c 1381: unable to write data hp:/usb/HP_LaserJet_1018?serial=KP1A4KL: 45 second io timeout
Jul 13 00:08:42 pn HP_LaserJet_1018?serial=KP1A4KL: prnt/backend/hp.c 676: INFO: open device failed stat=21; will retry in 30 seconds...

Googling I found following link:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=517434

and I'm going to try downgrade hplip.

Wawrzyniec Niewodniczański, before you try to downgrade, please post the output of

lsusb
ls -l /dev/bus/usb/*/*

Download full text (5.7 KiB)

My previous message was to prompt as the resolution of bug I listed was upgrade to the hplip version presented in U 9.04.

BTW. Please call me Wawrzek - much easier ;)

lsusb:
Bus 001 Device 003: ID 03f0:4117 Hewlett-Packard Printing Support
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 046d:092f Logitech, Inc. QuickCam Express Plus
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

root@pn:/var/log# ls -l /dev/bus/usb/*/*
crw-rw-r-- 1 root root 189, 0 2009-07-12 19:06 /dev/bus/usb/001/001
crw-rw-r--+ 1 root lp 189, 2 2009-07-13 01:25 /dev/bus/usb/001/003
crw-rw-r-- 1 root root 189, 128 2009-07-12 19:06 /dev/bus/usb/002/001
crw-rw-r-- 1 root root 189, 129 2009-07-12 19:06 /dev/bus/usb/002/002

and
root@pn:/var/log# grep lp /etc/group
lp:x:7:paveln,niewod
lpadmin:x:108:paveln,niewod

BTW:root@pn:/var/log# /usr/lib/cups/backend/hp
direct hp:/usb/HP_LaserJet_1018?serial=KP1A4KL "HP LaserJet 1018" "HP LaserJet 1018 USB KP1A4KL HPLIP" "MFG:HP;MDL:HP LaserJet 1018;CLS:PRINTER;DES:HP LaserJet 1018;SN:KP1A4KL;"

Based on 318262 I performed udevadm test:

root@pn:/var/log# udevadm test /dev/bus/usb/001/003
run_command: calling: test
udevadm_test: version 141
This program is for debugging only, it does not run any program,
specified by a RUN key. It may show incorrect results, because
some values may be different, or not available at a simulation run.

parse_file: reading '/etc/udev/rules.d/11-hplj10xx.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-alsa.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-hplip.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-ia64.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-infiniband.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-isdn.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-libpisock9.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-pilot-links.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-ppc.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-xserver-xorg-input-wacom.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-zaptel.rules' as rules file
parse_file: reading '/lib/udev/rules.d/45-fuse.rules' as rules file
parse_file: reading '/lib/udev/rules.d/45-libmtp8.rules' as rules file
parse_file: reading '/lib/udev/rules.d/50-firmware.rules' as rules file
parse_file: reading '/lib/udev/rules.d/50-udev-default.rules' as rules file
parse_file: reading '/lib/udev/rules.d/60-cdrom_id.rules' as rules file
parse_file: reading '/lib/udev/rules.d/60-persistent-input.rules' as rules file
parse_file: reading '/lib/udev/rules.d/60-persistent-serial.rules' as rules file
parse_file: reading '/lib/udev/rules.d/60-persistent-storage-tape.rules' as rules file
parse_file: reading '/lib/udev/rules.d/60-persistent-storage.rules' as rules file
parse_file: reading '/lib/udev/rules.d/60-persistent-v4l.rules' as rules file
pa...

Read more...

One more:

There were old, 'freeze' print request, after removing them (lprm number) I've go following error message

Jul 13 02:30:09 pn python: hp-testpage[19716]: error: Channel write error
Jul 13 02:30:09 pn python: io/hpmud/musb.c 547: aborting outstanding 7/1/2 write
Jul 13 02:30:09 pn python: hp-testpage[19716]: error: Device is busy or in an error state. Please check device and try again.

So the printer is working but only because I remove ANY Ubuntu packed related to the printer. After that I grabbed source of foo2zjs driver, built it and printer is working.

I think my father describe the situation quite well "You know it is working worse and worse with each re-installation [upgrade]". I think I won't update Ubuntu on my father box for a long time :-(

djahjah (boreste) wrote :

Wawrzyniec Niewodniczański,

i am having the same issue and trying to fix it for several days.
i reaaly thinking to give up on ubuntu. maybe going to debian-based AVLinux distro.

anyway, can you give the step-by-step way to do what you did?

thanks!

G104cch1n0 (gmazzurco89) on 2010-01-18
summary: - The HP 1018 printer is not supported in Ubuntu 8.10
+ The HP 1018 printer is not supported in Ubuntu 8.10 -> 9.10
summary: - The HP 1018 printer is not supported in Ubuntu 8.10 -> 9.10
+ The HP 1018 printer is not supported in Ubuntu 8.10, 9.10. In 10.04
+ supported but not work "out of the box".

RussianNeuroMancer, can you please plug in the printer and turn it on, then check the following:

Does a screen notification about firmware or a plug-in show up? Does a utility show up to download a plug-in for HPLIP?

Can you run the following commands in a terminal window and post the output here:

lsusb
ls -l /dev/usb/lp* /dev/bus/usb/*/*
sudo usb_printerid /dev/usb/lp0
sudo usb_printerid /dev/usb/lp1
sudo usb_printerid /dev/usb/lp2
/usr/lib/cups/backend/hp
sudo /usr/lib/cups/backend/hp
lpinfo -v

Can you also attach the PPD files in /etc/cups/ppd/?

Please do not compress or tar together any attachments. Please make one posting for each attachment.

Changed in hplip (Ubuntu):
status: New → Incomplete
Changed in hplip:
status: New → Incomplete

> Does a screen notification about firmware or a plug-in show up?
Yes.

> Does a utility show up to download a plug-in for HPLIP?
No. Also if user trying to install hplip-gui and use hp-setup for download and install plugin they (hp-setup utility) can't download plugin too with error "No internet connection" (actually internet connection is fine).

> Can you run the following commands in a terminal window and post the output here
> Can you also attach the PPD files in /etc/cups/ppd/?
I try to do this tomorrow or the day after, when I have access to this printer.

Can you run in a terminal and post the output here:

ifconfig
route
hp-plugin -ldebug

Try also

sudo hp-plugin -i -ldebug 2> error.txt

and attach the error.txt file.

Do not compress the file.

I guess you are using latest hplip release 3.10.5. if not please install latest.

Thanks!
Naga Samrat Chowdary, Narla

I using hplip from Ubuntu repository - it's build 3.10.2. Somewhere is PPA with latest hplip? If no, you can registr PPA for latest hplip builds?

Samrat, you can confirm this bug? Maybe you can upload new version of hplip to Ubuntu repository, to solve this bug for Ubuntu users?

~$ lsusb
Bus 005 Device 002: ID 046d:c051 Logitech, Inc. G3 (MX518) Optical Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 03f0:4117 Hewlett-Packard Printing Support
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

~$ ls -l /dev/usb/lp* /dev/bus/usb/*/*
ls: невозможно получить доступ к /dev/usb/lp*: Нет такого файла или каталога
crw-rw-r-- 1 root root 189, 0 2010-07-03 16:33 /dev/bus/usb/001/001
crw-rw-r--+ 1 root lp 189, 2 2010-07-03 16:37 /dev/bus/usb/001/003
crw-rw-r-- 1 root root 189, 128 2010-07-03 16:33 /dev/bus/usb/002/001
crw-rw-r-- 1 root root 189, 256 2010-07-03 16:33 /dev/bus/usb/003/001
crw-rw-r-- 1 root root 189, 384 2010-07-03 16:33 /dev/bus/usb/004/001
crw-rw-r-- 1 root root 189, 512 2010-07-03 16:33 /dev/bus/usb/005/001
crw-rw-r-- 1 root root 189, 513 2010-07-03 16:34 /dev/bus/usb/005/002

~$ sudo usb_printerid /dev/usb/lp0
Error: No such file or directory: can't open '/dev/usb/lp0'

~$ sudo usb_printerid /dev/usb/lp1
Error: No such file or directory: can't open '/dev/usb/lp1'

~$ sudo usb_printerid /dev/usb/lp2
Error: No such file or directory: can't open '/dev/usb/lp2'

~$ /usr/lib/cups/backend/hp
direct hp:/usb/HP_LaserJet_1018?serial=KP2QDTZ "HP LaserJet 1018" "HP LaserJet 1018 USB KP2QDTZ HPLIP" "MFG:Hewlett-Packard;MDL:HP LaserJet 1018;CLS:PRINTER;DES:HP LaserJet 1018;SN:KP2QDTZ;"

~$ sudo /usr/lib/cups/backend/hp
direct hp:/usb/HP_LaserJet_1018?serial=KP2QDTZ "HP LaserJet 1018" "HP LaserJet 1018 USB KP2QDTZ HPLIP" "MFG:Hewlett-Packard;MDL:HP LaserJet 1018;CLS:PRINTER;DES:HP LaserJet 1018;SN:KP2QDTZ;"

~$ lpinfo -v
direct scsi
network socket
network smb
network ipp
network beh
network lpd
network http
direct hp:/usb/HP_LaserJet_1018?serial=KP2QDTZ
direct usb://HP/LaserJet%201018?serial=KP2QDTZ
direct hpfax

~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:36:a7:ca:4a
          inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::216:36ff:fea7:ca4a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:5543 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4998 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5056117 (5.0 MB) TX bytes:778328 (778.3 KB)
          Interrupt:18

lo Link encap:Локальная петля (Loopback)
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:286 errors:0 dropped:0 overruns:0 frame:0
          TX packets:286 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:23482 (23.4 KB) TX bytes:23482 (23.4 KB)

wlan0 Link encap:Ethernet HWaddr 00:17:c4:03:51:2f
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

~$ route
Таблица маршутизации ядра протокола IP
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 1 0 0 eth0
link-local * 255.255.0.0 U 1000 0 0 eth0
default dsldevice.domai 0.0.0.0 UG 0 0 0 eth0

~$ sudo hp-plugin -i -ldebug 2> error.txt

"hp-plugin -ldebug" can't install plugin, but after "hp-plugin -i -ldebug 2" printer works.
Anyway, it's still not "out of the box" experience.

Your problem was that the printer´s firmware did not get installed properly with the hp-plugin utility. Downloading and verifying the digital signature worked, but the graphical user interface of hp-plugin had a bad interference with ibus. ibus is an input method infrastructure for non-latin-character languages. The firmware installation worked when you used the version of hp-plugin without graphical user interface ("hp-plugin -i").

Can anyone at HP check this? Note that the user works under Russian locale, probably under US English locale this bug will not appear.

To the ibus maintainers, can you check whether this is perhaps an ibus bug?

Set up russion locale, install hplip-gui, and run

hp-plugin -ldebug

The problem occurs after the download and verification of the firmware/plugin file.

summary: - The HP 1018 printer is not supported in Ubuntu 8.10, 9.10. In 10.04
- supported but not work "out of the box".
+ The HP 1018 printer not work out of the box if used non-US locale.
summary: - The HP 1018 printer not work out of the box if used non-US locale.
+ The HP 1018 printer not work out of the box if used non-US locale
Changed in ibus (Ubuntu Maverick):
importance: Undecided → High
Changed in ibus (Ubuntu Lucid):
importance: Undecided → High
Changed in hplip (Ubuntu Maverick):
importance: Undecided → High
Changed in hplip (Ubuntu Lucid):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

not sure why there is an ibus task there but that has nothing to do with printing so closing it

Changed in ibus (Ubuntu Lucid):
status: New → Invalid
Changed in hplip (Ubuntu Maverick):
assignee: nobody → Till Kamppeter (till-kamppeter)
Changed in ibus (Ubuntu Maverick):
status: New → Invalid

Sebastien, Robbie, the problem here is a bad interference of the hp-plugin utility with ibus. To reproduce this, you need to set Russian locale, install hplip-gui and run

hp-plugin -ldebug

Then you get the following output:

http://launchpadlibrarian.net/51322144/hp-plugin%20ldebug%20output.txt

which shows that there is a problem with ibus.

Changed in ibus (Ubuntu Maverick):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

is that still an issue with the new ibus? we don't have an ibus maintainer right now to investigate it...

Sebastien Bacher (seb128) wrote :

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=517434 which was mentioned in the comments has been closed, could those having the issue check if the bug is still there in maverick and if it happens with an english locale?

Changed in ibus (Ubuntu Maverick):
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

is the utility having the issue running as a normal user or under gksudo or similar?

> could those having the issue check if the bug is still there in maverick and if it happens with an english locale?
I can check this issue on this computer only after Maverick Beta released.

> is the utility having the issue running as a normal user or under gksudo or similar?
As a normal user.

Sebastien Bacher (seb128) wrote :

lowering the task since nobody respond, there is only one duplicate and 5 affected people there, doesn't seem a high priority issue for this cycle

Changed in hplip (Ubuntu Maverick):
importance: High → Low
Changed in ibus (Ubuntu Maverick):
importance: High → Low
Changed in ubuntu-release-notes:
status: New → Won't Fix

Sorry for late answer. I check this printer today.
Still issue in updated Maverick.

Changed in hplip:
status: Incomplete → New
Changed in hplip (Ubuntu):
status: Incomplete → New
Changed in hplip (Ubuntu Maverick):
status: Incomplete → New
Changed in ibus (Ubuntu):
status: Incomplete → New
Changed in ibus (Ubuntu Maverick):
status: Incomplete → New

If the problem is caused by HPLIP, we need a fix from upstream.

Has anyone checked whether the problem can be solved in IBus?

Sebastien, the utility is running under gksudo.

Changed in hplip (Ubuntu Maverick):
assignee: Till Kamppeter (till-kamppeter) → nobody
Changed in hplip (Ubuntu):
assignee: Till Kamppeter (till-kamppeter) → nobody

Also in Maverick there is another prolem with this printer. Even if I use workaround from commentary #29 I can not get this printer work at all.
Can someone from HPLIP Team look into this https://bugs.launchpad.net/bugs/732450 bugreport?

Current status of this bug:
Lucid: I didn't test it with latest updates, but probably not fixed.
Maverick: there is appear another bug - https://bugs.launchpad.net/bugs/732450
Natty: all problems fixed, complete out-of-the-box experience. Thank you!

> Natty: all problems fixed, complete out-of-the-box experience
Tested on three computers (two fresh Natty installation, one upgade from Maverick). Printer works just after I insert USB-cable

Changed in hplip (Ubuntu):
status: New → Fix Released
Changed in ibus (Ubuntu):
status: New → Fix Released

My commentary #45 is related to foo2zjs experieance, not hplip. Because there now some issues with foo2zjs https://bugs.launchpad.net/foo2zjs/+bug/489750/comments/25 I was try hplip today in Oneiric. Looks like is still not fixed - "hp-plugin -ldebug" still can't install plugin, but after "hp-plugin -i -ldebug 2" plugin installed sucefully. (Probably in Natty is still same problem.)

Changed in hplip (Ubuntu Lucid):
status: New → Won't Fix
Changed in hplip (Ubuntu Maverick):
status: New → Won't Fix
Changed in ibus (Ubuntu Maverick):
status: New → Won't Fix
Gannet (ken20001) wrote :

This issue is still is. Should we create a new report or can we change the status of this old one?

BakLan, probably your problem has a different cause. Please report a new bug. Tell us which locale you are using.

Gannet (ken20001) wrote :

I'm using Ukrainian locale. Till I didn't used hp-plugin-command by hand and plugin was downloaded and installed, it all the time the system is logged on or printed is turned on tells from pup-up message that there are proprietary plugin needed, tried to download it but failed at last.

Can someone of the HPLIP developers at HP look at this? It seems that hp-plugin does not work with non-English locales.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.