Ubuntu

[regression, intrepid] redraw problems, patches from fedora

Reported by Robert Jordens on 2008-09-19
104
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
libgnomecanvas (Suse)
Fix Released
Unknown
libgnomecanvas (Ubuntu)
Low
Ubuntu Desktop Bugs
Intrepid
Low
Ubuntu Desktop Bugs

Bug Description

Applications which use libgnomecanvas, such as xournal, do not update the screen properly when the user draws lines. Some lines don't appear, others are shown after the cursor moves off the canvas, others are partially displayed and are later completed after releasing the mouse button. This was patched, but did not solve the problem. The updated patch is located https://bugzilla.novell.com/show_bug.cgi?id=430785 and the debdiff is at http://launchpadlibrarian.net/19312323/libgnomecanvas_2.20.1.1-1ubuntu3.debdiff

Testcase:
1) Launch xournal
2) Maximize the window (it seems to help exacerbate the effect)
3) Try to draw by clicking, then holding the first mouse button and moving around
4) Wait a bit, then release. Notice the delayed update.

Robert Jordens (jordens) wrote :
description: updated
James Westby (james-w) wrote :

Hi,

I'm subscribing the sponsors team, in this case ubuntu-main-sponsors, which
you should do if you have a debdiff you would like to see uploaded.

Thanks,

James

Daniel Holbach (dholbach) wrote :

libgnomecanvas-2.19.2-avoid-tearing.patch was accepted upstream: http://svn.gnome.org/viewvc/libgnomecanvas/trunk/libgnomecanvas/gnome-canvas.c?r1=1257&r2=1263

Sebastien Bacher (seb128) wrote :

thank you for your bug report, hardy has exactly the same libgnomecanvas so if the issue is new in intrepid that's not likely due to it

Sebastien Bacher (seb128) wrote :

could you also use a proper patch in the debian directory rather than patching directly the source?

Changed in libgnomecanvas:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnomecanvas - 2.20.1.1-1ubuntu2

---------------
libgnomecanvas (2.20.1.1-1ubuntu2) intrepid; urgency=low

  * debian/patches/90_upstream_correctly_update.patch:
    - upstream change to fix canvas update issues, thank to Robert Jordens
      who opened the bug and suggested the change (lp: #272316)

 -- Sebastien Bacher <email address hidden> Wed, 08 Oct 2008 23:32:33 +0200

Changed in libgnomecanvas:
status: Incomplete → Fix Released
Ken Arnold (kenneth-arnold) wrote :

I think this just /broke/ xournal updating. I couldn't try out the hardy version without downgrading all of gtk, so I can't confirm unless somebody posts the previous intrepid package. But I'm definitely getting new issues that sound much like what the reporter described after upgrading this morning.

Ken Arnold (kenneth-arnold) wrote :

Confirmed that this patch BROKE xournal. The canvas basically didn't update unless a redraw was forced (window switching, scrolling, etc.). Occasionally it would partially draw some other part of some line, but never what I had just drawn. I rebuilt libgnomecanvas /disabling/ the patch and xournal now redraws just fine again.

zoomy942 (zoomy942) wrote :

I am confirming and subscribing to this bug also. I have the same problem.

zoomy942 (zoomy942) wrote :

Is there a fix?

Ken Arnold (kenneth-arnold) wrote :

I'm attaching the rebuild I did; I just disabled the patch described here and rebuilt. But do post if it works for you; let's see if we can get this reopened.

The attachment comes with no warranty! :)

zoomy942 (zoomy942) wrote :

I DL'ed that and it was for the i386 type. I'm AMD64. We're close my friend!

Joe Smith (yasumoto7) wrote :

According to https://bugs.edge.launchpad.net/ubuntu/+source/libgnomecanvas/+bug/284530, a fixed patch is located at https://bugzilla.novell.com/show_bug.cgi?id=430785. I'm attaching a new debdiff which (hopefully) fixes the problem.

Changed in libgnomecanvas:
status: Fix Released → Confirmed
Joe Smith (yasumoto7) wrote :

thanks - i can confirm the debdiff fixed the problem for me

Bogdan Radu (bog-radu) wrote :

Thanks!
I can also confirm it worked for me.

zoomy942 (zoomy942) wrote :

This may sound silly - but what do I do with that debdiff?

Andcor (corneliussen) wrote :

I can also confirm that this debdiff fixes the issue for me.

I too was a bit confused about what to do about such a debdiff, but then a quick search at google got me this: https://wiki.ubuntu.com/UbuntuPackagingGuide/BuildFromDebdiff which told me anything I needed to know.

Thank you very much for the patch.

zoomy942 (zoomy942) wrote :

So, i feel silly becasue I get an error but I dont know why.

you should replace any instances of PACKAGE with libgnomecanvas.
Furthermore, when you come to the point where you shall perform the apt-get
source command you shall do it like this

apt-get source libgnomecanvas libgnomecanvas2-0

And you should do the apt-get build-dep like this

apt-get build-dep libgnomecanvas2-0

OmniUni (omniuni) wrote :

Installing the built *.deb above worked perfectly for me. I accidentally marked this bug under Xournal, my apologies for that, but things work fine now, I hope this fix makes it in soon.

libgnomecanvas_2.20.1.1-1ubuntu3.debdiff solves the problem for me with Ubuntu 8.10 on amd64.

zoomy942 (zoomy942) wrote :

okay - i got stuck again...

this step

cd PACKAGE-* && patch -p1 < ../DEBDIFF

fails...

bash: cd: PACKAGE-*: No such file or directory
zimmerman@ubuntu-tablet:~/Desktop/PACKAGE$ cd libgnomecanvas-* && patch -p1 < ../DEBDIFF
bash: ../DEBDIFF: No such file or directory
zimmerman@ubuntu-tablet:~/Desktop/PACKAGE/libgnomecanvas-2.20.1.1$

cant someone just attach the deb they made or email it to me?

Joe Smith (yasumoto7) wrote :

Every time the wiki mentions PACKAGE, you should replace it with
"libgnomecanvas2-0" and in this case the DEBDIFF is
libgnomecanvas_2.20.1.1-1ubuntu3.debdiff (unless it's named something else).

On Sat, Nov 1, 2008 at 8:48 PM, zoomy942 <email address hidden> wrote:

> okay - i got stuck again...
>
> this step
>
> cd PACKAGE-* && patch -p1 < ../DEBDIFF
>
> fails...
>
> bash: cd: PACKAGE-*: No such file or directory
> zimmerman@ubuntu-tablet:~/Desktop/PACKAGE$ cd libgnomecanvas-* && patch
> -p1 < ../DEBDIFF
> bash: ../DEBDIFF: No such file or directory
> zimmerman@ubuntu-tablet:~/Desktop/PACKAGE/libgnomecanvas-2.20.1.1$
>
>
> cant someone just attach the deb they made or email it to me?
>
> --
> [regression, intrepid] redraw problems, patches from fedora
> https://bugs.launchpad.net/bugs/272316
> You received this bug notification because you are a direct subscriber
> of the bug.
>

zoomy942 (zoomy942) wrote :

Why am I not getting this?

I can confirm that applying libgnomecanvas_2.20.1.1-1ubuntu3.debdiff does indeed fix redraw problems with xournal.

Andcor (corneliussen) wrote :

I do not know why you can't understand it, but it seems that some of the
steps has been completed as they should. The thing you should do now:

   1. Open a new terminal
   2. cd ~/Desktop/PACKAGE
   3. sudo apt-get build-dep libgnomecanvas2-0
   4. cd libgnomecanvas_2.20.1.1
   5. patch -p1 < ../libgnomecanvas_2.20.1.1-1ubuntu3.debdiff
   6. debuild -uc -us
   7. sudo dpkg -i ../libgnomecanvas*.deb

It isn't that hard

Francois Deppierraz wrote:
> I can confirm that applying libgnomecanvas_2.20.1.1-1ubuntu3.debdiff
> does indeed fix redraw problems with xournal.
>
>

Sebastien Bacher (seb128) wrote :

thank you for your work there, intrepid is stable now so the change needs to go to intrepid-proposed and not intrepid, the control change is also not required in the debdiff, could you update the debdiff to reflect that and also add a testcase to the bug description?

Changed in libgnomecanvas:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
zoomy942 (zoomy942) wrote :

What is going on?

gah!

zimmerman@zimmerman-desktop:~/Desktop/PACKAGE$ cd libgnomecanvas_2.20.1.1
bash: cd: libgnomecanvas_2.20.1.1: No such file or directory
zimmerman@zimmerman-desktop:~/Desktop/PACKAGE$

khul (klas-hultqvist) wrote :

I also confirm that libgnomecanvas_2.20.1.1-1ubuntu3.debdiff did the trick for xournal for intrepid on an hp tc4400 tablet pc.

zoomy942 (zoomy942) wrote :

Now it seems silly that I can't get it to work.

Are .debs not allowed to be attached? That would be a million times easier for a guy like me who has never compiled anything before.

Joe Smith (yasumoto7) wrote :
description: updated
zoomy942 (zoomy942) wrote :

FYI - I downloaded the rpm for fedora, and tried converting it to a deb, but i have the AMD64 install and the rpm is for i386.

Andcor (corneliussen) wrote :

I don't have any amd64 setups so I can't make debs for you. but give me
an terminal with sudo access on your computer and I will do it for you.

Andreas

Hugh Eaves (hugh-hugheaves) wrote :

Here's the amd64 deb. This fixed the problem for me.

Joe Smith (yasumoto7) wrote :

Alright, here's the actual upstream bug in libgnomecanvas.

Changed in libgnomecanvas:
status: Unknown → Fix Released
zoomy942 (zoomy942) wrote :

@ Hugh - Thanks so much! That worked great on my 3 Tablet PC's I have!

nkri (nkri) wrote :

I can confirm that Ken Arnold's rebuilt package without the patch works great on my Toshiba Portege M400. Thanks!
-nkri

laurentp (laurentpotvin) wrote :

It did the trick for me too. I don't understand why it is not mainstream. Anyway thank you all!

Vincenzo Ciancia (vincenzo-ml) wrote :

If someone knows how to upload packages to a ppa (I used to, but have zero time due to overwork), you can use the toshiba-tablet launchpad team and its ppa. I think it's entirely free but if not just tell me and I'll give permission to upload to anybody (yes it's a bit liberal, but I don't expect any problems for now, and it's not anonymous in any case).

Vincenzo Ciancia (vincenzo-ml) wrote :

Here's the link

https://edge.launchpad.net/~toshiba-tablet

if you don't like the name I guess we can rename it or create a new one (originarily I meant that team for toshiba support but it's a bit too restrictive I think).

> I'm attaching the rebuild I did; I just disabled the patch described here and rebuilt. But do post if it
> works for you; let's see if we can get this reopened.

Ken Arnold's rebuilt package works here as well (so far). Not having a working Xournal is a showstopper bug for this tablet user, since I use that application to teach class and I've got to be able to change the zoom and use full-screen.

(Like some others, I never had xournal issues *until* this "fix" was released.)

Joe Smith (yasumoto7) wrote :

I've opened up a Debian bug, I'll email the libgnomecanvas maintainer
to ping him about this. If we don't hear from him, I think it'd be
best to get this fixed in Ubuntu and then merge with Debian once that
gets fixed.

James Westby (james-w) wrote :

Hi,

Please close the Debian bug, this problem is not present in Debian.

Thanks,

James

James Westby (james-w) wrote :

I meant that the regression in xournal isn't present, the original redraw
problem probably are.

Thanks,

James

Ed K (ekohlwey) wrote :

It looks like there still might be some issues for some users, so here's an updated ia32 package if anyone needs it (again, without warranty).

Joe Smith (yasumoto7) wrote :

James: Wow, you're right. This was never applied to Debian in the first place. Just closed the debian bug.

Sebastien Bacher (seb128) wrote :

would be rather useful to work on an intrepid update rather than add random deb builds to this bug

Vincenzo Ciancia (vincenzo-ml) wrote :

A developer may be very well used to the process of requesting updates, but at least for me, deleting a patch and rebuilding is a matter of half an hour, making a correct request for an update is beyond of my possibilities in terms of free time.

On the other hand, an updated deb is useful to let subscribers to the bug report test the fix, and to give them a workaround. In this case, I can confirm that the fix works, and can also use xournal in intrepid (but I can't use intrepid for so many other regressions).

So why complaining? I sincerely HOPE that people keeps uploading debs with fixes for other people to test, instead of let poorly tested patches pass trough the upload procedure. The easier you make testing, the more feedback you receive.

Is it the case that a quick revert of a wrong patch should go trough all the burocracy or could the patch just be reverted by somebody? It can't be so terribly difficult.

OTOH, a proper solution that fixes redraw problems AND does not break xournal is needed. That's a separate problem. For now the urgent matter is to repair broken xournal in intrepid, by reverting a patch that caused a known regression.

Andcor (corneliussen) wrote :

I agree. You cannot come here and bitch over the fact that this patch
hasn't reached the ubuntu repos'es. In stead you should be glad that the
patch is posted here for the ubuntu developers to find in stead of in
some bizare forum where it will never be found by a developer with the
time and knowledge sufficient for porting it to the repos'es.

My mother allways told me: "if you have nothing positive to say, then
don't say anything".

Pietro Battiston (toobaz) wrote :

Here is a patch targeted "intrepid-proposed" (I don't think Jaunty needs it).

Notice it does not give credit to Joe Smith only because I went to this bug trought #284530, so didn't see his debdiff (and in fact the resolution is _slightly_ different).

I already tested the patch (in xournal) and works perfectly.

Sebastien Bacher (seb128) wrote :

thank you for your work there, I did some small spacing changes and sponsored the update

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libgnomecanvas:
status: Confirmed → Fix Committed

The patch posted by Pietro on 2008-11-21 works good on my Intrepid Ibex amd64 (IBM X60tablet).

Pietro Battiston (toobaz) wrote :

I'm - obviously - using it and it works.

However there is a small problem - don't know if this is another bug or something that usually happens with libraries backporting and is considered normal: if one has "proposed" enabled, it is impossible to install libgnomecanvas2-dev, because it is still the old version, and it depends on the old libgnomecanvas2, which is no more available... so the only possibility is manually build the new libgnomecanvas2-dev and dpkg it...

None of libgnomecanvas -doc, -ruby and mm packages seems to have the same problem, only -dev.

Also bringingi in proposed -dev would solve the issue.

The package in intrepid-proposed works here on a Thinkpad X41 tablet, at least for this morning's classes. (I teach with the Xournal window maximized but set to 85% zoom, and that combination triggered redrawing/selection problems every time with the previous Ubuntu package)

Joe Smith (yasumoto7) wrote :

Thanks Pietro! :)

Pietro Battiston [2008-11-24 16:10 -0000]:
> However there is a small problem - don't know if this is another bug or
> something that usually happens with libraries backporting and is
> considered normal:

No, it isn't. -proposed should be perfectly installable.

> if one has "proposed" enabled, it is impossible to
> install libgnomecanvas2-dev, because it is still the old version

That's weird. The master archive on archive.ubuntu.com is okay:

$ rmadison -s intrepid-proposed -S libgnomecanvas
libgnomecanvas | 2.20.1.1-1ubuntu3 | intrepid-proposed | source
libgnomecanvas2-0 | 2.20.1.1-1ubuntu3 | intrepid-proposed | amd64, i386
libgnomecanvas2-common | 2.20.1.1-1ubuntu3 | intrepid-proposed | all
libgnomecanvas2-dev | 2.20.1.1-1ubuntu3 | intrepid-proposed | amd64, i386
libgnomecanvas2-doc | 2.20.1.1-1ubuntu3 | intrepid-proposed | all

Maybe your mirror has a problem? Which one are you using?

Pietro Battiston (toobaz) wrote :

Problem solved. Yes, I think it was a problem with my mirror (it.archive.ubuntu.com), but it disappeared, sorry for not checking before.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnomecanvas - 2.20.1.1-1ubuntu3

---------------
libgnomecanvas (2.20.1.1-1ubuntu3) intrepid-proposed; urgency=low

  * debian/patches/90_upstream_corretcly_update.patch:
   - fix the patch to solve problems with redrawing; thanks
     to Federico Mena Quintero who provided this version and to
     Denis Auroux who suggested it (LP: #272316)

 -- Pietro Battiston <email address hidden> Fri, 21 Nov 2008 02:16:04 +0100

Changed in libgnomecanvas:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

This is fixed in jaunty as well.

Changed in libgnomecanvas:
status: Confirmed → Fix Released
Changed in libgnomecanvas:
status: Fix Released → Confirmed
Bob McElrath (bob+ubuntu) wrote :

This is not fixed in intrepid for me.

It is however sensitive to the zoom level. In xournal, maximize by clicking the "set zoom" button, then select "page height".

The bug I see is that drawn lines appear a long time behind the stylus, and the bug gets worse as you move toward the lower right corner of the screen. Try drawing quick strokes in the upper left and lower right, and compare how long it takes for the stroke to appear on the screen.

I have 2.20.1.1-1ubuntu3 on intrepid. I recompiled by hand, removing the 90_upstream_correctly_update.patch, and the bug disappears. I can find no drawing errors

Note that the bugs reported in the original report above are still present with the intrepid package, and also disappear when I remove the 90_upstream_correctly_update.patch. I can find no drawing errors at all after removing it.

Did someone put a 'patch -R' in the wrong place?

Pietro Battiston (toobaz) wrote :

Actually, the package was tested by many and reported to work; it is true that without the patch the bug is not here, however notice the patch is not intended to solve this bug, but another one (having to do with tearing), so this is not strange.

Are you sure you didn't someway take the old version of the patch (from 2.20.1.1-1ubuntu2 or from the web)?

I see the exact same problem as Bob does. I first thougt it was because
I had set the virtual property in my xorg.conf, but If Bob has found a
solution to the problem I am all ears.
How did you remove the 90_upstream_correctly_update.patch Bob? I have
tried to make an apt-get source xournal in order to get the ubuntu
source code, but I didn't get the patches and the problem is still
present if just compiling the source code.

Bob McElrath (bob+ubuntu) wrote :

Absolutely positive about my versioning. I did an 'apt-get source libgnomecanvas' which gets libgnomecanvas_2.20.1.1-1ubuntu3, and built it by hand, with and without that patch which is a part of this package. The ubuntu-compiled package that was installed by default in intrepid definitely has the above problem. Took me nearly a week to track down the source...

The -1ubuntu2 package attached to this bug has the problem I see too.

Andcor: 'apt-get source libgnomecanvas' will create the directory libgnomecanvas-2.20.1.1, in which you will find debian/patches/90_upstream_correctly_update.patch. Rename (to something that doesn't end in .patch) or remove this file, and do a dpkg-buildpackage to get a libgnomecanvas without this bug.

Pietro Battiston (toobaz) wrote :

The "ubuntu-compiled package that was installed by default in intrepid" depends on which channels you have enabled, but notice that for instance in

http://packages.ubuntu.com/search?keywords=libgnomecanvas&searchon=names&suite=intrepid

you still get libgnomecanvas_2.20.1.1-1ubuntu2, which yes, has this bug.

Anyway: I tried to redownload (apt-get source libgnomecanvas) and recompile (dpkg-buildpackage -kfakeroot) the package, but I'm unable to reproduce the bug. May I ask you to attach the buggy binary (amd64, possibly?) recompiled by you, to try to see if I can reproduce it?

Bob McElrath (bob+ubuntu) wrote :

The package with the bug is:
    6f827fc1fffcbfa480dc548bb82b003a libgnomecanvas2-0_2.20.1.1-1ubuntu3_i386.deb
(that's the md5sum). I just re-downloaded it from the mirrors e.g.
    http://mirrors.kernel.org/ubuntu/pool/main/libg/libgnomecanvas/
and double checked. (i386 arch)

The package I compiled, simply removing 90_upstream_correctly_update.patch, and which does not have the bug, is attached.

This is not a -1ubuntu2 version misunderstanding.

Pietro Battiston (toobaz) wrote :

I'm trying to reproduce, and maybe a couple of times was successful, so I'm starting to think to some gcc misbehaviour (or, more realistically, some libgnomecanvas misbehaviour exposed only by some gcc)... does the bug also imply painful slowliness i.e. when resizing?

Andcor, do you have i386 too?

legobib13 (legobib13) wrote :

Hello,

I have been trying to get this debdiff to somehow patch my libgnomecanvas on openSUSE 11.1 x86_64. I can't do it. Is there any way I can? -- or is there a way a patch can be made for suse ?

I did upgrade my libgnomecanvas from shipped version 2.20.1.1-25.79 to 2.20.1.1-86.11 from http://download.opensuse.org/repositories/GNOME:/Factory:/Next/openSUSE_11.1/

Thanks.

Pietro Battiston (toobaz) wrote :

As far as I know, the fact that a SUSE corresponding bug is linked from here doesn't extend the scope of this page to how/which SUSE packages can be patched.

Also notice my patch didn't solve the problem for everybody. Anyway, you can find the patch itself in http://launchpadlibrarian.net/19312323/libgnomecanvas_2.20.1.1-1ubuntu3.debdiff
or
http://archive.ubuntu.com/ubuntu/pool/main/libg/libgnomecanvas/libgnomecanvas_2.20.1.1-1ubuntu3.diff.gz
, but they are not very friendly formats (for the not debian based)! Still, you can easily extract from it the real file.

Or you can go to the original Fedora bug from which I took the patch from.

legobib13 (legobib13) wrote :

I am new to the linux environment. How exactly would I go about extracting what I need? I noticed I can view a bunch of code in the .diff and .debdiff files, but I am not too familiar with much of it.

Pietro Battiston (toobaz) wrote :

I have absolutely _no_ idea of how a SUSE package must be patched (I don't even know how it must be compiled).

I'm not trying to be unpolite, I'm just trying to suggest that _this_ is not the right place to ask what you need.

Vincenzo Ciancia (vincenzo-ml) wrote :

legobib13: this is not the official suse bug tracker. Follow the link in the "assigned to" column for suse at the top of this page:

https://bugzilla.novell.com/show_bug.cgi?id=430785

and if the answer is not there, you may try to ask more information directly in the suse bug report.

Changed in libgnomecanvas:
status: Confirmed → Incomplete
Changed in libgnomecanvas:
status: Incomplete → In Progress
Changed in libgnomecanvas:
status: In Progress → Fix Released
Changed in libgnomecanvas:
status: Fix Released → Confirmed
Changed in libgnomecanvas (Suse):
status: Confirmed → Fix Released
Bob McElrath (bob+ubuntu) wrote :

This bug is still present in Jaunty and libgnomecanvas 2.26.

Unfortunately, the patch I removed from 2.20 to fix it is no longer present in 2.26. It looks like the libgnomecanvas people made the situation worse and incorporated the bug upstream.

The symptom is that what is drawn lags substantially behind the stylus, so much so that curved lines become joined line segments. It gets worse as you move to the bottom of the screen. It's more noticeable in portrait mode. Also, the effect is substantially worse than in Hardy. Xournal is basically unusable under Jaunty, unless you write REALLY slowly.

Changed in libgnomecanvas (Ubuntu):
status: Fix Released → Confirmed

I actually have not seen this bug in a long time (though admittedly I don't
use xournal much these days).

"Works for me" with latest Jaunty.
xournal/jaunty uptodate 0.4.2.1-0.1ubuntu1
libgnomecanvas2-0/jaunty uptodate 2.26.0-0ubuntu1
libgnomecanvas2-common/jaunty uptodate 2.26.0-0ubuntu1
libgnomecanvasmm-2.6-1c2a/jaunty uptodate 2.23.1-1

I tried most combinations of settings within xournal that I could think of.
Try making a temporary new user account and running it there?

-Ken

On Tue, Apr 28, 2009 at 9:57 AM, Bob McElrath
<<email address hidden><bob%<email address hidden>>
> wrote:

> This bug is still present in Jaunty and libgnomecanvas 2.26.
>
> Unfortunately, the patch I removed from 2.20 to fix it is no longer
> present in 2.26. It looks like the libgnomecanvas people made the
> situation worse and incorporated the bug upstream.
>
> The symptom is that what is drawn lags substantially behind the stylus,
> so much so that curved lines become joined line segments. It gets worse
> as you move to the bottom of the screen. It's more noticeable in
> portrait mode. Also, the effect is substantially worse than in Hardy.
> Xournal is basically unusable under Jaunty, unless you write REALLY
> slowly.
>
> ** Changed in: libgnomecanvas (Ubuntu)
> Status: Fix Released => Confirmed
>
> --
> [regression, intrepid] redraw problems, patches from fedora
> https://bugs.launchpad.net/bugs/272316
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Bob McElrath (bob+ubuntu) wrote :

On further investigation, it seems this was caused by the dastardly iowait kernel bug:

http://bugzilla.kernel.org/show_bug.cgi?id=12309

I'm sure that one is in launchpad somewhere but I couldn't find it.

Trackerd was running in the background right after the upgrade, and because the kernel can't properly load-balance when IO is occuring, everything became extremely slow. The X process (not xournal) was consuming 100% cpu while drawing. The result, ironically was nearly the same symptoms as I saw before with this bug.

Killing trackerd fixed it.

I hope someone fixes this kernel bug soon, it's hitting me from every side...

Changed in libgnomecanvas (Ubuntu):
status: Confirmed → Fix Released
Bob McElrath (bob+ubuntu) wrote :

In case anyone else looks here, the related launchpad bugs are:

https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/131983 (trackerd makes system crawl)

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/131094 (because of a kernel bug)

Changed in debian:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.