Ubuntu

bluetooth mouse stopped working after bluez-utils and bluetooth update [hardy]

Reported by Iakov Davydov on 2008-04-21
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned

Bug Description

After recent update:
bluetooth (3.26-0ubuntu6)
bluez-utils (3.26-0ubuntu6)

1. right-click on bluetooth icon -> preferneces
2. services->input service->Add->Bluetooth Laser Travel Mouse->Connect (it says connected, ok)
what suppose to happen
mouse shoud word (it was working before update)
what actually happens
a. mouse doesn't work
b. on mouse move connection icon appears on leftmost tab but it disapears in few seconds

Linux theatre 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux
Ubuntu 8.04

Brian Murray (brian-murray) wrote :

Possible regression from the fixes for bug 191704 and bug 192043.

Iakov Davydov (iakov-davydov) wrote :

I tried to make hidd --search/--connect and it seems to work again.

What is the prefered way? Should I perform some tests?

Gustavo Carneiro (gjc) wrote :

I have the same problem. After Bluetooth packages upgrade my bluetooth mouse doesn't work; how frustrating :-(

I can confirm this as well. Using Microsoft Bluetooth Mouse 5000. Was working prior to 3.26-0ubuntu6. Attempts to connect the mouse result is system freeze. I have tried disabling HIDD in /etc/default/bluetooth per a recommendation from a forum post, but this had no effect. In the short term does anyone know how to revert back to the previous version and lock the package(s) until a fix is available?

UPDATE: Reverting bluez-utils, bluez-audio, and bluez-cups back to 3.26-0ubuntu5 fixed the problem. Old packages can be downloaded from http://mirrors.kernel.org/ubuntu/pool/main/b/bluez-utils/ and installed manually with dpkg. Then to lock the version go into Synaptic, locate the packages, then go to Package -> Lock Version.

Matti Lindell (mlind) wrote :

Mike, could you try if earlier version (3.26-0ubuntu5) works for you. Head to https://launchpad.net/ubuntu/+source/bluez-utils/3.26-0ubuntu5, then choose your architecture from "Builds" section below, and then expand "Resulting binaries" dropdown from the left hand side. You'll need at least bluez-utils and bluez-audio packages.

'dpkg -l | grep 3.26-0ubuntu6' should show what other bluez-utils packages you need to downgrade. You can use synaptic or other package manager to 'pin-down/lock' the packages, so those won't get upgraded by newer version in the repository.

Remember to restart the bluetooth service if it's not done automatically. Does the problem persist with 3.26-0ubuntu5 ?

Gustavo Carneiro (gjc) wrote :

3.26-0ubuntu5 works, 3.26-0ubuntu6 does NOT work.

Onkar Shinde (onkarshinde) wrote :

The only difference in 3.26-0ubuntu6 from 3.26-0ubuntu5 is the presence of hidd and pand binaries. Can anyone try completely removing (including configuration) bluez-gnome and bluez-utils and reinstalling them so as to see if the problem is there with default installation.

These two binaries were enabled as solutions for the bugs specified in Brian's comments.

JorgeAT (jorgeat) wrote :

I confirm with the update 3.26-0ubuntu6 my MS Mouse 5000 stop moving, is detected but is not respond to movement.

I completely remove all bluez and related packages and reinstall 3.26-0ubuntu6, but mouse dont work, then I downgrade to 3.26-0ubuntu5 and restart services and my mouse is working again

regards

Gustavo Carneiro (gjc) wrote :

IMHO it would be just better to revert the change. It would be a shame if Hardy was released with this problem.
Beter something half working than not at all...

Onkar Shinde (onkarshinde) wrote :

Has anyone tried method mentioned by Yasha?

If that doesn't work then please raise a concern in #ubuntu-devel channel on irc.freenode.net. The last change was made because people were complaining about absence of these binaries. Now the presence is causing the problem. This needs to have definite solution.
Unfortunately I will not be having time for my day to debug due to office work.

Changed in bluez-utils:
importance: Undecided → Medium
milestone: none → ubuntu-8.04.1
status: New → Confirmed
a.l.e (ale-comp-06) wrote :

hello

i'm the reporter of the following bug:

https://bugs.launchpad.net/ubuntu/+bug/223132
apple bluetooth keyboard stopped working

it seems to me, that it's the same bug...

so, i've tried to

Completely removed the following packages:
bluez-audio
bluez-cups
bluez-gnome
bluez-utils

Removed the following packages:
bluetooth

and then

Installed the following packages:
bluetooth (3.26-0ubuntu6)
bluez-audio (3.26-0ubuntu6)
bluez-cups (3.26-0ubuntu6)
bluez-gnome (0.25-0ubuntu1)
bluez-utils (3.26-0ubuntu6)

but it didn't change the way Hardy (upgraded from RC) (not) handles my keyboard.

any further idea?

i've no idea, how the BT stack works in ubuntu, but if somebody contacts me, i will take the time to fully test everything s/he suggests...

ciao
a.l.e
a l e dot c o m p underscore 06 at x o x dot ch

Paco (nunuxboy) wrote :

same problem here on my 4 laptops after the updates!

they can't recognize my BT mouse , they can't see any BT device.

Changed in bluez-utils:
milestone: ubuntu-8.04.1 → none
importance: Undecided → Medium
status: New → Confirmed
riahmatic (riahmatic) wrote :

Still not working for me either. My logitech mouse flashes the LED like it should before connecting but keeps flashing it instead of establishing the connection. It is already listed as a bonded device in Bluetooth preferences.

Paco (nunuxboy) wrote :

So, is there a solution now??

As here my bluetooth mouse is still not working

Andreas Ntaflos (daff) wrote :

Still a problem and a very annoying one, to say the least. There doesn't even seem to be a hackish, dirty workaround. What does it take to get a bluetooth mouse working in Hardy?

Gustavo Carneiro (gjc) wrote :

Intrepid is out but I am afraid to upgrade only because of this bug :-(

samstitt (samstitt) wrote :

My Bluetooth mouse didn't work in Hardy but does in Intrepid (have been running for a month on Beta release and now RC) - one small glitch (not sure if it's been fixed now) but sometimes when the mouse failed to connect it had to be cleared from the bluetooth list and re-added, now works fine :-)

jasonq (jason-quinn) wrote :

The Microsoft 5000 Bluetooth mouse has trouble on 8.10 (won't reconnect after a boot, and you have to delete the entry and reconnect) and it doesn't connect at all in 9.04 beta.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers