[Ubuntu 20.04 s390] Failed to install os from CD

Bug #1875300 reported by bugproxy
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
High
Skipper Bug Screeners
subiquity
Undecided
Skipper Bug Screeners
casper (Ubuntu)
Undecided
Unassigned
Focal
High
Unassigned
Groovy
Undecided
Unassigned
lvm2 (Ubuntu)
Wishlist
Unassigned
Focal
High
Unassigned
Groovy
Wishlist
Unassigned

Bug Description

Failed to install os from CD

---Installation Media---
ubuntu-20.04-live-server-s390x.iso

---Machine type ---
model: 8561 - T01

---Steps---
Login to HMC
Load CD via 'Load from Removable media or Serer'
Select FTP
After loaded successfully

Get following message in Operating System Messages and installation failed:

ln: /tmp/mountroot-fail-hooks.d//scripts/init-premount/lvm2: No such file or dir
ectory

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-185591 severity-high targetmilestone-inin2004
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Frank Heimes (fheimes)
Changed in subiquity:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
no longer affects: linux (Ubuntu)
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Frank Heimes (fheimes)
tags: added: installer s390x
Revision history for this message
Frank Heimes (fheimes) wrote :

It's currently in discussion how to proceed on that ...

Changed in ubuntu-z-systems:
importance: Undecided → High
Revision history for this message
Frank Heimes (fheimes) wrote :

Would of course be good t improve the notification why it can't install.
See also LP 1875309 - "[UBUNTU 20.04] Add notification in case subiquity got booted on s390x w/o a parmfile in place"
For more instructions on how to install please also see:
https://ubuntu-on-big-iron.blogspot.com/2020/03/glimpse-at-subiquity.html

Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :

FWIW the "ln: /tmp/mountroot-fail-hooks.d//scripts/init-premount/lvm2: No such file or directory" message is harmless.

Revision history for this message
Frank Heimes (fheimes) wrote :

Yeah, "ln: /tmp/mountroot-fail-hooks.d//scripts/init-premount/lvm2: No such file or directory" is harmless.
But an installation without a proper parmfile in place stops roughly with that message, so it's a bit misleading and may point to a wrong direction.
Ideally this (harmless) message should be suppressed, and in case a parmfile is missing (or broken/insufficient) a message should indicate this - if that makes sense.

Changed in ubuntu-z-systems:
status: New → Triaged
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

"""
Get following message in Operating System Messages and installation failed:

ln: /tmp/mountroot-fail-hooks.d//scripts/init-premount/lvm2: No such file or dir
ectory
"""

Is it actually the last message?

Normally, we go looking / waiting for physical media to appear, and eventually should print an error message that no installation media was found.

Can you wait longer, and refresh the Operating systems messages screen to see if you eventually receive the error message?

Changed in subiquity:
status: New → Incomplete
Changed in ubuntu-z-systems:
assignee: Canonical Foundations Team (canonical-foundations) → nobody
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
status: Triaged → Incomplete
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2020-05-06 09:26 EDT-------
Just gave it a try - did a FTP load using the default .ins file in the ISO.

The only message that shows up at first indeed is
ln: /tmp/mountroot-fail-hooks.d//scripts/init-premount/lvm2: No such file or directory

Then there's no output for about 06:20 and then there's this:
BusyBox v1.30.1 (Ubuntu 1:1.30.1-4ubuntu6) built-in shell (ash)
Enter 'help' for a list of built-in commands.
(initramfs) [6n
Unable to find a medium containing a live file system

So yeah - if one waits long enough, there will be a hint that something went wrong. However that's still not a great out-of-box experience for customers who are used to this exact same method just working ever since 16.04.

While the error message is technically correct, without additional documentation the user will still not know how to get things working from there.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

The message about "Unable to find a medium containing a live file system" should appear after 60 seconds time out.

I wonder, if that message is not displayed, due to Operating Systems Messages window failing to refresh up to date messages.

If and when, https://bugs.launchpad.net/ubuntu/+source/casper/+bug/1854513 is implemented, instead of showing this "Unable to find a medium containing a live file system" we will instead trigger "configure manual networking & attempt manual network boot" experience.

But I wonder, if the 60s delay, will still be inadequate. I wonder if we should be checking for auto-zdev devices, and if all of them got activated, realize that it is pointless to wait for 60s on s390x, because no devices will be hotplugged (or are slow to appear) which may have the .iso DD'ed onto them.

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-05-20 07:53 EDT-------
@Canonical, which solution will be provided for this situation?

Revision history for this message
Frank Heimes (fheimes) wrote :

It is largely like mentioned an described in comment #7.
The issue reported here, will be gone if LP 1854513 is solved and implemented.
With having LP 1854513 completed, there will be no need anymore for handing over network configuration data per parmfile,
hence the message discussed here becomes obsolete and instead a way to manually configure networking will pop-up instead.
However, the implementation of LP 1854513 is not trivial and will require some time and effort, but it is reflected in the plan.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

The work to implement interactive network setup & boot, without paramfiles is in progress.

It will be available for 20.04.1.

Changed in lvm2 (Ubuntu):
importance: Undecided → Wishlist
Changed in lvm2 (Ubuntu Groovy):
status: New → Fix Released
Changed in casper (Ubuntu Groovy):
status: New → Fix Released
Changed in casper (Ubuntu Focal):
status: New → Confirmed
Changed in lvm2 (Ubuntu Focal):
status: New → Confirmed
Changed in casper (Ubuntu Focal):
importance: Undecided → High
Changed in lvm2 (Ubuntu Focal):
importance: Undecided → High
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

This is now available in groovy daily-live isos.

This is change in other os components rather than subiquity itself. Hence opening tasks against the other packages that we had to fix up. Cause we have fixes in busybox, initramfs-tools, lvm2, casper to make this to work.

Changed in subiquity:
status: Incomplete → Invalid
Changed in ubuntu-z-systems:
status: Incomplete → Confirmed
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-06-17 05:38 EDT-------
I just tried with groovy-live-server-s390x.iso from 2020-06-16. I get the "Attempt interactive netboot from a URL?" prompt and things seemed to be going fine at first. But it seems that the handling of subnets in the IP configuration is broken - giving the IP address in CIDR notation didn't result in the right netmask and there was no explicit prompt for a netmask which left me with an invalid subnet mask for my environment. It just seems to default to a netmask of 255.255.255.0 (/24).

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

"giving the IP address in CIDR notation" is not currently supported.

I feel like I must ditch the linux kernel cmdline ip= format rules, which is the only format supported by klibc ipconfig util in the initrd, and instead use `ip` command to setup static IP configuration.

Specifically, that will allows to support CIDR notation.

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-06-17 07:41 EDT-------
Either that or add a dedicated prompt for the subnet mask. Or let me ask another way: is there any way at the moment to enter a subnet mask at the IP configuration prompt and I just don't know about the correct format?

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

@dominik

I understand your request. I will work on getting that enabled.

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-08-27 02:54 EDT-------
@Canonical: Any news here?

Revision history for this message
Frank Heimes (fheimes) wrote :

Please take the latest Ubuntu Server Live image 20.04.1:
http://cdimage.ubuntu.com/cdimage/ubuntu/releases/20.04.1/release/ubuntu-20.04.1-live-server-s390x.iso

With the recent changes in the casper component of the installer (LP 1854513 and LP 1884933) this is should be fixed now - but the minimum levels are 20.04.1 or 20.10.

Changed in ubuntu-z-systems:
status: Confirmed → Fix Released
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-09-17 03:47 EDT-------
Just tried with ubuntu-20.04.1-live-server-s390x.iso and can confirm that it's now possible to enter a subnet mask which enables network installation without a customized parmfile in our environment.

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-09-17 03:53 EDT-------
IBM Bugzilla status-> closed, Verified by IBM

Revision history for this message
Frank Heimes (fheimes) wrote :

Thank you Dominik for testing and confirming!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers