casper should allow interactive configuration of ip= vlan= url= when incorrectly netbooted

Bug #1854513 reported by Dimitri John Ledkov
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
High
Unassigned
casper (Ubuntu)
Wishlist
Unassigned
Focal
High
Unassigned
Groovy
Wishlist
Unassigned

Bug Description

casper should allow interactive configuration of ip= vlan= url= when incorrectly netbooted

such that users, who can boot, but not modify their netboot infra should be able to fix up these things interactively.

This is part of s390x usability with HMC "netbooting" an ISO.

Related branches

description: updated
tags: added: s390x
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
importance: Undecided → High
tags: added: installer
Revision history for this message
Frank Heimes (fheimes) wrote :

This is quite important, since not everybody who performs installations on a s390x system is also able to modify the parmfile on the install server or installation media.
In fact only _very_ few will be able to do so.

Hence this is needed before subiquity becomes the default installer.

Frank Heimes (fheimes)
tags: added: req4focal
Revision history for this message
Steve Langasek (vorlon) wrote :

I understand this is required for parity with d-i because by its nature, d-i always does the full network and mirror configuration from the initramfs because that is the booted d-i environment.

tags: added: id-5daefa44bb1f1a6935ed0201
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
assignee: nobody → Canonical Foundations Team (canonical-foundations)
status: New → Triaged
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
importance: High → Critical
importance: Critical → High
Frank Heimes (fheimes)
tags: added: rls-ff-incoming
Steve Langasek (vorlon)
Changed in casper (Ubuntu Focal):
importance: Undecided → High
status: New → Triaged
tags: removed: rls-ff-incoming
Changed in casper (Ubuntu Focal):
importance: High → Wishlist
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Either it will make .0 release, or it will be release noted and moved to 20.04.1 milestone.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Still not started

tags: added: id-5e8b84defa0f7616c5fc329a
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

This bug report was never accepted as a release blocker and was never accepted to keep req4focal, and is only a wishlist.

Removing focal task, keeping this open for the next series, removing req4focal task.

no longer affects: casper (Ubuntu Focal)
Changed in ubuntu-z-systems:
status: Triaged → Incomplete
tags: removed: req4focal
Changed in ubuntu-z-systems:
assignee: Canonical Foundations Team (canonical-foundations) → nobody
Revision history for this message
Frank Heimes (fheimes) wrote :

I think it was, at the beginning of the discussions (Dec 2019, also planning doc), but got later dropped (updates from April 1st).
Some may consider this as a new feature that should to be added to subiquity, but other may see it as a lack and gap compared to the previous installer (which is still the base-line, especially for users that are familiar with it), hence more a bug.
I tend to rate it like the latter group, because of the degraded user experience w/o it.

tags: added: regression-release
Changed in casper (Ubuntu):
milestone: none → ubuntu-20.04.1
Changed in casper (Ubuntu):
status: Triaged → In Progress
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Incomplete → In Progress
Changed in casper (Ubuntu Groovy):
status: In Progress → Fix Released
Changed in casper (Ubuntu Focal):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-20.04.1
Changed in casper (Ubuntu Groovy):
milestone: ubuntu-20.04.1 → none
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

This is now available in groovy daily-live isos.

This is change in other os components rather than subiquity itself. Hence opening tasks against the other packages that we had to fix up. Cause we have fixes in busybox, initramfs-tools, lvm2, casper to make this to work.

Revision history for this message
Frank Heimes (fheimes) wrote :

With the release of 20.04.1 this also landed in focal, hence the focal entry can be changed to Fix Released, too.

Changed in casper (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in ubuntu-z-systems:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers