[mgag200] Ubuntu 19.10 upgrade results in invisible mouse cursor on Matrox G200eR2

Bug #1851340 reported by John Hartley on 2019-11-05
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Po-Hsu Lin

Bug Description

== SRU Justification ==
The cursor on Matrox G200eR2 will disappear after upgrading kernel from
Disco to Eoan, this is caused by this commit that got applied in Eoan:
    4dc57b10 (drm/mgag200: Rewrite cursor handling)

== Fix ==
* a9c342ab (drm/mgag200: Don't unpin the current cursor image's buffer.)
* cf578c8c (drm/mgag200: Set cursor scanout address to correct BO)
* e61576c4 (drm/mgag200: add in missing { } around if block)
* a0fd72d2 (drm/mgag200: Pin displayed cursor BO to video memory)

Focal got these patches already and it does not have this issue.

== Test ==
Test kernel could be found here:
  https://people.canonical.com/~phlin/kernel/lp-1851340-mgag200-cursor/

Verified by the bug reporter, John Hartley, the patched kernel can fix
this issue.

== Regression Potential ==
Low, change limited to mgag200 cursor itself, and it's already been
applied on newer releases.

== Original Bug Report ==
Following in place upgrade of Ubuntu 19.04 -> 19.10 I no longer have visible cursor with my Gnone desktop.

I have found the same problem when upgrading 2 machines from Ubuntu 19.04 -> 19.10.

Reproducing problem is easy:

1. Open Ubuntu Update Window
2. Select "Upgrade"
3. On completion of update (after reboot) cursor is no longer visible.
4. This applies to display connected to VGA port on host with USB Keyboard + Mouse

While the connected display has no visible cursor and so is usable, I have always used X11VNC Server to provide network GUI access. On the remote X11VNC display I see and can use the cursor.

This bug report is being sent via Remote X11VNC window, as I cannot use the main VGA display window (due to lack of visible cursor)

I have done search online and thought that maybe issue was with my USB Mighty Mouse, so I also tried with Logitech M100R USB Mouse. Same result, no visible mouse cursor.

I have done: "grep usb /var/log/syslog" and can see many USB events, including both Apple and Logitech mouse detection events.

NOTE:

Due to compatibility issue with X11VNC, I have disable Wayland on both machines by adding the following option to: /etc/gdm3/custom.conf

WaylandEnable=false

Regards,

John Hartley.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-19.20-generic 5.3.1
Uname: Linux 5.3.0-19-generic x86_64
ApportVersion: 2.20.11-0ubuntu8.1
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Tue Nov 5 18:25:23 2019
DistUpgraded: 2019-11-05 15:20:04,402 ERROR got error from PostInstallScript ./xorg_fix_proprietary.py (g-exec-error-quark: Failed to execute child process “./xorg_fix_proprietary.py” (No such file or directory) (8))
DistroCodename: eoan
DistroVariant: ubuntu
GraphicsCard:
 Matrox Electronics Systems Ltd. G200eR2 [102b:0534] (rev 01) (prog-if 00 [VGA controller])
   Subsystem: Lenovo G200eR2 [1d49:0a01]
InstallationDate: Installed on 2018-12-17 (322 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 (20181017.3)
MachineType: LENOVO System x3650 M5: -[8871AC1]-
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-19-generic root=UUID=3b8f415b-7e78-461c-83df-64f1f1a7826a ro ipv6.disable=1 quiet splash iommu=1 intel_iommu=on ipv6.disable=1 vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to eoan on 2019-11-05 (0 days ago)
dmi.bios.date: 06/03/2019
dmi.bios.vendor: LENOVO
dmi.bios.version: -[TCE140H-2.91]-
dmi.board.asset.tag: (none)
dmi.board.name: 01KN179
dmi.board.vendor: LENOVO
dmi.board.version: NULL
dmi.chassis.asset.tag: none
dmi.chassis.type: 23
dmi.chassis.vendor: LENOVO
dmi.chassis.version: none
dmi.modalias: dmi:bvnLENOVO:bvr-[TCE140H-2.91]-:bd06/03/2019:svnLENOVO:pnSystemx3650M5-[8871AC1]-:pvr13:rvnLENOVO:rn01KN179:rvrNULL:cvnLENOVO:ct23:cvrnone:
dmi.product.family: System X
dmi.product.name: System x3650 M5: -[8871AC1]-
dmi.product.sku: (none)
dmi.product.version: 13
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

John Hartley (graphdrum) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Do you use a non default cursor theme/config? Could you try in a wayland session to see if it has the issue as well?

John Hartley (graphdrum) wrote :

Hi, no I have never touched cursor/theme setting, so always default.
I turned on Wayland as requested (and also disabled x11vnc).
The result was that I just got purple splash screen and no log in window at all.
Likely I need to add addition UI packages, which may have been auto removed.
I will do UI package update and retest.
Likely will only have results later in day.
Thanks
John.

John Hartley (graphdrum) wrote :

Hi, did the following installs to try to get Wayland installed:

sudo apt install gnome-session-wayland
sudo apt install gnome-remote-desktop

Still just getting purple splash with no login;

Did "ps -ax | land"

ps -ax | grep land
 2127 tty1 Ssl+ 0:00 /usr/lib/gdm3/gdm-wayland-session gnome-session --autostart /usr/share/gdm/greeter/autostart
 2338 ? Sl 0:00 /usr/bin/Xwayland :1024 -rootless -noreset -accessx -core -auth /run/user/126/.mutter-Xwaylandauth.77M8A0 -listen 4 -listen 5 -displayfd 6
 4651 pts/0 S+ 0:00 grep --color=auto land

So Xwayland appears to be started, so not sure why I am just getting splash and no login prompt.

Thank,

John.

Gary Wright II (cleverthings) wrote :

Seeing same problem on my xubuntu machine after upgrade to 19.10. I tried different GDM's (xubuntu, gnome, xfce) and tried different themes (default, Adwaita, Breeze, DMZ). I have basic Intel graphics card with minimal capabilities, and machine is used in production so I'm unable to experiment much further. Logitech trackball mouse. I don't see anything obvious in logs. Everything was working properly prior to upgrade. I'm able to use the mouse to select and click, just no cursor is being display so it's hard to see where the pointer is located. I'm assuming this problem is related to this bug.

Paul Mundt (pmundt) wrote :

I'm also in a similar situation - cursor disappeared after upgrade, and doesn't show up in any Xorg sessions (whether invoked directly, or through different DMs), and regardless of cursor theme. I'm also using a basic graphics card - the on-board Matrox G200 on a Dell server machine. Mouse continues to work fine otherwise, both in X and in the console (via GPM).

John Hartley (graphdrum) wrote :

I have now done further testing and can confirm that this is more than just upgrade issue.

I have done the following tests:

A) Fresh 19.04 Desktop Install

A.1) Boot - Ubuntu 19.04 Desktop CD-ROM image via USB - Mouse / Cursor ok
A.2) Do clean disk install of 19.04 Desktop (Minimal Install Option selected) & Reboot. On reboot - Mouse / Curser ok
A.3) Disable Wayland and reboot - Mouse / Cursor ok
A.4) Do in place upgrade to 19.10 & reboot - Mouse / Cursor - Stopped Working

B) Attempt Fresh 19.10 Desktop Install

B.1) Boot - Ubuntu 19.10 Desktop CD-ROM image via USB - Mouse / Cursor not visible

So I have unable to proceed with clean 19.10 install as there was no mouse cursor visible.

So problem is to upgrade related but a general one for 19.10 release.

Both my testing and Paul Bundt's was on server boxes:
Dell Server with Matrox G200 and Lenovo x3650 with Matrox G200.

Paul Mundt (pmundt) wrote :

Thanks for the tip - now that we know we have the same graphics chip, it's obviously a G200 driver issue. Looking at the kernel history, we find:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=574cc4539762561d96b456dbc0544d8898bd4c6e

which includes:

mgag200:
   - cursor support fix

Which would suggest that this has since been fixed upstream, and it's just a matter of time until it hits the ubuntu repositories.

John Hartley (graphdrum) wrote :

Hi Paul,

thanks for pointing out upstream kernel update.

Where would this get pulled through into Ubuntu ?

To close this off I believe we should link to to either pending pull request or raise as issue with Kernel to get pull request into Ubuntu going.

This bug is currently in org, but looks like it needs to be linked to something in kernel somewhere ...

Cheers,

Zebity

John Hartley (graphdrum) wrote :

Paul & Co,

I have raised as "possible" kernel fix required here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1853721

Cheers,

Zebity

Paul Mundt (pmundt) wrote :

I manually rebuilt and installed the 5.4.0 kernel from git and can confirm that the cursor issues are resolved.

John Hartley (graphdrum) wrote :

Hi Paul,

I have also confirmed, that 5.4 kernel resolves issues:

Linux green 5.4.0-050400-generic #201911242031 SMP Mon Nov 25 01:35:10 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Rather than building from source I got updated kernel package via mainline kernel build site: https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.4/

with Installation of 5.4 via forked ukuu (Ubuntu Kernel Update Utility) kernel installer: https://github.com/alcharkov/free-ukuu

I have used UI both via direct physical screen and remote x11vnc with success.

Now we know resolution need to either just wait or get fix back ported into 5.3

I am going to remove mainline kernel and live with inconvenience for the time being.

Cheers,

Zebity.

affects: xorg (Ubuntu) → linux (Ubuntu)
summary: - Ubuntu 19.10 upgrade results in invisible mouse cursor
+ [mgag200] Ubuntu 19.10 upgrade results in invisible mouse cursor on
+ Matrox G200eR2
Po-Hsu Lin (cypressyew) wrote :

Hello,
can you give the Ubuntu Focal kernel a try?

It looks like the following commit is the culprit in Eoan:
    94dc57b1 drm/mgag200: Rewrite cursor handling

As it doesn't exist in Disco, and the following commits state that they're the fix for it:
    a9c342ab drm/mgag200: Don't unpin the current cursor image's buffer.
    cf578c8c drm/mgag200: Set cursor scanout address to correct BO
    a0fd72d2 drm/mgag200: Pin displayed cursor BO to video memory

I assume Ubuntu Focal 20.04 works in this case, if not, we might need more commits from the upstream tree.

Thanks

Here is the git history for drivers/gpu/drm/mgag200/mgag200_cursor.c:
(Upstream tree here)
dfc507b9 drm/mgag200: Allocate cursor BOs at high end of video memory
2c51a660 drm/mgag200: Reserve video memory for cursor plane
378c1838 drm/mgag200: Move cursor BO swapping into mgag200_show_cursor()
047244aa drm/mgag200: Move cursor-image update to mgag200_show_cursor()
6ae04536 drm/mgag200: Add separate move-cursor function
49b8d5ae drm/mgag200: Add init and fini functions for cursor handling
52e32da9 drm/mgag200: Rename cursor functions to use mgag200_ prefix
dcc7b1f3 drm/mgag200: Use drm_gem_vram_{vmap, vunmap}() to map cursor source BO
(20.04 focal here)
a9c342ab drm/mgag200: Don't unpin the current cursor image's buffer.
cf578c8c drm/mgag200: Set cursor scanout address to correct BO
a0fd72d2 drm/mgag200: Pin displayed cursor BO to video memory
9f397801 drm/mgag200: drop use of drmP.h
e61576c4 drm/mgag200: add in missing { } around if block
(19.10 Eoan here)
52d2d44e Merge v5.2-rc5 into drm-next
94dc57b1 drm/mgag200: Rewrite cursor handling
c51669ea treewide: Replace GPLv2 boilerplate/reference with SPDX - rule 377
cb1f8814 drm: Rename reserve/unreserve to lock/unlock in GEM VRAM helpers
82ff2fb5 drm: Add drm_gem_vram_{pin/unpin}_reserved() and convert mgag200
a7581343 drm/mgag200: Replace mapping code with drm_gem_vram_{kmap/kunmap}()
ebb04eb3 drm/mgag200: Convert mgag200 driver to |struct drm_gem_vram_object|
(19.04 Disco here)
c7ff96f8 drm/mgag200: switch to drm_*_get(), drm_*_put() helpers
a8ad0bd8 drm: Remove unused drm_device from drm_gem_object_lookup()
f6619ef7 drm/mgag200: fix kernel hang in cursor code.
bf89209a drm/mga200g: Hold a proper reference for cursor_set
53dac830 drm/mgag200: fix oops in cursor code.
a080db9f drm/mgag200: Hardware cursor support

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
John Hartley (graphdrum) wrote :

Hi Po-Hsu Lin,

I have done simple verification with latest Ubuntu Kernel (on 19.10 install):

cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=19.10
DISTRIB_CODENAME=eoan
DISTRIB_DESCRIPTION="Ubuntu 19.10"
NAME="Ubuntu"
VERSION="19.10 (Eoan Ermine)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 19.10"
VERSION_ID="19.10"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=eoan
UBUNTU_CODENAME=eoan

Installed lastest kernel via:
# Ubuntu Kernel PPA info
ppa_host="kernel.ubuntu.com"
ppa_index="/~kernel-ppa/mainline/"

$ uname -a
Linux green 5.4.6-050406-generic #201912211140 SMP Sat Dec 21 11:43:01 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

I can confirm that with 5.4.6 that the cursor is once more working ok.

In fact now that I have tested with this kernel I think I will do in place update on this machine to focal and use it to test some other new upstream inclusions targeted for Focal Fossa 20.04 LTS.

Please let me know if you want a more complete test, as this was a pretty simple one and I have not validated anything beyond working cursor, both from console (physical) and via remote (X11VNC).

Regards,

John.

John Hartley (graphdrum) wrote :

Hi Po-Hsu Lin,

I have now updated dev/test machine to Focal Fossa:

$ cat /etc/*release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu Focal Fossa (development branch)"
NAME="Ubuntu"
VERSION="20.04 LTS (Focal Fossa)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu Focal Fossa (development branch)"
VERSION_ID="20.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=focal
UBUNTU_CODENAME=focal

$ uname -a
Linux green 5.4.6-050406-generic #201912211140 SMP Sat Dec 21 11:43:01 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Again I can confirm that cursor is working on Console and remote,

Regards,

John.

Po-Hsu Lin (cypressyew) on 2019-12-27
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Po-Hsu Lin (cypressyew) wrote :

Hello John,
thanks for the quick test, now we can confirm that this issue only exist in Eoan 5.3.

Can you help us to test this kernel on Eoan?
https://people.canonical.com/~phlin/kernel/lp-1851340-mgag200-cursor/

It contains the following fixes:
    a9c342ab drm/mgag200: Don't unpin the current cursor image's buffer.
    cf578c8c drm/mgag200: Set cursor scanout address to correct BO
    a0fd72d2 drm/mgag200: Pin displayed cursor BO to video memory
    e61576c4 drm/mgag200: add in missing { } around if block

Thank you.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Eoan):
status: New → Confirmed
John Hartley (graphdrum) wrote :

Hi Po-Hsu Lin,

for for building update of 5.3 I have installed and verified that cursor is working on both console and remote.

$ cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=19.10
DISTRIB_CODENAME=eoan
DISTRIB_DESCRIPTION="Ubuntu 19.10"
NAME="Ubuntu"
VERSION="19.10 (Eoan Ermine)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 19.10"
VERSION_ID="19.10"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=eoan
UBUNTU_CODENAME=eoan

$ uname -a
Linux green 5.3.0-26-generic #28 SMP Fri Dec 27 06:29:53 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Regards,

John.

Po-Hsu Lin (cypressyew) on 2019-12-30
Changed in linux (Ubuntu Eoan):
status: Confirmed → In Progress
description: updated
description: updated
Po-Hsu Lin (cypressyew) wrote :

Thank you!
I will SRU this to get it fixed in Eoan.
https://lists.ubuntu.com/archives/kernel-team/2019-December/106562.html

Changed in linux (Ubuntu Eoan):
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Eoan):
status: In Progress → Fix Committed
Adedoyin Charles (doyinspc) wrote :

Good day just did an update and the issue is still their

John Hartley (graphdrum) wrote :

Hi Adedoyin,

if you are referring to update that provided:

Linux blue 5.3.0-26-generic #28-Ubuntu SMP Wed Dec 18 05:37:46 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

I also got this and yes cursor issue still exists, but details of release does not show this as including mgag200 fix:

https://launchpad.net/ubuntu/+source/linux/5.3.0-26.28

linux (5.3.0-26.28) eoan; urgency=medium

  * eoan/linux: 5.3.0-26.28 -proposed tracker (LP: #1856807)

  * nvidia-435 is in eoan, linux-restricted-modules only builds against 430,
    ubiquity gives me the self-signed modules experience instead of using the
    Canonical-signed modules (LP: #1856407)
    - Add nvidia-435 dkms build

I think the mgag200 fix is yet to flow through as available update.

Cheers,

John

Po-Hsu Lin (cypressyew) wrote :

Hello!

this will soon reach the proposed pocket (and we will need your help to verify the fix) in the following days, then to the released pocket after that.

Thanks

John Hartley (graphdrum) wrote :

Hi Po-Hsu Lin,

ready to test, once you advise when update is available ;-)

Cheers,

John.

Lynn (griffin-ld) wrote :

Po-Hsu Lin, I accidentally changed this to "Fix Released". Not sure if that affects everyone or just my view, but I cannot change it back. Please correct the status with my apologies for changing the status.

Changed in linux (Ubuntu Eoan):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Eoan):
status: Fix Released → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-eoan' to 'verification-done-eoan'. If the problem still exists, change the tag 'verification-needed-eoan' to 'verification-failed-eoan'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-eoan
John Hartley (graphdrum) wrote :

Hi Daniel & Po-Hsu Lin,

I have tried to do EnableProposed test, but the kernel fix does not seem to appear in my upgrades list:

<<APT UPGRADE RESULT>>
sudo apt upgrade -s
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  bluez bluez-cups bluez-obexd libbluetooth3 mdadm
5 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Inst bluez [5.50-0ubuntu4] (5.50-0ubuntu5 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
Inst bluez-cups [5.50-0ubuntu4] (5.50-0ubuntu5 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
Inst bluez-obexd [5.50-0ubuntu4] (5.50-0ubuntu5 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
Inst libbluetooth3 [5.50-0ubuntu4] (5.50-0ubuntu5 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
Inst mdadm [4.1-2ubuntu3] (4.1-2ubuntu3.2 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
Conf bluez (5.50-0ubuntu5 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
Conf bluez-cups (5.50-0ubuntu5 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
Conf bluez-obexd (5.50-0ubuntu5 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
Conf libbluetooth3 (5.50-0ubuntu5 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
Conf mdadm (4.1-2ubuntu3.2 Ubuntu:19.10/eoan-updates, Ubuntu:19.10/eoan-proposed [amd64])
<<APT UPGRADE RESULT>>

So it appears that only bluetooth / madam updates and not kernel does.

NOTE: I did "sudo apt update" after changing "Software Update" to include "proposed" apt.

Thanks,

John.

John Hartley (graphdrum) wrote :
Download full text (4.9 KiB)

Hi Daniel & Po-Hsu Lin,

Did some further testing against: linux-image-5.3.0-40-generic/eoan-proposed

<<INSTALL KERNEL VIA EOEM-PROPOSED>>
$ sudo apt install linux-headers-5.3.0-40-generic/eoan-proposed linux-image-5.3.0-40-generic/eoan-proposed linux-headers-5.3.0-40/eoan-proposed linux-modules-5.3.0-40-generic/eoan-proposed linux-modules-extra-5.3.0-40-generic/eoan-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-modules-5.3.0-40-generic is already the newest version (5.3.0-40.32).
linux-modules-5.3.0-40-generic set to manually installed.
Selected version '5.3.0-40.32' (Ubuntu:19.10/eoan-proposed [amd64]) for 'linux-headers-5.3.0-40-generic'
Selected version '5.3.0-40.32' (Ubuntu:19.10/eoan-proposed [amd64]) for 'linux-image-5.3.0-40-generic'
Selected version '5.3.0-40.32' (Ubuntu:19.10/eoan-proposed [all]) for 'linux-headers-5.3.0-40'
Selected version '5.3.0-40.32' (Ubuntu:19.10/eoan-proposed [amd64]) for 'linux-modules-5.3.0-40-generic'
Selected version '5.3.0-40.32' (Ubuntu:19.10/eoan-proposed [amd64]) for 'linux-modules-extra-5.3.0-40-generic'
Suggested packages:
  fdutils linux-doc-5.3.0 | linux-source-5.3.0 linux-tools
The following NEW packages will be installed:
  linux-headers-5.3.0-40 linux-headers-5.3.0-40-generic linux-image-5.3.0-40-generic linux-modules-extra-5.3.0-40-generic
0 upgraded, 4 newly installed, 0 to remove and 5 not upgraded.
Need to get 59.1 MB of archives.
After this operation, 285 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu eoan-proposed/main amd64 linux-headers-5.3.0-40 all 5.3.0-40.32 [11.0 MB]
Get:2 http://archive.ubuntu.com/ubuntu eoan-proposed/main amd64 linux-headers-5.3.0-40-generic amd64 5.3.0-40.32 [1,231 kB]
Get:3 http://archive.ubuntu.com/ubuntu eoan-proposed/main amd64 linux-image-5.3.0-40-generic amd64 5.3.0-40.32 [8,653 kB]
Get:4 http://archive.ubuntu.com/ubuntu eoan-proposed/main amd64 linux-modules-extra-5.3.0-40-generic amd64 5.3.0-40.32 [38.2 MB]
Fetched 59.1 MB in 17s (3,531 kB/s)
Selecting previously unselected package linux-headers-5.3.0-40.
(Reading database ... 258418 files and directories currently installed.)
Preparing to unpack .../linux-headers-5.3.0-40_5.3.0-40.32_all.deb ...
Unpacking linux-headers-5.3.0-40 (5.3.0-40.32) ...
Selecting previously unselected package linux-headers-5.3.0-40-generic.
Preparing to unpack .../linux-headers-5.3.0-40-generic_5.3.0-40.32_amd64.deb ...
Unpacking linux-headers-5.3.0-40-generic (5.3.0-40.32) ...
Selecting previously unselected package linux-image-5.3.0-40-generic.
Preparing to unpack .../linux-image-5.3.0-40-generic_5.3.0-40.32_amd64.deb ...
Unpacking linux-image-5.3.0-40-generic (5.3.0-40.32) ...
Selecting previously unselected package linux-modules-extra-5.3.0-40-generic.
Preparing to unpack .../linux-modules-extra-5.3.0-40-generic_5.3.0-40.32_amd64.deb ...
Unpacking linux-modules-extra-5.3.0-40-generic (5.3.0-40.32) ...
Setting up linux-headers-5.3.0-40 (5.3.0-40.32) ...
Setting ...

Read more...

John Hartley (graphdrum) wrote :

Hi Daniel & Po-Hsu Lin,

I have now tested: https://launchpad.net/ubuntu/+source/linux/5.3.0-40.32

Testing Results:

Console & Remote Cursor Support Confirmed as working

Run QEMU / KVM Machine and confirmed confirmed Hypervisor working and QEMU mouse functions working.

Attached is lshw results from test machine.

And uname to confirm updated kernel install:

$ uname -a
Linux green 5.3.0-40-generic #32-Ubuntu SMP Fri Jan 31 20:24:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

I am now updating tag to indicate 'verification-done-eoan'

Regards,

John.

John Hartley (graphdrum) wrote :

Test Lenovo X3650 M5 Server with mgag200 Graphica lshw results.

John Hartley (graphdrum) on 2020-02-05
tags: added: verification-done-eoan
removed: verification-needed-eoan
Po-Hsu Lin (cypressyew) wrote :

Yes that 5.3.0-40.32 Eoan kernel is the right one to test,
thanks for testing this.

John Hartley (graphdrum) wrote :

Hi Po-Hsu Lin,

thank very much for getting this fixed.

Cheers,

John

Launchpad Janitor (janitor) wrote :
Download full text (78.1 KiB)

This bug was fixed in the package linux - 5.3.0-40.32

---------------
linux (5.3.0-40.32) eoan; urgency=medium

  * eoan/linux: 5.3.0-40.32 -proposed tracker (LP: #1861214)

  * No sof soundcard for 'ASoC: CODEC DAI intel-hdmi-hifi1 not registered' after
    modprobe sof (LP: #1860248)
    - ASoC: SOF: Intel: fix HDA codec driver probe with multiple controllers

  * ocfs2-tools is causing kernel panics in Ubuntu Focal (Ubuntu-5.4.0-9.12)
    (LP: #1852122)
    - ocfs2: fix the crash due to call ocfs2_get_dlm_debug once less

  * QAT drivers for C3XXX and C62X not included as modules (LP: #1845959)
    - [Config] CRYPTO_DEV_QAT_C3XXX=m, CRYPTO_DEV_QAT_C62X=m and
      CRYPTO_DEV_QAT_DH895xCC=m

  * Eoan update: upstream stable patchset 2020-01-24 (LP: #1860816)
    - scsi: lpfc: Fix discovery failures when target device connectivity bounces
    - scsi: mpt3sas: Fix clear pending bit in ioctl status
    - scsi: lpfc: Fix locking on mailbox command completion
    - Input: atmel_mxt_ts - disable IRQ across suspend
    - f2fs: fix to update time in lazytime mode
    - iommu: rockchip: Free domain on .domain_free
    - iommu/tegra-smmu: Fix page tables in > 4 GiB memory
    - dmaengine: xilinx_dma: Clear desc_pendingcount in xilinx_dma_reset
    - scsi: target: compare full CHAP_A Algorithm strings
    - scsi: lpfc: Fix SLI3 hba in loop mode not discovering devices
    - scsi: csiostor: Don't enable IRQs too early
    - scsi: hisi_sas: Replace in_softirq() check in hisi_sas_task_exec()
    - powerpc/pseries: Mark accumulate_stolen_time() as notrace
    - powerpc/pseries: Don't fail hash page table insert for bolted mapping
    - powerpc/tools: Don't quote $objdump in scripts
    - dma-debug: add a schedule point in debug_dma_dump_mappings()
    - leds: lm3692x: Handle failure to probe the regulator
    - clocksource/drivers/asm9260: Add a check for of_clk_get
    - clocksource/drivers/timer-of: Use unique device name instead of timer
    - powerpc/security/book3s64: Report L1TF status in sysfs
    - powerpc/book3s64/hash: Add cond_resched to avoid soft lockup warning
    - ext4: update direct I/O read lock pattern for IOCB_NOWAIT
    - ext4: iomap that extends beyond EOF should be marked dirty
    - jbd2: Fix statistics for the number of logged blocks
    - scsi: tracing: Fix handling of TRANSFER LENGTH == 0 for READ(6) and WRITE(6)
    - scsi: lpfc: Fix duplicate unreg_rpi error in port offline flow
    - f2fs: fix to update dir's i_pino during cross_rename
    - clk: qcom: Allow constant ratio freq tables for rcg
    - clk: clk-gpio: propagate rate change to parent
    - irqchip/irq-bcm7038-l1: Enable parent IRQ if necessary
    - irqchip: ingenic: Error out if IRQ domain creation failed
    - fs/quota: handle overflows of sysctl fs.quota.* and report as unsigned long
    - scsi: lpfc: fix: Coverity: lpfc_cmpl_els_rsp(): Null pointer dereferences
    - PCI: rpaphp: Fix up pointer to first drc-info entry
    - scsi: ufs: fix potential bug which ends in system hang
    - powerpc/pseries/cmm: Implement release() function for sysfs device
    - PCI: rpaphp: Don't rely on firmware feature to imply drc-info support
    - PCI: rpaphp: Annotate and corr...

Changed in linux (Ubuntu Eoan):
status: Fix Committed → Fix Released
John Hartley (graphdrum) wrote :

Hi Po-Hsu Lin & others,

got fix via latest update, which was applied to 2 machines and confirmed cursor working again now on console:

$ uname -a
Linux blue 5.3.0-40-generic #32-Ubuntu SMP Fri Jan 31 20:24:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

$ uname -a
Linux green 5.3.0-40-generic #32-Ubuntu SMP Fri Jan 31 20:24:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Thank you again for working on this bug,

Cheers,

Zebity.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers