Comment 0 for bug 1799767

Started with Ubuntu Version 14.04 I always had SecureBoot enabled and also CSM (compatibility support module) enabled in BIOS of Motherboard ASUS Z170-A, BIOS 3802 03/15/2018.
On October, 13th i did the updates that UpdateManager showed in the morning.

After rebooting in the evening, afterwards the BIOS splash screen there was only a black screen. No grub menu, no booting in SecureBoot mode.
I tried different repairs (tool boot-repair, reinstalling grub, installing signed kernel transitional packages and so on, but nothing would help.

At the end I found out out, that switching CSM to disabled "solved" the problem and it is now reproducible: Switching CSM on, no secure boot, switching off, secure boot works.

But I did not wont to switch CSM off.

I also tried to get some help at ubuntuforum. But no luck.

See here
https://ubuntuforums.org/showthread.php?t=2404150

Since today I think it's a bug in shim or grub, because at the morning of Oct, 13th these have been updated.

Regards

Frank

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.27
ProcVersionSignature: Ubuntu 4.15.0-38.41-lowlatency 4.15.18
Uname: Linux 4.15.0-38-lowlatency x86_64
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: XFCE
Date: Wed Oct 24 20:36:17 2018
InstallationDate: Installed on 2016-04-03 (933 days ago)
InstallationMedia: Ubuntu-Studio 14.04.4 LTS "Trusty Tahr" - Release amd64 (20160217.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_DE
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: release-upgrade
UpgradeStatus: Upgraded to bionic on 2018-09-24 (30 days ago)
VarLogDistupgradeTermlog: