[regression][amdgpu] analog output stops working on R9 380/Tonga Pro after upgrading to Ubuntu 18.04

Bug #1784156 reported by Benjamin on 2018-07-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Status tracked in Cosmic
Bionic
High
Unassigned
Cosmic
High
Unassigned

Bug Description

After upgrading to Ubuntu 18.04 (and thus from Linux 4.13 to Linux 4.15) the Monitor connected via VGA (through DVI-I) shows a 'No Signal' message after amdgpu takes over from efifb and turns off.

The monitor worked fine in Ubuntu 17.10 and Linux 4.13.

When looking at the output of xrandr, the analog monitor is now detected as DVI-D instead of DVI-I and thus probably won't receive an analog signal anymore.

After some investigation, it turns out the monitor will light up when adding the `amdgpu.dc=0` kernel parameter.

I've tried Linux 4.18-rc6 from the mainline ppa and the issue persists unless I add the kernel parameter to disable DC.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-generic 4.15.0.29.31
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: benpicco 2151 F...m pulseaudio
 /dev/snd/controlC0: benpicco 2151 F.... pulseaudio
 /dev/snd/controlC1: benpicco 2151 F.... pulseaudio
CurrentDesktop: MATE
Date: Sat Jul 28 17:55:35 2018
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=ef400a46-b237-4272-b4a7-f866e92d00a0
InstallationDate: Installed on 2016-08-06 (720 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
IwConfig:
 lo no wireless extensions.

 eno1 no wireless extensions.
MachineType: System manufacturer System Product Name
ProcFB: 0 amdgpudrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=UUID=8e6b0d6a-eb87-44cf-8fc3-b13bd97b71d2 ro amdgpu.dc=0
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-29-generic N/A
 linux-backports-modules-4.15.0-29-generic N/A
 linux-firmware 1.173.1
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to bionic on 2018-07-28 (0 days ago)
dmi.bios.date: 11/09/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3603
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z68-V
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3603:bd11/09/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8Z68-V:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Benjamin (pantalaimon) wrote :
Benjamin (pantalaimon) wrote :
Benjamin (pantalaimon) wrote :
Benjamin (pantalaimon) wrote :
Benjamin (pantalaimon) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Benjamin (pantalaimon) on 2018-07-28
summary: - [regression][amdgpu] analog outputs stop working after upgrading to
- Ubuntu 18.04
+ [regression][amdgpu] analog output stops working on R9 380/Tonga Pro
+ after upgrading to Ubuntu 18.04
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

Once this bug is reported upstream, please add the tag: 'kernel-bug-reported-upstream'.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in linux (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → High
tags: added: kernel-da-key
Kai-Heng Feng (kaihengfeng) wrote :

Is it possible for you to try https://cgit.freedesktop.org/~agd5f/linux/ branch amd-staging-drm-next?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers