Ubuntu 18.04 getting stuck at "Starting Reboot" and "Starting Power-Off"

Bug #1776616 reported by Lasse
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Hardware: HPE ProLiant DL360 gen9
Ubuntu Version: 18.04

Problem: When rebooting the server, everything goes well (shutting down services, unmounting etc) until the last step where it reads "Starting Reboot". At this point the system is getting stuck and nothing else can can be done than holding the power button in for a long enough time to turn it off. At the same time as the system get stuck, a red error light is lightening up on the server. This light is green until it reaches this "Starting Reboot" stage. The same happens if the server is shutdown, with the difference that the last message is "Starting Power-Off" instead of "Starting Reboot".

The server is installed with a new clean 18.04 installation. This server was rebooting/shutting down without a problem with all releases between 16.04 and 17.10.

This problem is serious as it prevents remote reboot.
ProblemType: Bug
 total 0
 crw-rw---- 1 root audio 116, 1 Jun 13 11:16 seq
 crw-rw---- 1 root audio 116, 33 Jun 13 11:16 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
DistroRelease: Ubuntu 18.04
HibernationDevice: RESUME=none
MachineType: HP ProLiant DL360 Gen9
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
Package: linux (not installed)

 PATH=(custom, no user)
ProcFB: 0 mgadrmfb
ProcKernelCmdLine: BOOT_IMAGE=/ROOT/ubuntu@/boot/vmlinuz-4.15.0-23-generic root=ZFS=rpool/ROOT/ubuntu ro
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
 linux-restricted-modules-4.15.0-23-generic N/A
 linux-backports-modules-4.15.0-23-generic N/A
 linux-firmware 1.173.1
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
Tags: bionic
Uname: Linux 4.15.0-23-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)

_MarkForUpload: True
dmi.bios.date: 05/21/2018
dmi.bios.vendor: HP
dmi.bios.version: P89
dmi.board.name: ProLiant DL360 Gen9
dmi.board.vendor: HP
dmi.chassis.type: 23
dmi.chassis.vendor: HP
dmi.modalias: dmi:bvnHP:bvrP89:bd05/21/2018:svnHP:pnProLiantDL360Gen9:pvr:rvnHP:rnProLiantDL360Gen9:rvr:cvnHP:ct23:cvr:
dmi.product.family: ProLiant
dmi.product.name: ProLiant DL360 Gen9
dmi.sys.vendor: HP

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1776616/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1776616

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic
Lasse (lars-engblom)
tags: added: apport-collected
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.17 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17

Changed in linux (Ubuntu):
importance: Undecided → High
Changed in linux (Ubuntu Bionic):
importance: Undecided → High
status: New → Incomplete
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-da-key
tags: added: needs-bisect
Revision history for this message
Lasse (lars-engblom) wrote :

This installation is running from a ZFS root. Would upgrading the kernel to mainline cause the zfs module to not work?

Revision history for this message
Schoof (andreas-schoof) wrote :

hardware: IBM thinkpad T41p
xubuntu version 18.04 LTS 32bit

got same problem with my elderly machine since installing with Actual kernel 4.15.0-30-generic. Thought, it could depend on old BIOS (AHCI) with my pentium M. It appears with reboot - normal shutdown normally works. Don't remember problems with xubuntu 16/17 versions.

Revision history for this message
Jörg Franke (newjorg) wrote :

System: Packard Bell imedia S3210
Board: Packard Bell WMCP78M (nvidia based)
CPU: AMD Athlon(tm) 7550 Dual-Core Processor

Ubuntu 18.04.1 64-bit with lubuntu-desktop

My problem is exactly like the origin one. Reboot and power off get stuck in 4.15.0-33-generic.

So I tested the mainline kernels v4.17, v4.17.19, v4.18 and v4.18.5 and it gets always stuck.
Then I tested mainline kernel v4.14.67 then reboot restarts the system and power off shut it down.

Changed in linux (Ubuntu Bionic):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Fabian Schlenz (fabianonline) wrote :

4.15.0-38-generic is also affected. I had zero problems with xenial, this only happens since I upgraded to bionic...

Revision history for this message
Kerem Gümrükcü (kerrygee) wrote :

Exactly the same problem with current 18.04 kernels and also current 4.19 mainline kernels. System hangs at shutdown/reboot/poweroff etc.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Seems like it's a regression happens between v4.4 and v4.15?

Revision history for this message
Hey! (press-1p-start) wrote :

I would say that this started with kernel 4.8 ( Ubuntu 16.10).

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Would it be possible for you to do a kernel bisection?

First, find the last good kernel and the first bad kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/

The range is from v4.5-rc1 to v4.8.

$ sudo apt build-dep linux
$ git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git
$ cd linux
$ git bisect start
$ git bisect good $(the good version you found)
$ git bisect bad $(the bad version found)
$ make localmodconfig
$ make -j`nproc` deb-pkg
Install the newly built kernel, then reboot with it.
If the issue still happens,
$ git bisect bad
$ git bisect good
Repeat to "make -j`nproc` deb-pkg" until you find the commit that causes the regression.

Revision history for this message
Hey! (press-1p-start) wrote :


Thanks for trying to help, but unfortunately I can't test that at this time since I'm not that experienced and i can't take the risk of ruining this installation. Sorry.

On my computer the transition from 4.5.7 to 4.6.0 is the cause of this bug.

Toshiba A210 with AMD CPU and graphics.

4.5.7 - Works

4.6.0 - Doesn't work

Can anyone try to install the following kernels to check if the same behavior happens on other computers?



Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

Just upgraded an old Toshiba Satellite A215-S7422 with AMD Turion X2 from 16.04 to 18.04. Was working fine under 16.04. Now I'm encountering this same issue. I don't use this laptop very much, so I can run tests on it.

I'm running the Ubuntu Mate flavor. The current kernel it is running is 4.15.0-38-generic. Would it make any sense for me to try 4.5.7-yakkety, since I'm already well past that? I had fully updated the laptop with 16.04 prior to upgrading, so I know the latest kernel version from Ubuntu Mate 16.04 as of yesterday Nov 12 2018 works.

Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

Got some testing results:

4.19.0 latest currently listed stable release hangs latest version listed for 16.04 works

I'll try a couple later kernels tomorrow - might as well follow the lead in #10.

Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

Following the lead of #12 (sorry, I originally said #10, but could not edit to correct), I confirm those findings.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.7-yakkety/ works
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/ hangs

I purposely skipped the v4.6 release candidates since changes may have been redone or removed throughout the RC process; a change that might be suspect in RC1 may not even be present in subsequent RCs.

I tried comparing syslog after rebooting both of these, but they too different to provide anything useful. I'll attempt to follow the bisect instructions to identify the problem commit.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Minimize the bisection range can save lots of time to compile kernel. Of course you can still start a bisect right away:

$ git bisect good v4.5
$ git bisect bad v4.6

Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

I found a related post here:


My Toshiba laptop does not have any power settings in the BIOS, so I tried adding "acpi=off noapic" to the kernel boot parameters in grub 2. That fixed the problem. I'll proceed with the bisect, but I'm guessing it will come down to this.

Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

I tried the bisect procedure, but failed to build a kernel. First, the provided link won't work:

git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git

This repo only contains major releases. To get minor releases, this link is necessary:


In the step "make localmodconfig", I accepted all the default config values, because I'm assuming that is what produces the published kernels.

When I attempted to build the kernel, I got the following:

guyr@tosh:/data/ubuntu_mainline_kernel/linux-minor$ make -j2 deb-pkg
arch/x86/Makefile:133: stack-protector enabled but compiler support broken
Makefile:666: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
  CHK include/config/kernel.release
  UPD include/config/kernel.release
make clean
  TAR linux-4.5.0.tar.gz
arch/x86/Makefile:133: stack-protector enabled but compiler support broken
Makefile:666: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
  SYSTBL arch/x86/entry/syscalls/../../include/generated/asm/syscalls_32.h
  HOSTCC scripts/basic/fixdep
  HOSTCC scripts/basic/bin2c
  SYSHDR arch/x86/entry/syscalls/../../include/generated/asm/unistd_32_ia32.h
  SYSHDR arch/x86/entry/syscalls/../../include/generated/asm/unistd_64_x32.h
  SYSTBL arch/x86/entry/syscalls/../../include/generated/asm/syscalls_64.h
  HYPERCALLS arch/x86/entry/syscalls/../../include/generated/asm/xen-hypercalls.h
  SYSHDR arch/x86/entry/syscalls/../../include/generated/uapi/asm/unistd_32.h
  CHK include/config/kernel.release
  WRAP arch/x86/include/generated/asm/clkdev.h
  WRAP arch/x86/include/generated/asm/cputime.h
  WRAP arch/x86/include/generated/asm/dma-contiguous.h
  WRAP arch/x86/include/generated/asm/early_ioremap.h
  WRAP arch/x86/include/generated/asm/mcs_spinlock.h
  WRAP arch/x86/include/generated/asm/mm-arch-hooks.h
  CHK include/generated/uapi/linux/version.h
  UPD include/generated/uapi/linux/version.h
  CHK include/generated/utsrelease.h
  UPD include/generated/utsrelease.h
  CC scripts/mod/empty.o
cc1: error: code model kernel does not support PIC mode
  SYSHDR arch/x86/entry/syscalls/../../include/generated/uapi/asm/unistd_64.h
scripts/Makefile.build:258: recipe for target 'scripts/mod/empty.o' failed
make[4]: *** [scripts/mod/empty.o] Error 1
scripts/Makefile.build:407: recipe for target 'scripts/mod' failed
make[3]: *** [scripts/mod] Error 2
Makefile:551: recipe for target 'scripts' failed
make[2]: *** [scripts] Error 2
make[2]: *** Waiting for unfinished jobs....
  SYSHDR arch/x86/entry/syscalls/../../include/generated/uapi/asm/unistd_x32.h
scripts/package/Makefile:91: recipe for target 'deb-pkg' failed
make[1]: *** [deb-pkg] Error 2
Makefile:1238: recipe for target 'deb-pkg' failed
make: *** [deb-pkg] Error 2

Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

Ugh, partial retraction. The above solution works for reboot, but not for shutdown. I managed to get one shutdown session to show me the console, and the final statement was something like "poweroff reached", and then it just sits there forever.

Revision history for this message
Hey! (press-1p-start) wrote :

Guy Rouillier, thank you very much for trying to fix this issue.

Do you also have an issue that makes the laptop freeze on the toshiba splash screen, if you reboot with the wi-fi turned on? This happens on a210 with 16.04 (kernel 4.4). Is it the same on a215?


Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

Hey! I'm typing this from the laptop over WiFi. I powered on the laptop with the WiFi off, but then turned it on before booting up 18.04. I got connected, then did a reboot. That went without any issues, and I got back into Ubuntu 18.04. After getting back into Ubuntu, I started up this browser session; Ubuntu remembered my WiFi configuration from the previous boot. So, no issues rebooting with WiFi turned on (or off). Sorry, I no longer have 16.04, so I can't comment on that. My active kernel is 4.15.0-39-generic.

You say your laptop freezes on the Toshiba splash screen? Or did you mean the Ubuntu splash screen? Either way, mine is not freezing, either during power up or reboot. I doubt the WiFi being on will alter my hangs on power down, though I'll try that now. Hmm, I still have 4.5.7, I'll try rebooting with that to see if it changes anything. That was a 16.04 kernel.

Hope this helps.

Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

I tried with 4.5.7, nothing changes with WiFi on or off

However, back to the original problem, while playing with WiFi, I discovered that 4.5.7 was now freezing during shutdown (reboot okay). So, I then tried removing "acpi=off noapic" again, and 4.5.7 was now able to reboot and shutdown. But as before, any later kernel now hangs during both reboot and shutdown.

So, in summary:

   - with "acpi=off noapic", all kernels can reboot but hang during shutdown

Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

Ugh, tab key did a submit! Launchpad needs some work.

So, in summary:

   - with "acpi=off noapic", all kernels can reboot but hang during shutdown

   - without "acpi=off noapic", <= 4.5.7 can reboot and shutdown, but later kernels hang during both reboot and shutdown.

Since I can't run the ancient kernels forever, I'm adding "acpi=off noapic" and will just live with the hang during shutdown. Fortunately, the filesystem appears to close before hang, so I don't have filesystem corruptions when I start up the next time.

Revision history for this message
Hey! (press-1p-start) wrote :


Yeah, the computer freezes in the bios splash screen (Toshiba logo) if the wi-fi is enabled on reboot. You can see more of this issue and solution in the following link:


I checked a215 specs and it seems to have a different wi-fi card than a210. Maybe it's that or it was fixed in 18.04. I haven't tested because of this bug.

Thank you very much.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Stable releases are not linearly dependent on previous releases, so we need to use mainline (Linus' tree) to find a meaningful bisect point. In this case, it should be v4.5 and v4.6.

Hey!, probably file a new bug for your wifi issue? Seems to be another bug.

Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

Ok, I started with v4.5 and v4.6. I successfully did a couple iterations, after adding the follownig CFLAGS to Makefile to get past compiler errors:

-fno-pie -fno-stack-protector

But I then ran into this error when trying to compile both 4.9.0 and 4.8.0:

kernel/built-in.o: In function `update_wall_time':
/data/ubuntu_mainline_kernel/linux/kernel/time/timekeeping.c:2073: undefined reference to `____ilog2_NaN'

This appears to be a problem with GCC 7:


This is taking too much time, and I don't use this laptop enough to justify the time expenditure.

Revision history for this message
Guy Rouillier (guy-rouillier) wrote :

I couldn't resist a challenge :), so I installed GCC version 5. In the process of trying to compile a bisected kernel, my file system somehow got corrupted. I have no idea who the culprit is, as this laptop is very old. So, it could be a hardware issue, who knows.

But this exercise has convinced me that these Toshiba laptops are just too outdated for modern Linux versions. I've reformatted my filesystems, and I'm falling back to 16.04 Mate. I'll stay there as long as the laptop lasts.

Thanks all for attempting to help. As Kenny Rogers would say, you gotta know when to fold 'em.

Revision history for this message
Hey! (press-1p-start) wrote :

Thank you for trying to solve this issue.

Revision history for this message
expos (exmons) wrote :

Hi, I updated my Maxdata Belinea o.book 2.1 with AMD Processor (AMD Turion(tm) 64 X2 Mobile Technology TL-60) from Kubuntu 14.04 to Mint Xfce 19 (reinstall). Same issue here. Then I tried Mint 18.3 which is built upon Ubuntu 16.04, again the same issue. I installed upstream kernel 4.20.0-042000-generic - problem persists.
When I read the previous comments, it's always an aging AMD processor involved...

Here's probably a workaround described (again with AMD Turion TL-60 processor):

Unfortunately I cannot test it as I don't see the option to disable AMD Power Now in my BIOS.

Revision history for this message
Hey! (press-1p-start) wrote :

Yeah, they all seem to be similar CPU.

Have you tried to see if you get the same results as above when you try to run 4.5.7 and 4.6?

It's sad because, apart from that, the computers run just fine.

Revision history for this message
Lasse (lars-engblom) wrote :

I have this problem with Intel Xeon CPU E5-2620 v4. I do not think it is CPU related.

Revision history for this message
Hey! (press-1p-start) wrote :

Have you tested 4.5.7 and 4.6 to see if this was the transition where the bug started?

Revision history for this message
Lasse (lars-engblom) wrote :

No, I do not have the possibility to test this as the server is in production now.

Revision history for this message
expos (exmons) wrote :

I installed many upstream kernels via UKUU. I did several verifications with shutdown and reboot, last version where both works is 4.6.2, first version where neither shutdown nor reboot works is 4.6.3 . Both kernels 4.5.7 and 4.6 work fine for me.

BTW: Kernel Bugtracker has corresponding bugs (https://bugzilla.kernel.org/show_bug.cgi?id=199349) & (https://bugzilla.kernel.org/show_bug.cgi?id=201965)

Revision history for this message
Hey! (press-1p-start) wrote :

Thanks expos.

That seems to close. Maybe a difference between UKUU and the link posted above.

That links shows exactly the problem. Thanks.

Revision history for this message
Hey! (press-1p-start) wrote :


Just a heads up:

In this link provided by "expos" https://bugzilla.kernel.org/show_bug.cgi?id=199349 someone talks about a possible cause to this issue and a solution.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

If it's the same one as LP: #1771467, then it's fixed.

Revision history for this message
Hey! (press-1p-start) wrote :

This is also happening on Fedora 30

Strangely, when Ubuntu is started on recovery mode/root option, the reboot and poweroff command works perfectly.

Brad Figg (brad-figg)
tags: added: ubuntu-certified
Revision history for this message
B. C. Schmerker (bcschmerker) wrote :

I encountered this issue installing xubuntu™ 18.04-LTS on an emachines®/acer® EL1210-09 (2.3 GHz Advanced Micro Devices® Athlon® LE-1620; nVIDIA® nFORCE® 720 chipset; 2 x 2 GiB DDR2 main memory) with a Shuttle® PSU upgrade (PC6300001 in for stock 220W LITEON®) and the planar C77 geForce® 64-bit GPU by-passed for the nVIDIA® GF-109 on an msi® N610GT-MD1GD3/LP half-height video display adapter. I normally use:


in /etc/default/grub, which is how I confirmed the issue: Depending on shutdown or reboot option, the system halts at "Starting reboot..." or "Starting power-off...", forcing a manual power-down. Additionally:


had no effect, and:


only got me to a timestamped "reboot:System halted". Will report back after checking effect of nVIDIA® geForce® driver package for C77 GPU (part of nF720 chipset).

Revision history for this message
B. C. Schmerker (bcschmerker) wrote :

Update: nVIDIA® geForce® driver 340.107 for the C77 GPU (package: nvidia-340) got to a successful power-down. Be advised that Packages nvidia-n are to be reserved for nVIDIA® nFORCE® MCP chipsets such as the MCP78 northbridge my EL1210-09; intel®, AMD®, and VIA® chipsets require different solutions.

Revision history for this message
Hey! (press-1p-start) wrote :

Kernel 4.15 4.15.0-72 seems to have fixed this issue.

Can anyone else confirm?

Revision history for this message
Rene Herman (rene.herman) wrote :

Re #41, "Can anyone else confirm?"

For me and for a few other reports out there, the problem *started* with 4.15.0-72. Core 2 Duo with old G45 onboard graphics.

Revision history for this message
Rene Herman (rene.herman) wrote :

Re #42; pardon; machine-confusion. The problem with 4.15.0-72 indeed but on a Xeon E5606, AMD HD 5770 graphics

Revision history for this message
Pankaj Rai (ipankaj) wrote :


I'm also facing the same problem(stuck while rebooting) and also sometimes my integrated webcam of my laptop (dell vostro) doesnt work since i updated my ubuntu sytem to 18.04

does any one on know what could be the resolution for this problem.


To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.