Comment 34 for bug 1736390

On Wed, Jan 10, 2018 at 5:45 PM, Joseph Salisbury
<email address hidden> wrote:
> Thanks for the feedback, Christian. I would much rather install them
> manually. I am able to do that without a problem. However, I am unable
> to access the GRUB menu in the usual way to select a specific kernel.

If you test through autotest, then there isn't a good way to manually
intercept "while" running.

> I tried all the usual way, holding shift, modifying /etc/default/grub
> setting, but none seem to work.

Other than just making sure that grub picks the right default by
making sue the to-be-tested kernel is the latest I worked by modifying
grub.

Checking again if this still works ...
I had a zesty testbed to remove anyway, so I could kill it if needed.
By default it does boot "4.8.0-26-generic"

Note: working in guest image via:
$ qemu-system-x86_64 -m 1024 -smp 1 -nographic -net nic,model=virtio
-net user -enable-kvm -cpu kvm64,+vmx,+lahf_lm
~/work/autopkgtest-zesty-amd64.img

I installed 4.7.10-040710_4.7.10-040710.201610220847 from mainline
builds as it is older and therefore would not be selected by grub
automatically.
After install I checked autopkgtest output...

autopkgtest [07:54:48]: testbed running kernel: Linux 4.8.0-26-generic
#28-Ubuntu SMP Tue Oct 18 14:39:52 UTC 2016

Ok, now lets modify grub to boot the older kernel:
I found that (at least in this case) the BIOS boot partition kind of
breaks update-grub.
/dev/sda1 227328 25583582 25356255 12.1G Linux filesystem
/dev/sda14 2048 10239 8192 4M BIOS boot
/dev/sda15 10240 227327 217088 106M EFI System

The middle one is the odd one - that is the non efi compat grub img
storage area.
Anyway - to get around that I was adding:

$ apt-get install --reinstall grub-efi
$ echo "GRUB_DISABLE_OS_PROBER=true" | sudo tee -a /etc/default/grub
So as usual e.g.:
echo 'GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux
4.7.10-040710-generic"' | sudo tee -a /etc/default/grub
$ sudo update-grub

And e voila:
autopkgtest [08:20:29]: testbed running kernel: Linux
4.7.10-040710-generic #201610220847 SMP Sat Oct 22 12:50:14 UTC 2016

Other than the extra hoop I had to jump for the BIOS boot there was
nothing special in my try.
And I'd assume that could as much appear on real HW.

I hope that helps to drive your test kernels.