Ubuntu

Yelp uses wrong encoding for localized manpages

Reported by Alexey Shumitsky on 2007-10-20
10
Affects Status Importance Assigned to Milestone
Yelp
New
Medium
yelp (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: yelp

To reproduce this bug you should open any localized manpage in Yelp, for example - a page for "chgrp".
1. Enter "chgrp" in search box.
2. In the opened page choose "chgrp manual page" link.

I'm using Ubuntu 7.10 after upgrade from 7.04, with Russian localization. (LANG=ru_RU.UTF-8)

ProblemType: Bug
Architecture: i386
Date: Sat Oct 20 12:26:01 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.20.0-0ubuntu3
PackageArchitecture: i386
ProcCmdline: yelp
ProcCwd: /home/alexeys
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux ava 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Related branches

Here is screenshot of Yelp.

Sebastien Bacher (seb128) wrote :

Thank you for your bug, the manpage rendering having issue is known upstream, there is discussion about that on http://bugzilla.gnome.org/show_bug.cgi?id=488807

Changed in yelp:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in yelp:
status: Unknown → New
Colin Watson (cjwatson) wrote :

For what it's worth, the Bugzilla link above seems to be to the wrong bug ...

Anyway, I put together a patch for this, which is almost working. I seem to have done something slightly wrong, though. Whenever I open a manual page with this patch, I get a "Page not found" error, saying "The requested page was not found in the document /usr/share/man/man1/chgrp.1.gz" (for example); but it then goes ahead and displays the page correctly anyway! What have I done wrong?

Colin Watson (cjwatson) wrote :

Apparently this is http://bugzilla.gnome.org/show_bug.cgi?id=476498 and nothing to do with my patch, so I think you can go ahead with my patch after review. While it probably isn't suitable for upstream (fixes for http://bugzilla.gnome.org/show_bug.cgi?id=477788 may avoid the need for it), it would be suitable for Debian and I'd appreciate it being forwarded there.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yelp - 2.21.90-0ubuntu2

---------------
yelp (2.21.90-0ubuntu2) hardy; urgency=low

  * debian/control.in:
    - add a Depends on man-db (>= 2.5.1-1)
  * debian/patches/07_man_utf8.patch:
    -"Recode manual pages to UTF-8 (LP: #154829). Requires man-db (>= 2.5.1-1)."
     Thanks Colin Watson
  * debian/patches/80_from_bugzilla_correct_manpage_loading.patch:
    - change from bugzilla, fix manpage loading

 -- Sebastien Bacher <email address hidden> Tue, 05 Feb 2008 12:10:23 +0100

Changed in yelp:
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

I've forwarded this patch to Debian now.

Changed in yelp:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.