package xulrunner-1.9 1.9.0.10+nobinonly-0ubuntu0.9.04.1 failed to install/upgrade: subprocess post-installation script returned error exit status 2

Bug #370093 reported by Sonny on 2009-04-30
74
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xulrunner-1.9 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xulrunner-1.9

Unable to install/uninstall/reinstall/run firefox.

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage: subprocess post-installation script returned error exit status 2
Package: xulrunner-1.9 1.9.0.10+nobinonly-0ubuntu0.9.04.1
SourcePackage: xulrunner-1.9
Title: package xulrunner-1.9 1.9.0.10+nobinonly-0ubuntu0.9.04.1 failed to install/upgrade: subprocess post-installation script returned error exit status 2
Uname: Linux 2.6.28-11-generic i686

Sonny (aadityabhatia) wrote :
Sonny (aadityabhatia) wrote :

$ sudo dpkg --purge xulrunner-1.9
(Reading database ... 113621 files and directories currently installed.)
Removing xulrunner-1.9 ...
update-alternatives: error or eof reading /var/lib/dpkg/alternatives/xulrunner for update_mode ()
dpkg: error processing xulrunner-1.9 (--purge):
 subprocess pre-removal script returned error exit status 2
Errors were encountered while processing:
 xulrunner-1.9

Sonny (aadityabhatia) wrote :

Copying the file "/var/lib/dpkg/alternatives/xulrunner" from another machine fixed the problem.
The file was deleted upon purging the package "xulrunner-1.9", while the package "xulrunner-1.9.1" was still installed.
Successfully re-installed "xulrunner-1.9" afterwards, which is required by "firefox".

What triggered the problem? Was it caused by installing "shiretoko" without removing "firefox"?

many thanks, i will try your solution.
I don't know what causes the problem.. I have only installed KUBUNTU
9.04. A windows proposed me 3 security updates, i launched this updates,
my pc crashed, and after the crash this little problem start. Firefox
run correctly, but every time i launch other installation or upgrades
this message of error appears!

Aaditya ha scritto:
> Copying the file "/var/lib/dpkg/alternatives/xulrunner" from another machine fixed the problem.
> The file was deleted upon purging the package "xulrunner-1.9", while the package "xulrunner-1.9.1" was still installed.
> Successfully re-installed "xulrunner-1.9" afterwards, which is required by "firefox".
>
> What triggered the problem? Was it caused by installing "shiretoko"
> without removing "firefox"?
>
>

Arne Nordmann (launchpad-norro) wrote :

I may have triggered the problem with installing firefox 3 and firefox 3.1/3.5 in parallel.

Cristiano 147 (c-pomini) wrote :

i've tryed your solution, now xlurunnere in correctly installed!!
Many many thanks!!

Aaditya ha scritto:
> Copying the file "/var/lib/dpkg/alternatives/xulrunner" from another machine fixed the problem.
> The file was deleted upon purging the package "xulrunner-1.9", while the package "xulrunner-1.9.1" was still installed.
> Successfully re-installed "xulrunner-1.9" afterwards, which is required by "firefox".
>
> What triggered the problem? Was it caused by installing "shiretoko"
> without removing "firefox"?
>
>

Volegost (ffrooty) wrote :

SPASIBO !! Thanks a lot!
>> Copying the file "/var/lib/dpkg/alternatives/xulrunner" from another machine fixed the problem.
>> The file was deleted upon purging the package "xulrunner-1.9", while the package "xulrunner-1.9.1" was still installed.
>> Successfully re-installed "xulrunner-1.9" afterwards, which is required by "firefox".
>>
>> What triggered the problem? Was it caused by installing "shiretoko"
>> without removing "firefox"?
>>
>>
>>
>
>

What is the solution if you do not have access to another machine to take xulrunner?
I cannot seem to purge it and re-installing does not help.
Problem was caused by normal update by the update manager.
Thanks

Sonny (aadityabhatia) wrote :

> What is the solution if you do not have access to another machine to take xulrunner?

Create a new file "/var/lib/dpkg/alternatives/xulrunner" with the following contents (exclude the ===):

===
auto
/usr/bin/xulrunner

/usr/bin/xulrunner-1.9
50

===

-Aaditya

Aaditya,

Unfortunately this does not solve the problem for me.

Solved it by manually removing all the files belonging to the xulrunner package and editing the dpkg status file by setting it to: purge ok not-installed.
Then re-installed the package and now all is well.

Ben (bugben) wrote :

For me removing the file (/var/lib/dpkg/alternatives/xulrunner) was what I finally needed to do to complete the install, so to summarize:

Delete the files listed here: http://packages.ubuntu.com/jaunty/i386/xulrunner-1.9/filelist
Delete /var/lib/dpkg/alternatives/xulrunner
resinstall manually by downloading xulrunner from: http://packages.ubuntu.com/jaunty/i386/xulrunner-1.9/download

Changed in xulrunner-1.9 (Ubuntu):
status: New → Confirmed
Alexander Sack (asac) wrote :

should be fixed a while back.

Changed in xulrunner-1.9 (Ubuntu):
status: Confirmed → Fix Released
sdaau (sd-imi) wrote :

Had the same issue on upgrade from 9.04 to 9.10 ; removing manually as in https://bugs.launchpad.net/ubuntu/+source/xulrunner-1.9/+bug/370093/comments/11 and https://bugs.launchpad.net/ubuntu/+source/xulrunner-1.9/+bug/370093/comments/12 helped.

Maybe the issue was in me having xulrunner 1.9.1 in 9.04; however the default universe version for xulrunner in both 9.04 and 9.10 seems to be 1.8.1.16 ??

sdaau (sd-imi) wrote :

Funnily, after I removed everything, ran sudo apt-get install xulrunner (which installed 1.8.1.16), and tried to remove it, and again I get "error: no alternatives for xulrunner" ..

If I copy the xulrunner file into /var/lib/dpkg/alternatives, and try to apt-get remove xulrunner, it says "update-alternatives: warning: alternative /usr/bin/xulrunner-1.9 (part of link group xulrunner) doesn't exist. Removing from list of alternatives" and the removal process fails yet again..

Is there not a way to force a dpkg removal even if update-alternative fails?

sdaau (sd-imi) wrote :

Ok, followed http://blog.ixti.ru/archives/6 (via https://bugs.launchpad.net/ubuntu/+source/gnash/+bug/422745 ) - and basically a line
   update-alternatives --remove-all xulrunner
in /var/lib/dpkg/info/xulrunner.prerm needs to be commented - however, just commenting it will cause the bash script to fail, so just replace that line with something like "echo blabla" and then it will be possible to sudo apt-get remove --purge xulrunner ...

Cristiano 147 (c-pomini) wrote :

I solved the problem one year ago, only substituting the corrupted file
xulrunner on /var/lib/dpkg/alternatives with a file xulrunner taken from
another computer... then sudo apt-get update and sudo apt-get upgrade.
This fixed my problem.

Il giorno mer, 04/11/2009 alle 21.43 +0000, sdaau ha scritto:
> Ok, followed http://blog.ixti.ru/archives/6 (via https://bugs.launchpad.net/ubuntu/+source/gnash/+bug/422745 ) - and basically a line
> update-alternatives --remove-all xulrunner
> in /var/lib/dpkg/info/xulrunner.prerm needs to be commented - however, just commenting it will cause the bash script to fail, so just replace that line with something like "echo blabla" and then it will be possible to sudo apt-get remove --purge xulrunner ...
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers