Ubuntu

no alternatives for iceape-flashplugin

Reported by Bepy on 2009-09-01
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
adobe-flashplugin (Ubuntu)
High
Brian Thomason
gnash (Ubuntu)
Undecided
Alexander Sack

Bug Description

Binary package hint: gnash

Upgrade from 9.04 to karmic alpha4

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.10
ErrorMessage:
 ErrorMessage: il sottoprocesso nuovo script di pre-removal ha restituito un codice di errore 1
Package: mozilla-plugin-gnash 0.8.5-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.28-15.49-generic
SourcePackage: gnash
Title: package mozilla-plugin-gnash 0.8.5-0ubuntu1 failed to install/upgrade:
Uname: Linux 2.6.28-15-generic i686

Bepy (freddy-junior) wrote :
Vladtn (vladtn) wrote :

 sudo apt-get remove mozilla-plugin-gnash

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  mozilla-plugin-gnash
0 upgraded, 0 newly installed, 1 to remove and 30 not upgraded.
5 not fully installed or removed.
After this operation, 221kB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: error processing mozilla-plugin-gnash (--remove):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 mozilla-plugin-gnash
.....................................................................
sudo apt-get -f install mozilla-plugin-gnash

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  mozilla-plugin-gnash
1 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
5 not fully installed or removed.
Need to get 0B/41.9kB of archives.
After this operation, 0B of additional disk space will be used.
Selecting previously deselected package mozilla-plugin-gnash.
(Reading database ... 159858 files and directories currently installed.)
Preparing to replace mozilla-plugin-gnash 0.8.5-0ubuntu1 (using .../mozilla-plugin-gnash_0.8.5-0ubuntu2_i386.deb) ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: warning: old pre-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
prerm called with argument `failed-upgrade'
dpkg: error processing /var/cache/apt/archives/mozilla-plugin-gnash_0.8.5-0ubuntu2_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
postinst called with argument `abort-upgrade'
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/mozilla-plugin-gnash_0.8.5-0ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
...................................................................................................

and etc upgrade impossible remove impossible

summary: - package mozilla-plugin-gnash 0.8.5-0ubuntu1 failed to install/upgrade:
+ no alternatives for iceape-flashplugin
Alexander Sack (asac) wrote :

bzr commit -m '* fix LP: #422745 - no alternatives for iceape-flashplugin; ignore
  upgrade failures from << 0.8.5-0ubuntu3 (caused by LP: #398213)
  - update debian/mozilla-plugin-gnash.prerm' --fixes 'lp:398213' --fixes 'lp:422745'
Committing to: bzr+ssh://<email address hidden>/~gnash/gnash/ubuntu/
modified debian/changelog
modified debian/mozilla-plugin-gnash.prerm
Committed revision 174.

Changed in gnash (Ubuntu):
status: New → In Progress
status: In Progress → Fix Committed
Alexander Sack (asac) wrote :

uploaded the fix as 0.8.5-0ubuntu3. in case this update doesnt cure you let us know.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnash - 0.8.5-0ubuntu3

---------------
gnash (0.8.5-0ubuntu3) karmic; urgency=low

  * fix LP: #422745 - no alternatives for iceape-flashplugin; ignore
    upgrade failures from << 0.8.5-0ubuntu3 (caused by LP: #398213)
    - update debian/mozilla-plugin-gnash.prerm

 -- Alexander Sack <email address hidden> Fri, 11 Sep 2009 13:21:54 +0200

Changed in gnash (Ubuntu):
status: Fix Committed → Fix Released
Alexander Sack (asac) on 2009-09-11
Changed in gnash (Ubuntu):
assignee: nobody → Alexander Sack (asac)
Juancarlo An~ez (apalala) wrote :

I get this same error after the upgrade to Karmic of today 2009/10/23.

Preparing to replace adobe-flashplugin 10.0.32.18-1jaunty1 (using .../adobe-flashplugin_10.0.32.18-1karmic1_i386.deb) ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: warning: old pre-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: error processing /var/cache/apt/archives/adobe-flashplugin_10.0.32.18-1karmic1_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 2
postinst called with argument `abort-upgrade'
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/adobe-flashplugin_10.0.32.18-1karmic1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Chris Heeney (heeney-cs) wrote :

I am having the same problem as Juanca. However the problem package is adobe-flashplugin and not the mozilla-plugin-gnash so this might not be the correct post.

It does not seem to matter wether I use Synaptic or aptitude in the terminal I cannot remove, re-install, or upgrade this package. is there a workaround to remove this package or correct this problem so I can continue with the Distribution Upgrade?

Thanks,

Chris

Alexander Sack (asac) wrote :

adobe-flashplugin has the same problem. Brian, did you fix it in latest update round? Otherwise get in touch with me so we can fix this before releaes still.

Changed in adobe-flashplugin (Ubuntu):
assignee: nobody → Brian Thomason (brian-thomason)
importance: Undecided → Critical
milestone: none → ubuntu-9.10
status: New → Triaged
importance: Critical → High
Alexander Sack (asac) wrote :

verified that gnash is fixed as the status suggests ...

Alexander Sack (asac) wrote :

flashplugin-installer also has not this problem

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers