Should depend on qt5-style-plugins

Bug #1728236 reported by Teresa e Junior on 2017-10-28
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xubuntu-docs (Ubuntu)
Undecided
Unassigned
xubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

xubuntu-default-settings has both the file /etc/skel/.config/Trolltech.conf, which sets the look of Qt applications, and /etc/X11/Xsession.d/56xubuntu-session, which sets QT_QPA_PLATFORMTHEME=gtk2.

The package qt5-style-plugins is still needed, though, for Qt 5 applications to use the Greybird theme and Xfce4 font settings.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: xubuntu-default-settings 17.10.0
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Oct 28 12:16:00 2017
InstallationDate: Installed on 2017-04-23 (188 days ago)
InstallationMedia: Xubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
PackageArchitecture: all
SourcePackage: xubuntu-default-settings
UpgradeStatus: Upgraded to artful on 2017-10-28 (0 days ago)

Teresa e Junior (teresaejunior) wrote :

Should "qt5-style-plugins" and its various dependencies be pulled in by default (as recommended package)? At least that is what Ubuntu MATE does.

---

$ sudo apt install --no-install-recommends qt5-style-plugins
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libdouble-conversion1 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5
  libqt5widgets5 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0
  libxcb-render-util0 libxcb-xinerama0 libxcb-xkb1 libxkbcommon-x11-0
Suggested packages:
  qt5-image-formats-plugins qtwayland5
Recommended packages:
  qttranslations5-l10n libqt5svg5 qt5-gtk-platformtheme
The following NEW packages will be installed:
  libdouble-conversion1 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5
  libqt5widgets5 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0
  libxcb-render-util0 libxcb-xinerama0 libxcb-xkb1 libxkbcommon-x11-0
  qt5-style-plugins
0 upgraded, 15 newly installed, 0 to remove and 0 not upgraded.
Need to get 8,195 kB of archives.
After this operation, 28.8 MB of additional disk space will be used.
Do you want to continue? [Y/n]

affects: xubuntu-default-settings (Ubuntu) → xubuntu-meta (Ubuntu)
Teresa e Junior (teresaejunior) wrote :

I find it gives a good first impression when people install Qt applications and they look similar to the desktop. Don't know if there is room for it in the ISO, though.

It is mentioned in the release notes for 17.04 that an extra installation of qt5-style-plugins is needed, but that may be not easy to find.

https://wiki.xubuntu.org/releases/17.04/release-notes

We will have to wait for an answer from the Xubuntu team.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre) wrote :

We don't want to include it on the ISO because it pulls quite a few other QT dependencies. However, we should better surface this issue on the documentation.

Since Xubuntu now includes AptURL, we can even include a one-click installer.

Changed in xubuntu-meta (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints