Thunar should show up by name, if user searches the app by typing in 'thunar' in whiskermenu

Bug #1774046 reported by Willem Hobers
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Xfce4 Whisker Menu Plugin
Won't Fix
Medium
Xubuntu Default Settings
Fix Committed
Undecided
Unassigned
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

On Xubuntu 18.04 when using whisker menu Thunar does not show up when the end user types in "thunar".
Cheching with people over at xfce.org it was suggested that this is a Xubuntu-specific phenomenon.
Please see here; https://bugzilla.xfce.org/show_bug.cgi?id=14326

Revision history for this message
In , Willem Hobers (whobers) wrote :

As Thunar is the default xfce-filemanager and whiskermenu allows the user to find an app by typing its name, I think whiskermenu should allow the user to find and start thunar by typing "thunar", just like typing "fire..." finds firefox, and "write" finds libreoffice write.
I realize that the user can adjust whiskermenu to make it possible to find thunar by name, but I feel the default settings of whiskermenu should allow for thunar to be found by name.
Using whiskermenu version 2.1.5

Revision history for this message
In , Graeme Gott (gottcode) wrote :

It does for me with the default settings. When I search for "thunar", I get the result "Thunar File Manager". What distro are you using? What do you see?

Revision history for this message
In , Willem Hobers (whobers) wrote :

I use Xubuntu 18.04 at the moment (daily-iso).
Linux Xubuntu-18-04 4.15.0-13-generic #14-Ubuntu SMP Sat Mar 17 13:44:27 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

What I see: http://i.imgur.com/auIZZ93.png

I have checked on a Xubuntu 16.04, and on a freshly installed 18.04: none of these show thunar when typing in thun...

Any more information I can provide to help?

Revision history for this message
In , Graeme Gott (gottcode) wrote :

Interesting. When I run Xubuntu in a virtual machine, I also can't find thunar when I search for it by name. I will have to investigate further.

When you said that users could adjust Whisker Menu to show thunar, what do you mean? The search results are supposed to contain the same applications no what settings the user has. Is there a setting you have changed to be able to see thunar when you search?

I am not willing to hardcode any application in Whisker Menu. Especially as Whisker Menu doesn't even know what applications there are to show; it relies on garcon to find all the applications on your system.

Revision history for this message
In , Willem Hobers (whobers) wrote :

I may have been mistaken about being able to adjust Whisker menu. I was referring to MenuLibre (https://bluesabre.org/projects/menulibre/), which allows me to add keywords as metadata to apps, I think; please see here: http://i.imgur.com/gEHmltO.png, sorry about the Dutch language- I refer to the field "Trefwoorden", which I would translate as "Keywords". I take it that this field gives me the possibility to put in "thunar", and that then thunar can be found by typing... Haven't tested this yet, though.

I don't know how garcon gets its information.
As far as I can see there is a "thunar" entry in /usr/bin.

Any more information I can help you with?

Revision history for this message
In , Graeme Gott (gottcode) wrote :

The more I look into this, the more it looks like something you need to report to Xubuntu. For some reason, garcon is not loading the /usr/share/applications/Thunar.desktop file, which means that Whisker Menu doesn't see Thunar.

That isn't the way things are configured by Xfce as far as I can tell, so I think Xubuntu must have changed something. In Arch Linux it sees that file, so when I search I find "Thunar File Manager". I also see it under "System", which is where it would show up if it was loading the .desktop file.

I don't think there is anything I can do, sorry.

Revision history for this message
In , Willem Hobers (whobers) wrote :

No problem. Will head over de #xubuntu-devel and try to get their attention. :-)
Thank you for looking into this issue.

Willem Hobers (whobers)
tags: added: thunar
tags: added: whiskermenu
removed: thunar
affects: ubuntu-manual-tests → xfce4-whiskermenu-plugin (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-whiskermenu-plugin (Ubuntu):
status: New → Confirmed
Revision history for this message
In , Willem Hobers (whobers) wrote :
Changed in xfce4-whiskermenu-plugin:
importance: Unknown → Medium
status: Unknown → Won't Fix
Revision history for this message
Theo Linkspfeifer (lastonestanding) wrote :

Xubuntu hides the Thunar entry by default [1] and only shows the exo wrapper "File Manager".

[1] https://git.launchpad.net/xubuntu-default-settings/tree/usr/share/xubuntu/applications/Thunar.desktop

affects: xfce4-whiskermenu-plugin (Ubuntu) → xubuntu-default-settings (Ubuntu)
Revision history for this message
Theo Linkspfeifer (lastonestanding) wrote :

Deleting that .desktop file would let Thunar show up as "Thunar File Manager" in whisker menu (generic application names are not shown by default).

Similar case: "Web Browser" and "Firefox Web Browser"

Revision history for this message
Sean Davis (bluesabre) wrote :
Changed in xubuntu-default-settings:
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 18.10.2

---------------
xubuntu-default-settings (18.10.2) cosmic; urgency=medium

  * etc/skel/.config/atril/atril_toolbar.xml:
    - Add items to the Atril toolbar for improved usability (LP: #1792788)
  * etc/xdg/xdg-xubuntu/Thunar/uca.xml.in:
    - Fix file matching for the Print file/s custom command
  * etc/xdg/xdg-xubuntu/xfce4/whiskermenu/defaults.rc,
    etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-appfinder.xml:
    - Add file search custom command (-) to Whisker Menu and
      Application Finder (LP: #1793393)
  * usr/share/xubuntu/applications/Thunar.desktop:
    - Removed, Thunar File Manager will now be displayed in
      the menu again (LP: #1774046)
  * debian/xubuntu-live-settings.install,
    debian/light-locker.desktop:
    - Disable lock-on-suspend on the live session (LP: #1421443)

 -- Sean Davis <email address hidden> Mon, 24 Sep 2018 05:02:21 -0400

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
In , Nic Brown (nicbrown) wrote :

Thanks reported in https://goo.gl/XVUN7p

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.