Disable numlockx on laptops

Bug #1759112 reported by Kev Bowring on 2018-03-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

We added numlockx to seed - so numlock is on at login window https://bugs.launchpad.net/ubuntu/+source/xubuntu-meta/+bug/1746556

Can we disable on laptops.

Kev Bowring (flocculant) on 2018-03-27
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 18.04.5

---------------
xubuntu-default-settings (18.04.5) bionic; urgency=medium

  [ Krytarik Raido ]
  * Use 55numlockx to not enable numlock for laptops (LP: #1759112)

 -- Sean Davis <email address hidden> Tue, 27 Mar 2018 20:21:14 -0400

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released
Pjotr12345 (computertip) wrote :

OK, but what if you have a big laptop that does have a separate numeric keypad?

There's still a bug in line 23 of file /etc/X11/Xsession.d/55numlockx.
ltd=/usr/sbin/laptop-detect
should be
ltd=/usr/bin/laptop-detect

since file in package laptop-detect is /usr/bin/laptop-detect

Present state makes login in a laptop without separate keypad troublesome.
Since NumLock stays on, you think you're typing the correct password
but that's not the case. You can keep trying until you realize that
NumLock is on, which can be a long time, since that, unless CapLock,
isn't advertised.

Pjotr12345 (computertip) wrote :

Even when laptop-detect is being called properly: there are also laptops that *do* have a separate numeric keypad. On those, the numeric keypad should be turned on....

I can't help but feeling that installing numlockx by default, is a design choice that creates more problems than it solves.

Kev Bowring (flocculant) wrote :

@ pjotr12345 - the 55numlockx file is supposed to check for this - perhaps you can test it. You'll need to edit the file to make ltd=/usr/sbin/laptop-detect ltd=/usr/bin/laptop-detect as that's moved.

Kev Bowring (flocculant) wrote :

Alternatively - updated numlockx is on the way, currently in -proposed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints