Xubuntu needs a better numlock handler at login and during user session

Bug #1746556 reported by Chris Rainey
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned
xubuntu-meta (Ubuntu)
Wishlist
Sean Davis

Bug Description

Please make xubuntu-desktop depend on numlockx and then add the following code to /etc/lightdm/lightdm.conf.d/50-numlock.conf:

[Seat:*]
greeter-setup-script=numlockx on

in order to make the numlock = on, by default, on desktop machines(laptop-detect = 0)

The lack of this functionality has been a constant irritant to my Microsoft Windows converts.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: xubuntu-desktop 2.218
ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
Uname: Linux 4.13.0-32-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Jan 31 11:10:26 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2018-01-22 (8 days ago)
InstallationMedia: Xubuntu 17.10 "Artful Aardvark" - Release amd64 (20180105)
SourcePackage: xubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Chris Rainey (ckrzen) wrote :
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre)
Changed in xubuntu-meta (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
assignee: nobody → Sean Davis (bluesabre)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.222

---------------
xubuntu-meta (2.222) bionic; urgency=medium

  * Refreshed dependencies
  * Added firefox to desktop-recommends [ppc64el]
  * Added fonts-ubuntu to core-recommends, desktop-recommends
  * Added libu2f-udev to core, desktop
  * Added numlockx to desktop-recommends (LP: #1746556)
  * Added printer-driver-m2300w to core-recommends, desktop-recommends
  * Added spice-vdagent to core, desktop
  * Removed gtk-theme-config from desktop-recommends
  * Removed ttf-ancient-fonts-symbola from core-recommends, desktop-
    recommends
  * Removed ttf-ubuntu-font-family from core-recommends, desktop-
    recommends
  * d/control, d/compat:
    - Bump standards version to 4.1.3, debhelper to 11
  * d/changelog: Striped trailing whitespace

 -- Sean Davis <email address hidden> Thu, 01 Mar 2018 00:33:47 -0500

Changed in xubuntu-meta (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 18.04.2

---------------
xubuntu-default-settings (18.04.2) bionic; urgency=medium

  [ Sean Davis ]
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/parole.xml:
    - Use autoimagesink, introduced in Parole 1.0.0, to fix playback
      in virtual machines
  * usr/share/lightdm/lightdm.conf.d/50-xubuntu-numlock.conf:
    - Enable numlock at greeter startup (LP: #1746556)
  * d/compat, d/control:
    - Bump standards version to 4.1.3 and debhelper to 11
  * d/changelog: Stripped trailing whitespace

  [ Simon Steinbeiß ]
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml:
    - Add Super+F1 as default shortcut for xfce4-find-cursor,
      added in xfce4-settings 4.12.2

 -- Sean Davis <email address hidden> Thu, 01 Mar 2018 00:55:44 -0500

Changed in xubuntu-default-settings (Ubuntu):
status: New → Fix Released
Chris Rainey (ckrzen)
summary: - Xubuntu needs a better num lock handler at login and during user session
+ Xubuntu needs a better numlock handler at login and during user session
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers