XFCE 4.12 Black screen after wakeup from suspending by closing the laptop lid

Bug #1431149 reported by Michael Wyraz on 2015-03-12
This bug affects 17 people
Affects Status Importance Assigned to Milestone
xfce4-settings (Ubuntu)
xubuntu-default-settings (Ubuntu)

Bug Description

This seems to be a regression to #1303736. I have installed Xubuntu 14.04.2 and verified that suspend/resume works. Then I've upgraded to XFCE 4.12 using the ppa. After the upgrade, the problem occurs again.

Steps to reproduce:

- Fresh install of XUbuntu 14.04.2 on an Acer TravelMate-8371
- > Lid close, Lid open, Wakeup by keypress, Login -> works fine

- Installing xfce 4.12 from PPA
- > Lid close, Lid open, Wakeup by keypress, Login -> Screen remains black

No other software was installed for this test. Only plain install of xubuntu from official ISO to fresh harddisk + upgrade xfce via ppa.

Michael Wyraz (michael-wyraz) wrote :

Sorry, changed it accidentally

affects: xubuntu-default-settings (Ubuntu) → xfce4-settings (Ubuntu)
affects: xfce4-settings (Ubuntu) → xubuntu-default-settings (Ubuntu)
Michael Wyraz (michael-wyraz) wrote :

According to an archlinux forum discussion, the bug _might_ be caused by xfce4-settings. I'm not entirely sure, so I changed the affected package back to xubuntu-default-settings until I know it exactly.

Here's the post of one who testet the fix: https://bbs.archlinux.org/viewtopic.php?pid=1507949#p1507949

And there's the fix they've done:

The mentioned PPA does not install or update xubuntu-default-settings, so it is most likely not a bug in this package.

Please download and test Xubuntu 15.04 which ships with Xfce 4.12 by default. We need to know if the bug is reproducible with the current (development) release.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Incomplete
Michael Wyraz (michael-wyraz) wrote :

I'm running XUbuntu 15.04 (final release) for a few weeks on my laptop. I did some initial tests directly after I installed it and it worked properly. But unfortunately after a few days the bug occured from time to time. It's not reproducible. I'm using the laptop almost every day and every 4-5 days, the screen remains black after login (after it woke up from standby or hibernation).

Can you switch to another screen locker (probably xscreensaver) and see if the problem still occurs?

The light-locker fix for bug 1307545 may require tweaking to cover some corner case which still triggers the black screen issue.

Launchpad Janitor (janitor) wrote :

[Expired for xubuntu-default-settings (Ubuntu) because there has been no activity for 60 days.]

Changed in xubuntu-default-settings (Ubuntu):
status: Incomplete → Expired
Changed in xubuntu-default-settings (Ubuntu):
status: Expired → Confirmed
Michael Wyraz (michael-wyraz) wrote :

I reopen the bug since it still occurs from time to time. Switching to xscreensaver will probably "fix" it because the locking mechanism is completely different.

Please let me know what I can do to gather more information about this bug when the following situation occurs:
- Laptop was in suspend
- Laptop woke up, screen is locked
- I enter my password, the screen becomes black
- I still can switch to console (Strg+Alt+F1) - it shows a login prompt and can switch back to X11 (Strg+F7) to see the balck screen

How (wonghow) wrote :

Also the action only works when both battery and AC are selected the same action.

Derf Skren (awron) wrote :

Me too! I was Googling about screensavers and it said to try running 'xflock4' which is how I first ended up with a black screen unable to return to the desktop. If I press the power button and hit 'suspend' I get the same thing.

Derf Skren (awron) wrote :

Also I just shut my lid as a test, the display comes back but as soon as I press any key it goes blank and I'm left hanging again.

Acer Travelmate 7750G.

Derf Skren (awron) wrote :

In case it helps anyone who's a total newbie like me, install xscreensaver. It will take over the blanking and switching off of your screen as well as allow you to lock the machine when it times out (tick "Lock Screen After" on the "Display Modes" tab). That seems to work for me.

El (elbrook33) wrote :

I have the same problem on a fresh install of Xubuntu 15.10.

* Suspending without closing laptop lid is fine.
* Turning off lock screen on sleep makes no difference (screen is black when opened even without a lock screen).
* Removing light-locker makes no difference.
* Installing xscreensaver makes no difference.
* Problem persists whether I choose lock screen, turn off display or suspend on action for closing laptop lid.
* xrandr --auto (and switching consoles) works.

El (elbrook33) wrote :

Just to add: closing the laptop lid (and waking up) works fine if I've logged out of Xfce (and am at the LightDM login screen), so it seems to be an issue with Xfce/Xubuntu. Thanks.

Piotr Admin (piotr-wroclaw) wrote :

This solution works on my laptop (ubuntu 16.04, but should work on previous OS):
open as root file
and change IgnoreLid=false ==> IgnoreLid=true
save changes, restart system and now it works :-)
You can remove light-locker now.

You can use bash for these:
sudo sed -i -e 's/IgnoreLid=false/IgnoreLid=true/g' /etc/UPower/UPower.conf
sudo apt-get remove --purge -y light-locker light-locker-settings

Kethen (scootalootf2) wrote :

Removing light-locker and light-locker-settings works for me. Originally even if I suspend manually from whisker menu, I get a black screen whenever I unlock my computer. Now it works!

One notable thing is that I use gdm3 instead of lightdm, maybe that's the reason.

Mario Di Nicola (warp99) wrote :

I don't have light-locker installed, using GDM3 instead, and just upgraded to Bionic, but this bug appears to have reared it's ugly head again. The solution however of changing IgnoreLid to true in UPower.conf clears up the problem. Hats off to piotr-wroclaw for figuring this out.

This solution also doesn't affect any of the other desktops I have installed, which is Gnome 3 and Unity. All three desktops now suspend and resume correctly as expected when closing the lid. Just remember to reboot so the settings take affect.

I also have this problem, which has been bugging me also in the pre-alpha releases of 18.04. It happens occasionally to me on a Thinkpad E580, and was expecting hardware-like resume problems, or issues with light-locker.

I noticed that connecting an external display worked for the external display, so the desktop was running properly. Trying to revive my laptop display using xrandr gave me an error: "Configure CRTC 0 failed".

I found a solution posted here that works for me: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=785622

Which is:
xfsettingsd --replace

agriomaroulo (ttapp) wrote :

Bug is present for me in Xubuntu 18.04 (Kernel: 4.15.0-20-generic x86; Xfce 4.12.3; Graphics Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics]).
Black screen (so no backlight at all) after resume, but only in case the suspend was initiated by lid closing. Replacing lightdm or light-locker didnt solve the problem.
Solution offered in #14 by Piotr Admin (piotr-wroclaw) solves it, but also removes the opportunity to set lid action from xfce power manager and moreover screen is not locked while laptop sleeps.

Mario Di Nicola (warp99) wrote :

My screen does lock when going to sleep, by I have gnome-screensaver installed instead of xscreensaver. XFCE checks which screensaver you have and calls that version prior to suspend for the lock screen. I have this setup on my desktop and laptop, both work without issue.

agriomaroulo (ttapp) wrote :

After changing to IgnoreLid=true, are you able to set lid closing action for battery/AC somewhere? Because this way its been disappeared from xfce power manager. I would like to set different behaviour for those.

At this point we have comments about various setups (software + hardware) with different screen lockers involved across a couple of (X)Ubuntu releases.

I suggest to open a new report for Xubuntu 18.04. Thanks.

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Invalid

New report should be filed against xfce4-settings/xfce4-power-manager or light-locker if used.

agriomaroulo (ttapp) wrote :

Sorry, my self can not open a new report about it, because the issue was so annoying that sadly I have switched to cinnamon... so I'm not affected atm.
But just asking: are you sure this occurs on different hardware, and not only with the amd gpu (driver)? Its just an idea as for years now nobody has found the root cause of this bug. Simply closing and reopening the report seems for me just a newer postponing of the solution.

The report is quite old now, and some things have changed under the hood over the years. I think it will help to start gathering information in new report(s) without mixing different test setups, and therefore mixing potentially different root causes.

It does not look like anyone here has tested the proposed build change from comment #2. I will reassign this report to "xfce4-settings", and let the Xubuntu devs decide if that change should be applied.

Changed in xfce4-settings (Ubuntu):
status: New → Confirmed

For Xubuntu 18.04 + light-locker there is bug 1759950.

kjur (kjur) wrote :

I used Xubuntu 18.04 LTS. It was ok for a few months, then the problem started. Recently upgraded to Xubuntu 19.10 (completely fresh install). Still blank screen after waking up fro suspend.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.