Ubuntu

xterm fonts get corrupted while typing

Reported by Kalle Valo on 2010-09-22
This bug report is a duplicate of:  Bug #635258: Garbled chars in xterm. Edit Remove
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by Stephane Epardaud
xterm (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by Stephane Epardaud

Bug Description

Binary package hint: xterm

Since I upgrade to maverick from lucid I have seen extremely annoying font corruption while typing which makes unpossible to read what I'm currently writing. It looks like some extra lines are drawn on top of the glyphs. But if I do SHIFT-PageUp and SHIFT-PageDown to refresh the screen, the corruption is gone and the text looks perfect again.

I had to switch using gnome-terminal because of this bug. But I really would prefer using xterm.

This problem doesn't seem to be computer nor settings specific. I have seen the problem with my two different maverick laptops, Samsung X120 and Dell E5410. Also I have seen it with pristine user settings. And both with default and finnish locale.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xterm 261-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-21.31-generic 2.6.35.4
Uname: Linux 2.6.35-21-generic x86_64
Architecture: amd64
DRM.card0.DisplayPort.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DisplayPort.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DisplayPort.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI_Type_A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI_Type_A.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wBMo1IwAAAAAAATAQOAGg54CjUlk1ZVjikdUFQAAAABAQEBAQEBAQEBAQEBAQEBjxtWgFAAEzAwICUAAJAQAAAZAAAADwAAAAAAAAAAAB60AnQAAAAA/gBTQU1TVU5HCiAgICAgAAAA/gBMVE4xMTZBVDAxMDAwAMw=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed Sep 22 09:37:18 2010
MachineType: SAMSUNG ELECTRONICS CO., LTD. X120/X170
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-21-generic root=UUID=b345284f-a700-4b71-a796-254f8e2835e8 ro quiet splash security=
ProcEnviron:
 LC_TIME=en_US.utf8
 PATH=(custom, user)
 LANG=fi_FI.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xterm
dmi.bios.date: 10/13/2009
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 04CX.M005.20091013.KSY
dmi.board.name: X120/X170
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr04CX.M005.20091013.KSY:bd10/13/2009:svnSAMSUNGELECTRONICSCO.,LTD.:pnX120/X170:pvrNotApplicable:rvnSAMSUNGELECTRONICSCO.,LTD.:rnX120/X170:rvrNotApplicable:cvnSAMSUNGELECTRONICSCO.,LTD.:ct10:cvrN/A:
dmi.product.name: X120/X170
dmi.product.version: Not Applicable
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-21-generic

Kalle Valo (kvalo) wrote :
Liam Dunn (ldunn) wrote :

This occurs on my system as well, and I'll just note that anything at all that causes the xterm window to redraw removes the extra crud.

Kalle Valo (kvalo) wrote :

I attached "xterm screenshot" in which I try to write "cd /usr/include" but the output in xterm in unreadable.

Liam Dunn (ldunn) on 2010-09-22
Changed in xterm (Ubuntu):
status: New → Confirmed
Thomas Dickey (dickey-his) wrote :

Which fonts are being used?

Thomas Dickey <email address hidden> writes:

> Which fonts are being used?

Actually I don't know how to get the used font from xterm. But I can
reproduce with the default xterm font in maverick.

--
Kalle Valo

Thomas Dickey (dickey-his) wrote :

I was curious if it was in Xft/render. I've not seen this in Debian/testing, so I'd expect
the problem to be Ubuntu-specific. Can someone reproduce the effect with a previous
version of xterm (or is #261 the only choice for maverick)?

Kalle Valo (kvalo) wrote :

I installed xterm_256-1ubuntu1_amd64.deb from lucid (which doesn't have this problem in my lucid workstation) and I was able to reproduce the problem immediately. So the bug is elsewhere than in xterm. But where? My knowledge of X is limited, so I would appreciate some help to find the culprit.

Thomas Dickey (dickey-his) wrote :

On Sat, 25 Sep 2010, Kalle Valo wrote:

> I installed xterm_256-1ubuntu1_amd64.deb from lucid (which doesn't have
> this problem in my lucid workstation) and I was able to reproduce the
> problem immediately. So the bug is elsewhere than in xterm. But where?
> My knowledge of X is limited, so I would appreciate some help to find
> the culprit.

The screenshots seemed to show that some parts of the cells drawn for
each character weren't being (re)painted. The problem could be from
a variety of places, however for the default "fixed" font, it usually
doesn't point at xterm (otherwise it would be visible in lots of
configurations).

Most of the logic involved for the fixed font seems to be in the X server
itself (xterm is using Xlib calls which have been very stable, barring
whatever's going on with Xcb). So I'd start by trying to factor out the X
server, then look at libraries (on the client side) such as the low-level
X11 vs Xcb.

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

I have this problem too. It goes away if I disable compiz though. Metacity will make the xterms work fine. This could be a bug in compiz, xorg or nvidia…

This screenshot shows several things:

The red and green rectangles show that the cursor artifacts change depending on offset from the left of the window.

The blue and yellow rectangles show that the window is missing two column of pixels at the same distance from the left and right borders.

Also note two artifacts highlighted on the left.

Ah, since you're using an intel graphics card, this should rule out nvidia :)

Changed in xterm (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed

This is a duplicate of #635258, which is filed against xorg.

I just found a workaround: resize your window to a differente size at least once and the problem goes away. You can even bring back the window to the original size afterwards and it will keep working.

The problem comes back again when you minimise your window, but again resizing it after you bring it back will fix the issue.

I think this should be marked as important for ubuntu's maverick release. An xterm that looks this wrong on compiz which is now the default, that doesn't cut it ;)

Muharem Hrnjadovic (al-maisan) wrote :

This *is* quite annoying. Affects me as well.

Kalle Valo (kvalo) wrote :

Stephane Epardaud <email address hidden> writes:

> I just found a workaround: resize your window to a differente size at
> least once and the problem goes away. You can even bring back the window
> to the original size afterwards and it will keep working.

Oh wow, this works. And is a really simple workaround and I can use
xterms again.

Stephane, thank you very much! I owe you one :)

--
Kalle Valo

John Clemens (clemej) wrote :

Throwing my hat into the "please fix for maverick release". This is really obnoxious, and easy to reproduce (just run xterm in compiz and start typing). It effect my systems with radeon, intel, and nouveau drivers. Please at least assign to someone so that it can be worked on.

John Clemens (clemej) wrote :

Oh, and something productive to add instead of just whining: Another font artefact happens if you use the xterm popup windows (ctrl-right click, for example). Moving the mouse over the menu entries leaves lines under the menu text.

Could the be somehow related to xterm now using true-type fonts?

Thomas Dickey (dickey-his) wrote :

On Sat, 2 Oct 2010, John Clemens wrote:

> Oh, and something productive to add instead of just whining: Another
> font artefact happens if you use the xterm popup windows (ctrl-right
> click, for example). Moving the mouse over the menu entries leaves
> lines under the menu text.
>
> Could the be somehow related to xterm now using true-type fonts?

I asked, and was told it's using the default (bitmap) fonts.

All of the symptoms sound similar - and since none of my changes would
affect the menu text (in Xaw), it's fairly likely they have a common
cause.

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Michel Pelzer (mp-nsas) wrote :

I have this bug too :)

Didier Roche (didrocks) wrote :

I'm putting this one as a dup of the other one as I contains more tech inside and will just copy it's only appearing with compiz, doesn't seem to be linked with either nvidia or intel hw.

Charles Cox (chuck-chezcox) wrote :

I'm getting the same behavior since upgrading from 10.04 to 10.10. This is on an HP laptop with Intel graphics.

Prem Anand (hprem) wrote :

I am also seeing this after upgrading from 10.04 to 10.10 on a lenova thinkpad with nividia graphics card :(
Is there a workaround for this problem. It is too annoying

Jan Zacharias (janz) wrote :

Good workaround:

 In gnome, click System -> Preferences -> Apprearance -> Visual Effects and change to "None".

So this is compiz related...

ghat (ghatothkach) wrote :

I have this problem too, I am using xfonts-terminus (since gutsy days) and I got the problem as soon as I upgraded from lucid to maverick...
visual-effects were 'normal' when I see the problem, now I have switched them to 'none' and the problem is gone so to say...

fred99 (fred99) wrote :

This is now fixed. Just upgrade your compiz package.

Refer to bug #635258 (https://bugs.launchpad.net/bugs/635258) for more information.

Changed in compiz (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers