Kernel Panic using 14.04

Bug #1286911 reported by Patrick Domack on 2014-03-02
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xtables-addons (Ubuntu)
Undecided
Unassigned

Bug Description

When I have xtables-addons-dkms installed, I get kernel panics when loading my iptables rule set.

xtables-addons-common 2.3-1
xtables-addons-dkms 2.3-1

linux-image-3.13.0-13-generic
linux-image-3.13.0-14-generic

I tested both of the above linux kernels.

Attached is the screenshot of the panic.

Patrick Domack (patrickdk) wrote :
Patrick Domack (patrickdk) wrote :

I have confirmed, using xtables 2.4 corrects this issue. Looks like lots of pointer issues where fixed from 2.3 to 2.4

I built a sample package at https://launchpad.net/~patrickdk/+archive/general-lucid/

zoolook (nbensa) wrote :

Thanks!

My proxy box was crashing after an upgrade to trusty. I removed xtables-addons-dkms and now is working.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xtables-addons (Ubuntu):
status: New → Confirmed
Patrick Domack (patrickdk) wrote :

It crashs when iptables_rawpost is loaded, and a packet is received.

QuinnHarris (ubuntu-quinnh) wrote :

I can confirm that xtables-addons-dkms 2.3-1 installed with linux-image-3.13.0-27-generic caused a kernel panic soon after loading shorewall. Is there any good reason to keep the 2.3 package if its known to cause kernel panics and the 2.4 or later works?

Simon Eriksson (simon-eriksson) wrote :

Hello all, experiencing kernel panics with 14.04 LTS and xtables-addons 2.3. Is there a work around for this?

Patrick Domack (patrickdk) wrote :

Is there a work around? I posted 2 workarounds this? did you fail to read?

Simon Eriksson (simon-eriksson) wrote :

I saw the URL you posted and assumed it was for Lucid, Patrick. There was no need for the attitude. If anything you fail the attitude test. Have a nice day...

Serge Victor (ser) wrote :

It is really strange, nobody uses ubuntu with xtables-addons, really?? I think ubuntu package must be upgraded to 2.4 in trusty updates ASAP.

Patrick Domack (patrickdk) wrote :

This package is not part of ubuntu though, it's in the universe pool, no ubuntu support is provided by them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers