shut down hangs after white ubuntu logo disappears

Bug #507555 reported by RobertH on 2010-01-14
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xsplash (Ubuntu)
Undecided
Unassigned

Bug Description

I was so pleased with Ubuntu (9.10) on my desktop that I installed it on my Acer TravelMate 4001LMi laptop, too. However, on the laptop (but not on the desktop) I cannot shut down properly. I get a black screen, most usually with the following text:

"* Stopping MySQL database server mysqld...done
* Shutting down Alsa...
* Asking remaining processes to terminate...
* Deconfiguring network interfaces...
* Deactivating Swap...
* Will now halt"
(Flashing cursor)

Sometimes the text is:

"Ubuntu 9.10 (my computer name) tty1
(my computer name) login:" (flashing cursor)

On one occasion I got:

"Ubuntu 9.10 (my computer name) tty1
(my computer name) login: init: usplash main process (10187) killed by TERM signal"

Sometimes I just get a black screen with a white flashing cursor.

In all cases it hangs there and does not completely shut down.
Restart works normally. I have WinXP installed on a separate partition and this shuts down normally.

Updating with all recommended updates including the latest kernel version did not solve the problem. I have now reinstalled Ubuntu 9.10 freshly, but the problem remains.

I'd be very grateful for help to triage this bug. Many thanks.

RobertH (rh-roberthale) on 2010-01-14
tags: added: down shut
tags: added: shutdown
removed: down shut
description: updated
RobertH (rh-roberthale) wrote :

https://bugs.launchpad.net/dell-mini/+bug/301520

Just came across the apparently similar bug above in which Luis Lumbrera Picazo proposed:

"SOLUTION THAT WORKS FOR ME:
Ctrl+Alt+F2 -> Login -> Password -> sudo /etc/init.d/gdm stop -> sudo halt --poweroff"

(I used "sudo service gdm stop").

Unfortunately this makes no difference to me: system still hangs on shutdown with text:

"* Stopping MySQL database server mysqld...done
* Shutting down Alsa...
* Asking remaining processes to terminate...
* Deconfiguring network interfaces...
* Deactivating Swap...
* Will now halt"

RobertH (rh-roberthale) wrote :

Maybe this is a bug in ACPI.

I found the following work round (from various sources) which works for me:

Edit file /etc/modules: add line "apm" (no quotation marks)
Edit file /etc/default/grub: at GRUB_CMDLINE_LINUX_DEFAULT add "apm=power-off" in quotation marks and directly after any other kernel line commands without leaving a space between them (if I left a space it didn't work!)
Then in terminal type: sudo update-grub

After rebooting shutdown works normally.

RobertH (rh-roberthale) wrote :

I spoke too soon. Bug isn't fixed. After I did the above (see last entry) it powered off correctly a total of four times successively, then reverted to hanging before power off. Odd. Back to square one.

Marcnexus (marcnexus) wrote :

Same laptop same problem shutting down on Karmic. Funny thing is it worked right on Ubuntu 9.04 if I recall properly.
To try fix the problem I read about updating the kernel to 2.6.32, unfortunately it didnt work. Actually the laptop woudnt even start with that kernel. I downgraded and still waiting for a fix.
Thanks to anyone that can shed some light on this issue.

adriangoodyer (adriangoodyer) wrote :

Thanks for your bug report and for your contribution to ubuntu. In order to determine if this issue is usplash related, please boot your computer with usplash disabled and then shutdown to see if you can reproduce the issue? To disable usplash for a single boot, follow these steps:

1. Press Esc during Grub boot delay to access the boot menu.
2. Select your actual Ubuntu boot line and press "e" to edit it.
3. Select the "kernel" line and press "e" to edit it.
4. At the end of the line, remove "splash" and "quiet" and press "enter".
5. Type "b" to boot the custom boot line.

Changed in ubuntu:
status: New → Incomplete
RobertH (rh-roberthale) wrote :

Thank you for your help. I have done as you suggested, but this did not change the behaviour - still would not power off.

P.S. Typing "b" did not cause to boot. I had to use Ctrl+x.

adriangoodyer (adriangoodyer) wrote :

Not to worry, I am a little curious that you had usplash displayed during shutdown as I though 9.10 and later was handled by xsplash but nevermind for now??

If you could please run the following command in the terminal which will attach necessary information:

apport-collect 507555

Bear in mind that you may need to install the python-launchpadlib package from the universe repository with 'sudo apt-get install python-launchpadlib'. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report.

This will use Apport to gather information about your system, I can then mark this bug as Confirmed and it will go to a developer to be solved.

RobertH (rh-roberthale) wrote :

I have now done this as instructed, but I don't know if it concluded successfully. The process concluded with the following lines:

"Ignoring task https://api.edge.launchpad.net/beta/ubuntu
No additional information collected."

Is this OK? Can you confirm that the process concluded successfully?
Thank you.

adriangoodyer (adriangoodyer) wrote :

No the process hasn't concluded successfully, for some reason it has chosen not to provide the information which is a little odd but I have seen this message before, we will have to collect the info ourselves which will require a little work on your behalf I'm afraid.

If you could open the terminal again and run the following commands, separately and by pressing enter after each one.

1) uname -a > uname-a.log
2) dmesg > dmesg.log
3) sudo lspci -vvnn > lspci-vvnn.log
4) cat /proc/version_signature > version.log
then attach the files separately to the bug report (not pasted into comments or tar/zip-ed).

The if you go to "Places" > "Home folder" at the top of your screen you should find the four .log files from above in there.

You need to go back to the bug report on launchpad and attach **not copy and paste** these files to the bug report. (it's located at the bottom of the screen below the add comment box).

adriangoodyer (adriangoodyer) wrote :

This is a little bit more tricky as it requires a search so i have posted it seperatley.

I then need you to click "Add attachment" again > then click "browse" and then click on "File system" which should be located on the left hand side.
Then open "var" then open "log" and search for the "messages" text file. There may be more than one (e.g. messages.0 and messages.1), if so post them all but ONLY POST THE TEXT FILES as there is likely to be .gz files in there too.

Now repeat the above process exactly but this time you need to post the "dmesg" files, again make sure you only post the text files.

RobertH (rh-roberthale) wrote :

I am attaching the four files requested.

RobertH (rh-roberthale) wrote :
RobertH (rh-roberthale) wrote :
RobertH (rh-roberthale) wrote :
RobertH (rh-roberthale) wrote :

messages text files

RobertH (rh-roberthale) wrote :
RobertH (rh-roberthale) wrote :

dmesg text files

RobertH (rh-roberthale) wrote :
Marcnexus (marcnexus) wrote :

Adegoodyer.
Thinking it could be of help I've decided to run 'apport-collect 507555'. It all seemed Ok but in the end it warned me that I was not the reporter of this bug. I am not sure if any of my info got to you but I am more than willing to give a hand.
As previously stated I have the same laptop and identical problem to RobertH.

adriangoodyer (adriangoodyer) wrote :

Robert,
Thats brilliant, well done! I can now mark the bug report as complete and confirm it to the developers who will hopefully be able to find a solution to this problem.

Changed in ubuntu:
status: Incomplete → Confirmed
adriangoodyer (adriangoodyer) wrote :

Marcnexus,

If you click "Places" > "Home folder" and then once there click "Help" > "Report a problem" then you will file your very own report and (hopefully) have Apport collect all the information for you!

Be sure to jot down the bug number of this report and then once you have filed your new report if you could have a look down the right hand side and click "mark as duplicate" and enter the bug number from this report than that would be even more brilliant. If you need any help then contact me and I will always do my best to help. Thanks.

Marcnexus (marcnexus) wrote :

Bug filed and marked as duplicate of this one.(#514469)
Thanks for the help

adriangoodyer (adriangoodyer) wrote :

@Marcnexus

Not a problem, I'm always happy to help out. Because we now have the bug confirmed with two different users and as a result two separate sets of logs it can only increase the chances of the developers finding a solution to this problem. I would hope to see some developer activity on this very soon!

RobertH (rh-roberthale) wrote :

As of yesterday, same problem has begun happening on my desktop, too. Running Ubuntu 9.10.
No updates performed yesterday or the day before.
This makes me unwilling to believe only two of us have experienced this problem!
Hope it's sorted on 10.04, or there'll be the temptation to migrate.

RobertH (rh-roberthale) wrote :

OK, I considered that it might be worth purging my last updates which were on 30 April. My reasoning was that while the following text...

"* Stopping MySQL database server mysqld...done
* Shutting down Alsa...
* Asking remaining processes to terminate...
* Deconfiguring network interfaces...
* Deactivating Swap...
* Will now halt"

...had only been appearing since yesterday, sometimes this text does not appear but the screen goes black without powering off the computer. So I may not have noticed it till yesterday. (Long shot).

Anyway, I got rid of the latest linux-headers, linux-headers generic, and linux-image generic packages (2.6.31.21.24) (I still had the previous ones installed), and the problem was solved - on my desktop.

But not on my laptop (the object of this bug), which has the problem ever since first installation of Ubuntu months ago. However, this further info may help somebody... ?

rictec (rictec) wrote :

hi
i have this Acer TravelMate 4001LMi laptop and the some problem
no power off with 10.04

thanks
rictec

RobertH (rh-roberthale) wrote :

I can confirm the problem has NOT been resolved in 10.04. No power off - just the red/white dots interminably. (Great work guys!) I'll be filing a separate bug report for 10.04.

rictec (rictec-netcabo) wrote :

i found something odd
if i press "esc" after shutdown and see the white letters as the pc shutdown it powers off...

so maybe its something with Xorg?

RobertH (rh-roberthale) wrote :

@rictec

You're right, mine does that too... but only sometimes.

I have filed a separate bug (number 579999) for this issue with 10.04. Perhaps you could go there and confirm it.

Marcnexus (marcnexus) wrote :

Well, I downgraded to ubuntu 9.04 and the problem is gone. In case it helps I have also installed Linux Mint LXDE "Isadora" and the shutting down problem is also there.

It would be nice if you could test Maverick to see if the issue is still here. If you do, please report back. Thanks!

affects: ubuntu → plymouth (Ubuntu)
Changed in plymouth (Ubuntu):
status: Confirmed → Incomplete
Steve Langasek (vorlon) wrote :

I don't know which package this is a bug in, but plymouth isn't even *in* Ubuntu 9.10, so it's not this one. Reassigning back to Ubuntu for re-triaging.

affects: plymouth (Ubuntu) → ubuntu

Yes, sorry. Re-assigning to xsplash. But could someone test in Lucid or Maverick?

affects: ubuntu → xsplash (Ubuntu)
Launchpad Janitor (janitor) wrote :

[Expired for xsplash (Ubuntu) because there has been no activity for 60 days.]

Changed in xsplash (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers