xsplash crashed with signal 5 in g_type_create_instance()

Bug #412648 reported by Krzysztof Klimonda on 2009-08-12
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xsplash
Low
Cody Russell
xsplash (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xsplash

I just ran it from terminal.

ProblemType: Crash
Architecture: i386
Date: Wed Aug 12 19:55:02 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/xsplash
NonfreeKernelModules: nvidia
Package: xsplash 0.3-0ubuntu1
ProcCmdline: xsplash
ProcCwd: /home/kklimonda
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-6.25-generic-pae
Signal: 5
SourcePackage: xsplash
StacktraceTop:
 ?? ()
 g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_object_newv () from /usr/lib/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
Title: xsplash crashed with signal 5 in g_type_create_instance()
Uname: Linux 2.6.31-6-generic-pae i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Krzysztof Klimonda (kklimonda) wrote :
visibility: private → public

StacktraceTop:xsplash_server_init (server=0x9ba1940) at xsplash.c:202
IA__g_type_create_instance (type=163192656)
g_object_constructor (type=163192656,
IA__g_object_newv (object_type=163192656, n_parameters=1,
IA__g_object_new_valist (object_type=163192656,

Changed in xsplash (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Krzysztof Klimonda (kklimonda) wrote :

confirmed on 0.4-0ubuntu1

Cody Russell (bratsche) wrote :

FYI, you can't just run it from the terminal because it needs to use the dbus system bus.

That said, it should also exit gracefully and tell you not to do this. ;) So I'll get this fixed in the next release.

Changed in xsplash:
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → Low
Cody Russell (bratsche) wrote :

Fixed in bzr revno 39. Will be in the next release.

Changed in xsplash:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xsplash - 0.6-0ubuntu1

---------------
xsplash (0.6-0ubuntu1) karmic; urgency=low

  [ Ken VanDine ]
  * New version (LP: #418974)
    - Don't set xsplash binary setuid gdm, use setuid in xsplash
    - Xsplash flickers and uses the gtk_color_scheme's window background
      color (LP: #416004)
    - Image size popping on login (LP: #411720)
    - xsplash crashed with signal 5 in g_type_create_instance() (LP: #412648)
    - Fixes for the non-compositing case
    - Added configure time argument to allow building with a user to run as
    - Added throbber and logo
    - Added command line arguments to set:
      * background image
      * logo image
      * throbber image
      * number of frames for the throbber
      * pingpong (reverse throbber)
  * debian/rules:
    - Added --with-user=gdm to configure

  [ Martin Pitt ]
  * debian/control: Fix Vcs-*.

 -- Ken VanDine <email address hidden> Wed, 26 Aug 2009 18:09:27 +0200

Changed in xsplash (Ubuntu):
status: New → Fix Released
Cody Russell (bratsche) on 2009-08-26
Changed in xsplash:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers