[ATI X1300] Could not generate /etc/X11/xorg.conf.failsafe

Bug #174434 reported by EowynCarter on 2007-12-06
96
Affects Status Importance Assigned to Milestone
xserver-xorg-video-vesa (Baltix)
Undecided
Unassigned
xserver-xorg-video-vesa-lts-trusty (Ubuntu)
High
Unassigned

Bug Description

I just tried to use Hardy with the live cd.

But, problem. X-won't start. The free ati drivers won't work with my ATI X1300 mobility. And, somehow, the fall back to vesa crashes.

UPDATE: information from log in duplicate bug report:
(II) VESA(0): Modeline "1280x800"x0.0 71.11 1280 1328 1360 1440 800 802 808 823 -hsync -vsync (49.4 kHz)
(EE) VESA(0): No valid modes
(EE) Screen(s) found, but none have a usable configuration.

Koen Beek (koen-beek) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux.

Koen Beek (koen-beek) wrote :

Could you attach the following files to this bug please

uname -a > uname-a.log
cat /proc/version_signature > version.log
dmesg > dmesg.log
sudo lspci -vvnn > lspci-vvnn.log

Tormod Volden (tormodvolden) wrote :

This will probably be fixed in Hardy, where the "radeonhd" driver will be chosen for your hardware. Anyway, vesa should not crash.

Changed in linux:
status: New → Incomplete
EowynCarter (churbain) wrote :

I first try with the network cable plugged. And saw that it get get stuck at "running local boot script"

Witout the network, i see this message : Could not retrieve EDID because get-edid is not installed"
and
this program does not know how to configure the "10 shared/default-x-server dosn't exist" X server

Could not generate /ect/X11/Xorg.conf.failsafe for vesa driver.

uname gives :
Linux ubuntu 2.6.22-14-generic

cat /proc/version_signature
Linux ubuntu 2.6.22-14.46-generic

For the two other, i don't really know how to get them here, with only the command line..

Tormod Volden (tormodvolden) wrote :

Can you please try the alpha-2 CD ?

Can you please attach the file /var/log/Xorg.0.log ?

EowynCarter (churbain) wrote :

it don't crash when the network cable is plugged any more.

however, display still won't work; same problem.

the Xorg.conf is :
Section "Device"
Indentifier "Generic Video Card"
Driver "vesa"
BusID "PCI:1:0:0"

I also have a xorg.conf.20071232131439, that is empty.
somehow i have no xorg log at all.

I tried to install the ati proprietary driver, and got a message from apt saying the package xserver-xorg-core was broken.

Tormod Volden (tormodvolden) wrote :

Reassigning to xorg, since I am not sure it is the vesa driver itself, but maybe the failsafe configuration.

description: updated
Changed in xserver-xorg-driver-vesa:
status: Incomplete → Confirmed
masj (alu3222) wrote :

I have the same problem with an Ati X1200 integrated in chipset AMD RS690M.
I have copied the xorg file generated by the ubuntu 7.10 livecd, and it works now.
I think the problem is not in vesa driver, beacuse of the output in xorg.log
I attached my log.

I get the same error message with the Hardy Desktop CD daily build (latest tested: 2008-01-02) on a Dell OptiPlex GX100 system with a Intel i810 graphics chip.

I've attached an image of the error message.

Regards,
Niels Kristian

Changed in xorg:
importance: Undecided → High
Andrea Colangelo (warp10) wrote :

This bug is still present in Hardy Alpha 3, desktop i386 live.

Timo Aaltonen (tjaalton) wrote :

Could you try to run '/etc/gdm/failsafeDexconf -o /tmp/xorg.conf' and post the error message you get.

There were some debconf keys that were removed and cleaned from the "real" dexconf but mistakenly left on failsafeDexconf.

Andrea Colangelo (warp10) wrote :

Running that command as you wrote it results in this error message:
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied

Running it with sudo doesn't produce any error message. The xorg.conf it creates under /tmp is attached here:

Timo Aaltonen (tjaalton) wrote :

Yep, that bug is fixed but not on hardy yet.

I'm not sure what to do with the real problem; why does it fall back to failsafe. When x-x-v-ati driver supports these chips it'll probably be "fixed" automatically, but vesa seems to have issues.

The alpha-3 desktop CD works for me on my Dell OptiPlex GX100.

Regards,
Niels Kristian

Timo Aaltonen (tjaalton) wrote :

Oh, so it works correctly out-of-the-box, and doesn't fall back to failsafe? Could you attach your xorg.conf to be sure?

Timo Aaltonen (tjaalton) wrote :

ah, sorry.. Niels, you are not using an ATI chip, so this bug is not for you anymore :)

Pär Lidén (par-liden) wrote :

I have an ATI X1250 card, using a hp 6715s notebook with an amd sempron 3600+ processor and 1gig ram. Using alpha2, I got exactly the same error message as the others here. I tried to copy over all the relevant log files via ssh to post them here. But before I had the time to do that, the screen just turned black, and the computer froze completely. This happened several times, every time within a few minutes. So, every time, before I had the time to scp the files over, the computer froze.

With alpha3, if I disable usplash this will happen:
It will come past "starting gdm", then switch between blank screen and the bootup-text screen a few times, and after that nothing happens. I'm still able to use the computer in terminal-mode, but it does not even put out an error message that configuring X failed.
With usplash enabled it get's quite far in the booting process, and then suddenly just turns blank, and freezes completely.

So alpha3 works worse for me. Maybe my problem with the freezing is due to something else than X, i don't know, but it seems quite likely as it freezes as the screen turns blank, and about the same time when X was supposed to start. It's quite hard to investigate any further when it is completely frozen. ;-)

Note: This notebook did not work with Gutsy either. I'm using the 32-bit version of ubuntu.

Tormod Volden (tormodvolden) wrote :

Pär, please file a new bug, your issues are completely different from the one in this bug report.

Pär Lidén (par-liden) wrote :

Well, they were exactly the same for alpha2, so I would not say they are completely different. However, I will file this as a new bug whenever I get the time. Thanks for your advice.

Bryce Harrington (bryce) on 2008-01-18
Changed in xserver-xorg-video-vesa:
assignee: nobody → bryceharrington
Andrea Colangelo (warp10) wrote :

Still present in Hardy Alpha 4 on my Dell Inspiron 6400 (Ati Radeon Mobility X1400).
I really hope that we can fix this issue ASAP: lots of users are hit from this issue.

Glen (synergy-oz) wrote :

My Asus A6J with an ATI X1600 Mobility won't start the xserver either.
Running Hardy Live CD Alpha 4.

(EE) Vesa (0) No valid mode
(EE) Screens found but none have usable configuration.

Bryce Harrington (bryce) on 2008-02-14
Changed in xserver-xorg-video-vesa:
assignee: bryceharrington → nobody
timbl (timbl) wrote :

this bug is still present in (Kubuntu) Hardy Alpha 5.

sudo dpkg-reconfigure xserver-xorg just skips the first part about the driver and also the part about the monitor
xorg.conf.failsafe also does not work

My video card is Ati Mobility Radeon X1400, which worked fine in gutsy (although wrong resolution (fixed by either fglrx or radeonhd driver)) but now X won't even start. I did manage to start X by copying xorg.conf from my gutsy install and installing fglrx

Andrea Colangelo (warp10) wrote :

Hardy Alpha 5: the bug is still present.
:-(

Tormod Volden (tormodvolden) wrote :

I guess the new 6.8.0 didn't make it for alpha-5, but came in just after it, so please try a newer daily CD.

Andrea Colangelo (warp10) wrote :

I just tried 20080225 daily-live CD, and the new -ati driver works great. Since support for Ati Mobility chips has been reenabled, this should definitely fix this issue.

Trond Thorbjørnsen (tthorb) wrote :

Also worked with a dist-upgrade and
$ sudo dpkg-reconfigure xserver-xorg
on my X1400

Very nice - finally both my compiz and my suspend works!

I can confirm this on my LG P1 Express with an ATI X1400.

Alpha 5 won't work:

"(EE) VESA(0): No valid modes
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found.
giving up."

Daily built CD works just fine. Quite an improvement for all the ATI-suffering users. Yes!!! Thank you very much! :)

Wolke Liu (wolke-liu) wrote :

I met the same problem with M82(RV620).
And I find it's the patch: 100-fedora-vesa-1.3.0-mode-heuristics.patch causes this bug.

I have test it the latest git code of VESA driver and other version driver without this patch, all will work.

Meanwhile, If I add HorizSync and VertRefresh to the xorg.conf, this bug also can be avoid.

Section "Monitor"
        Identifier "Configured Monitor"
        HorizSync 31-38
        VertRefresh 50-60
EndSection

Pär Lidén (par-liden) wrote :

With the Beta1 live-cd, X works fine for me. So this bug seems to be solved for me! :-)
Sadly, there are still multiple other bugs left affecting my hardware... :-(

Cheers to the developers!

Liu Xinyun (xinyunliu) wrote :

8.04 Beta still has this issue!

A patch from the FC9 fix this issue.

This issue occurs as a corner case that the monitor's timing is not a range. The mode will all be pruned.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-vesa - 1:1.3.0-4ubuntu4

---------------
xserver-xorg-video-vesa (1:1.3.0-4ubuntu4) hardy; urgency=low

  * 102-fedora-vesa-1.3.0-range-hack.patch: Work around broken ATI video
    BIOSes. (LP: #174434)

 -- Timo Aaltonen <email address hidden> Tue, 25 Mar 2008 12:30:13 +0200

Changed in xserver-xorg-video-vesa:
status: Confirmed → Fix Released
CxuLo (culokbl) on 2014-09-05
affects: xserver-xorg-video-vesa (Ubuntu) → xserver-xorg-video-vesa-lts-trusty (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers