Video on Intel D201GLY2 motherboard broken, can't compile Intel's fixed SiS662 drivers

Bug #297335 reported by Dan Weiss on 2008-11-12
74
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-sis
Invalid
Medium
xserver-xorg-video-sis (Baltix)
Undecided
Unassigned
xserver-xorg-video-sis (Fedora)
Won't Fix
High
xserver-xorg-video-sis (Ubuntu)
Low
Unassigned
Nominated for Intrepid by reinhard
Nominated for Jaunty by reinhard
Nominated for Karmic by reinhard
Declined for Lucid by Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-sis

Ubuntu's drivers for SiS video on the Intel D201GLY2 motherboard have known issues, namely that there is "Vertical Noise" on the screen. (It looks like it's displaying an incorrect pixel every time there's a write to video RAM). It happens on Ubuntu's stock drivers on both Hardy and Intrepid (haven't tried earlier versions).

Intel has their driver source code available which fixes the issues, except while it would compile under Hardy, it won't compile under Intrepid, apparently due to using a different xorg API.

I recently tried switching from Hardy to Intrepid. Before, I was able to use a binary driver which someone built for Hardy. But on Intrepid, the binary driver has the wrong ABI version, so it won't work.

I ended up reverting back to Hardy.

Is there any work going on at making this motherboard work? I briefly tried porting the code to the new API, but it was too complicated for me, considering that I know absolutely nothing about how to write xorg drivers.

This problem is still present in Karmic, even a little worse than ever.

Adding 662 path to the driver

Created attachment 8217
patch for 662 path

adding path for 662

Created attachment 8218
add 662 path

add 662 path

add 662 path

Created attachment 8219
add 662 path

add 662 path

can you please attach a diff relative to the current driver? trying to just pick
the changes out is difficult.

This "patch" (ie the code) is totally flawed and full of bugs. Don't even think
about using it.

Dear Thomas:
Nice to hear you from the bugzilla. The driver I attached is based on what you
mail to me on 2005/12/20 and it is quite like the one which included in
xorg6.9.0. Below I list what I remembered that I added in.
1. adding pcie interface enabling sequence.
2. TV timing.
3. fix 662 single CRT garbage.

I also list some already known bugs that I have no time to fix.
1. the channel A does not work properly.
2. The s-video TV has some wrong timeing in channel B

After 2005/12, I lost you and have no idea how to contact you. I have build
that driver within xorg7.1 and run it on both 662 single CRT and
662/761gx+307LV/cp in channl B with DVI or LVDS.

After comparing the driver on git repository with this one, I found you modify
the driver initialization sequence, change some 550 path and reorder the
chipId enum sequence,etc. I have mailed the driver to the mail box,
<email address hidden>, and want to get your consent before putting it on the
bugzilla. My job has transfered to XP-video/DirectDraw driver and some
customers want to get some ok driver to run 662 single CRT from Xorg, so I
brutally put the whole driver source rather than diff on bugzilla.

If you have any question please let me know.
appreciate your help and sincerely hope you fine,
cckuo

Sorry about the phenomenal bug spam, guys. Adding xorg-team@ to the QA contact so bugs don't get lost in future.

*** Bug 12813 has been marked as a duplicate of this bug. ***

Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi danweiss,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xserver-xorg-video-sis:
status: New → Incomplete
LaurensV (laurens-daemon) wrote :
Download full text (10.1 KiB)

I have the same issue, the sis driver doesn't work on this board (Intel D201GLY2).

lspci -vvnn:
laurens@ilvius:~$ lspci -vvnn
00:00.0 Host bridge [0600]: Silicon Integrated Systems [SiS] 662 Host [1039:0662] (rev 01)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
        Latency: 32
        Region 0: Memory at 88000000 (32-bit, non-prefetchable) [size=32M]
        Capabilities: <access denied>
        Kernel driver in use: agpgart-sis
        Kernel modules: sis-agp

00:01.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge) [1039:0003]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 00001000-00001fff
        Memory behind bridge: 8a000000-8a0fffff
        Prefetchable memory behind bridge: 80000000-87ffffff
        Secondary status: 66MHz+ FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
                PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
        Kernel modules: shpchp

00:02.0 ISA bridge [0601]: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] [1039:0964] (rev 36)
        Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0

00:02.5 IDE interface [0101]: Silicon Integrated Systems [SiS] 5513 [IDE] [1039:5513] (rev 01) (prog-if 80 [Master])
        Subsystem: Intel Corporation Device [8086:d61f]
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32
        Region 0: I/O ports at 01f0 [size=8]
        Region 1: I/O ports at 03f4 [size=1]
        Region 2: I/O ports at 0170 [size=8]
        Region 3: I/O ports at 0374 [size=1]
        Region 4: I/O ports at 2320 [size=16]
        Capabilities: <access denied>
        Kernel driver in use: pata_sis
        Kernel modules: pata_sis

00:02.7 Multimedia audio controller [0401]: Silicon Integrated Systems [SiS] AC'97 Sound Controller [1039:7012] (rev a0)
        Subsystem: Intel Corporation Device [8086:d61f]
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32 (13000ns min, 2750ns max)
        Interrupt: pin C routed to IRQ 18
        Region 0: I/O ports at 2100 [size=256]
        Region 1: I/O ports at 2280 [size=128]
 ...

Master One (masterone) wrote :

I can confirm the issue. I already opened a forum thread on 26th September 2008, when I first discovered the issue. Please have a look for detailed information:

http://ubuntuforums.org/showthread.php?t=930930

Dan Weiss (danweiss) wrote :

I have tested the Beta version of 9.04, and it still has the broken SiS driver.

Mike Godin (mikegodin) wrote :

This problem exists on the current 9.04 distro.

There is evidence of a work-around here:
http://ubuntu-virginia.ubuntuforums.org/showthread.php?t=958967&page=22

Bryce Harrington (bryce) on 2009-09-02
tags: added: intrepid
dn2010 (dn2010) wrote :

Same problem on the 9.10.

Master One (masterone) wrote :

This is ridiculous! It is a long standing and well known issue, and there is a fixed driver available. Unfortunately this is an upstream issue, so I doubt someone here at Ubuntu will care about. This is really sad, because it's not that nobody was unfortunate to buy something with such a crappy SiS chipset... :(

reinhard (maak2) on 2009-11-26
Changed in xserver-xorg-video-sis (Ubuntu):
status: Incomplete → Confirmed
reinhard (maak2) wrote :

I still have this problem as well, under 9.10 it is even heavier than under ther earlier Uby's.
With those verticalartefacts the system is just unworkable.

The only "workaround" still is to use "vesa" graphics, without *any* hardware enhancement.
(and that means incredibly slow graphics !)

What is going wrong that this problem is not even noticed ????
(let alone being looked at :-[ )

reinhard (maak2) on 2009-11-26
tags: added: karmic
removed: intrepid
description: updated
description: updated
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Dan,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 297335

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 297335 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/297335

Changed in xserver-xorg-video-sis (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
sieni (ksieni) wrote :

I can confirm this issue still exist on Lucid.
Vertical noise is still there.

papukaija (papukaija) wrote :

@subscribers: We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

@sieni: Then please do as suggested in comment 9.

@reinhard: Please don't remove those tag, just add them.

tags: added: intrepid
tags: added: jaunty
greenjeeper (steinhorst) wrote :

In lucid, the driver has a bug. Furthermore, there are vertical stripes. A compiling the driver with the patch for the X-Server7.4 is not possible. Hardy Heron was my last version that I could compile.

papukaija (papukaija) wrote :

Please do as suggested in comment 9 if you can reproduce this bug in lucid/maverick. There is no need to compile, just use the repos.

papukaija (papukaija) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in xserver-xorg-video-sis (Ubuntu):
status: Incomplete → Invalid
9Sageev George (sageev) wrote :

Hi. I am seeing the same problems in Lucid. I'll follow the instructions in Comment #9, but I am hoping that my comment here will remove the Invalid flag.

Timo Aaltonen (tjaalton) wrote :

Sorry, was under the impression that this board had 771/671, which isn't the case. Reopening.

Changed in xserver-xorg-video-sis (Ubuntu):
importance: Undecided → Low
status: Invalid → Confirmed
9Sageev George (sageev) wrote :

I was able to successfully get a different sis driver to that eliminated the problems mentioned in this bug report using the workaround mentioned in #5 above ( the location of the source for this sis driver is mentioned in http://ubuntuforums.org/showthread.php?t=958967&page=37, and is located at http://estebanordano.com/sis-m671m672-driver-for-xorg-xserver-7-5-on-debian-sidux/ ). The workaround involves commenting out the "check chipset" code ( http://ubuntuforums.org/showthread.php?t=958967&page=22 ). I still think the bug report should remain since the SiS driver included with Ubuntu 10.04 has this bug, but I wanted people trying to solve this problem to have a way of getting around it.

9Sageev George (sageev) on 2011-03-31
tags: added: lucid
removed: needs-retested-on-lucid-by-june
summary: - Video on Intel D201GLY2 motherboard still broken, can't compile Intel's
- fixed drivers
+ Video on Intel D201GLY2 motherboard broken, can't compile Intel's fixed
+ SiS662 drivers
tags: added: natty precise
Mantas Kriaučiūnas (mantas) wrote :

Bug #164258 and bug #556051 are also about broken Ubuntu SiS662 video drivers on computers with Intel D201GLY motherboard.
Maybe we should mark bug #164258 as a duplicate of this bug (297335) ?

Mantas Kriaučiūnas (mantas) wrote :

Several users confirm, that patched sis671 driver works with sis622 chipset, see http://ubuntuforums.org/showpost.php?p=7415090&postcount=213

papukaija (papukaija) wrote :

I removed the tags of unsupported Ubuntu releases. Do you know if the patch works in newer Ubuntu releases?

tags: added: i386 ubuntu
removed: intrepid jaunty karmic natty
Changed in xserver-xorg-video-sis (Fedora):
importance: Unknown → High
status: Unknown → Won't Fix

Mass closure: This bug has been untouched for more than six years, and is not
obviously still valid. Please reopen this bug or file a new report if you continue to experience issues with current releases.

Changed in xserver-xorg-video-sis:
importance: Unknown → Medium
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.