Comment 14 for bug 33617

Note: This report was sent in using reportbug by martin.ferrari at gmail.com

Hi, a week ago installed Dapper, and when it finished, I stared at a
blank screen. Later I found out that X was crashing the video adapter.
Not even soft reboot would recover it, only power cycling. I learned
this is a rare problem, solved with the following option in xorg.conf:

        Option "BusType" "PCI"

Now it works, but I still have Oopses in the savage kernel module, and
the occassional freeze (as it's a total freeze, I cannot know what
causes it, but I'd bet on the savage). Maybe those symptoms are related.

I found some info on this on:
https://bugs.freedesktop.org/show_bug.cgi?id=3835

My system is a IBM Thinkpad portable. T20 series, model 2647.

report-hw output is included.

-- System Information:
Debian Release: testing/unstable
  APT prefers dapper-updates
  APT policy: (500, 'dapper-updates'), (500, 'dapper-security'), (500,
'dapper-backports'), (500, 'dapper')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-21-386
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages xserver-xorg-driver-savage depends on:
ii libc6 2.3.6-0ubuntu17 GNU C Library: Shared libraries an
ii xserver-xorg-core 1:1.0.2-0ubuntu9 X.Org X server -- core server

xserver-xorg-driver-savage recommends no packages.

-- no debconf information