Xorg crashes when a player plays a video - sync xserver-xorg-video-openchrome (1:0.2.904+svn920-1) from Debian resolve this problem

Bug #760743 reported by Michael Moroni on 2011-04-14
112
This bug affects 19 people
Affects Status Importance Assigned to Milestone
openchrome
Fix Released
Unknown
xserver-xorg-video-openchrome (Ubuntu)
High
Bartosz Kosiorek
Nominated for Oneiric by Bartosz Kosiorek
Natty
High
Unassigned

Bug Description

Binary package hint: xorg

Hi, since I upgraded to natty last month totem and vlc restart gdm when I play a video (always when during a video I press a button and when I lead cursor on the menu and the first two-three times when I load a video from my HD).
Please see bug 752405!

airon90@haikara:~$ lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04
airon90@haikara:~$ apt-cache policy xorg
xorg:
  Instalita: 1:7.6+4ubuntu3
  Kandidata: 1:7.6+4ubuntu3
  Tabella versione:
 *** 1:7.6+4ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Thu Apr 14 16:29:18 2011
DistUpgraded: Log time: 2011-03-02 16:50:00.736596
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] [1106:3371] (rev 01) (prog-if 00 [VGA controller])
   Subsystem: Foxconn International, Inc. Device [105b:0c87]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: DIXONSXP Ei 105
ProcEnviron:
 LANGUAGE=eo:it:en
 LANG=eo.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=f37c264b-310d-4cad-a87d-421a7d367241 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: Upgraded to natty on 2011-03-02 (42 days ago)
dmi.bios.date: 12/30/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: P4M900-8237A
dmi.board.vendor: DIXONSXP
dmi.chassis.type: 3
dmi.chassis.vendor: OEM
dmi.chassis.version: OEM
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd12/30/2006:svnDIXONSXP:pnEi105:pvrOEM:rvnDIXONSXP:rnP4M900-8237A:rvr:cvnOEM:ct3:cvrOEM:
dmi.product.name: Ei 105
dmi.product.version: OEM
dmi.sys.vendor: DIXONSXP
version.compiz: compiz 1:0.9.4+bzr20110411-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Michael Moroni (airon90) wrote :
Sebastien Bacher (seb128) wrote :
bugbot (bugbot) on 2011-04-15
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
artjermyn (artjermyn) wrote :

All my logs look just like the ones above. It seems x is having a problem with via graphics cards (openchrome driver)?

Timo Aaltonen (tjaalton) on 2011-04-18
affects: xorg-server (Ubuntu) → xserver-xorg-video-openchrome (Ubuntu)
Changed in xserver-xorg-video-openchrome (Ubuntu):
status: New → Confirmed
artjermyn (artjermyn) wrote :

It looks like ubuntu is using the latest driver. It also looks like this driver is not updated frequently. I wonder if there's any hope of getting this fixed?

What about the xf86-video-unichrome driver?

Michael Moroni (airon90) wrote :

I update my computer more than one time daily.
And I cannot find anywhere the package "xf86-video-unichrome" (sorry, if I made something wrong in searching it...)

artjermyn (artjermyn) wrote :

http://unichrome.sourceforge.net/

it hasn't been updated in years though.

artjermyn (artjermyn) wrote :

http://openchrome.org/trac/ticket/404

This bug report looks like what I am experiencing. It's marked as critical, so hopefully we can get a fix.

artjermyn (artjermyn) wrote :

I downloaded the latest trunk from openchrome.org (svn co http://svn.openchrome.org/svn/trunk openchrome) and changed the arguments in function viaReputImage to match the arguments xserver 1.10 is passing.

Then i basically followed steps 1 & 2 at https://help.ubuntu.com/community/OpenChrome to compile and install the driver.

Then i restarted the computer and mplayer worked fine. I'm now able to move it around and work with the window with no crashes. However, I've only been using it a couple of hours, so YMMV.

I've attached the changed via_video.c file. If anyone wants to give it a try, you should just replace via_video.c with this one and then make and make install.

igorsh (ishipenkov) wrote :

I try this patch and everything works fine - just like before upgrade.

bruno (bruninho-ro) wrote :

The solution incomplete is SMplayer and select option in preference -> Output Driver: X11

Bartosz Kosiorek (gang65) wrote :

This bug was fixed in the Openchrome r920.
Try to build according to the instruction:
https://help.ubuntu.com/community/OpenChrome

and check if it works for you

Changed in xserver-xorg-video-openchrome (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
assignee: nobody → Bartosz (gang65)
artjermyn (artjermyn) wrote :

I downloaded and compiled r920 and everything is working fine.

Bernhard G (bernhard001-gmx) wrote :

I've had the same problem (XServer crash with segmentation fault on video playback), not only with MPlayer, but also with VLC, when I moved the VLC window, and with the Parole Media Player, as soon as I started playing a video.
Using r920 of http://svn.openchrome.org/svn/trunk fixed this issue for me, too.
Hopefully, this will be soon available in the xserver-xorg-video-openchrome package.

Thank you all!

Changed in openchrome:
status: Unknown → Fix Released
Bartosz Kosiorek (gang65) wrote :

The Openchrome r920 is bugfix release - it has fixes for X Server 1.10 which is available in Ubuntu 11.04.
Please sync it with Ubuntu 11.04 and Ubuntu 11.10

summary: - Xorg crashes when a player plays a video
+ Xorg crashes when a player plays a video - sync xserver-xorg-video-
+ openchrome (1:0.2.904+svn920-1) from Debian resolve this problem
Colin Watson (cjwatson) wrote :

This is already done in Oneiric:

xserver-xorg-video-openchrome | 1:0.2.904+svn920-1 | oneiric | source, amd64, i386

Natty will require a developer uploading a targeted backport of the necessary fixes, per https://wiki.ubuntu.com/StableReleaseUpdates.

Changed in xserver-xorg-video-openchrome (Ubuntu Natty):
status: New → Triaged
importance: Undecided → High
Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Triaged → Fix Released
Bartosz Kosiorek (gang65) wrote :

The patch which fix this bug is available here:
https://launchpadlibrarian.net/71134179/xserver-xorg-video-openchrome_1%3A0.2.904%2Bsvn918-1_1%3A0.2.904%2Bsvn920-1.diff.gz

Is it will be enough?
Could you please provide package with that patch to test?

summary: - Xorg crashes when a player plays a video - sync xserver-xorg-video-
- openchrome (1:0.2.904+svn920-1) from Debian resolve this problem
+ Xorg trava quando um jogador joga um vídeo - sync xserver-xorg-video-
+ openchrome (1:0.2.904 + svn920-1) do Debian resolver esse problema
summary: - Xorg trava quando um jogador joga um vídeo - sync xserver-xorg-video-
+ Xorg trava quando alguem roda um vídeo - sync xserver-xorg-video-
openchrome (1:0.2.904 + svn920-1) do Debian resolver esse problema
Michael Moroni (airon90) on 2011-05-17
summary: - Xorg trava quando alguem roda um vídeo - sync xserver-xorg-video-
- openchrome (1:0.2.904 + svn920-1) do Debian resolver esse problema
+ Xorg crashes when a player plays a video - sync xserver-xorg-video-
+ openchrome (1:0.2.904+svn920-1) from Debian resolve this problem
uhu (w2q) wrote :

I am running natty, and had the same problem.

I downloaded from this site
https://launchpad.net/ubuntu/+source/xserver-xorg-video-openchrome/1:0.2.904+svn920-1/+build/2484053
the deb-package
https://launchpad.net/ubuntu/+source/xserver-xorg-video-openchrome/1:0.2.904+svn920-1/+build/2484053/+files/xserver-xorg-video-openchrome_0.2.904%2Bsvn920-1_i386.deb

and everything seems to be ok. No crash up to now!
Only a pity that it is not updated automagically.

Thanks to all!

Woozle (k9copy) wrote :

I still get this crash on Ubuntu 11.04; problem solved by uninstalling xserver-xorg-video-openchrome.

Steps to reproduce (there are several ways, but this is the most reliable):
- install ElectricSheep
- run Screensaver preferences
- select ElectricSheep screensaver
- press "Power Management" button
- X crashes and returns you to login screen

Hi, I'm using natty and had Xorg restart when working with players like VLC, Dragon and SMPlayer. Furthermore, using video chat in Skype it Xorg restarts too.
It was partialy solved with the installation of the deb-package <https://launchpad.net/ubuntu/+source/xserver-xorg-video-openchrome/1:0.2.904+svn920-1/+build/2484053/+files/xserver-xorg-video-openchrome_0.2.904%2Bsvn920-1_i386.deb>, but the crashes continue with Skype video chats.

When I'm using generic vesa driver it doesn't happens.

Chris Hills (orictosh) wrote :

Hi, I'm using mythtv, vlc and was having the same problem with X crashing and dropping to login on prompt in Natty. I installed the dep package from the same location as Alessandro above

https://launchpad.net/ubuntu/+source/xserver-xorg-video-openchrome/1:0.2.904+svn920-1/+build/2484053/+files/xserver-xorg-video-openchrome_0.2.904%2Bsvn920-1_i386.deb

installed and rebooted which solved my problem in mythtv which was "when displaying the epg which contains an PIP (picture in Picture) " which would crash X and drop to login. It's a bit slow at the display, but that I would put down to the Unichrome pro 2d/3d 128 bits Graphics onboard graphics being a bit low on power.

During the research of this problem, many solutions detailed the solution to be change the driver name from vesa to openchrome in xorg.conf which is not possible when the natty upgrade has removed the file.

Try to generate a xorg.conf file with the command [ Xorg -configure ] in a CLI before start X server, then you can modify it.

Martin Pitt (pitti) wrote :

Unsubscribing ~ubuntu-archive, ther is no apparent archive admin request here.

lys (lys) wrote :

this is not limited to openchrome drivers, got same here in gentoo with ati-drivers

dino99 (9d9) wrote :
Changed in xserver-xorg-video-openchrome (Ubuntu Natty):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.