10de:11c0 [Asus Maximus IV GENE-Z] Strange line on left screen side

Bug #1203731 reported by Vincent Thiele on 2013-07-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Fix Released
Medium
xserver-xorg-video-nouveau (Ubuntu)
Low
Unassigned

Bug Description

This Line is displayed all the time while using nouveau.

WORKAROUND: Use the nvidia proprietary drivers.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
Uname: Linux 3.11.0-031100rc2-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Mon Jul 22 14:27:36 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.2.10, 3.11.0-031100rc2-generic, x86_64: installed
 virtualbox, 4.2.10, 3.8.0-25-generic, x86_64: installed
 virtualbox, 4.2.10, 3.8.0-26-generic, x86_64: installed
 virtualbox, 4.2.10, 3.8.13-03081304-generic, x86_64: installed
 virtualbox, 4.2.10, 3.9.11-030911-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 NVIDIA Corporation GK106 [GeForce GTX 660] [10de:11c0] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8422]
InstallationDate: Installed on 2013-07-01 (20 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: System manufacturer System Product Name
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-031100rc2-generic root=UUID=b03e8634-09c0-4fe7-8de4-2039a742e8ff ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-nouveau
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/09/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3603
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Maximus IV GENE-Z
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3603:bd11/09/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnMaximusIVGENE-Z:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.9~daily13.06.19~13.04-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.43-0ubuntu1.1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.3-0ubuntu0.3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.3-0ubuntu0.3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.6-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
xserver.bootTime: Mon Jul 22 14:03:22 2013
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu6
xserver.video_driver: nouveau
---
.tmp.unity.support.test.0:

ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
DistUpgraded: Fresh install
DistroCodename: trusty
DistroRelease: Ubuntu 14.04
DistroVariant: ubuntu
DkmsStatus:
 8192cu, 4.0.2.9000.20130911, 3.13.0-7-generic, x86_64: installed
 8192cu, 4.0.2.9000.20130911, 3.13.0-8-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 NVIDIA Corporation GK106 [GeForce GTX 660] [10de:11c0] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8422]
InstallationDate: Installed on 2014-02-08 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140207)
MachineType: System manufacturer System Product Name
Package: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-8-generic.efi.signed root=UUID=130fb282-fee3-4163-8402-e5b27fc942d5 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-8.27-generic 3.13.2
Tags: trusty ubuntu reproducible compiz-0.9
Uname: Linux 3.13.0-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 11/09/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3603
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Maximus IV GENE-Z
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3603:bd11/09/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnMaximusIVGENE-Z:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.909-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Sat Feb 8 13:05:24 2014
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.0-1ubuntu3

Vincent Thiele (vincentthiele) wrote :

Vincent Thiele, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-nouveau REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

apport information

tags: added: apport-collected reproducible trusty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Vincent Thiele, thank you for testing Trusty. As a WORKAROUND, does the nvidia proprietary drivers demonstrate this problem?

tags: added: latest-bios-3603
summary: - Strange line on left screen side
+ 10de:11c0 [Asus Maximus IV GENE-Z] Strange line on left screen side
Vincent Thiele (vincentthiele) wrote :

No only nouveau.

Vincent Thiele, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at http://nouveau.freedesktop.org/wiki/Bugs/ ?

Please provide a direct URL to your bug report once you have made it so that it may be tracked.

Thank you for your understanding.

description: updated
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Triaged
tags: added: saucy
tags: added: quantal

This Line is displayed all the time while using nouveau.
WORKAROUND: Use the nvidia proprietary drivers.

Tested on DistroRelease: Ubuntu 12.10, 13.04, 13.10, 14.04
Bugreport on Launchpad: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1203731

Created attachment 94354
dmesg output

Created attachment 94355
screenshot shows the bug

Vincent Thiele (vincentthiele) wrote :

Bug reported at bugs.freedesktop.org: https://bugs.freedesktop.org/show_bug.cgi?id=75203

*** Bug 75202 has been marked as a duplicate of this bug. ***

I'm sorry for posting this bug two times (I messed something up with my browser).

Hi Vincent

Looking at your launchpad bug it seems that you're using old version of xserver-xorg-video-nouveau(1.0.7), amongst others.

Can you update to:
* libdrm 2.4.52
* Mesa 10.0.3
* xserver-xorg-video-nouveau 1.0.10

Additionally does the pink line appear in VT or is it present only within X ?

I wonder if playing with xrandr settings will make the line go away.

Take a look at "xrandr --props". Things like "scaling mode" and the various "underscan" stuff.

Changed in nouveau:
importance: Unknown → Medium
status: Unknown → Confirmed

Line is visible in VT. No changes with xrandr.

(In reply to comment #7)
> Line is visible in VT. No changes with xrandr.

Ubuntu 14.04 versions:
mesa = 10.1.0~rc1-1ubuntu3
xserver-xorg-video-nouveau = 1:1.0.10-1ubuntu2
libdrm = 2.4.52-1

*** Bug 75800 has been marked as a duplicate of this bug. ***

Created attachment 95180
dmesg with nouveau debug info

This debug output was created by adding 'nouveau.debug="PDISP=trace,I2C=trace,VBIOS=trace"' to the kernel commandline.

Same problem here, with my K1000M. It actually doesn't happen after startup, just when I lock and unlock. I have been able to fix the problem by switching terminals, starting X, killing it and switching back to my normal session.

I can confirm i have this happening with my GeForce GTX 780 Ti (GK110B) connected over HDMI to my Asus PB278Q monitor running Arch linux (3.16.1-1-ARCH).

xf86-video-nouveau 1.0.10-3
nouveau-dri 10.2.6-1

I just posted a tentative fix on nouveau mailing list:
http://lists.freedesktop.org/archives/nouveau/2014-September/018654.html

Beware, it hasn't been reviewed yet, values may be specific to my card/setup.

Also, I only enabled my change on nve0 cards, so GTX 780 is likely to see no change.

(In reply to comment #14)
> http://cgit.freedesktop.org/nouveau/linux-2.6/commit/?h=linux-3.
> 18&id=a522946174b5ae389af0856c422d865a63c70316
>
> Please test & confirm.

I built & ran, but I hit a panic - which may not be related to nouveau: I booted with blob and got a panic ending with "recursion stopped but you need to reboot" or so message.
With nouveau it booted just a past nouveau initialisation before panic'ing again (I had the time to see at least 3 panic/oops messages scroll by, like 500ms from each other), so I could at least see the HDMI initialising properly on HDMI-1 in console. I didn't test other outputs, HDMI audio, and different resolution.
I'll be away for 3 weeks starting tomorrow, so sadly I won't have much time to test further until then.

BTW, isn't "ret" returned uninitialised in the "else" branch of "if(nvif_unpack(args->v0, 0, 0, false))" ? Or is there some macro magic ?

Hello,

this issue is closest to the one I'm experiencing. There is a pink line at the left of the screen. But it appears as soon as X starts and additionally the rest of the screen seems to be shrinked by just those few pixels. This means alternating regions of sharp and blurry image (just horizontally).

Just up front, my graphics card is an AMD Radeon R280. And I see this only with latest kernel version. So maybe the guys who work on the radeon driver just introduced a similar issue.

There are no error/warn/fail messages in dmesg and playing with xrandr won't change anything. Even restarting X doesn't change a thing.

found the solution to my issue. seems to be a bug with HDMI audio enabled by default.
see https://bugzilla.kernel.org/show_bug.cgi?id=93701
sry for the distraction

This bug should have been fixed in ~3.18 or so. Re 'ret' being special, it is, see nvif_unpack macro definition. Feel free to reopen if you're still seeing pink lines on Kepler GPUs.

Changed in nouveau:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.