xrandr Xerrors with the nvidia binary drivers (optimus)

Bug #1224254 reported by odror on 2013-09-12
174
This bug affects 23 people
Affects Status Importance Assigned to Milestone
gnome-desktop
Fix Released
High
gnome-desktop3 (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone
Saucy
High
Alberto Milone
nvidia-graphics-drivers-319 (Ubuntu)
High
Unassigned
Saucy
Undecided
Unassigned
xserver-xorg-video-modesetting (Ubuntu)
Medium
Maarten Lankhorst
Precise
Medium
Unassigned
Saucy
Medium
Unassigned

Bug Description

SRU request:

Please accept gnome-desktop3 (3.4.2-0ubuntu0.2) in precise-proposed and gnome-desktop3 (3.8.4-0ubuntu1.1) in saucy-proposed.

[Impact]
In Precise and Saucy, we support hybrid graphics, and this issue prevents users from enabling external screens (the ones connected to the Intel card), and to benefit from all the features that the gnome-settings-daemon provides (font settings, input settings, theming, etc.).

[Test Case]
After installing the update, users should be able to open the Displays configuration tool, and the gnome-settings-daemon will be running (as shown by the "ps aux | grep gnome-settings-daemon" command).

[Regression Potential]
None. We simply trap and ignore an error when setting the primary output, as the rest of the program already does when getting the primary output.

---
Original report:

New install of 13.10 on HP envy 17t j000

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: gnome-settings-daemon 3.8.5-0ubuntu2
ProcVersionSignature: Ubuntu 3.11.0-7.13-generic 3.11.0
Uname: Linux 3.11.0-7-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
CrashCounter: 1
Date: Wed Sep 11 20:48:40 2013
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationDate: Installed on 2013-09-08 (3 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130908)
MarkForUpload: True
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/false
Signal: 5
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XReply () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XSync () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 gdk_flush () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
Title: [xrandr]: gnome-settings-daemon crashed with signal 5 in _XReply()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

odror (ozdror) wrote :

StacktraceTop:
 XSync (dpy=0x2560760, discard=0) at ../../src/Sync.c:44
 gdk_flush () at /build/buildd/gtk+3.0-3.8.4/./gdk/gdkdisplay.c:478
 gnome_rr_config_apply_with_time (config=config@entry=0x25c2e70, screen=<optimized out>, timestamp=timestamp@entry=0, error=error@entry=0x7fff02dca878) at gnome-rr-config.c:1312
 apply_configuration (manager=manager@entry=0x25c2df0, config=config@entry=0x25c2e70, timestamp=timestamp@entry=0, show_error=show_error@entry=1, save_configuration=save_configuration@entry=0) at gsd-xrandr-manager.c:501
 apply_default_boot_configuration (timestamp=0, mgr=0x25c2df0) at gsd-xrandr-manager.c:1901

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Iain Lane (laney) on 2013-10-18
information type: Private → Public
Sergio Benjamim (sergio-br2) wrote :

Is this hardware has Nvidia Optimus technology? Nvidia-prime was installed?

If "yes", I think that Bug #1227747 is an duplicate of this.

op 18-10-13 14:02, Sergio Benjamim schreef:
> Is this hardware has Nvidia Optimus technology? Nvidia-prime was
> installed?
>
> If "yes", I think that Bug #1227747 is an duplicate of this.
>
In my case it is both a yes.

gkey (gmkey) wrote :

op 18-10-13 14:02, Sergio Benjamim schreef:
> Is this hardware has Nvidia Optimus technology? Nvidia-prime was
> installed?
>
> If "yes", I think that Bug #1227747 is an duplicate of this.
>
Yes it is nvidia geforce GT 620M 1GB (with NVIDIA OPTIMUS) in a acer
v5-571g.
I'm thinking it has something to do with the combination of nvidia-prime
and psensor or indicator multiload. Since I disabled both (actually this
morning) it seems my system is a bit more stable, allthoug I still have
a lot of pauses....

My laptop has an optimus graphics card.

I don't have nvidia-prime installed. I condifured it manually since nvidia-prime doesn't configure it for gdm only for lightdm.

and the problem persists, so it's not specifically to do with nvidia-prime.

With nvidia-prime, nvidia-319 drivers, and a GT650M I faced the same problem. The desktop theme was broken, and the keyboard was in English layout, while I configured it for French.

summary: - [xrandr]: gnome-settings-daemon crashed with signal 5 in _XReply()
+ xrandr Xerrors with the nvidia binary drivers

I can reproduce this when using the nvidia driver and offloading rendering to it using RandR on an NVIDIA Optimus system. This is what nvidia-prime does and what NVIDIA suggests on their website.

I've assigned the bug report to both the nvidia driver and the modesettings driver since they are both used. The modesettings driver is the one which ultimately deals with RandR (and therefore the gnome-settings-daemon).

Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: New → Triaged
Changed in xserver-xorg-video-modesetting (Ubuntu):
status: New → Triaged
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-graphics-drivers-319 (Ubuntu):
importance: Undecided → Medium
Changed in xserver-xorg-video-modesetting (Ubuntu):
importance: Undecided → Medium
Alberto Milone (albertomilone) wrote :

Apparently, if I use the "intel" driver instead of the "modesettings" driver, I can't reproduce the problem. This is not a bug in the nvidia driver, it's definitely an issue in the modesetting driver.

Alberto Milone (albertomilone) wrote :

I take back what I said, I had a false positive. I probably know what's going on but I need to investigate this a little further.

Changed in gnome-settings-daemon (Ubuntu):
status: Invalid → Triaged
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in xserver-xorg-video-modesetting (Ubuntu):
importance: Medium → High
Changed in nvidia-graphics-drivers-319 (Ubuntu):
importance: Medium → High
Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Invalid
summary: - xrandr Xerrors with the nvidia binary drivers
+ xrandr Xerrors with the nvidia binary drivers (optimus)
Changed in gnome-settings-daemon (Ubuntu):
status: Invalid → Triaged
Alberto Milone (albertomilone) wrote :

Apparently the modesetting driver doesn't play well when trying to set the primary output (which does not seem to be supported by the driver).

In any case, we should really make sure to trap the XError and to ignore it when setting the primary output, instead of only ignoring the error when we look for the primary output. This solves the problem in libgnome-desktop.

Changed in gnome-desktop-3 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Invalid
Changed in gnome-desktop-3 (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: Triaged → Invalid
Changed in gnome-desktop-3 (Ubuntu):
importance: Undecided → High
Changed in gnome-settings-daemon (Ubuntu):
assignee: Alberto Milone (albertomilone) → nobody
affects: gnome-desktop-3 (Ubuntu) → gnome-desktop3 (Ubuntu)
Changed in gnome-desktop3 (Ubuntu):
assignee: Alberto Milone (albertomilone) → nobody
assignee: nobody → Alberto Milone (albertomilone)
Changed in gnome-desktop3 (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
no longer affects: gnome-settings-daemon (Ubuntu Precise)
no longer affects: nvidia-graphics-drivers-319 (Ubuntu Precise)
Changed in xserver-xorg-video-modesetting (Ubuntu Precise):
status: New → Triaged
Changed in xserver-xorg-video-modesetting (Ubuntu):
importance: High → Medium
Changed in xserver-xorg-video-modesetting (Ubuntu Precise):
importance: Undecided → Medium
Alberto Milone (albertomilone) wrote :
Sebastien Bacher (seb128) wrote :

The debdiff looks fine to me, thanks Alberto! Could you upstream the bug/patch and include the bug reference in the header? Then feel free to upload

tags: added: patch
Changed in gnome-desktop3 (Ubuntu):
milestone: none → saucy-updates
milestone: saucy-updates → none
no longer affects: gnome-settings-daemon (Ubuntu)
no longer affects: gnome-settings-daemon (Ubuntu Saucy)
Changed in gnome-desktop3 (Ubuntu Saucy):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in xserver-xorg-video-modesetting (Ubuntu Saucy):
status: New → Triaged
importance: Undecided → Medium
Maarten Lankhorst (mlankhorst) wrote :

I've released upstream modesetting 0.8.1 which contains the fix for the duplicate VGA-0 output. I've uploaded a package to debian, which should be synced to ubuntu today or tomorrow.

Changed in xserver-xorg-video-modesetting (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Maarten Lankhorst (mlankhorst)
Alberto Milone (albertomilone) wrote :

SRU request:

Please accept gnome-desktop3 (3.4.2-0ubuntu0.2) in precise-proposed and gnome-desktop3 (3.8.4-0ubuntu1.1) in saucy-proposed.

[Impact]
In Precise and Saucy, we support hybrid graphics, and this issue prevents users from enabling external screens (the ones connected to the Intel card), and to benefit from all the features that the gnome-settings-daemon provides (font settings, input settings, theming, etc.).

[Test Case]
After installing the update, users should be able to open the Displays configuration tool, and the gnome-settings-daemon will be running (as shown by the "ps aux | grep gnome-settings-daemon" command).

[Regression Potential]
None. We simply trap and ignore an error when setting the primary output, as the rest of the program already does when getting the primary output.

Changed in gnome-desktop:
importance: Unknown → High
status: Unknown → New
Maarten Lankhorst (mlankhorst) wrote :

Duplicate output names that crash gsd fixed with xserver-xorg-video-modesetting 0.8.1-1.

Changed in xserver-xorg-video-modesetting (Ubuntu):
status: Fix Committed → Fix Released
description: updated
description: updated
Changed in gnome-desktop3 (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-desktop3 (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in gnome-desktop3 (Ubuntu Saucy):
status: In Progress → Fix Committed

Hello odror, or anyone else affected,

Accepted gnome-desktop3 into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-desktop3/3.8.4-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello odror, or anyone else affected,

Accepted gnome-desktop3 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-desktop3/3.4.2-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Paul le Roux (xonar-leroux) wrote :

Hello Brian

Using the proposed package fixes the XReply bug.

I now experience other bugs from other display related packages. I set up my display incorrectly at first so they just might be reports of that. I'll reboot and see if they remain.

Otherwise the theme is correct, the keyboard layout holds and key combinations work again. Thanks.

Paul le Roux (xonar-leroux) wrote :

An update:

No other crashes after rebooting.

Booting with a secondary display attached causes it to fail miserably though. Attaching the display after the xsession is up and running works as it should. I'll play around with the xorg,conf and see if I can sort it out. I don't think it has anything to do with this package. (Probably just a mistake in xorg.conf from my part)

Thanks again.

Alberto Milone (albertomilone) wrote :

the package doesn't affect the boot process. That would be an issue in the xserver (i.e. a separate problem).

tags: added: verification-done
removed: verification-needed
Fredericko XG (fredericko-xg) wrote :

I've installed the nvidia-319, nvidia-settings-319, nvidia-primus on a ubuntu 13.10 (unity) and had the "[xrandr]: gnome-settings-daemon crashed with signal 5 in _XReply() " when i logged in, so I ran "sudo apt-get build-dep nvidia-319" and reboot the pc, and the error was gone.

PS:
- i've only experienced error on login, so i don't now if it fixed all the problems or just the login one.
- some themes were broken like chromium and stills broken (i don't know if it's a gtk2 or gtk3 theme).

Installed nvidia-319, nvidia-settings-319, nvidia-prime on a ubuntu 13.10 64-bit (unity) (Sony Vaio SBS15127PXB), and it worked perfectly!

glxspheres runnind about 620fps!!! :D

GREAT WORK! Thanks a lot!

Changed in gnome-desktop:
status: New → Fix Released
Sayantan Das (sayantan13) wrote :

Problem persists with nvidia-331 with kernel 3.12

Alberto Milone (albertomilone) wrote :

@Sayantan: what version of Ubuntu are you running and what version of libgnome-desktop did you install?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.4.2-0ubuntu0.2

---------------
gnome-desktop3 (3.4.2-0ubuntu0.2) precise-proposed; urgency=low

  * debian/patches/ignore_errors_with_primary_outputs.patch:
    - Ignore failures when setting the primary output (LP: #1224254).
 -- Alberto Milone <email address hidden> Tue, 03 Dec 2013 16:30:22 +0100

Changed in gnome-desktop3 (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-desktop3 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-319 (Ubuntu Saucy):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.8.4-0ubuntu1.1

---------------
gnome-desktop3 (3.8.4-0ubuntu1.1) saucy-proposed; urgency=low

  * debian/patches/ignore_errors_with_primary_outputs.patch:
    - Ignore failures when setting the primary output (LP: #1224254).
 -- Alberto Milone <email address hidden> Tue, 03 Dec 2013 17:25:35 +0100

Changed in gnome-desktop3 (Ubuntu Saucy):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in xserver-xorg-video-modesetting (Ubuntu Saucy):
status: Triaged → Won't Fix
Rolf Leggewie (r0lf) on 2014-12-05
Changed in nvidia-graphics-drivers-319 (Ubuntu Saucy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.