Panel utilities not shown on startup using Matrox gfx with compiz

Bug #572550 reported by Kalle Tuulos on 2010-04-30
146
This bug affects 24 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned
xserver-xorg-video-mga (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: gnome-panel

Ubuntu 10.04 installation was fresh from CD and the computer was first time booted right after installation was finished. When I logged to Gnome, panels on both bottom and top did not continue through the monitor, instead they stopped on 3/4, rest of screen being just background picture (see the attached video for clarification). Utilities on panel, e.g. date and time, were not shown.

When I clicked the mouse right key on middle of desktop and chose "Change Desktop Background", and from this menu chose "Theme", and from there selected just any other theme than currently was shown, panels got populated with applications. See the video.

1) Release of Ubuntu: 10.04 LTS (Installation date: 30-Apr-2010)
2) Version of package "gnome-panel": 1:2.30.0-0ubuntu1
3) Panels were expected to be both on top and bottom of the screen, through the whole screen, and populated with utilities
4) Panels ended on both, top and bottom, on about 3/4 of the screen, and there were no utilities

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-panel 1:2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Fri Apr 30 21:38:27 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-panel

Kalle Tuulos (kalle-tuulos) wrote :
Kalle Tuulos (kalle-tuulos) wrote :

You are not alone...

I've just experienced this bug on a new installation of Lucid final release on an old PIII machine with a matrox video card running a 5:4 ratio flat panel (not native 1024x768). The panels would show correctly after any change to their properties, but be incomplete again at the next login.

My workaround was to change the screen resolution to 1024x768, after which the panels show correctly on login without any tweaking.

I did see an odd 'flicker' effect on opening the screen, when the right hand edge (where the panel display is missing) was refreshed after the rest of the screen.

Chris Coulson (chrisccoulson) wrote :

This could be related to bug 439448

Chris Sharman (sharman-chris) wrote :

Looks like 574247 too - although my workaround was to right click on panel position.

I don't much fancy downgrading my lcd screen - any other suggestions?

Thanks
Chris

Kalle Tuulos (kalle-tuulos) wrote :

Additional information: this error occurs with Matrox G550 video card. The bug #57424 has rather similar symptoms, there are Matrox G400/G450 video cards.

I'd agree that this is likely a duplicate of bug https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/574247

It was certainly a hardware problem for me, swapping the Matrox out for an ATI cured it. Though I'd like to use the old Matrox as it drives my old good quality CRT monitors very well.

Kalle Tuulos (kalle-tuulos) wrote :

It is not completely a hardware problem, as the 10.04 live CD works fine i.e. the panel is correctly visible. So the magic question: what are the differences between live CD and the brand new installation? Is the live CD using only some generic hardware driver instead of Matrox-specific?

Yes; the hardware didn't suffer from the problem before 10.04 or with the live CD. So it is the driver *installed* in 10.04 that causes the problem. However, it is linked to using a Matrox card.

I've not seen bug https://bugs.launchpad.net/bugs/439448 with the Matrox card, but have seen it on other machines with Intel graphics, so I'm not sure that is a related bug, although it seems to affect the same end (right hand side) of the top panel so maybe there is a link.

Chris Sharman (sharman-chris) wrote :

The live cd exhibits a similar problem for me (broken bars top & bottom). It's not curable via panel / properties / background either - I had to use change desktop / themes to recover the bar.
Screenshot attached.

Yup, same here. LiveCD or fresh install, no difference.

Another thing, I remember when wanting to do the install directly from
the livecd boot menu it complained it couldn't start the installation
and would start an interactive full session instead. Installation from
there went fine. This could be something completely different, but
thought I'd mention it anyway. If I need to collect some logging from
that problem I can try to reproduce it upon request.
Perhaps Neil and Chris have time to try and see if they have the same
problem when starting a direct install from the livecd boot menu? That
would rule out it being a coincidence, I guess.

I presume you mean the point at which it offers "try ubuntu" (boot live cd) or "install ubuntu" ?
I chose install, and had no problems - I didn't actually boot off the cd until 30 minutes ago, to test it.
I didn't feel the need to check it out, as I was keeping my 9.10 partition & overwriting an older one.

Casper Aleva (tonus) on 2010-05-15
summary: - Panel utilities not shown on startup
+ Panel utilities not shown on startup using Matrox gfx
Changed in gnome-panel (Ubuntu):
status: New → Confirmed

I have just installed 10.04 (in parallel with 9.10) and find I have the same problem here (and also with the Live CD).

A few bits of information incase it is helpful:
Matrox G550 graphics card
Ubuntu 2.6.32-22-generic
x86_64

I'm going back to 9.10 for now.

Casper Aleva (tonus) wrote :

For the record, a poster on ubuntuforums mentions:
> I've tried other Gnome 2.3 based distributions and occurs the same issue. With Gnome 2.28 it doesn't occurs. Then ii seems a gnome 2.3 problem.
Source: http://ubuntuforums.org/showthread.php?p=9285332#post9285332

Josef Wolf (jw-raven) wrote :

I was directed to here from bug #581046. I'd like to mention that with my g400/450

  gconftool-2 --recursive-unset /apps/panel ; pkill gnome-panel

gives me a working panel.

Over there at #581046 I attached a .xsession.errors and a diff of the home directory from non-working to working panel (that is before executing the above command and after executing it).

Should I move the attachments to this bug?

Sebastien Bacher (seb128) wrote :

the issue is not likely a gnome-panel one

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
Leo Ponton (ponton-leo) wrote :

I've been holding off making a me-too! claim, but this might be useful:

lspci reports: 01:05.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400/G450 (rev 82)

I replaced this card with an ATI dual head to see if it would work any better than the Matrox (which doesn't dual properly). It kind of worked, but the res was wrong and the brightness was burned out so I created a xorg.conf

No progress, so I swapped the cards back and now the Matrox works as well as it did in 9.10 - no panel problems.

The xorg.conf is no longer active (I changed the name), so something must be cached somewhere.

Michael (walkingreen) wrote :

similar issues for me

lspci:
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400/G450 (rev 04

10.04 relatively fresh install.

had no problems with livecd (apart from same issue as Casper Aleva)...or while i was setting up after install...

problem occurred when i switched monitor from flat panel widescreen to an old crt.

Only tmp solution i found was to go into Preferences > Monitors; switch to 800 x 600, corrects issue, then back to 1024x768...

Any ideas? The monitor is not recognised, and I have no xorg.conf to try and edit (being lucid)...

Davide Saurino (dsaurino) wrote :

same issue for me, the only stable solution that I've found to get working panels through different login was to remove compiz.

So, I run
sudo aptitude remove compiz compiz-core

After that, panel works fine.

Furthermore, if you want to really use compiz on this hardware you can reinstall it and from now on everything it's ok.

PS: I've not run a dpkg-reconfigure on compiz packages, possibly it should be enough.

Chris Sharman (sharman-chris) wrote :

Complete removal of the compiz packages via synaptic package manager SOLVED it for me too - thanks Davide.
I tried reinstallation first, and that didn't fix it.

Don't know what Compiz did - if it's just 3d-effects too subtle to notice, I'm happy now.

John Moriarty (johnmoriarty) wrote :

Me too.
dpkg-reconfigure didn't solve the problem, but removing and reinstalling has. Thanks Davide.

Joshua Duncan (ready2go) wrote :

I used Synaptic Package Manager to "completely remove" compiz and compiz-core, logged out, logged back in, then reinstalled compiz and compiz-core (again with Synaptic) and it seems to be fine now. It didn't work unless I logged out between removing and reinstalling. Thanks, all!

Joshua Duncan (ready2go) wrote :

As some additional information, there appears to be a per-user component to this. The steps I followed above only fixed my user account; my guest account was still broken. I had to remove it again, log in as my guest user, log back in as myself, then reinstall to fix both. It's acting like some user configuration file has to get built while compiz is not installed in order for the panels to function properly, though I don't know if that's actually the case.

Michael (walkingreen) wrote :

Cool. Worked for me too!

Many thanks...out of interest, is there any real need to reinstall Compiz? (At least in this scenario - the machine I have put together is an Internet Kiosk).

Josef Wolf (jw-raven) wrote :

Sebastien, what makes you think that the bug is not related to gnome-panel?

Given the fact that

  gconftool-2 --recursive-unset /apps/panel ; pkill gnome-panel

fixes it, makes me believe that the bug is triggered by some panel settings and therefore by the behavior of the panel.

Sebastien Bacher (seb128) wrote :

the bug wouldn't be specific to a video driver if it was in gnome-panel's code, gnome-panel might do something which trigger the video driver bug but it doesn't mean it should stop doing that just because a video driver is buggy there

Gerry O'Rourke (gorourke) wrote :

Davide's solution worked for me also.

I've not bothered to re-install Compiz.

lspci reports a Matrox Graphics, Inc. MGA G550

Had the problem since upgrading to 10.04 LTS.

Rod Roark (rod) wrote :
Rod Roark (rod) wrote :

Accepting that my bug duplicates this one, then it's not specific to the video driver (mine is an Nvidia GEForce MX 4000).

Removing compiz as Davide suggests fixed it for me also. I'd suspect a race condition involving compiz and gnome-panel, and perhaps all these other variables are just things that affect the timing.

Toni Ruottu (toni-ruottu) wrote :

Removing Compiz did not fix this on my system.

Sebastien Bacher (seb128) wrote :

the issue there is an matrox one if you have issue on nvidia open a new bug

affects: gnome-panel (Ubuntu) → xserver-xorg-video-mga (Ubuntu)
summary: - Panel utilities not shown on startup using Matrox gfx
+ Panel utilities not shown on startup using Matrox gfx with compiz
Changed in compiz (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Chris could you have a look to this issue? Do you think it's a matrox issue which can be sorted easily or should we turn compiz off on matrox cards?

Changed in compiz (Ubuntu Lucid):
importance: Undecided → Low
Changed in xserver-xorg-video-mga (Ubuntu Lucid):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

could people having the issue run "lspci | grep -v matrox" and copy the line there?

Sebastien Bacher (seb128) wrote :

rather "grep -i" than "grep -v"

Sebastien Bacher (seb128) wrote :

Robert, could you look at making compiz not run on matrox cards? It used to be the case before lucid but the wrapper dropping seems to have change that now

Changed in compiz (Ubuntu Lucid):
assignee: nobody → Robert Ancell (robert-ancell)
Rod Roark (rod) wrote :

As I noted above there is already a bug report for my (nvidia) case. It got tagged as a duplicate of this one. If the solution will simply be to turn off compiz for matrox cards, then would someone please remove this tagging?

Sebastien Bacher (seb128) wrote :

the issue seems a compiz one, Savatt get it on intel as well by running the compiz-decorator after selecting no effect in the gnome-appearance-capplet, it seems that stopping compiz should stop the decorator as well there

Travis Watkins (amaranth) wrote :

Compiz has never stopped the decorator on exit before so something in the system must have changed to trigger this. The decorator is supposed to do absolutely nothing without compiz running to give it commands. Can someone (who could run compiz in karmic) downgrade to karmic compiz packages and see if this happens?

Chris Sharman (sharman-chris) wrote :

lspci | grep -i matrox
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400/G450 (rev 05)

Joshua Duncan (ready2go) wrote :

lspci | grep -i matrox
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400/G450 (rev 82)

Kalle Tuulos (kalle-tuulos) wrote :

lspci | grep -i matrox
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G550 AGP (rev 01)

mishabhi (mishabhi) wrote :

same problem .. blank screen after log on .. right click gets the entire desktop immediately.

but neither a new installation, nor a Matrox card in my case.
Mine is ATI FireGL5200 and I was using this install of lucid for more than a week

I did do some tweaking with the "appearance" I installed a theme from gnome.org (Alphacube Metacity)

I also changed the wallpaper and firefox theme (hopefully those wouldn't cause this problem)

Olli (ollli) wrote :

I confirm this bug. I have the exact same problem. This is my configuration:
Fresh Ubuntu 10.04 install.
Graphics card Matrox G550.
No compiz effects in use.
No matter what screen resolution or what theme, the gnome-panels are always only partly visible after boot or logout/login.

I also confirm the solution that worked in my case:
By completely removing all compiz package by Synaptic, the panels were ok after boot or logout/login.

lspci | grep -i matrox
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G550 AGP (rev 01)

mishabhi (mishabhi) wrote :

it was definitely to do with the theme in my case. I managed to change the theme somehow and the problem is solved. (please refer my earlier comment #42)

Michl (michl-polarkosmos) wrote :

I ran into the same issue as I also use a MatroxCard here's my grep:

$ lspci | grep -i matrox
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G550 AGP (rev 01)

Michl (michl-polarkosmos) wrote :

Changing the theme just helped me out for a moment as the bug reappeared after a reboot/restart.

Additionally I tried to apply an automated restore of the genome panel defaults with an script, based on BitHacker's tool (se: http://bithacker.blogspot.com/2010/05/restore-default-gnome-panels-in-ubuntu.html).
Here's my mod which disabled all questions and restores both the top and the bottom panel:

----
#!/bin/sh
# Originally from: PanelRestore
#
# GNOME Panel Save / Restore
# Writen by PhrankDaChicken
#
# http://ubuntu.online02.com
#
#
# Updated to add restore defaults by jimjimovich
# http://www.starryhope.com
#
#
# Modified to be Autostart capable by:
# Michl Schmid
# Allgaeuer Kraftwerke GmbH
# Am Alten Bahnhof 10
#
# D-87521 Sonthofen
#
# mailto:<email address hidden>
# http://www.allgaeukraft.de
#

gconftool-2 --recursive-unset /apps/panel
rm -rf ~/.gconf/apps/panel
pkill gnome-panel

----

The problem herein is that the tool only works properly as long as it's started "after" the GNOME Desktop has been completely started. Right now I haven't found the right position in the GNOME autostart chain to launch the modified script automatically, yet.

Hope someone finds a solution in the near future... :-)

Tony Crawford (tc-crawfords) wrote :

$ lspci | grep -i matrox
02:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400/450 (rev 85)

Fresh installation yesterday from the Alternate Install CD.

After restoring my panel on each login by opening Properties and switching Expand off and on again, I googled and took the advice above: remove compiz, log out, log in, install compiz. Now I seem to be set.

Thanks folks.

Filippo Cattaneo (n1jpr) wrote :

----------------------------------------------------------
PLEASE ADVISE

Should I file a separate bug report or should I add my details?
Same problem on 2 PC's, I have the same dynamics but
- no Matrox, I have an Nvidia binary on one and a generic FLOSS driver on the other.
- no panels at all, not partially showing panels.
- my very 1st account is not affected, while all subsequent ones are.

Since I have both working and borked accounts on the same machines I could provide comparisons.

Also, perhaps I can point to a filesystem metadata issue.
----------------------------------------------------------

I can reproduce the disappearance in 2 different ways:

1) Just LOGGING INTO the account.

Code:
adduser username
[etc.]

Login -> panels are there.
Logout. Login again. -> panels gone.

On 1st login, the user's home gets filled with the standard Gnome conffiles. Those Gnome files may be originally generated with a wrong configuration.

2) Don't even use the account, but back up and restore the user's home directory.

Code:
adduser user username
...
cp -avx /home/username /backup-path/username
rm -rf /home/username
cp -avx /backup-path/username /home/username

In this case, /home/username should be a straight copy of the original freshly generated /home/username WITHOUT any Gnome-added conffiles.

So a login SHOULD result in a full, fresh Gnome with the panels as on a 1st login.

Yet, even on the 1st login, panels gone.

IS IT FILESYSTEM METADATA?
This is germane to an account losing the panels after a crash / power failure, as that too may impede disk flushing and syncing.
A metadata change also happens during a successful login with panels.

However, my so far little-used but older personal account is fine. It has survived several login-logout cycles and even one instance of power failure without proper logout.

Michl (michl-polarkosmos) wrote :

@Tony Crawford:
> I googled and took the advice above: remove compiz, log out, log in, install compiz. Now I seem to be set.
...

Sorry, but this doesn't work for me...I have same malfunction of the panels as before, due to the compiz reinstall.

- Michl

Kalle Tuulos (kalle-tuulos) wrote :

I just upgraded my distribution to Maverick and the error still exists.

David Barth (dbarth) on 2011-01-12
tags: added: 0.8
Changed in compiz (Ubuntu Lucid):
assignee: Robert Ancell (robert-ancell) → nobody
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in compiz (Ubuntu Lucid):
status: New → Won't Fix
Changed in xserver-xorg-video-mga (Ubuntu Lucid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers