[i855] Lucid Freeze shortly after X startup (needs KMS blacklist?)

Bug #511001 reported by Bill Farrow on 2010-01-22
208
This bug affects 37 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Confirmed
Critical
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Testing with Lucid Lynx Alpha 2 Netbook Remix on USB stick. The laptop is an Asus M5200N with Intel i855GM graphics chip.

I have the same graphics freezing bug when running 9.10 Karmic. There is already an open bug for Karmic https://bugs.launchpad.net/bugs/447892 but since this bug has not been fixed in the Lucid yet, I am raising a separate bug report.

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
---
Architecture: i386
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK Computer Inc. M5N
Package: xserver-xorg-video-intel 2:2.10.0+git20100220.c2c670ef-0ubuntu0sarvatt
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
ProcCmdLine: auto BOOT_IMAGE=Linux ro root=/dev/sda1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu6
 libgl1-mesa-glx 7.8.0~git20100219.496724b8-0ubuntu0sarvatt
 libdrm2 2.4.18+git20100217.2d9990c7-0ubuntu0sarvatt
 xserver-xorg-video-intel 2:2.10.0+git20100220.c2c670ef-0ubuntu0sarvatt
Tags: lucid
Uname: Linux 2.6.32-14-generic i686
UnreportableReason: This is not a genuine Ubuntu package
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/08/2004
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0212
dmi.board.name: M5N
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0212:bd12/08/2004:svnASUSTeKComputerInc.:pnM5N:pvr1.0:rvnASUSTeKComputerInc.:rnM5N:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: M5N
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.32-14-generic

Geir Ove Myhr (gomyhr) wrote :

Thank you for filing a 855GM freeze bug report with Lucid. I have missed that. We have several for Karmic(bug 378147, bug 423663, bug 447892, bug 477256, bug 477972, bug 484412, and bug 496187), but have missed Lucid testing. I would like to gather some logs and additional information from you and then we can send it upstream. Hopefully, a bug report with more recent software will receive more attention upstream.

It would be nice if you could install Lucid on a partition, since that will allow you to test different kernels. The other tests should be doable with a USB stick.

Test 1: Install the packages from the xorg-edgers PPA [1]. There are instructions for how to do it with a USB-stick. Get a batchbuffer dump according to the instructions on [2] (use the DebugFlushCaches option described there). In order to do all this you will probably need boot the USB in safe mode, then choose netroot (have ethernet network, not wireless), install openssh-server so that you can ssh in, make the xorg.conf with DebugFlushCaches option, install xorg-egers using the script, and then finally start gdm with `start gdm`. Then make org freeze and you can get the batchbuffer dump. While you are logged in you can also do a `apport-collect 511001` in order to upload log files to this bug report.

If installing xorg-edgers above stops the freezing, we will try and identify the fix and get it into Lucid.

Test 2 (requires install): In addition to xorg-edgers, try the two mainline kernels [3,4] 2.6.33-rc4 and the newest one in the drm-intel-next folder. Report if this freezes or not. It is possible that another batchbuffer dump is useful for these cases.

Test 3 (requires install): Test the kernels with 599 and 600 from [5] and if they boot with Lucid, check if 600 freezes and 599 does not.

[1]: https://launchpad.net/~xorg-edgers/+archive/ppa
[2]: https://wiki.ubuntu.com/X/Troubleshooting/Freeze
[3]: https://wiki.ubuntu.com/KernelTeam/MainlineBuilds
[4]: http://kernel.ubuntu.com/~kernel-ppa/mainline/
[5]: http://www.kvante.info/855GMfreeze/

tags: added: 855gm freeze lucid
Geir Ove Myhr (gomyhr) on 2010-01-23
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Geir Ove Myhr (gomyhr) wrote :

I see that you have already filed an upstream bug report at https://bugs.freedesktop.org/show_bug.cgi?id=25325 . That is great! Could you also attach the information I asked for in comment #1 there when you get it?

Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Bryce Harrington (bryce) on 2010-01-25
summary: - [i855GM] Lucid Freeze shortly after X startup on Intel i855
+ [i855] [i855GM] Lucid Freeze shortly after X startup on Intel i855
Bryce Harrington (bryce) on 2010-02-16
summary: - [i855] [i855GM] Lucid Freeze shortly after X startup on Intel i855
+ [i855] Lucid Freeze shortly after X startup

Sorry, I have been overseas for a few weeks. I will set up a new HDD
install and get some better logs for this issue.

On Tue, Feb 16, 2010 at 4:20 PM, Bryce Harrington
<email address hidden> wrote:
> ** Summary changed:
>
> - [i855]  [i855GM] Lucid Freeze shortly after X startup on Intel i855
> + [i855] Lucid Freeze shortly after X startup
>
> --
> [i855] Lucid Freeze shortly after X startup
> https://bugs.launchpad.net/bugs/511001
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Thank you. Forget about the batchbuffer dump for now, since they contain no information on kernel 2.6.32. There is an experimental kernel patch upstream that will record information again (which applies fine to 2.6.33-rc8 at least) [1]. If you're comfortable with patching and building a kernel, you may try that. (Description of the build process at [2], manpage of git-am for how to patch from a mailbox)

[1]: http://lists.freedesktop.org/archives/intel-gfx/2010-February/005883.html
[2]: https://wiki.ubuntu.com/KernelTeam/GitKernelBuild

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Installed xorg-edgers PPA [1] and did: aptitude update, aptitude upgrade, reboot
After logging in and starting to pull down menus, I no longer get a freeze, but Xorg crashes and I am left with a black screen with a mouse pointer that I can move about, but I am now able to switch VT (Ctrl-Alt-F2) and log in to a console. At this point, restarting gdm switches it back to X but it is just a black screen with a movable mouse cursor.

Is there a quick way to generate an xorg.conf file with the current settings being used by Xorg ? or do I have to create one from scratch ? (BTW "sudo dpkg-reconfigure xserver-xorg -phigh" doesn't work)

[1]: https://launchpad.net/~xorg-edgers/+archive/ppa

Installed mainline kernels [1] 2.6.33-020633rc4 and 2.6.33-999. In both cases I got a freeze after logging in and pulling down menus. The mouse pointer still moves, and I can switch VT using Ctrl-Alt-F2 to get a console.

[1]: https://wiki.ubuntu.com/KernelTeam/MainlineBuilds

Installed drm-intel-next kernel [1] 2.6.33-997.201002111148 but similar sort of freeze immediately when logging in.

I will install the packages required to build the kernel source and try the patch [2] to capture more info. I am quite comfortable patching the kernel and I have written several device drivers - but I haven't delved into the dark depths of the video subsystem yet ! You got to learn somehow...

[1]: http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2010-02-11/
[2]: http://lists.freedesktop.org/archives/intel-gfx/2010-February/005883.html

On Tue, Feb 23, 2010 at 4:53 AM, Bill Farrow wrote:
> I will install the packages required to build the kernel source and try
> the patch [2] to capture more info.  I am quite comfortable patching the
> kernel and I have written several device drivers - but I haven't delved
> into the dark depths of the video subsystem yet !  You got to learn
> somehow...

I just finished building packages for amd64, but I see that you are
using i386. It's available at
http://www.kvante.info/recordbatchbuffer/ . I had some problems [1],
so you may be able to build it "better" than me if you have some
experience. There is an updated version of the patch (version 8) at
[2] .

[1]: https://lists.ubuntu.com/archives/kernel-team/2010-February/009003.html
and follow-up
[2]: http://bugs.freedesktop.org/show_bug.cgi?id=26333#c8

I have patched kernel 2.6.33-999 with the batch buffer dump v8 patch [1] and compiled everything. This has been installed, rebooted, and the new kernel version confirmed. I have captured the batch buffer dump after the crash/freeze and attached it here.

uname -a
  Linux ubuntu 2.6.33-rc8-gpudumpv8 #2 SMP Tue Feb 23 08:35:04 EST 2010 i686 GNU/Linux

cat /sys/kernel/debug/dri/0/i915_error_state > /tmp/i915_error_state-dump.txt

[1]: http://bugs.freedesktop.org/show_bug.cgi?id=26333#c8

Geir Ove Myhr (gomyhr) wrote :

Great! I'd like to send it upstream to the intel developers now and see if they can get some useful information out of the batchbuffer dump. I just wonder, which kernel exactly do you mean by 2.6.33-999? Is it from the drm-intel git tree, from Linus' git tree, from [1], or somewhere else? The patch (but v7) was applied to the drm-intel tree (head intel-drm-next) two days ago [2], but if you grabbed it before then it wouldn't have been there.

[1]: http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/
[2]: http://git.kernel.org/?p=linux/kernel/git/anholt/drm-intel.git

The kernel source that I used was not from the drm-intel tree, it was the mainline [1]. The exact source package that I downloaded was:
  linux-source-2.6.33_2.6.33-999.201002211003_all.deb

I then applied the batch buffer dump v8 patch [2].

It would probably make it easier for the Intel developers if I used the drm-intel branch. i will grab their source from the git repo that you mentioned (thanks).

[1]; http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2010-02-23/
[2]: http://bugs.freedesktop.org/show_bug.cgi?id=26333#c8

Just in case anyone is following in my footsteps...

git clone git://git.kernel.org/pub/scm/linux/kernel/git/anholt/drm-intel.git
cd drm-intel/
cp /boot/config-2.6.32-14-generic .config
fakeroot make-kpkg --initrd --append-to-version=-`git describe` kernel_image

For my build git describe returned "v2.6.29-rc1-51333-g9df3079". This source tree already has the batch buffer dump v8 patch applied, which I checked using "git log".

Then install the new kernel. I'm using lilo bootloader because the lucid alpha2 alternate install CD refused to install grub.

sudo dpkg -i ../linux-image-2.6.33-rc8-v2.6.29-rc1-51333-g9df3079_2.6.33-rc8-v2.6.29-rc1-51333-g9df3079-10.00.Custom_i386.deb
sudo update-initramfs -c -k 2.6.33-rc8-v2.6.29-rc1-51333-g9df3079
sudo ln -sf /boot/initrd.img-2.6.33-rc8-v2.6.29-rc1-51333-g9df3079 /initrd.img
sudo ln -sf /boot/vmlinuz-2.6.33-rc8-v2.6.29-rc1-51333-g9df3079 /vmlinuz
sudo lilo
sudo reboot

Linux ubuntu 2.6.33-rc8-v2.6.29-rc1-51333-g9df3079 #1 SMP Wed Feb 24 11:29:05 EST 2010 i686 GNU/Linux
cat /sys/kernel/debug/dri/0/i915_error_state > /tmp/i915_error_state-dump2.txt

You can send the attached dump to the Intel folks.

Geir Ove Myhr (gomyhr) wrote :

Bill, as you probably have seen I have submitted a bug report with the batchbuffer dumps at https://bugs.freedesktop.org/show_bug.cgi?id=26746 and added you in the CC field. I think the logs I uploaded are somewhat inconsistent since they come from different runs and slightly different versions. Maybe you could grab a batchbuffer dump, dmesg, and Xorg.0.log from the _same_ run and attach upstream?

Geir Ove Myhr (gomyhr) on 2010-02-25
Changed in xserver-xorg-video-intel:
status: Confirmed → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed

> Is there a quick way to generate an xorg.conf file with the current
> settings being used by Xorg ? or do I have to create one from scratch ?
> (BTW "sudo dpkg-reconfigure xserver-xorg -phigh" doesn't work)

Sorry, I missed this this before. I think the standard way is `sudo X
-configure`, but it only seems to work if X isn't already running. I
usually just copy it from the beginning of /var/log/Xorg.0.log where
it is printed.

Bryce Harrington (bryce) on 2010-02-27
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete

Bill, there is a possible work around patch upstream. Do you have the chance to test it?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High

Geir, the upstream msleep() patch works. The performance is woeful, but at least it helps narrow down where the problem is.

On Sun, Feb 28, 2010 at 7:37 PM, Bill Farrow wrote:
> Geir, the upstream msleep() patch works.  The performance is woeful, but
> at least it helps narrow down where the problem is.

Thanks. It looks like you can handle this well upstream yourself. Let
me know if there is anything more I can help with.

Bryce Harrington (bryce) on 2010-03-02
summary: - [i855] Lucid Freeze shortly after X startup
+ [i855] [i855] Lucid Freeze shortly after X startup
Bryce Harrington (bryce) on 2010-03-02
summary: - [i855] [i855] Lucid Freeze shortly after X startup
+ [i855] Lucid Freeze shortly after X startup
Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid

The upstream bug was marked as a duplicate, so we need to follow the main upstream bug instead.

Changed in xserver-xorg-video-intel:
status: Invalid → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Chris Halse Rogers (raof) wrote :

Since this has been marked upstream as the same bug as bug #541492, which we're considering working around by blacklisting KMS on that chipset it would be useful if people who are encountering this problem could try booting with KMS disabled (by adding “i915.modeset=0” after “quiet splash” in the kernel boot line).

If there seems to be a consensus favoring blacklisting KMS, then we'll reassign this bug to the kernel and have andy blacklist for us.

If anyone finds that their i855 system works *worse* with KMS turned off for some reason, please shout; I wouldn't expect turning KMS to cause regressions so this would be a surprise, but with i8xx weirder things have been known to happen!

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
summary: - [i855] Lucid Freeze shortly after X startup
+ [i855] Lucid Freeze shortly after X startup (needs KMS blacklist?)
Bryce Harrington (bryce) wrote :

I wish we had more testing evidence to base this decision on, but I've posted a kernel bug report requesting KMS disablement on three of the older 8xx cards: lp #563277

We've already sent up a fair plentitude of bug reports to upstream, so I'm hopeful that they'll come up with fixes to this and to KMS, so we can re-enable in meerkat, or maybe even in 10.04.1, but we'll have to see how things go.

This is an unfortunate situation. There is a non-trivial number of users with 845 and 855 chips who are impacted by a regressions in stability in the current x stack when running 3d and KMS.

We have opted for a "stability first" approach for these users. We will disable 3D and KMS for these chips in Lucid final release. This will have the unfortunate effect of disabling compiz. This will introduce a functional regression. So we will be sacrificing functionality for these users in favor of stability. This is a painful choice to make, but we feel that stability must trump functionality when we are forced to make such choices.

We will be pursuing functional fixes. However, we will do this outside the main release, for example in a PPA. If we are able to provide a fix that delivers stability and functionality, we will consider this a potential SRU in 10.04.1.

Just to let you know that bug #565870 presents a case where disabling KMS actually causes X to crash on boot.

Kai F. Lahmann (kfl) wrote :

the PPA gave back something similar to the 9.10-freeze bug.

Interesting like at the end of Xorg.0.log:
"(EE) intel(0): Failed to submit batch buffer, expect rendering corruption or eben a frozen display: Input/output error."

...it decided to freeze.

Kai F. Lahmann (kfl) wrote :

Strange things:
- downgraded to 2.9 driver -> it still behaved as the 2.11 driver (=freeze after a while, can switch to console).
- back to vesa -> got an error about a KMS driver being loaded (!).
- fix for this was to purge the intel driver and reinstall it. This also restored the instant crash from times before. Looks, like I can dance between this and bug #565870 and we can forget the last comment (as that was no change but only the alltime state _with_ KMS).

Looking a bit deeper the 2.11-driver *required* KMS and enables this using a file in /etc/modprobe.d, which is kept after downgrade. That file needs to be killed to get at least vesa back.

Stefan Glasenhardt (glasen) wrote :

Hi,

I've backported the patch from http://bugs.freedesktop.org/show_bug.cgi?id=27187 to the latest Lucid kernel. I'm using the fixed kernel modules since a week and all stability issues disappeared on my system. There are only two problems with the patch :

1. The "wandering dots" in the Plymouth boot-screen have false colors.

2. Some Gtk+-functions are slower than normal. But the situation is not as bad as it sounds. I can perfectly do my normal work (Browsing, emailing, etc.) and also play SDL- and OpenGL-based games without noticing any slowdowns. Only when running the "gtkperf"-Benchmark you can notice a slowdown (Mostly in the "Circles"-Benchmark).

tags: added: patch
Bryce Harrington (bryce) wrote :

Awesome, thanks Stefan! Just for completeness can you indicate which xorg-server-video-intel and libdrm versions you were running? Just stock Ubuntu versions, or did you install from upstream?

Andrew Burns (burn-that-piano) wrote :

The graphics problem still exists on lucid final.
After a couple of minutes of the boot screen progression, I receive no graphical output and am unable to switch to a terminal. The system then requires a hard reset.

Passing options "i915.modeset=0" or "apci=off" makes no difference.

AM (macchi) wrote :

Yes, I confirm that this problem is still present on the final release of Lucid.

 A clean (atlernate) install of the Ubuntu 10.04 LTS fails completely to boot on machines with Intel 855 etc graphics family. This is a catastrophe for me since we have several of those systems in the surroundings and I cannot fall back to previous Ubuntu versions that lack support for certain hardware. I wish there was a stronger push for stability and slightly weaker emphasis on cosmetic improvements to boot screen and 3D graphics.

Gard Spreemann (gspreemann) wrote :

I was also affected by this bug with:
  00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

After upgrading from Karmic, the system would deadlock when starting X. Forcing KMS back on seems to fix the problem for me, although I won't have time for stability tests for a few days (but at least X comes up and everything seems fine). Passing i915.modeset=0 did NOT work, but following Workaround A from [1] did, i.e. I forced KMS by adding
  options i915 modeset=1
to a file in /etc/modprobe.d and running update-initramfs -u.

[1] https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes

I have encountered the same problem on my IBM Thinkpad X40 after upgrading Karmic to Lucid Lynx.
My display adapter :
description: VGA compatible controller
product: 82852/855GM Integrated Graphics Device

I can confirm that enabling KMS fixed the freezing and now I am able to boot in a normal manner.

My setup is a bit different though, the i915.modeset=1 gets passed to the kernel by GRUB while booting. This can be acheived by adding 915.modeset=1 to the grub boot options after pressing 'e' in the GRUB menu.
To make these settings persistent edit /etc/defaults/grub and run grub-update.

nomnex (nomnex) wrote :

here is the original bug report https://bugs.launchpad.net/xserver-xorg-video-intel/+bug/370292
Downgrading to the 2.4 driver is not perfect but it is stable

Gard Spreemann (gspreemann) wrote :

Update to comment #42: I've used the computer in question a bit now, and discovered that video playback (VLC with Xv output) garbles the screen and then completely deadlocks the machine. Other than that, the KMS workaround seems just fine here.

HAY! 2.6.32-20 works very fine on my i-ru notebook. But after upgrading to 2.6.32-21, I can't run X at all. It was OK in karmic, it was OK on lycid prior to 2.6.32-21.

mmarkk@i2-ru:~$ lspci | fgrep VGA
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

How I can help to investigate the problem ?

Gard Spreemann (gspreemann) wrote :

Update to comment #42: After leaving the computer overnight, I found it in "graphics safe mode" (or whatever it's called) the following morning. The last part of dmesg read:
[29429.364045] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[29429.364065] render error detected, EIR: 0x00000000
[29429.365431] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 13532528 at 13532527)

Thus, forcing KMS back on only results in a partially usable system for me.

Alkis Georgopoulos (alkisg) wrote :

I can't boot with any of the recent kernels. I have this card on my laptop:
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)

I'm using the linux-image-generic kernels:
2.6.32-20.30 => Last one that boots
2.6.32-21.32 => It hangs when X starts
2.6.32-22.33 => It hangs when X starts

I've tried nomodeset, i915.modeset=0 etc with no difference.

Also, while 2.6.32-20.30 boots fine, it crashes when I try anything Xv-related (gstreamer-properties, totem, vlc...)

I was having the same problem, but after switching to a newer kernel found in:
https://launchpad.net/~brian-rogers/+archive/experimental

Which was proposed here:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/476817

I am not having any problems anymore. It boots normal, no kernel options need to be passed. It just works. And has been confirmed by at least one other person. Maybe it is an idea for people here to check it out?

Alkis Georgopoulos (alkisg) wrote :

Thank you for the tip Willem, with that kernel I'm also able to boot with KMS on and Xv and everything.
I only noticed a small glitch, in Xv sometimes (e.g. in totem, but not with fullscreen nor in vlc) there's a black overlay over the video. And if I click on a totem menu, and then I close the totem menu, the black overlay is left where the menu was.

Anyway, it's very workable with that kernel, thanks again.

benbenian (benbenian) wrote :

Thanks Willem, the experimental kernel works for me too.

Juan Vicente (amdschumy) wrote :

Worked for me too.
After 5 or 6 restarts, I have everything working.

Regards and thanks!

kaefert (kaefert) wrote :

I upgraded yesterday from 9.10 to 10.04 and now compiz doesn't work anymore. I never had any problems with Graphics with the past Ubuntu versions.

My Graphiccard is an:
~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

My Kernel:
~$ uname -a
Linux Computername 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux

I think that my problem is what Rick Spencer said in comment #33 --> that they disabled 3D and KMS for these chips.
Can somebody tell me how to enable it again? I had no stability issues yet.

kaefert (kaefert) wrote :

Okey, so I found what I was looking for, a way to revert the disabling of all the 3d stuff (here: https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes)

These are the commands that do the trick:
echo options i915 modeset=1 | sudo tee /etc/modprobe.d/i915-kms.conf
sudo update-initramfs -u

The stability issues don't seem to apply for my graphics chip:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

Stenten (stenten) wrote :

Blacklisting KMS causes Lucid to boot to a black screen on my i855 as well, in both the LiveCD and an installation. Re-enabling them per:
https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes
fixes all issues.

Is this the appropriate place to post bugs about needing to *enable* KMS? It seems like "me too"ing this bug would have the opposite effect of fixing it.

The PPA kernel from Brian is working on my ASUS M5200N laptop with
855GM graphics. No freezes after 12 hours. I can do full screen
xv video, firefox etc without any freezes or glitches.

sudo add-apt-repository ppa:brian-rogers/experimental
sudo apt-get update
sudo apt-get install linux-image-2.6.34rc3-51-generic

kenden (kenden) wrote :

These bugs are all bugs with Ubuntu LUCID/10.04 not booting with an Intel 855
511001 [i855] Lucid Freeze shortly after X startup (needs KMS blacklist?) (this bug)
528467 [i855] GPU hung (drm i915 intel) on Lucid Lynx Alpha 3 live CD
566379 [i855] X doesn't start with kernel 2.6.32-21 unless passing i915.modeset=1
570299 [linux-image-2.6.32-21-generic] i855 won't display
there seem to be duplicates...

Stenten (stenten) wrote :

They are not the same. This is a bug for KMS where *disabling* KMS fixes graphics for i855 users. However, that fix has caused *another* bug, where i855 users need to *enable* KMS to fix graphics issues. That is what all the comments are about.

Ixtao (ixtao) wrote :

Upgrading the kernel as suggested in #56 seems to work for me as well, but only with KMS enabled - which confused me a bit as it is disabled by default. I suspect this comes from a lacking of understanding the technical details of the issue ;)

gene (eugenios) wrote :

Hi, ran into a similar problem: My desktop display froze and both keyboard and mouse did not work. I haven't checked if my webserver was running/available, since I prematurely powered off the pc.
My issue seems to be a little different from those reported though. The freeze has never occurred before since my upgrade to Lucid more than a week ago. The kernel
uname -a: Linux 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 x86_64 GNU/Linux
has been run for about a couple days before it happened.
I will continue using this very kernel (I do not want to try the ppa fix yet, since this intel machine used to be very effective before). After a next freeze I will try to grab some earlier/later versions of the kernel from ppa/kernel
Here are some specs:
sudo lshw: lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
03:03.0 Modem: Intel Corporation FA82537EP 56K V.92 Data/Fax Modem PCI (rev 04)
03:08.0 Ethernet controller: Intel Corporation N10/ICH 7 Family LAN Controller (rev 01)

And

 description: Mini Tower Computer
    product: Dell DM051
    vendor: Dell Inc.
    serial: B4KPL81
    width: 64 bits
    capabilities: smbios-2.3 dmi-2.3 vsyscall64 vsyscall32
..........................
description: VGA compatible controller
             product: 82945G/GZ Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: msi pm bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:16 memory:eff00000-eff7ffff ioport:ecd8(size=8) memo
ry:d0000000-dfffffff(prefetchable) memory:efec0000-efefffff

gene (eugenios) wrote :

Oops, I wanted different but similar bug...

Download full text (3.2 KiB)

Try Fedora 13, it works!

gene wrote:
> Hi, ran into a similar problem: My desktop display froze and both keyboard and mouse did not work. I haven't checked if my webserver was running/available, since I prematurely powered off the pc.
> My issue seems to be a little different from those reported though. The freeze has never occurred before since my upgrade to Lucid more than a week ago. The kernel
> uname -a: Linux 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 x86_64 GNU/Linux
> has been run for about a couple days before it happened.
> I will continue using this very kernel (I do not want to try the ppa fix yet, since this intel machine used to be very effective before). After a next freeze I will try to grab some earlier/later versions of the kernel from ppa/kernel
> Here are some specs:
> sudo lshw: lspci
> 00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
> 00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 02)
> 00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
> 00:02.1 Display controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
> 00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
> 00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
> 00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 01)
> 00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
> 00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
> 00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
> 00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
> 00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
> 00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
> 00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
> 00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
> 00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
> 03:03.0 Modem: Intel Corporation FA82537EP 56K V.92 Data/Fax Modem PCI (rev 04)
> 03:08.0 Ethernet controller: Intel Corporation N10/ICH 7 Family LAN Controller (rev 01)
>
> And
>
> description: Mini Tower Computer
> product: Dell DM051
> vendor: Dell Inc.
> serial: B4KPL81
> width: 64 bits
> capabilities: smbios-2.3 dmi-2.3 vsyscall64 vsyscall32
> ..........................
> description: VGA compatible controller
> product: 82945G/GZ Integrated Graphics Controller
> vendor: Intel Corporation
> physical id: 2
> bus info: pci@0000:00:02.0
> version: 02
> width: 32 bits
> clock: 33MHz
> capabilities: msi pm bus_master cap_list rom
> configuration: driver=i915 latency=0
> resources: irq:16 memory:eff00000-eff7ffff ioport:ecd8(size=8) memo
> ry:d0000000-dffff...

Read more...

tplus (tripleplussolutionz) wrote :
Download full text (7.9 KiB)

Same issue and the following error on hang in kern.log:

[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
render error detected, EIR: 0x00000000
[drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 220195 at 220192)
[drm:i915_gem_idle] *ERROR* hardware wedged

after this the computer restarts.

lshw:

description: Computer
    width: 32 bits
  *-core
       description: Motherboard
       physical id: 0
     *-memory
          description: System memory
          physical id: 0
          size: 1015MiB
     *-cpu
          product: Intel(R) Pentium(R) 4 CPU 2.40GHz
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          version: 15.3.3
          serial: 0000-0F33-0000-0000-0000-0000
          size: 2400MHz
          width: 32 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc up pebs bts pni dtes64 monitor ds_cpl cid
          configuration: id=0
     *-pci
          description: Host bridge
          product: 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 03
          width: 32 bits
          clock: 33MHz
          configuration: driver=agpgart-intel
          resources: irq:0 memory:d0000000-d7ffffff(prefetchable)
        *-display UNCLAIMED
             description: VGA compatible controller
             product: 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 03
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master cap_list
             configuration: latency=0
             resources: memory:d8000000-dfffffff(prefetchable) memory:e2000000-e207ffff
        *-usb:0
             description: USB Controller
             product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1
             vendor: Intel Corporation
             physical id: 1d
             bus info: pci@0000:00:1d.0
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master
             configuration: driver=uhci_hcd latency=0
             resources: irq:16 ioport:d800(size=32)
        *-usb:1
             description: USB Controller
             product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2
             vendor: Intel Corporation
             physical id: 1d.1
             bus info: pci@0000:00:1d.1
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master
             configuration: driver=uhci_hcd latency=0
             resources: irq:19 ioport:d000(size=32)
        *-usb:2
             description: USB Controller
             product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3
             vendor: Intel Corporation
             physical id: 1d.2
             bus info: pci@0000:00:1d.2
         ...

Read more...

tplus (tripleplussolutionz) wrote :

uname - a
Linux 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:22:14 UTC 2010 i686 GNU/Linux

sww5523 (peter-krneki) wrote :

I confirm this , kernel 2.6.32-24 breaks it again.
2.6.32.23 was working.

Chris Halse Rogers (raof) wrote :

Ok! Ladies and Gentlemen! Chris Wilson of upstream fame has done some work to re-integrate a legacy driver for the Intel cards that have been hard done by in the GEM transition.

The xserver-xorg-video-intel packages in https://edge.launchpad.net/~raof/+archive/aubergine have a GEM-less legacy driver re-integrated which is activated when KMS is disabled - which it is by default on your card for Lucid.

It would be useful if you could remove any work-arounds you've used to get your system more stable and test the drivers from this PPA. They should hopefully end up slightly more stable than the drivers in Ubuntu 9.04 (Jaunty), which were the last set of drivers to not use the GEM memory manager, and so significantly more stable than the drivers in Ubuntu 9.10 and Ubuntu 10.04 (Karmic and Maverick).

Could you please test the drivers from this PPA and report your experiences with them?

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
Alkis Georgopoulos (alkisg) wrote :

I tested https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes#GTT%20Incoherency%20Patch on my laptop with:
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)

While it allowed the system to boot, and KMS / 3D acceleration were working fine, it had problems with XV. E.g. testing XV with gstreamer-properties resulted in a crash:
$ gstreamer-properties
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
The program 'gstreamer-properties' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 60 error_code 11 request_code 132 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

So the best workaround so far for me is to use the https://launchpad.net/~brian-rogers/+archive/experimental kernel which gives me KMS, 3D and XV with no problems.

Alkis Georgopoulos (alkisg) wrote :

> So the best workaround so far for me is to use the https://launchpad.net/~brian-rogers/+archive/experimental kernel which gives me KMS, 3D and XV with no problems.

Erm, actually that's true for an older kernel that Brian Rogers had uploaded there: 2.6.34rc3-51-generic
With the last kernel there (2.6.35rc4-v9patch1.e467e10), KMS isn't working and X will only start in fail-safe mode (vesa).

@Brian, could you please reupload 2.6.34rc3-51-generic because I want to install it to another laptop with 855 and I didn't keep the .deb? Thank you!

Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
axion (bugzilla-axion) wrote :

This patch breaks the possibility to force kms with:

 options i915 modeset=1

I have not been having any problems with kms on my i855 chipset, until it got unblacklisted in the kernel and blacklisted in xorg, would you please pst a workaround to get kms with this patch ?

axion.
--

Stenten (stenten) wrote :

axion:

Huh?? KMS hasn't been enabled at the kernel-level and blacklisted in xorg-server in Lucid (actually, I think this is impossible). The patch in this bug report doesn't even do anything to KMS; it just forces writes in the GTT.

I have a sneaking suspicion you're actually talking about the switch to the fbdev driver instead of the Intel driver in Maverick. If this is true, you should post your question to the ubuntu-x mailing list instead.

Chris Halse Rogers (raof) wrote :

I'm no longer waiting on more information here; just the GTT patch to get re-worked in such a way that it could be accepted to the mainline kernel.

You can re-enable the intel driver in Maverick with the instructions here: https://wiki.ubuntu.com/X/Bugs/Mavericki8xxStatus

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
assignee: Chris Halse Rogers (raof) → nobody
Bryce Harrington (bryce) wrote :

[Untagging the patch as a fix, since we've decided we're going to wait until this gets accepted and provided by upstream rather than ship it as a distro patch. There are sufficient ppa's with the patch included for those who need it as a workaround.]

Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical

Tried Ubuntu 11.04 Daily CD (2011-03-27) and suffered system freeze during CD boot up graphics. Second attempt resulted in a sudden system reset instead of a freeze. I have now rolled back to Ubuntu 8.10 which works, but is no longer supported and does not have any repositories available.

Ignore my last comment #73. On further investigation I believe that I now have a hardware fault, flexing the laptop cause screen corruption or hard resets.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.