Ubuntu

[i915] [i945gm] Black video playback with dual screen enabled

Reported by davidcaste on 2009-10-25
102
This bug affects 20 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I have a dual screen configuration, with a Dell Inspiron 640m laptop and an external LG flat screen. Both have a 1440x900 resolution, so I have a 2880x900 virtual resolution. After a clean Karmic install, I'm unable to reproduce a video with Totem/VLC/MPlayer; I hear audio and see the progress bar move as the video plays but there is no video output (only black). But if I reproduce the same video with mplayer, and select 'X11 (XImage/Shm)' video driver, the video is displayed correctly. The problem appears when the default 'XV' video driver is selected.

Thank you very much :-)

ProblemType: Bug
Architecture: amd64
Date: Sun Oct 25 20:21:22 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate amd64 (20091020.3)
MachineType: Dell Inc. MXC061
Package: xserver-xorg-video-intel 2:2.9.0-1ubuntu2
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=77350615-6349-44bd-82fe-9359707d5514 ro quiet splash
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.1~git20091025.dc8b139a-0ubuntu0~xup~1
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.31-14-generic x86_64
XorgConf: Error: [Errno 2] No existe el fichero ó directorio: '/etc/X11/xorg.conf'
dmi.bios.date: 04/02/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.name: 0MG532
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd04/02/2007:svnDellInc.:pnMXC061:pvr:rvnDellInc.:rn0MG532:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MXC061
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-14-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
     Subsystem: Dell Device [1028:01d8]

davidcaste (davidcaste) wrote :
Bryce Harrington (bryce) on 2009-10-26
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

Has anyone found a workaround for this? Also, if there is any other output I need to provide to help with the troubleshooting, please let me know. This problem makes it hard for me to use my ubuntu machine as a conference room presentation pc because I can't play videos when the secondar monitor is attached.

Thanks very much!

I've attached the output from strace if it helps at all. The command I used was: "strace vlc "test_video.ogg" 2>strace_output_dual_screen_vlc_oggvideo.txt"

The video I tested is a native *.ogg format video.

davidcaste (davidcaste) wrote :

Hi!

I've encountered a workaround for this problem. I've created a /etc/X11/xorg.conf file, and I specified on it the virtual resolution of my display. Then I've restarted, and I able to play videos correctly with Totem and MPlayer using XV video output.

 At least in my case, the xorg.conf file has the following content:

Section "Screen"
        Identifier "Configured Screen Device"
        Device "Configured Video Device"
        SubSection "Display"
                Virtual 2880 900
        EndSubSection
EndSection

Section "Device"
        Identifier "Configured Video Device"
EndSection

HTH!!

Geir Ove Myhr (gomyhr) on 2009-10-30
tags: added: 945gm karmic videoplayback
tags: added: dual-head
summary: - Black video playback with dual screen enabled
+ [i945GM] Black video playback with dual screen enabled

@davidcaste, your workaround works for me, Thanks a bunch for posting it!!

(Doesn't Work)Previously my xorg.conf showed:
Virtual 2048 2048

Now it's set as you said to:
Virtual 2880 900
and I can play videos.

When I first changed the setting, I thought the screen resolution for my dual monitor configuration was going to suffer, but it didn't. The resolutions for my monitors are as follows:
1280x1024 Planar 19" lcd monitor
1400x1050 hp Compaq nc6320 lcd screen

Right On. That just made my day. Ubuntu is awesome! Freedom and GNU/Linux is awesome!!

Shannon VanWagner
humans enabled

I didn't mention it above - Step #4 fixes the problem for me.

Stephen Ostrow (isleshocky77) wrote :

This work around worked for me as well on Ubuntu 9.10 i386 using an old Compaq Presario v2575us (v2000 series)

Nico (nchuecos) wrote :

Step #4 worked for me too
Thx a lot.

------
Ubuntu Karmic Koala on a Lenovo 3000 C100 + a 17" Samsung SyncMaster 713N

Bryce Harrington (bryce) on 2010-02-09
description: updated
Bryce Harrington (bryce) on 2010-02-27
tags: added: black-screen
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945GM] Black video playback with dual screen enabled
+ [i945] [i945GM] Black video playback with dual screen enabled
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] [i945GM] Black video playback with dual screen enabled
+ [i945gm] Black video playback with dual screen enabled
Rolf Leggewie (r0lf) wrote :

I experience this on an ASUS 1001p netbook with 1024*600 internal and 1680*1050 external resolution as well. Will try the suggested fix to xorg.conf in a minute. What I've done so far is to disable one of the two displays with the monitor applet as a workaround.

summary: - [i945gm] Black video playback with dual screen enabled
+ [i915] [i945gm] Black video playback with dual screen enabled
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Rolf Leggewie (r0lf) wrote :

$ lspci -v -s 00:02.0 -k
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
 Subsystem: ASUSTeK Computer Inc. Device 83ac
 Flags: bus master, fast devsel, latency 0, IRQ 28
 Memory at f7e00000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at dc00 [size=8]
 Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Memory at f7d00000 (32-bit, non-prefetchable) [size=1M]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

Rolf Leggewie (r0lf) wrote :

hm, my lucid system does not seem to use an xorg.conf file any longer. Looks like for now I'm stuck.

otakuj462 (otakuj462) wrote :

I found a good workaround for this problem here: http://ubuntuforums.org/showthread.php?p=9774183#post9774183
Also, possible duplicate bug report here: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/583012

Rolf Leggewie (r0lf) wrote :

good find, otakuj462.

http://www.thinkwiki.org/wiki/Xorg_RandR_1.2#the_Virtual_screen

2048 seems to be magical threshold indeed. I can have the internal display of my netbook at 1024x600 below my external display at 1680x1050 and play Video just fine. If set side to side and thus exceeding 2048 pixels dimension I only get the black square.

I've reported the bug upstream at https://bugs.freedesktop.org/show_bug.cgi?id=32750

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Bryce Harrington (bryce) wrote :

Should be fixed in natty. Also, see bug #555641 for reference.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
Clint Byrum (clint-fewbar) wrote :

I only see mention of lucid being affected once, by Rolf, who nominated the bug for SRU to lucid. Can any other lucid users confirm the issue?

Rolf Leggewie (r0lf) wrote :

Are you seriously asking me to dig up a user who has the hardware in question, runs lucid and is technically skilled enough to find this ticket? You gotta be kidding. This ticket was originally filed against karmic. Bryce said it should be fixed in Natty. Am I such a newbie in bug reporting that my word and all these facts are STILL not enough that this is an issue that needs fixing in lucid? OMG!

Rolf Leggewie (r0lf) wrote :

Anyhow, the latter two dupes of this ticket were filed against lucid. Now, can we please see the bug task for lucid confirmed? Thank you.

Rolf Leggewie (r0lf) wrote :

All the love needed is probably to go through upstream git and find the commit that fixed it. As the angry comment by upstream suggests the commit that fixed this must have been made around the time that lucid went into freeze. So, if we're lucky the upstream patch still applies cleanly to lucid sources. I tried to look for the patch myself, but unfortunately it's beyond my skills and #xorg was quiet on it when I asked.

Changed in xserver-xorg-video-intel (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.