[i945] X flickers wildly whenever anything on-screen updates

Bug #412492 reported by Ronald McCollam on 2009-08-12
This bug report is a duplicate of:  Bug #415023: brightness is broken on MSI WIND U100. Edit Remove
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Unknown
linux (Ubuntu)
Medium
Leann Ogasawara
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

After dist-upgrading today on , X flickers and is unusable any time any object on the screen is painted. Opening the main menu from the panel causes the entire screen to flicker for around a second. Switching desktops or opening/closing/moving a window causes similar behavior.

The flickering appears to be parts of the screen being briefly updated in the wrong place; it's much like a jerky shift of halves or quarters of the screen to the wrong position very briefly.

Deactivating compiz does not seem to change this behavior.

The graphics controller is:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

I've attached a video of an example of the effect captured from my phone. (I apologize for the poor quality of the video, but it gives a sample of the effect.) In the video I have opened the main menu and then switched to another virtual desktop. However the same effect happens during nearly any screen update -- every character I type right now in this bug report is causing a brief nauseating flash.

ProblemType: Bug
Architecture: amd64
Date: Wed Aug 12 08:30:34 2009
DistroRelease: Ubuntu 9.10
MachineType: Dell Inc. MXC061
Package: xorg 1:7.4+3ubuntu5
ProcCmdLine: root=UUID=4e88e4b9-d7a1-4e91-8105-ecfbf01429a9 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.5-1ubuntu1
 libdrm2 2.4.12-1ubuntu1
 xserver-xorg-video-intel 2:2.8.0-0ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu5
SourcePackage: xorg
Uname: Linux 2.6.31-5-generic x86_64
dmi.bios.date: 04/02/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.name: 0MG532
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd04/02/2007:svnDellInc.:pnMXC061:pvr:rvnDellInc.:rn0MG532:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MXC061
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-5-generic

Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :

Further testing reveals that this appears to affect my display only when set to its native resolution (1440x900). Changing to another resolution, e.g. 1024x768, makes this problem go away.

Daniel K (sinani201) on 2009-08-12
Changed in xorg (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-08-18
summary: - X flickers wildly whenever anything on-screen updates
+ [i945] X flickers wildly whenever anything on-screen updates
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Bryce Harrington (bryce) wrote :

Ronald - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=23398 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

Leann, looking like this may be another one needing a kernel fix... would you mind getting Ronald a kernel built with this patch rolled in for him to test to verify this?

https://bugs.freedesktop.org/attachment.cgi?id=28751

Hey Bryce and Ronald,

Sorry for the delay. Ronald, I'll queue up a build and post a link to the test package when it's ready. Thanks!

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Geir Ove Myhr (gomyhr) on 2009-08-20
tags: added: 945gm flicker karmic

Hi Ronald,

I've posted a test kernel at the following. Please test and let us know your results. Thanks.

http://people.canonical.com/~ogasawara/lp412492/

Ronald McCollam (fader) wrote :

Leann,

This kernel seems to have fixed the issue! I will report back if the behavior reoccurs.

Thank you -- my laptop is usable again :)

Omer Mano (mermerico-gmail) wrote :

Hey, I'm having what looks to be the same problem, but with a 32 bit machine. The bug report is here https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/417744

Is this a duplicate of this bug, or is it an unrelated issue?

Hi Ronald,

Just fyi, I've submitted this patch to the kernel team to consider carrying temporarily until it's merged upstream and subsequently automatically rebased into the Ubuntu kernel.

https://lists.ubuntu.com/archives/kernel-team/2009-August/006966.html

Tim Gardner (timg-tpi) on 2009-08-25
Changed in linux (Ubuntu):
status: In Progress → Fix Committed

Marking this Fix Commited as it looks like this has just been applied.

https://lists.ubuntu.com/archives/kernel-team/2009-August/006967.html

The launchpad janitor should automatically post a comment here when this fix has been officially released. Thanks!

Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
Geir Ove Myhr (gomyhr) wrote :

Updated the bug watch.

Changed in xserver-xorg-video-intel:
status: Invalid → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-8.28

---------------
linux (2.6.31-8.28) karmic; urgency=low

  [ Ike Panhc ]

  * [Config] Let nic-shared-modules depends on crypto-modules
    - LP: #360966

  [ Leann Ogasawara ]

  * [Upstream] (drop after 2.6.31) drm/i915: increase default latency
    constant
    - LP: #412492

  [ Mario Limonciello ]

  * [Upstream]: (drop after 2.6.31) dell-laptop: don't change softblock
    status if HW switch is disabled
    - LP: #418721
  * [Upstream]: (drop after 2.6.31) compal-laptop: Add support for known
    Compal made Dell laptops
  * [Upstream]: (drop after 2.6.31) compal-laptop: Replace sysfs support
    with rfkill support

  [ Tim Gardner ]

  * [Config] Add acpiphp to virtual sub-flavour
    - LP: #364916
  * Drop KSM patch set for now because of instabilities with encrypted swap.
    - LP: #418781

 -- Tim Gardner <email address hidden> Wed, 26 Aug 2009 08:14:26 -0600

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2009-10-08
Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Confirmed
Changed in linux (Ubuntu):
status: Fix Released → Confirmed

I am still affected by this bug, with all the latest updates applied.

Geir Ove Myhr (gomyhr) wrote :

István, please don't reopen closed bug reports unless you are the original reporter. Rather, file a new bug with the `ubuntu-bug -p xserver-xorg-video-intel`. You can mention this bug report in the description if you'd like. That way we can focus on the details of _your_ system rather than on Ronald's (original reporter of this bug) whose issue has now been fixed.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.