Comment 149 for bug 397617

Not sure if this explains why it's not working, but after updating the BIOS
on my NC10 I had both a NICOM and BIOS version of 11CA.

On Oct 25, 2009 11:01 AM, "uxinity" <email address hidden> wrote:

Brightness keys (Fn + arrow up/down) are still NOT working on my Samsung
NC10 despite latest daily updates from Update Manager and using latest
Samsung BIOS version 04CA / MICOM version 11CA.

(Brightness keys work while in BIOS (F2 key while power on), but you do
not want to reboot the computer to adjust display brightness.)

Using the nomodeset parameter in GRUB forces the brightness keys to work
(didn’t work some weeks ago when I tried that for the first time). But I
really liked Kernel-based mode setting, so it would be slightly
disappointing to use nomodeset to turn it off. Of course, non-functional
brightness settings are a bigger hassle than screen flickering, so I am
forced to nomodeset.

As others are reporting brightness keys working on NC10: Could the LPIA
instead of i386 be the problem for me? (kernel 2.6.31-14-lpia)

-- brightness no more working on karmic (KMS) You received ...