[82865g] Playing video with acceleration enabled crashes Xorg

Bug #352760 reported by wilbur on 2009-03-31
16
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

After resolving the DRI issue with the Intel 865G I have been encountering unworkable video problems with streaming video, slide shows and flash.

As can be seen from the section of the xorg.conf file I have been trying a number of variations.

Section "Device"
 VendorName "Intel Corporation"
     BoardName "Intel 82865G"
 Identifier "82865G Integrated Graphics Controller"
 Driver "intel"
 BusID "PCI:0:2:0"
# Option "XvMC" "true"
 Option "DRI" "False"
# Option "NoAccel" "True"
# Option "AccelMethod" "UXA" # "EXA"
     Option "DPMS" "false"
# Option "Legacy3d" "false"
EndSection

The only solution I have found so far is to use the 'Option "NoAccel" "True"' line and with this video will run, although very poorly, and the system is virtually unusable for anything else.

With the 'NoAccel' line commented as above X will act exactly as though Ctrl+Alt+Backspace has been pressed. So far I have been unable to get UXA to run as it hangs the system. There are no error messages and I can find nothing in the logs.

This is in 9.04 with all updates as of the evening of March 30, 09

Thank you for reporting this issue, it helps make Ubuntu better. Confirmed.

Changed in xserver-xorg-video-intel:
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Please collect a full backtrace - see http://wiki.ubuntu.com/X/Backtracing for directions.

Also, if you could attach your lspci -vvnn output and Xorg.0.log that would be of use.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
  • Xorg.0.log Edit (33.6 KiB, text/x-log; charset=UTF-8; name="Xorg.0.log")
Download full text (9.6 KiB)

lspci -vvnn
00:00.0 Host bridge [0600]: Intel Corporation 82865G/PE/P DRAM
Controller/Host-Hub Interface [8086:2570] (rev 02)
    Subsystem: Dell Device [1028:0174]
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort+ >SERR- <PERR- INTx-
    Latency: 0
    Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
    Capabilities: [e4] Vendor Specific Information <?>
    Kernel driver in use: agpgart-intel
    Kernel modules: intel-agp

00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G
Integrated Graphics Controller [8086:2572] (rev 02)
    Subsystem: Dell Device [1028:0174]
    Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at e8000000 (32-bit, prefetchable) [size=128M]
    Region 1: Memory at feb80000 (32-bit, non-prefetchable) [size=512K]
    Region 2: I/O ports at ed98 [size=8]
    Capabilities: [d0] Power Management version 1
        Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
        Status: D0 PME-Enable- DSel=0 DScale=0 PME-
    Kernel modules: intelfb

00:1d.0 USB Controller [0c03]: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB
UHCI Controller #1 [8086:24d2] (rev 02)
    Subsystem: Dell Device [1028:0174]
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 16
    Region 4: I/O ports at ff80 [size=32]
    Kernel driver in use: uhci_hcd

00:1d.1 USB Controller [0c03]: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB
UHCI Controller #2 [8086:24d4] (rev 02)
    Subsystem: Dell Device [1028:0174]
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin B routed to IRQ 19
    Region 4: I/O ports at ff60 [size=32]
    Kernel driver in use: uhci_hcd

00:1d.2 USB Controller [0c03]: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB
UHCI Controller #3 [8086:24d7] (rev 02)
    Subsystem: Dell Device [1028:0174]
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin C routed to IRQ 18
    Region 4: I/O ports at ff40 [size=32]
    Kernel driver in use: uhci_hcd

00:1d.3 USB Controller [0c03]: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB
UHCI Controller #4 [8086:24de] (rev 02)
    Subsystem: Dell Device [1028:0174]
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSE...

Read more...

wilbur (wilburgr) wrote :

This log is from directly after a crash trying to play this video the
attached video in mplayer.

2009/4/1 Bryce Harrington <email address hidden>

> Please collect a full backtrace - see
> http://wiki.ubuntu.com/X/Backtracing for directions.
>
> Also, if you could attach your lspci -vvnn output and Xorg.0.log that
> would be of use.
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Intel 82865G. Unable to run video with Acceleration on. Causes and imediate
> restart in X exactly like Ctl+Alt+Bksp.
> https://bugs.launchpad.net/bugs/352760
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-intel” source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> After resolving the DRI issue with the Intel 865G I have been encountering
> unworkable video problems with streaming video, slide shows and flash.
>
> As can be seen from the section of the xorg.conf file I have been trying a
> number of variations.
>
> Section "Device"
> VendorName "Intel Corporation"
> BoardName "Intel 82865G"
> Identifier "82865G Integrated Graphics Controller"
> Driver "intel"
> BusID "PCI:0:2:0"
> # Option "XvMC" "true"
> Option "DRI" "False"
> # Option "NoAccel" "True"
> # Option "AccelMethod" "UXA" # "EXA"
> Option "DPMS" "false"
> # Option "Legacy3d" "false"
> EndSection
>
> The only solution I have found so far is to use the 'Option "NoAccel"
> "True"' line and with this video will run, although very poorly, and the
> system is virtually unusable for anything else.
>
> With the 'NoAccel' line commented as above X will act exactly as though
> Ctrl+Alt+Backspace has been pressed. So far I have been unable to get UXA to
> run as it hangs the system. There are no error messages and I can find
> nothing in the logs.
>
> This is in 9.04 with all updates as of the evening of March 30, 09
>

I can confirm this bug, too.
Todays build Kubuntu jaunty desktop i386 CD + mplayer installed.
Attached logs are catched "directly after a crash trying to play this video the
 attached video in mplayer". Mplayer window shows with blue background and after a second Xorg is crashing.

Tomasz Czapiewski (xeros) wrote :
Tomasz Czapiewski (xeros) wrote :
Tomasz Czapiewski (xeros) wrote :

Log from working "mplayer -vo x11 Suzuki.wmv" command.

Tomasz Czapiewski (xeros) wrote :

Log from working "mplayer -vo gl Suzuki.wmv" command, but slow in fullscreen due to DRI disabled by current packages.

Tomasz Czapiewski (xeros) wrote :

Log from crashing Xorg "mplayer -vo xv Suzuki.wmv" command.

Tomasz Czapiewski (xeros) wrote :

I've tried to use UXA and XAA, too.
UXA does hang/crash Xorg on Xorg start so I can't even check XV there, but with XAA an XV the video is played for few seconds (I can see the playing movie on the screen but with image artefacts - in the mouse pointer place and some on the video window) and then Xorg hard locks - even keyboard does not work (numlock etc.).

Carey Underwood (cwillu) wrote :

Tomasz, can you collect a full backtrace of the crash?

See http://wiki.ubuntu.com/X/Backtracing for directions.

tags: added: 865g hang intel
summary: - Intel 82865G. Unable to run video with Acceleration on. Causes and
- imediate restart in X exactly like Ctl+Alt+Bksp.
+ [82865Gg] Unable to run video with Acceleration on. Causes and imediate
+ restart in X exactly like Ctl+Alt+Bksp.
summary: - [82865Gg] Unable to run video with Acceleration on. Causes and imediate
+ [82865g] Unable to run video with Acceleration on. Causes and imediate
restart in X exactly like Ctl+Alt+Bksp.
summary: - [82865g] Unable to run video with Acceleration on. Causes and imediate
- restart in X exactly like Ctl+Alt+Bksp.
+ [82865g] Playing video with acceleration enabled crashes Xorg
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.6.3-0ubuntu7

---------------
xserver-xorg-video-intel (2:2.6.3-0ubuntu7) jaunty; urgency=low

  * Add 119_drm_bo_unreference_needs_null.patch:
    - The first time through the Xv code, an allocated buffer is
      unreferenced but the pointer is not reset to NULL. Thus, the next time
      a video is played, -intel thinks it has a valid buffer and crashes
      when it tries to access the freed memory. Fixes a number of crashes
      reported since moving to the 2.6.3 driver.
    - Fixes crash on i945 with frame buffer width > 2048. DRI is disabled
      on this chipset when the frame buffer exceeds this width.
      (LP: #354688)
    - Fixes crash on i865 where DRI is off because of patch 116
      (LP: #352760)
    - Fixes crash on i845 starting after 304871 was fixed
      (LP: #354889)
    - Fixes crash on i830 when manually disabling DRI
      (LP: #347527)

 -- Bryce Harrington <email address hidden> Mon, 06 Apr 2009 14:28:29 -0700

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
vmc (vmclark) wrote :

I cannot play any movie files - avi, vob, using the current Intel driver 2.6. If I revert to old driver everything resumes back to normal. I'm able to play all video movies. This is reported on a Ubuntu 9.04 (Jaunty).

Mu integrated Intel chip is 82865G

2009/4/26 vmc <email address hidden>

> I cannot play any movie files - avi, vob, using the current Intel driver
> 2.6. If I revert to old driver everything resumes back to normal. I'm
> able to play all video movies. This is reported on a Ubuntu 9.04
> (Jaunty).
>
> Mu integrated Intel chip is 82865G
>
> --
> [82865g] Playing video with acceleration enabled crashes Xorg
> https://bugs.launchpad.net/bugs/352760
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-intel” source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> After resolving the DRI issue with the Intel 865G I have been encountering
> unworkable video problems with streaming video, slide shows and flash.
>
> As can be seen from the section of the xorg.conf file I have been trying a
> number of variations.
>
> Section "Device"
> VendorName "Intel Corporation"
> BoardName "Intel 82865G"
> Identifier "82865G Integrated Graphics Controller"
> Driver "intel"
> BusID "PCI:0:2:0"
> # Option "XvMC" "true"
> Option "DRI" "False"
> # Option "NoAccel" "True"
> # Option "AccelMethod" "UXA" # "EXA"
> Option "DPMS" "false"
> # Option "Legacy3d" "false"
> EndSection
>
> The only solution I have found so far is to use the 'Option "NoAccel"
> "True"' line and with this video will run, although very poorly, and the
> system is virtually unusable for anything else.
>
> With the 'NoAccel' line commented as above X will act exactly as though
> Ctrl+Alt+Backspace has been pressed. So far I have been unable to get UXA to
> run as it hangs the system. There are no error messages and I can find
> nothing in the logs.
>
> This is in 9.04 with all updates as of the evening of March 30, 09
>

wilbur (wilburgr) wrote : Intel 865G

I have installed the fix as reported in:

http://ubuntuforums.org/showthread.php?t=1130582

to the latest kernel 2.6.30-rc2 and run the fixmtrr.sh script. UXA now will
launch but crashes when anything is opened so it is back to EXA which runs
most video very poorly. Scrolling is about to same, choppy. I used the
xorg.conf as shown and have also tried a number of other ideas but nothing
works. The Intel 865G driver still has serious issues.

2009/4/26 vmc <email address hidden>

> I cannot play any movie files - avi, vob, using the current Intel driver
> 2.6. If I revert to old driver everything resumes back to normal. I'm
> able to play all video movies. This is reported on a Ubuntu 9.04
> (Jaunty).
>
> Mu integrated Intel chip is 82865G
>
> --
> [82865g] Playing video with acceleration enabled crashes Xorg
> https://bugs.launchpad.net/bugs/352760
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-intel” source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> After resolving the DRI issue with the Intel 865G I have been encountering
> unworkable video problems with streaming video, slide shows and flash.
>
> As can be seen from the section of the xorg.conf file I have been trying a
> number of variations.
>
> Section "Device"
> VendorName "Intel Corporation"
> BoardName "Intel 82865G"
> Identifier "82865G Integrated Graphics Controller"
> Driver "intel"
> BusID "PCI:0:2:0"
> # Option "XvMC" "true"
> Option "DRI" "False"
> # Option "NoAccel" "True"
> # Option "AccelMethod" "UXA" # "EXA"
> Option "DPMS" "false"
> # Option "Legacy3d" "false"
> EndSection
>
> The only solution I have found so far is to use the 'Option "NoAccel"
> "True"' line and with this video will run, although very poorly, and the
> system is virtually unusable for anything else.
>
> With the 'NoAccel' line commented as above X will act exactly as though
> Ctrl+Alt+Backspace has been pressed. So far I have been unable to get UXA to
> run as it hangs the system. There are no error messages and I can find
> nothing in the logs.
>
> This is in 9.04 with all updates as of the evening of March 30, 09
>

Denis Walrave (deniswalrave) wrote :

Same problem today :

Linux osnp1197956p 2.6.28-15-server #49-Ubuntu SMP Tue Aug 18 19:30:06 UTC 2009 i686 GNU/Linux

    description: Notebook
    product: 8933AS3
    vendor: LENOVO
    version: ThinkPad R61

     *-pci
          description: Host bridge
          product: Mobile PM965/GM965/GL960 Memory Controller Hub
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 0c
          width: 32 bits
          clock: 33MHz
          configuration: driver=agpgart-intel module=intel_agp
        *-display:0 UNCLAIMED
             description: VGA compatible controller
             product: Mobile GM965/GL960 Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 0c
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm bus_master cap_list
             configuration: latency=0

-Denis

Denis Walrave (deniswalrave) wrote :

Parts of lspci output:

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controlle
r Hub (rev 0c)
        Subsystem: Lenovo Device 20b3
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Step
ping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
        Latency: 0
        Capabilities: [e0] Vendor Specific Information <?>
        Kernel driver in use: agpgart-intel
        Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
        Subsystem: Lenovo Device 20b5
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 2296
        Region 0: Memory at f8100000 (64-bit, non-prefetchable) [size=1M]
        Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Region 4: I/O ports at 1800 [size=8]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+
                Address: fee0300c Data: 41c1
        Capabilities: [d0] Power Management version 3
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
                Bridge: PM- B3+
        Kernel modules: intelfb

-Denis

Denis Walrave (deniswalrave) wrote :

Xorg.0.log.old (tail)

Backtrace:
0: /usr/X11R6/bin/X(xorg_backtrace+0x3b) [0x813518b]
1: /usr/X11R6/bin/X(xf86SigHandler+0x55) [0x80c7be5]
2: [0xb801f400]
3: /usr/lib/libdrm_intel.so.1 [0xb787abca]
4: /usr/lib/libdrm_intel.so.1 [0xb787acb2]
5: /usr/lib/libdrm_intel.so.1(drm_intel_bo_unreference+0x16) [0xb7879336]
6: /usr/lib/xorg/modules/drivers//intel_drv.so [0xb78e37a6]
7: /usr/lib/xorg/modules/drivers//intel_drv.so(I965DisplayVideoTextured+0xa09) [0xb78e5bd9]
8: /usr/lib/xorg/modules/drivers//intel_drv.so [0xb78d5e2a]
9: /usr/X11R6/bin/X [0x80de538]
10: /usr/lib/xorg/modules/extensions//libextmod.so(XvdiPutImage+0x190) [0xb800f890]
11: /usr/lib/xorg/modules/extensions//libextmod.so [0xb8012c2a]
12: /usr/lib/xorg/modules/extensions//libextmod.so(ProcXvDispatch+0x3a) [0xb8013f8a]
13: /usr/X11R6/bin/X(Dispatch+0x33f) [0x808d57f]
14: /usr/X11R6/bin/X(main+0x3bd) [0x80722ed]
15: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7be2775]
16: /usr/X11R6/bin/X [0x80717a1]
Saw signal 11. Server aborting.
(II) ThinkPad Extra Buttons: Close
(II) UnloadModule: "evdev"
(II) Video Bus: Close
(II) UnloadModule: "evdev"
(II) AT Translated Set 2 keyboard: Close
(II) UnloadModule: "evdev"
(II) UnloadModule: "synaptics"
(II) DualPoint Stick: Close
(II) UnloadModule: "evdev"
(II) Macintosh mouse button emulation: Close
(II) UnloadModule: "evdev"
(II) AIGLX: Suspending AIGLX clients for VT switch

Fatal server error:
I830EmitFlush: BEGIN_BATCH called without closing ADVANCE_BATCH

Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(II) AIGLX: Suspending AIGLX clients for VT switch

FatalError re-entered, aborting
I830EmitFlush: BEGIN_BATCH called without closing ADVANCE_BATCH

-Denis

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers