[855] unable to run X in 9.04 - couldn't bind memory for BO backbuffer

Bug #322646 reported by trylik on 2009-01-29
36
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Bryce Harrington
Jaunty
Undecided
Bryce Harrington

Bug Description

i installed fresh 9.04 alpha 3, i have IBM X40 with intel 855

i cannot run X, even xfix dont help

i have this line when i try to start xserver manually

couldn't bind memory for BO back buffer

the same is with alternate and desktop image

trylik (marek-nasionka) wrote :

@Christoph Schmidt-Hieber

i think yes, i have the same output

Bryce Harrington (bryce) on 2009-03-31
summary: - serious bug - unable to run X in 9.04 with intel 855
+ [855] unable to run X in 9.04 - couldn't bind memory for BO backbuffer
Martin Pitt (pitti) on 2009-04-01
tags: added: regression-potential
Martin Pitt (pitti) wrote :

Bryce, would the same fallback plan of disabling DRI work here as well, if there's no better solution?

Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
assignee: nobody → bryceharrington
Bryce Harrington (bryce) wrote :

I've got a different plan in mind for this.

Bryce Harrington (bryce) wrote :

Testing on bug 304871 indicates for 855, dropping Legacy3D does the trick.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.6.3-0ubuntu4

---------------
xserver-xorg-video-intel (2:2.6.3-0ubuntu4) jaunty; urgency=low

  * Add 117_quirk_thinkpad_x30.patch:
    - Pipe-A quirk to fix lid close freeze on Thinkpad X30
      (LP: #304614)
  * Add 118_drop_legacy3d.patch:
    - Remove Legacy3D as a user-configurable option and force fallback to
      legacy fixed textures when GEM is not being used. Fixes "couldn't
      bind memory for BO backbuffer" issue on at least i855 chipsets.
      (LP: #322646)

 -- Bryce Harrington <email address hidden> Wed, 01 Apr 2009 00:25:55 -0700

Changed in xserver-xorg-video-intel:
status: New → Fix Released
muzzamo (murray-waters) wrote :

Confirming its fixed in package 2:2.6.3-0ubuntu4, on a dell 700m with 855 graphics.

VangelistX (vangelistx) wrote :

Run Update Manager, install xserver-xorg-video-intel 2:2.6.3-0ubuntu5,
 and report if you had any problems after this update.

 Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers